Jump to content











Photo
* * * * * 1 votes

nativeEx_Win7


  • Please log in to reply
216 replies to this topic

#201 was_JFX

was_JFX

    Frequent Member

  • Advanced user
  • 483 posts
  •  
    Germany

Posted 03 April 2010 - 02:57 PM

Can you help and explain me what "elevation" here means?

Heißt hier so viel wie die Erhöhung der Benutzerrechte (zum Administrator)

#202 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12707 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 03 April 2010 - 03:50 PM

@Paraglider,

Before I upload, can you test?

I made two changes
  • _tcprintf replaced by _tprintf
  • Let Linker add level="requireAdministrator" and uiAccess="false"

Peter

Attached Files



#203 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12707 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 13 May 2010 - 03:06 PM

Several members have had last days some troubles with nativeEX_Win7 / Win7RescuePE.

I looked deeply into it and found the reason:

As known, to build correctly, nativeEx_Win7 needs that Win7RescuePE at least once made a successful build.

But here is a small issue:

When you define for nativeEx_Win7 a different source CD than that one which has been used in Win7RescuePE, you'll get copy errors and other nice surprises.

This is caused by the fact that the linked Win7RescuePE core scripts are processed with Exec. That means that they use their own variables.

I'm going to fix that, but that will take a while.

Until I finished, please take care that the source CD (and also the host architecture) are not changed between Win7RescuePE and nativeEx_Win7.

Peter

#204 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12707 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 13 May 2010 - 03:18 PM

This post
http://www.boot-land...?...st&p=100028
Gives me the opinion that there is something else.

I'm working on it, but as already told, it needs some time to find the real root of the evil.

Peter

#205 MedEvil

MedEvil

    Platinum Member

  • .script developer
  • 7771 posts

Posted 13 May 2010 - 07:08 PM

Just that i understand you right.

To use nativeEx_Win7, the one project which does not require WAIK to be installed, i need to at least once run Win7RescuePE which does require WAIK to be installed.

Sounds stupid to me.

If i did not understood you wrong, i think you should change nativeEx_Win7 to not require Win7RescuePE to ever be run, by itself.

:cheers:

#206 paraglider

paraglider

    Gold Member

  • .script developer
  • 1739 posts
  • Location:NC,USA
  •  
    United States

Posted 14 May 2010 - 03:35 AM

@psc,

Just noticed your test versions. No I am not getting the prompt from UAC when I run your two test versions. If the manifest is set correctly then UAC will prompt to allow elevation to administrator when the program is run on vista / win7 / w2008 if not being launched by a program that is already elevated.

#207 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12707 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 14 May 2010 - 07:36 AM

Just that i understand you right.

To use nativeEx_Win7, the one project which does not require WAIK to be installed, i need to at least once run Win7RescuePE which does require WAIK to be installed.

Sounds stupid to me.

If i did not understood you wrong, i think you should change nativeEx_Win7 to not require Win7RescuePE to ever be run, by itself.

:cheers:

Because nativeEx_Win7 calls some Win7RescuePE scripts by Exec, it must be true that the Win7RescuePE parameters, variables and extracted attachments are correct to make a successful build.

Rather than giving a tutorial 'How to set Win7RescuePE parameters for use by nativeEx_Win7' the easiest way to validate is, to see Win7RescuePE building a running PE once.

BTW: I did not try, but I think that nativeEx_Win7 can also be attached to other Win7 projects.

Peter

#208 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12707 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 14 May 2010 - 07:38 AM

@psc,

Just noticed your test versions. No I am not getting the prompt from UAC when I run your two test versions. If the manifest is set correctly then UAC will prompt to allow elevation to administrator when the program is run on vista / win7 / w2008 if not being launched by a program that is already elevated.


@Paraglider.

Sorry for my poor English, but I have troubles to understand.

Can you shortly explain what you suggest me to do / change?

Peter

#209 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12707 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 14 May 2010 - 09:05 AM

A new version of nativeEx_Win7 is uploaded.

Fixed the bug occuring depending on change of source CD

script.project
ImageIndex.Script
ManageWims.Script

Win7RescuePE must not be run anymore before running nativeEx_Win7


Peter

#210 MedEvil

MedEvil

    Platinum Member

  • .script developer
  • 7771 posts

Posted 14 May 2010 - 11:24 AM

Win7RescuePE must not be run anymore before running nativeEx_Win7

Great! :cheers:
Will give it a spin.

:(

#211 patsch

patsch

    Silver Member

  • Advanced user
  • 785 posts
  •  
    Germany

Posted 14 May 2010 - 03:57 PM

hmm, a new problem ... I only get iso images of 34kb size
http://www.fileden.c...uilder/log11.7z

#212 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12707 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 14 May 2010 - 06:29 PM

hmm, a new problem ... I only get iso images of 34kb size
http://www.fileden.c...uilder/log11.7z

Please check in your target dir "Boot/etfsboot.com" for upper / lower case.

If that is not identic, please try to add some code in MakeISO.Script after
echo,"Creating ISO: [%burnISO%] Folder size: %sizeFolder%"
insert
FileRename,%TargetDir%\%BootSect%,%TargetDir%\DummySect

FileRename,%TargetDir%\DummySect,%TargetDir%\%BootSect%

Peter

#213 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12707 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 14 May 2010 - 07:01 PM

FileRename,%TargetDir%\%BootSect%,%TargetDir%\DummySect

FileRename,%TargetDir%\DummySect,%TargetDir%\%BootSect%

Sorry!

Must be:
FileRename,%ISOSourceDir%\%BootSect%,%ISOSourceDir%\DummySect

FileRename,%ISOSourceDir%\DummySect,%ISOSourceDir%\%BootSect%

Peter

#214 carloscape

carloscape

    Frequent Member

  • Advanced user
  • 108 posts
  •  
    Honduras

Posted 07 June 2010 - 07:52 PM

Included Irfanview plugin is outdated, please update.

#215 patsch

patsch

    Silver Member

  • Advanced user
  • 785 posts
  •  
    Germany

Posted 08 June 2010 - 05:29 AM

there are no apps included in nativeEx_Win7 ... they are from Win7RescuePE but that project was not updated for a longer time. Please feel free to update for your own or to search the forum for a newer version of that app

edit..:: I see you also posted here: http://www.boot-land...?...st&p=101870

#216 carloscape

carloscape

    Frequent Member

  • Advanced user
  • 108 posts
  •  
    Honduras

Posted 08 June 2010 - 12:55 PM

Already did :) . I am having another issue however, the Nativeex Win7PE disc I built won't boot. The grub4dos menu appears and when you select Nativeex the installed OS runs. I haven't added any new files to the ones included on the download. Funny enough, the Win7RescuePE Project by psc posted by Holmes recently, works.

Since RescuePE has been discontinued, and this project (Nativeex) builds on and improves it. I would like for it to work properly. My only guess to what is wrong is that I haven't been able to download all the tools from the Nativeex Server.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users