Jump to content











Photo
* * * * * 1 votes

[NotActiveProject] Multi 7PEs


  • Please log in to reply
164 replies to this topic

#51 yahoouk

yahoouk

    Silver Member

  • .script developer
  • 518 posts

Posted 27 November 2009 - 02:56 PM

Hi Paraglider,

Thanks always for your reply.
I'll check when I arrive home. :)

YahooUK

#52 Zhang Heng

Zhang Heng

    Member

  • Members
  • 51 posts
  •  
    China

Posted 27 November 2009 - 08:43 PM

Some bug.

1.
In shell\0-explorer.script

classes.reg in Reg.7z include some wrong lines

at the bottom of the reg file, the clsid should be in hklm\wb-software\classes\clsid

not in hk_classes_root\....

2.
in build\1-copyfiles.script, line 34

"CommandFileCopy " seems to be a mistake.

3.

Copy nls should from installsrc,

if copied all nls from bootsrc, a chinese version failed boot.

#53 yahoouk

yahoouk

    Silver Member

  • .script developer
  • 518 posts

Posted 27 November 2009 - 09:58 PM

Thanks a lot, Zhang Heng. :)

Yes. Classes registries are wrong input into wb-hklm classes.
I've repaired just now.

If,ExistFile,%TargetDir%\Boot\Bootfix.bin,CommandFileDelete,%TargetDir%\Boot\BootFix.bin

This line is not error. intend to delete .bin file.

Copy nls files are need to be changed with some exact nls files.

Please give a time to do all be done and will upload soon.

B Regards,

YahooUK

#54 Zhang Heng

Zhang Heng

    Member

  • Members
  • 51 posts
  •  
    China

Posted 28 November 2009 - 05:07 AM

Thanks a lot, Zhang Heng. :)

Yes. Classes registries are wrong input into wb-hklm classes.
I've repaired just now.


This line is not error. intend to delete .bin file.

Copy nls files are need to be changed with some exact nls files.

Please give a time to do all be done and will upload soon.

B Regards,

YahooUK


but wb does not know "CommandFileDelete", is it just "FileDelete"?

#55 dera

dera

    Gold Member

  • .script developer
  • 1335 posts
  •  
    Hungary

Posted 28 November 2009 - 08:06 AM

i think there is no such script command: "CommandFileDelete",
at least for me such script line doesn't delete the file

#56 yahoouk

yahoouk

    Silver Member

  • .script developer
  • 518 posts

Posted 28 November 2009 - 01:00 PM

i think there is no such script command: "CommandFileDelete",
at least for me such script line doesn't delete the file


Thanks dera and Zhang Heng.
Yes, that is totally wrong command for WB. :) which I recornised from my bad memory. :thumbup: or I was mad. :rofl:
I copied this command from somewhere for other projects which I can't remember.

I'll change it and upload in next upload.

I've replaced DaRT65.script included erdlogon.bat and uploaded.

BTW, I've found nls files which explained exact language in this forum few days ago, but I can't search now. Can any one point me out, please? Thanks.

B Regards,

YahooUK

#57 Zhang Heng

Zhang Heng

    Member

  • Members
  • 51 posts
  •  
    China

Posted 28 November 2009 - 02:42 PM

Thanks dera and Zhang Heng.
Yes, that is totally wrong command for WB. :) which I recornised from my bad memory. :thumbup: or I was mad. :rofl:
I copied this command from somewhere for other projects which I can't remember.

I'll change it and upload in next upload.

I've replaced DaRT65.script included erdlogon.bat and uploaded.

BTW, I've found nls files which explained exact language in this forum few days ago, but I can't search now. Can any one point me out, please? Thanks.

B Regards,

YahooUK

Oh, it was me.

I deleted it.

In current script, just copy all nls from bootsrc,

We dont need to select some nls to save space.

#58 acus

acus

    Member

  • Members
  • 37 posts
  •  
    Italy

Posted 28 November 2009 - 06:39 PM

@yahoouk,

thanks for sharing the script for dart65.
But also the new version does not contain the file erdlogon.bat

regards

#59 yahoouk

yahoouk

    Silver Member

  • .script developer
  • 518 posts

Posted 28 November 2009 - 07:36 PM

Referrence into DaRT65.7z, please.

Thanks,

YahooUK

#60 acus

acus

    Member

  • Members
  • 37 posts
  •  
    Italy

Posted 28 November 2009 - 10:09 PM

@yahoouk

sorry again,
i've downloaded the script and unzipped it. There is a folder tree, some text files and ERDlogon.exe.
I've looked also the attachment, but i've found only the file DaRT65.vbs.

Regards

#61 yahoouk

yahoouk

    Silver Member

  • .script developer
  • 518 posts

Posted 28 November 2009 - 11:24 PM

Yes, I've checked it. Unfortunately, there is still old file.
Now, I've uploaded again.

Erdlogon.bat:
cmd.exe /c "x:\windows\system32\erdlogon.exe "x:\sources\recovery\tools\MSDartTools.exe""


Put it in system32 folder. That's it.

B Regards,

YahooUK

#62 acus

acus

    Member

  • Members
  • 37 posts
  •  
    Italy

Posted 29 November 2009 - 07:55 AM

@yahoouk

thanks for your collaboration

regards

#63 paraglider

paraglider

    Gold Member

  • .script developer
  • 1705 posts
  • Location:NC,USA
  •  
    United States

Posted 29 November 2009 - 12:47 PM

Don't see the point of the vbs script or the batch file. I just added this to the script:
If,ExistFile,%TargetDir%\Sources\Recovery\Tools\MSDartTools.exe,Add_Shortcut,StartMenu,"MS-DART 6",%SystemRoot%\System32\ERDLogon.exe,"MS-DART Tools",,#$pSystemDrive#$p\Sources\Recovery\Tools\MSDartTools.exe,#$pSystemDrive#$p\Sources\Recovery\Tools\MSDartTools.exe If,ExistFile,%TargetDir%\Program Files\Standalone System Sweeper\mpam-fe.exe,Add_Shortcut,StartMenu,"MS-DART 6",#$pSystemDrive#$p\Program Files\Standalone System Sweeper\mpam-fe.exe,"Standalone System Sweeper" If,ExistFile,%Target_Sys%\COMPMGMT.exe,Add_Shortcut,StartMenu,"MS-DART 6",%SystemRoot%\System32\ERDLogon.exe,"Computer Management",,"#$q%SystemRoot%\System32\COMPMGMT.exe#$q",%SystemRoot%\System32\COMPMGMT.exe If,ExistFile,%Target_Sys%\CrashAnalyze.exe,Add_Shortcut,StartMenu,"MS-DART 6",%SystemRoot%\System32\ERDLogon.exe,"Crash Analyzer",,"#$q%SystemRoot%\System32\CrashAnalyze.exe#$q",%SystemRoot%\System32\CrashAnalyze.exe If,ExistFile,%Target_Sys%\DiskCmdr.exe,Add_Shortcut,StartMenu,"MS-DART 6",%SystemRoot%\System32\DiskCmdr.exe,"Disk Commander" If,ExistFile,%Target_Sys%\DiskWipe.exe,Add_Shortcut,StartMenu,"MS-DART 6",%SystemRoot%\System32\DiskWipe.exe,"Disk Wipe" If,ExistFile,%Target_Sys%\erddiskpart.exe,Add_Shortcut,StartMenu,"MS-DART 6",%SystemRoot%\System32\ERDLogon.exe,"Disk Partitioner",,"#$q%SystemRoot%\System32\erddiskpart.exe#$q",%SystemRoot%\System32\erddiskpart.exe If,ExistFile,%Target_Sys%\ErdHelp.exe,Add_Shortcut,StartMenu,"MS-DART 6",%SystemRoot%\System32%\ERDLogon.exe,"Help",,"#$q%SystemRoot%\System32\ErdHelp.exe#$q",%SystemRoot%\System32\ErdHelp.exe If,ExistFile,%Target_Sys%\ErdRegedit.exe,Add_Shortcut,StartMenu,"MS-DART 6",%SystemRoot%\System32\ERDLogon.exe,"Registry Editor",,"#$q%SystemRoot%\System32\ErdRegedit.exe#$q",%SystemRoot%\System32\ErdRegedit.exe If,ExistFile,%Target_Sys%\FileRestore.exe,Add_Shortcut,StartMenu,"MS-DART 6",%SystemRoot%\System32\FileRestore.exe,"File Restore", If,ExistFile,%Target_Sys%\FileSearch.exe,Add_Shortcut,StartMenu,"MS-DART 6",%SystemRoot%\System32\FileSearch.exe,"File Search" If,ExistFile,%Target_Sys%\HotfixUninstall.exe,Add_Shortcut,StartMenu,"MS-DART 6",%SystemRoot%\System32\ERDLogon.exe,"Hotfix Uninstall",,"#$q%SystemRoot%\System32\HotfixUninstall.exe#$q",%SystemRoot%\System32\HotfixUninstall.exe If,ExistFile,%Target_Sys%\Locksmith.exe,Add_Shortcut,StartMenu,"MS-DART 6",%SystemRoot%\System32\ERDLogon.exe,"Locksmith",,"#$q%SystemRoot%\System32\Locksmith.exe#$q",%SystemRoot%\System32\Locksmith.exe If,ExistFile,%Target_Sys%\SfcScan.exe,Add_Shortcut,StartMenu,"MS-DART 6",%SystemRoot%\System32\ERDLogon.exe,"SFC Scan",,"#$q%SystemRoot%\System32\SfcScan.exe#$q",%SystemRoot%\System32\SfcScan.exe If,ExistFile,%Target_Sys%\SolutionWizard.exe,Add_Shortcut,StartMenu,"MS-DART 6",%SystemRoot%\System32\ERDLogon.exe,"Solution Wizard",,"#$q%SystemRoot%\System32\SolutionWizard.exe#$q",%SystemRoot%\System32\SolutionWizard.exe If,ExistFile,%Target_Sys%\TcpCfg.exe,Add_Shortcut,StartMenu,"MS-DART 6",%SystemRoot%\System32\TcpCfg.exe,"TCP\IP Config"


#64 yahoouk

yahoouk

    Silver Member

  • .script developer
  • 518 posts

Posted 29 November 2009 - 03:47 PM

Thanks Paraglider.
For my point of view, I've just pointed to Main DartTools.exe and selected target dir as follow:
Pic 1 point to erdlogon.
DaRT0.jpg

Pic 2 point to target. And done.
DaRT1.jpg

But your shortcuts are more beautiful. (Unfortunately, I can't add Shortcuts in my 64bit one)

B Regards,

YahooUK

#65 Zhang Heng

Zhang Heng

    Member

  • Members
  • 51 posts
  •  
    China

Posted 02 December 2009 - 05:32 AM

Still one problem.

I plug a usb disk after the 7PE started.

The drive letter does not show in MyComputer.

But I can access the drive in cmd, and also the device can be found in device manager and disk management.

Is there any solution?

Thanks

#66 yahoouk

yahoouk

    Silver Member

  • .script developer
  • 518 posts

Posted 02 December 2009 - 10:21 AM

Still one problem.

I plug a usb disk after the 7PE started.

The drive letter does not show in MyComputer.

But I can access the drive in cmd, and also the device can be found in device manager and disk management.

Is there any solution?

Thanks


Me too, :clap: I'll find out if I've a time.
This might be the driver was'nt installed for PCI to USB RootHubs.
Try to reload PCI drivers.

Thanks for your feedback.

YahooUK

#67 Zhang Heng

Zhang Heng

    Member

  • Members
  • 51 posts
  •  
    China

Posted 03 December 2009 - 02:36 PM

Me too, :clap: I'll find out if I've a time.
This might be the driver was'nt installed for PCI to USB RootHubs.
Try to reload PCI drivers.

Thanks for your feedback.

YahooUK

I don't think it due to the driver.

Because in device manager, the USB device and USB hub installed correctly.

Actually, when I build on vistape, I found the usb device cannot be installed correctly, so I copied all drivers, infs, and the whole driverstore from bootsrc, the problem solved.

I copied all drivers from bootsrc in 7pe, but the drive letter cannot be showed in explorer.

And the usb drive can be accessed in cmd as normal.

I think there must be some services or other daemons to refresh the access entry in explorer.

#68 dera

dera

    Gold Member

  • .script developer
  • 1335 posts
  •  
    Hungary

Posted 03 December 2009 - 04:03 PM

I think there must be some services or other daemons to refresh the access entry in explorer.

i think so
that is why i prefer the PE Shell Swapper
i can restart the shell
after restarting the explorer shell the drive letter is assigned to the USB

#69 yahoouk

yahoouk

    Silver Member

  • .script developer
  • 518 posts

Posted 05 December 2009 - 11:49 AM

You both are correct.
I thought that would relate to Shell Hardware Detect service but NO.
Refleshing PEShell is simple and only way at the moment.
Or use thirtparty tools. (USBDLM or MountStorPE)
Sharing some images what I've done.
Pic 1. PEShell swapper is working.
PEShell.JPG

Pic 2. RightClickContextMenu is working. (Copy to, Move to, Manage, Services, DeviceManager, RegistryEditor, TaskManager)
RightClick.JPG

Pic 3. Desktoolsbar is working.
Desktop.JPG

I'm thinking less people is intrested in this project. I'll stop it after final upload.

B Regards,

YahooUK

#70 Lancelot

Lancelot

    Frequent Member

  • .script developer
  • 5013 posts
  • Location:Turkiye/Izmir
  • Interests:*Mechanical stuff and Physics,
    *LiveXP, BartPE, SherpyaXPE,
    *Basketball and Looong Walking,
    *Buying outwear for my girlf (Reason: Girls are stupid about buying bad stuff to make themselves uglier :))
    *Girls (Lyric: Girl,...., You will be a womann, Soon)
    *Answering questions for "Meaning of life",
    *Helping people,

    Kung with LiveXP, Fu with Peter :)
  •  
    Turkey

Posted 05 December 2009 - 11:55 AM

I'm thinking less people is intrested in this project. I'll stop it after final upload.

Please don't, From my personal experience active users (who posts on topics) around boot-land is very low numbered compared with the number of boot-land users who comes to keep up to date. :thumbsup:
Personally I wait for your capi integration to introduce a new (currently developing) script :whistling:

#71 dera

dera

    Gold Member

  • .script developer
  • 1335 posts
  •  
    Hungary

Posted 05 December 2009 - 12:03 PM

i am sorry to hear this

Please don't

I second this

regarding drive letter assigned to the USB
for me e.g. Total Commander or Cubic Explorer can see the drive letter without restarting via PE Shell Swapper,
also e.g. 'explorer /e,' works

#72 was_JFX

was_JFX

    Frequent Member

  • Advanced user
  • 483 posts
  •  
    Germany

Posted 05 December 2009 - 12:19 PM

I'm thinking less people is intrested in this project. I'll stop it after final upload.

:thumbsup: I am trying to make WOW64 script, for your nice project. :whistling:

Please let me know, if this is no longer needed :thumbup:

#73 yahoouk

yahoouk

    Silver Member

  • .script developer
  • 518 posts

Posted 05 December 2009 - 01:25 PM

:thumbsup: I am trying to make WOW64 script, for your nice project. :whistling:

Please let me know, if this is no longer needed :thumbup:


Thanks for your offer. I'd like to ask you one thing.
For what?

I've wow64 script support most 32 progs and now PEShell swapper is supported.

YahooUK

#74 yahoouk

yahoouk

    Silver Member

  • .script developer
  • 518 posts

Posted 05 December 2009 - 01:29 PM

Please don't, From my personal experience active users (who posts on topics) around boot-land is very low numbered compared with the number of boot-land users who comes to keep up to date. :thumbsup:
Personally I wait for your capi integration to introduce a new (currently developing) script :whistling:


OK, I'll upload with CAPI in final one.
Wow script is calling a huge list of files and reg.
PEiso size became over 500mb. I don't think it is worth for a PE.
How do you think?

Thanks.

YahooUK

#75 was_JFX

was_JFX

    Frequent Member

  • Advanced user
  • 483 posts
  •  
    Germany

Posted 05 December 2009 - 01:40 PM

Thanks for your offer. I'd like to ask you one thing.
For what?

I've wow64 script support most 32 progs and now PEShell swapper is supported.

I've only readed first post:

In the other hand, from 64 bit PE does not support 32bit programs like in real 64bit installed machine.

Very good you already have a script :thumbsup:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users