Jump to content











Photo
- - - - -

Multiboot ISO Maker


  • Please log in to reply
78 replies to this topic

#1 skyide

skyide

    Frequent Member

  • Advanced user
  • 218 posts
  •  
    Australia

Posted 02 November 2009 - 09:05 PM

Hi everyone,

Multiboot ISO Maker (freeware) is an unrestrained graphical front end for mkisofs for Windows and a multiboot ISO creator. It supports all mkisofs options and it is aimed at people who know what mkisofs is and what is not. It is unrestrained because it supports all mkisofs options without any limits and you are not restrained to the bundled version of mkisofs. Multiboot ISO Maker works by placing all mkisofs options in a check list. You can activate and deactivate any mkisofs option by clicking on the item in the list.

Activated mkisofs options are bold so you can distinguish which option is active and which is not. On the right there is a filter box that lets you do a search for mkisofs options in real time. With every option there is associated help text (help text will change) that corresponds to each mkisofs option. The help text appears as a hint/balloon as soon as you hover with mouse over an option. All of options are organized in ascending order.

When you are ready to build the project all you have to do is press the "Build" button on the toolbar. You can also click on the Config File tab to add menu entries to your config file. Multiboot ISO Maker supports multiple projects so you are not restrained to one project. If you've used mkisofs before, you will find Multiboot ISO Maker as a very convenient tool (well I do ;))

This is a very early alpha release and although while testing this latest version, I did not find any errors, no software is error free. If you find something wrong, it would not have been done intentionally.

Please do not replace the bundled mkisofs.exe yet. Although it is possible, there are a few gothchas and should there be an error, it would be hard to track down if you replace the bundeled version. For now, for testing purposes please use the one included and then I will give clear instructions how to replace mkisofs.exe with your own version and what you need to do.


Latest release is: Alpha 7:

Screenshot: http://www.techopini...s/alpha7-01.png
Download: http://www.techopini...lpha_07_R01.zip


Feedback is welcome :lol:

#2 amalux

amalux

    Platinum Member

  • Tutorial Writer
  • 2813 posts
  •  
    United States

Posted 02 November 2009 - 09:35 PM

Hi skyide :lol:

This looks very nice, thank you for sharing! I'll be playing with it as soon as I get some time ;)

Oh, welcome to the forum ;)

#3 skyide

skyide

    Frequent Member

  • Advanced user
  • 218 posts
  •  
    Australia

Posted 03 November 2009 - 03:44 AM

Thank you amalux.

*** To everyone that has downloaded Alpha 1 ***

A critical bug has been found and fixed and Alpha 2 is now available (same download link).

If you have already downloaded Alpha 1, please download Alpha 2. The error is severe and it causes the program to abnormally exit (with an error message that I did not type thrown at you before it exits). You can reproduce the error my moving the mouse pointer to the bottom of the main list. An invalid option index is generated when you move the mouse at the bottom of the list confusing the program and causing it to abnormally exit. The option index is needed to retrieve the help text associated with the option. The error is fixed and Alpha 2 is ready.

#4 Lancelot

Lancelot

    Frequent Member

  • .script developer
  • 5013 posts
  • Location:Turkiye/Izmir
  • Interests:*Mechanical stuff and Physics,
    *LiveXP, BartPE, SherpyaXPE,
    *Basketball and Looong Walking,
    *Buying outwear for my girlf (Reason: Girls are stupid about buying bad stuff to make themselves uglier :))
    *Girls (Lyric: Girl,...., You will be a womann, Soon)
    *Answering questions for "Meaning of life",
    *Helping people,

    Kung with LiveXP, Fu with Peter :)
  •  
    Turkey

Posted 03 November 2009 - 03:58 AM

Very much look like the winbuilder project I could never start,

Welcome to boot-land skyide , it is a nice entrance :lol:

#5 skyide

skyide

    Frequent Member

  • Advanced user
  • 218 posts
  •  
    Australia

Posted 03 November 2009 - 04:11 AM

Thanks Lancelot,

Just a note for everyone, when you start it up, make sure it is indeed labeled as Alpha 2. For some reason, my FF insists on downloading Alpha 1 and the download takes like 2 seconds. I think somehow it gets the file of its cache. Weird, if you have problems getting Alpha 2 using the link above, try this:

http://techopinion.n...bim-alpha-2.zip


Thanks,

#6 was_jaclaz

was_jaclaz

    Finder

  • Advanced user
  • 7100 posts
  • Location:Gone in the mist
  •  
    Italy

Posted 03 November 2009 - 06:04 PM

Some critics ;) (remember you actually asked for them :)):
  • the colour choices are AWFUL:
  • the "Parameters Value" written in white over very light blue is UNREADABLE :cheers:
  • same goes for "Option Filter"
  • same goes for "Active Options"
  • there is NO visible separator between the upper multitab window and the "Parameters Value" field/line
  • More generally the bright white background of windows tends to make unreadable the very thin blue font you use.
  • The CD-like icon (light blue on bright white background is barely visible).
  • When you click on:

    This option requitres an input parameter. Please enter your input input it here

    the pre-typed text should "go away" immediately (i.e. you shouldn't need to select the whole string and delete it in order to write the actual parameter, or at least if you double click on it, the whole string - as opposed to the single word - should get selected)
  • The "filter" in the search box "Start of each line"/"Anywhere online" gets more visibility (being at the top) than the actual textbox where you should type the "search" string (at the bottom): this is non-standard and innatural in any "search" app, you FIRST state WHAT you are looking for and THEN choose which option - if any - you want to apply to the search, since you have only two choices, the use of "radio buttons" (mutually exclusive) instead of a drop-down combo-box is advisable
  • You should give in the download at least one "test" project, a new user will be confused by the need to create one to start playing with the app.
  • The "build window with the message:

    Press the Build button when ready.

    is either unneeded or misleading: there is NO "Build" button, there is a "Build Selected Project" one, which of course doesn't make much sense either, I mean who would like to build an UNselected project? ;)
  • The "Config File" tab is misleading, if it's grub4dos based, it should be called menu.lst, if it's a isolinux project it should be called isolinux.cfg, etc. :), but I would personally prefer, instead of an integrated text editor with the (yet another time UNreadable light green on bright white of pseudo parsed commands - BTW why the strings "is" or "if" are parsed as if it were a parenthesis or a comma? ), a link to the actual menu.lst used so that I could open it in my preferred text editor.
  • In the "Project Properties" the "Volume ID" is NOT a property of th eproject, it is a pre-checked -V options of th ecommand line, this can confuse a newbie


Additional:
  • it would be nice, when you click on an already "checked" or "active" option (i.e. you make the line blue by clicking over it), the corresponding command line part in the actual command view becomes highlighted.


Besides the few trivialities above :cheers:, VERY good work! :)


:cheers:

jaclaz

#7 skyide

skyide

    Frequent Member

  • Advanced user
  • 218 posts
  •  
    Australia

Posted 03 November 2009 - 07:42 PM

Hi jaclaz,

Consider it done ;)

Give me a few hours, like 8 or so ;) I have to go to work first and I will do the requested changes once I get back.

A small note, I agree with everything you say except for point number 1 - Color Choices.

The color of the UI is currently based on Office 2007, what color would you rather want to see? I honestly ask, I will try the color you'd suggest and see how it looks . Should I make it gray? I think that's ugly and dated (<=Windows 2000 ). What's your opinion? In relation to the text borders you've mentioned, text labels, search location etc that's easy, it will take me a few seconds to a minute for each option etc....:cheers:

There is one other point I should add. The splitter bars that splits the sections are same color as the rest of the GUI (blue) thus making it harder to click/see.

In relation to config file section, would you prefer to rename the tab E.g: "Menu.lst", or "isoconfig.cfg" based on the project type or eliminate it completely? In relation to the the numbers in the config editor, I know what you are saying, this is a problem with the highlighter and I am already doing a research. This part though will take some time but I can completely disable the highlighter if that is ideal.....the comments at least are highlighted properly. There is more problems, I will also need to implement a full editor so I can support the syntax of major boot loader config scripts.....I am not sure if this ideal for thetype of project I am working on?

#8 was_jaclaz

was_jaclaz

    Finder

  • Advanced user
  • 7100 posts
  • Location:Gone in the mist
  •  
    Italy

Posted 03 November 2009 - 08:08 PM

1 - No hurry whatsoever :cheers: remember, this is FUN!
2 -I personally don't care much about the actual colours, as long as they are readable, i.e. there is adequate contrast between the font colour and the background. You can call it old as you wish, but the best readabilty is dark blue on light grey, black or blue on white is NO good as the bright white lessens readability -expecially when there is very little black or blue text in a relatively large window, ever wondered why AutoCAD uses colours on a BLACK background? ;)

E.g: "Menu.lst", or "isoconfig.cfg" based on the project type

Yes, as said that would be nice, but read below.

There is more problems, I will also need to implement a full editor so I can support the syntax of major boot loader config scripts.....I am not sure if this ideal for thetype of project I am working on?

That was part of what I tried suggesting, you have a bifurcation in front of you, I would personally use an already made Text editor, like Scite:
http://www.scintilla.org/SciTE.html
and (and this would be really a great thing to do) create a specific parser for it for the various loaders (grub4dos's .lst, syslinux/isolinux's .cfg, etc.) syntax.
This way the thing could be of more general use, a separate download, and so on.
Think at 7-zip in which in Options you can set which editor to use.
At this point the menu.lst/isolinux.cfg tab would be unneeded, you could show DATA\Grub4dos\<projectname>\ ( which is actually a directory) as a directory ;) and it's contents, in the top left "Projects" hierarchical view, adding a right click option of "EDIT..." to the editable files (menu.lst, isolinux.cfg, etc. only).

:)

jaclaz

#9 skyide

skyide

    Frequent Member

  • Advanced user
  • 218 posts
  •  
    Australia

Posted 04 November 2009 - 10:55 AM

Alpha 3 Released. Changes are listed below:

# the colour choices are AWFUL [Fixed, I hope, text is now black]
# the "Parameters Value" written in white over very light blue is UNREADABLE [fixed]
# there is NO visible separator between the upper multitab window and the "Parameters Value" field/line [fixed]
# More generally the bright white background of windows tends to make unreadable the very thin blue font you use. [pls refer to #1]
# When you click on....[fixed, also thx for the typo notification]
# The "filter" in the search box "Start of each line"/"Anywhere online....[fixed]
# The "build window with the message...[fixed]

# You should give in the download at least one "test" project [in progress]
# The CD-like icon...[in progress, searching for better 'free' icons, I am very bad @ art :cheers:]
# The "Config File" tab is misleading [in progress]
# it would be nice, when you click on an already "checked" (i.e. you make the line blue by clicking over it) [ok, I will see what I can do with this one, it will require some testing]

New:
+ The activated options are not only bold now + highlighted too! Color shaded orange to white..Check it out
+ Existing open projects are now detected
+ While fixing the search filter as per request, I detected a few bugs which would lead the search to misbehave. This is now fixed.

Alpha 3 screenshot with all of the new features including the highlighted active options: http://techopinion.n...bim-alpha-3.png

Download: http://techopinion.n...bim-alpha-3.zip

More feedback is welcome, I hope you guys are happy with the changes.

Cheers,

#10 skyide

skyide

    Frequent Member

  • Advanced user
  • 218 posts
  •  
    Australia

Posted 05 November 2009 - 12:27 PM

Alpha 3 - Build 004 available.

- After I made the option highlighted and added a detection of open projects (so you don't open them twice), a few bugs were introduced - FIXED
- Sometimes the Active Options would raise an "Index Out Of Bounds" messaged - FIXED
- Double clicking on a check box in the main items caused the command string not to be built regardless whether the check box item was clicked or not - FIXED
+ The little CD icons on the project view are now gray and are much easier to spot [NEW]

Alpha 4 To Do:

- Eliminate config file section -- will let the user define a custom editor of choice
- Add "Make Windows Bootable CD" - this will not make a rescue disk, it will instead re-package the contents of an existing non-bootable Windows CD and make it bootable.
+ Some of the remaining features requested above

Alpha 4 ETA: Hopefully by the end of the week depending on time.

Download: http://techopinion.n...bim-alpha-3.zip

P.S. If you are using FF, you may need to download this from a different browser as FF may re-download a cached version (unless you clear your cache) and give you the old build instead. To find out if you have the latest build, go to the about box and look at the build number, it should say 004 + you will know you have the old build if it takes 2 seconds to download. I am not sure why this happens on my FF, it could be a bug. It should always get the latest of the server.


Alpha 3 Released. Changes are listed below:

# the colour choices are AWFUL [Fixed, I hope, text is now black]
# the "Parameters Value" written in white over very light blue is UNREADABLE [fixed]
# there is NO visible separator between the upper multitab window and the "Parameters Value" field/line [fixed]
# More generally the bright white background of windows tends to make unreadable the very thin blue font you use. [pls refer to #1]
# When you click on....[fixed, also thx for the typo notification]
# The "filter" in the search box "Start of each line"/"Anywhere online....[fixed]
# The "build window with the message...[fixed]

# You should give in the download at least one "test" project [in progress]
# The CD-like icon...[in progress, searching for better 'free' icons, I am very bad @ art :dubbio:]
# The "Config File" tab is misleading [in progress]
# it would be nice, when you click on an already "checked" (i.e. you make the line blue by clicking over it) [ok, I will see what I can do with this one, it will require some testing]

New:
+ The activated options are not only bold now + highlighted too! Color shaded orange to white..Check it out
+ Existing open projects are now detected
+ While fixing the search filter as per request, I detected a few bugs which would lead the search to misbehave. This is now fixed.

Alpha 3 screenshot with all of the new features including the highlighted active options: http://techopinion.n...bim-alpha-3.png

Download: http://techopinion.n...bim-alpha-3.zip

More feedback is welcome, I hope you guys are happy with the changes.

Cheers,



#11 was_jaclaz

was_jaclaz

    Finder

  • Advanced user
  • 7100 posts
  • Location:Gone in the mist
  •  
    Italy

Posted 05 November 2009 - 03:28 PM

I can see very nice progresses. :(

The "white text over light blue" is still "white" and unreadable. :thumbup: Maybe some settings on my particular machine? :thumbup:

It would be nice if you could put somewhere something to switch "contextual baloon help on and off", it's nice but if one already knows about the command it's obnoxious/unneeded.

There is something "wrong"on the search line, when you open the app the "Start of line" is selected by default, since first character on any line is - (minus sign), if one types (example) "hide" the search returns nothing, then user realizes he should click on "Anywhere on line" and the search is not refreshed, and he needs to re-type "hide".

I tried opening TWO projects at the same time, and notwithstanding which one I selected in top left window (presumably the highlighted one is the "active" one) changes I made were applied to BOTH projects. :w00t:

There is a "logical failure":
  • when you "create a new project" you actually create a folder with the given name, as an example \GRUB4DOS\test\
  • when you "open an existing project" you actually have to point to the \GRUB4DOS\test\test.grub4dos file

Clicking on the checkboxes in middle window is "queer": there should be only two states ON/OFF, Checkhed/UNchecked, it seems like when you click there are other "states" of the control and you often have to click on the checkbox more than one time to revert it's state.

:thumbup:

jaclaz

#12 skyide

skyide

    Frequent Member

  • Advanced user
  • 218 posts
  •  
    Australia

Posted 05 November 2009 - 07:32 PM

Hi jaclaz,

The "white text over light blue" is still "white" and unreadable. unsure.gif Maybe some settings on my particular machine?


Hmm I am not sure what you mean? Unless a typo with the settings, I would never put bright text on bright background, it is silly. I do not see any white text? Would you mind attaching a screenshot? I really don't see white text over here. Also the original purple text on the tabs, I got this idea from the MS' ribbon style UI. If you open Word 2007 you will see they use purple text on the ribbons.

It would be nice if you could put somewhere something to switch "contextual baloon help on and off", it's nice but if one already knows about the command it's obnoxious/unneeded.


I expected someone to ask this. Not a problem.

There is something "wrong"on the search line, when you open the app the "Start of line" is selected by default, since first character on any line is - (minus sign), if one types (example) "hide" the search returns nothing, then user realizes he should click on "Anywhere on line" and the search is not refreshed, and he needs to re-type "hide".


Ok when you select "Start Of Line", in order for you to search, you must also include the "-" dash. The user input including the "-" is also searched. If you just type in "hide", "start of line" will not work because you have not typed "-" in front. Is this a silly behavior? Do you think I should make it search without the "-" when "Start of Line" is selected? You see, I made "Start of Line" mean exactly that) "Start of Line" and this includes the dash.


Clicking on the checkboxes in middle window is "queer": there should be only two states ON/OFF, Checkhed/UNchecked, it seems like when you click there are other "states" of the control and you often have to click on the checkbox more than one time to revert it's state.


Do you mean clicking on a check box, does not actually put a mark on a check box? If yes, check your mouse settings in Control Panel. Is it set to "Enhance Pointer Precision" as I have never seen this problem. If you are referring to something else though, for example, clicking on a check box, the line does not always reflect the check box state, for example, the line became bold but the checkbox is unchecked, please try the latest build Alpha 3 004 which already addresses this issue.

As in for both of the projects being updated, check 004 again, I will see if I can reproduce the issue later. If you can reproduce the issue, please list the steps as I did not see this issue over here. 004 fixes a few bugs with clicking on projects. Yes, the highlighted is the selected project.

Cheers,

#13 was_jaclaz

was_jaclaz

    Finder

  • Advanced user
  • 7100 posts
  • Location:Gone in the mist
  •  
    Italy

Posted 05 November 2009 - 08:33 PM

Here is the screenshot.

Please do re-read my previous report.

Text:
  • "Parameters Value"
  • "Option Filter"
  • "Active Options"
looks pretty whitish to me :w00t:

The point I addressed about the "search" is that when you click on the radio button to switch from (default) "Start of Line" to "Anywhere on line" test ALREADY typed in the box is NOT parsed (you need something like a refresh when the state of the radio buttons changes), try doing EXACTLY the following:

when you open the app the "Start of line" is selected by default, since first character on any line is - (minus sign), if one types (example) "hide" the search returns nothing, then user realizes he should click on "Anywhere on line" and the search is not refreshed, and he needs to re-type "hide"

and you will see.

Same goes for the "selected" project, it simply does not work all opened projects get the SAME contents.

Same goes for mouse clicking, to be more precise, rest assured my mouse works perfectly :(: when you click on one line sometimes the checkboxes on OTHER lines vanish or the checkbox appears like being half filled with blue, see the screenshot and compare what is actually checked and appears on the command line and which lines in the middle window have a check mark ....:thumbup:


:thumbup:

jaclaz

Attached Thumbnails

  • mbim.jpeg


#14 skyide

skyide

    Frequent Member

  • Advanced user
  • 218 posts
  •  
    Australia

Posted 05 November 2009 - 11:09 PM

oh I see, that is so weird, I don't get it like that on Windows 7.

http://techopinion.n...bim-alpha-3.png

May I know what Windows OS you are running pleasse?

I will have to check this out

#15 skyide

skyide

    Frequent Member

  • Advanced user
  • 218 posts
  •  
    Australia

Posted 05 November 2009 - 11:14 PM

Ok I have also seen you are running an old build. The latest one is 004. I know this because in 004 the CD icons are gray. Can you please check whether you get the error in relation to the project clicking in 004? I did some changes in code and it might have been related.

oh I see, that is so weird, I don't get it like that on Windows 7.

http://techopinion.n...bim-alpha-3.png

May I know what OS are you running pleasse?

I will have to check this out



#16 was_jaclaz

was_jaclaz

    Finder

  • Advanced user
  • 7100 posts
  • Location:Gone in the mist
  •  
    Italy

Posted 06 November 2009 - 08:35 AM

"plain" XP.

Where can I get the 004?

Or is it the one deftly named:
mbim-alpha-3.zip		05-Nov-2009 23&#58;06  1.9M
:(

No, that is the one I have taken a screenshot of. :dubbio:

:thumbup:

jaclaz

#17 skyide

skyide

    Frequent Member

  • Advanced user
  • 218 posts
  •  
    Australia

Posted 06 November 2009 - 10:00 AM

Hi jaclaz,

Fortunately, I had XP Mode installed on my Windows 7 work station and I managed to re-produce your screenshot. Ouch this thing looks so ugly in XP classic! I fixed the major GUI inconsistencies with classic XP and I am working on the rest. See for your self. The following is using the classic XP look and no bright text on white background :thumbup:

http://techopinion.n...ages/testxp.png

Much better :( :thumbup: Sorry about the old one, I really missed that one. I never tested it with XP classic.....


As far as the download goes, it is the daily one and the link you posted is correct however if you are running FF, it might get you a cached version (build 003 or 2 etc) so try downloading it with IE or Opera | http://techopinion.n...bim-alpha-3.zip

P.S. In the screenshot above, you may have noticed I have relocated the command window and increased the space for "Active Options".


"plain" XP.

Where can I get the 004?

Or is it the one deftly named:

mbim-alpha-3.zip		05-Nov-2009 23&#58;06  1.9M
:dubbio:

No, that is the one I have taken a screenshot of. :(

:w00t:

jaclaz



#18 was_jaclaz

was_jaclaz

    Finder

  • Advanced user
  • 7100 posts
  • Location:Gone in the mist
  •  
    Italy

Posted 06 November 2009 - 10:49 AM

Really, don't want to seem picky (which actually I am :() but should you name releases something like:
  • mbim_Alpha_02_R01.zip
  • mbim_Alpha_03_R01.zip
  • mbim_Alpha_03_R02.zip
  • mbim_Alpha_03_R03.zip
  • mbim_Alpha_03_R04.zip
  • .....
like all the rest of the world does when developing an app, it may be a lot easier to "talk the same language". :thumbup:

An alternative may be using FOLDERS, like:

mbim\
mbim\Alpha\
mbim\Alpha\02\
mbim\Alpha\02\Release01\
etc., etc.


JFYI:
1) I normally know how to manage web cache
2) I use Opera: "The fastest browser on Earth" :dubbio:

However, besides naming different files with SAME name :thumbup:, do you also manage to "touch" their dates accordingly? :(

I can guarantee you that the file that is downloadable right now is:
mbim-alpha-3.zip		05-Nov-2009 23&#58;06  1.9M
it is exactly 2,004,506 bytes in size

:w00t:

jaclaz

#19 skyide

skyide

    Frequent Member

  • Advanced user
  • 218 posts
  •  
    Australia

Posted 06 November 2009 - 10:54 AM

Ok, as from now on, I will name them as you suggested and will leave all files on the server. Alpha_03_R05 is on the way and will also investigate the project manager (the issue you reported) and don't worry about being picky, I asked for feedback so thank you! :( Without your input, none of these issues would have been discovered so I do appreciate it.

Really, don't want to seem picky (which actually I am :thumbup:) but should you name releases something like:

  • mbim_Alpha_02_R01.zip
  • mbim_Alpha_03_R01.zip
  • mbim_Alpha_03_R02.zip
  • mbim_Alpha_03_R03.zip
  • mbim_Alpha_03_R04.zip
  • .....
like all the rest of the world does when developing an app, it may be a lot easier to "talk the same language". :w00t:

An alternative may be using FOLDERS, like:


JFYI:
1) I normally know how to manage web cache
2) I use Opera: "The fastest browser on Earth" :dubbio:

:(

jaclaz



#20 skyide

skyide

    Frequent Member

  • Advanced user
  • 218 posts
  •  
    Australia

Posted 06 November 2009 - 01:02 PM

ok jaclaz, I have re-produced the project explorer issue you reported. The problem seems to occur when you quickly switch between projects. This will be fixed. This is a tricky one though.

#21 skyide

skyide

    Frequent Member

  • Advanced user
  • 218 posts
  •  
    Australia

Posted 07 November 2009 - 09:32 PM

vAlpha_03_05 has been released. I took my time with this one but some of the issues reported required a lot of troubleshooting.

There is a good news and bad news.

The GOOD news:

# Issue with the project explorer has been fixed - clicking on a project works with multiple projects open
# White text on bright background when used with XP classic mode has been fixed
# Search filter's option clicking has been fixed (search is case sensitive, I will add an option to change this)
# The GUI now looks as intended to look even if you use XP classic skin except for the hints popup

BAD News:

There seems to be a problem with the way the check boxes are drawn on the screen when one is using a classic skin regardless if this is XP, Vista or Windows 7. When you move the mouse over a check box, you get the balloon popup hint telling you what the option does. However the text in the hint does not look as intended and the major one is when the hint hides while it is displayed over an actual "check box", the check box does not redraw itself and it will become dark blue, half-drawn or the whole area the hint was covering will not draw correctly. This does *not* happen when you use the skin mode of XP for example Luna. It only happens when you use classic mode. So far I have failed to find a solution for this problem and I am not sure which direction I should go to. I have a few options:

- Option 1: Ignore the problem as most people will be using a non classic mode (I'd like to think so)

- Option 2: Instead of showing the hint over the item where the mouse is, show it somewhere else such a corner edge or add a special text area where the help text will be shown when you move the mouse over an item

- Option 3: Replace the check list box with a more advanced excel/access like grid but this will require an enormous amount of coding as I will have to change *everything*


So jaclaz, if you don't mind, please test this in XP Luna or other theme you may have rather than classic mode. It would eliminate the GUI glitch describe above.

Download: http://techopinion.n...lpha_03_R05.zip

Cheers,

#22 skyide

skyide

    Frequent Member

  • Advanced user
  • 218 posts
  •  
    Australia

Posted 08 November 2009 - 06:27 AM

Well, I've chosen Option 3 (the Excel like look): http://techopinion.n...GridOptions.png <-- This is just a sample, it doesn't quite work yet so ignore the output in the command window.

This fixes all of the graphical issues reported earlier. If I find (and I hope I do) find a proper solution for the current one before I go any further with the new solution, I shall revert back to the original.

#23 was_jaclaz

was_jaclaz

    Finder

  • Advanced user
  • 7100 posts
  • Location:Gone in the mist
  •  
    Italy

Posted 08 November 2009 - 11:43 AM

Much better. :(

Just as a reminder:

There is a "logical failure":

  • when you "create a new project" you actually create a folder with the given name, as an example \GRUB4DOS\test\
  • when you "open an existing project" you actually have to point to the \GRUB4DOS\test\test.grub4dos file


Maybe you could use a modifying key to turn the contextual help on/off, like:
CAPS LOCK on = Contextual help displayed
CAPS LOCK off = Contextual help NOTdisplayed
SHIFT key pressed= Contextual help displayed until key is released

:dubbio:

:w00t:

jaclaz

#24 skyide

skyide

    Frequent Member

  • Advanced user
  • 218 posts
  •  
    Australia

Posted 08 November 2009 - 12:35 PM

I have "*good news.*"

I have successfully converted the whole thing in a string grid format and there are 4 sections. There are 4 columns: [option state] [option name][option description] [parameter value]

I think this is a lot more friendly than before + it works with all skins.

Check it out, it's very user friendly

http://techopinion.n...lpha_04_001.png

Alpha 4 Build 001 is out!

Download: http://techopinion.n...lpha_04_R01.zip

A few little glitches which will be fixed: You can't re-size the grid and the first column is labeled as 'N'.

I need feedback on this latest design please. I personally believe it's really good and I spent hours on it. The whole core has been re-written.


Maybe you could use a modifying key to turn the contextual help on/off, like:
CAPS LOCK on = Contextual help displayed
CAPS LOCK off = Contextual help NOTdisplayed
SHIFT key pressed= Contextual help displayed until key is released


Ok I will look at that next.

#25 was_jaclaz

was_jaclaz

    Finder

  • Advanced user
  • 7100 posts
  • Location:Gone in the mist
  •  
    Italy

Posted 08 November 2009 - 02:31 PM

I need feedback on this latest design please. I personally believe it's really good and I spent a hours on it. The whole core has been re-written.


It's MUCH better than any previous one. :thumbup:

If I may the "CHECKED" options are not easily visible: it would be nice if once an option is checked the background of the whole "N" cell changes colour, so that is easily detectable at first view.

An idea:
as soon as an option is checked it "floats" to the top of the list, i.e. the display gets:
[Start Checked options]
Option 1 (in alphabetical order)
Option 2 (in alphabetical order)
.....
Option n (in alphabetical order)
[End Checked options]
[Start UNchecked options]
Option 1 (in alphabetical order)
Option 2 (in alphabetical order)
.....
Option n (in alphabetical order)
[End UNchecked options]


Another idea. :w00t:

Now that you are into a Column/Lines design, it would be nice if clicking on the ccolumn header Items would become ordered by that column contents.
If this is possible, I would add 5th column with a "filter" possibility and a number of "presets".
What I am trying to say is that the number of options available with mkisofs is enormous, of those a large number are rarely or never used.
Since the idea of the app is to be a "helper" for less experienced users, we could have "filters" like:
  • Typical DOS
  • Typical Linux
  • Typical MAC
  • Typical Windows/PE
  • Hybrid
  • Advanced

Options like (just examples):
  • all the the -hfs ones
  • all the --osx ones
  • -icon-position

are VERY rarely used (please read as "never") by the "average Joe", thus filtering them out would remove some of the "noise" and make the use of the app much easier.

:dubbio:

jaclaz




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users