Jump to content











Photo
- - - - -

Since when does USB-Hotplug not work anymore?


  • Please log in to reply
12 replies to this topic

#1 MedEvil

MedEvil

    Platinum Member

  • .script developer
  • 7771 posts

Posted 19 October 2009 - 12:03 AM

Attached today for the first time in ages my USB Stick after bootup of NaughtyPE and it didn't show up like it used to do.

Since i remember that LiveXP has some Mounting program for USB-Sticks, i guess that Hotplug isn't working there anymore eighter. ?

Can someone maybe pinpoint, around when this stoped working?


;)

#2 Lancelot

Lancelot

    Frequent Member

  • .script developer
  • 5013 posts
  • Location:Turkiye/Izmir
  • Interests:*Mechanical stuff and Physics,
    *LiveXP, BartPE, SherpyaXPE,
    *Basketball and Looong Walking,
    *Buying outwear for my girlf (Reason: Girls are stupid about buying bad stuff to make themselves uglier :))
    *Girls (Lyric: Girl,...., You will be a womann, Soon)
    *Answering questions for "Meaning of life",
    *Helping people,

    Kung with LiveXP, Fu with Peter :)
  •  
    Turkey

Posted 19 October 2009 - 01:01 AM

Is there a mounted hd in your tests?
with other words:
is there at least a C:\ drive on PE?

#3 MedEvil

MedEvil

    Platinum Member

  • .script developer
  • 7771 posts

Posted 19 October 2009 - 10:07 AM

Yes and no. On one computer there is one on another there wasn't.

;)

#4 Lancelot

Lancelot

    Frequent Member

  • .script developer
  • 5013 posts
  • Location:Turkiye/Izmir
  • Interests:*Mechanical stuff and Physics,
    *LiveXP, BartPE, SherpyaXPE,
    *Basketball and Looong Walking,
    *Buying outwear for my girlf (Reason: Girls are stupid about buying bad stuff to make themselves uglier :))
    *Girls (Lyric: Girl,...., You will be a womann, Soon)
    *Answering questions for "Meaning of life",
    *Helping people,

    Kung with LiveXP, Fu with Peter :)
  •  
    Turkey

Posted 19 October 2009 - 04:44 PM

if you are using xp as source:
+ with Livexp:
use bootsdi with one computer that do not have hd (use default: after download only enable bootsdi)
with one computer that have hd, no problem with any build method.

last time i check LiveXP with xp source, all working nice. (plugin ufd, plugout ufd, plugin ufd ==> get drive letter all the time...)

if you are using 2k3 source: all methods should be working on both pc. (not tested .)


Please inform your LiveXP test results.

#5 MedEvil

MedEvil

    Platinum Member

  • .script developer
  • 7771 posts

Posted 19 October 2009 - 05:01 PM

Ok, will run a test with LiveXP.
Would be nice if it's just a NaughtyPE problem. Much easier to fix if one of the Pe's is properly working. :cheers:

;)

#6 Lancelot

Lancelot

    Frequent Member

  • .script developer
  • 5013 posts
  • Location:Turkiye/Izmir
  • Interests:*Mechanical stuff and Physics,
    *LiveXP, BartPE, SherpyaXPE,
    *Basketball and Looong Walking,
    *Buying outwear for my girlf (Reason: Girls are stupid about buying bad stuff to make themselves uglier :))
    *Girls (Lyric: Girl,...., You will be a womann, Soon)
    *Answering questions for "Meaning of life",
    *Helping people,

    Kung with LiveXP, Fu with Peter :)
  •  
    Turkey

Posted 19 October 2009 - 05:06 PM

just checked, LiveXP recommended will hopefully work for you.
Only enable bootsdi before big blue with xp source :cheers: (no win2k3 files etc. needed)

edit:
and use right version of winbuilder for livexp http://www.boot-land...?showtopic=6798 ;)

#7 MedEvil

MedEvil

    Platinum Member

  • .script developer
  • 7771 posts

Posted 19 October 2009 - 06:46 PM

Lancelot couldn't you just post in that topic which version is required, instead of that pick any version to download and then overwrite it with the right one?

:cheers:

#8 Lancelot

Lancelot

    Frequent Member

  • .script developer
  • 5013 posts
  • Location:Turkiye/Izmir
  • Interests:*Mechanical stuff and Physics,
    *LiveXP, BartPE, SherpyaXPE,
    *Basketball and Looong Walking,
    *Buying outwear for my girlf (Reason: Girls are stupid about buying bad stuff to make themselves uglier :))
    *Girls (Lyric: Girl,...., You will be a womann, Soon)
    *Answering questions for "Meaning of life",
    *Helping people,

    Kung with LiveXP, Fu with Peter :)
  •  
    Turkey

Posted 19 October 2009 - 06:51 PM

MedEvil, version number changes in time, methods stay the same :cheers: As a result, I dont change the topic, I only update winbuilder.exe on LiveXP server. ;)

#9 MedEvil

MedEvil

    Platinum Member

  • .script developer
  • 7771 posts

Posted 22 October 2009 - 01:04 PM

Ran a bunch of tests.

No PE, not Naughty, not Live, not Bart have working hotplug when no HDD like drive exists at bootup.
Rerunning HwPnP once the USB-Stick is connected solves this problem.
Seems a needed driver does not get loaded.

Why i initialy had this problem with a computer having a HDD is still a mystery, but couldn't be replicated.

:cheers:

#10 Lancelot

Lancelot

    Frequent Member

  • .script developer
  • 5013 posts
  • Location:Turkiye/Izmir
  • Interests:*Mechanical stuff and Physics,
    *LiveXP, BartPE, SherpyaXPE,
    *Basketball and Looong Walking,
    *Buying outwear for my girlf (Reason: Girls are stupid about buying bad stuff to make themselves uglier :))
    *Girls (Lyric: Girl,...., You will be a womann, Soon)
    *Answering questions for "Meaning of life",
    *Helping people,

    Kung with LiveXP, Fu with Peter :)
  •  
    Turkey

Posted 22 October 2009 - 02:34 PM

as i wrote before, have you tested by using 2k3 as source.

#11 MedEvil

MedEvil

    Platinum Member

  • .script developer
  • 7771 posts

Posted 22 October 2009 - 03:22 PM

No, i have no W2k3.
I also do not see how this can make any difference. It appearantly is a driver loading issue.
Writing the driver into the registry by default, should make it always work.

:cheers:

#12 Lancelot

Lancelot

    Frequent Member

  • .script developer
  • 5013 posts
  • Location:Turkiye/Izmir
  • Interests:*Mechanical stuff and Physics,
    *LiveXP, BartPE, SherpyaXPE,
    *Basketball and Looong Walking,
    *Buying outwear for my girlf (Reason: Girls are stupid about buying bad stuff to make themselves uglier :))
    *Girls (Lyric: Girl,...., You will be a womann, Soon)
    *Answering questions for "Meaning of life",
    *Helping people,

    Kung with LiveXP, Fu with Peter :)
  •  
    Turkey

Posted 22 October 2009 - 03:34 PM

I also do not see how this can make any difference.

so you havent tested xp source with bootsdi too which i wrote before.

Good luck. :cheers:

#13 MedEvil

MedEvil

    Platinum Member

  • .script developer
  • 7771 posts

Posted 22 October 2009 - 04:54 PM

I know english isn't your mother langugae, so let me rephrase what i wrote before.

[qoute]No PE, not Naughty, not Live, not Bart have working hotplug when no HDD like drive exists at bootup.[/quote]
HDD like drive, includes internal and external HDD, USB-Sticks and ramdisks.

:cheers:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users