Jump to content











Photo
- - - - -

Booting Opensolaris0906 LiveCD with grub4dos


  • Please log in to reply
1 reply to this topic

#1 Agent

Agent
  • Members
  • 7 posts
  •  
    Germany

Posted 09 October 2009 - 12:46 PM

Hi everybody,

I'm trying to boot the Opensolaris0906 Live CD from a FAT32 Partition where the ISO file is located.
Boot.ini is adjusted to boot grub4dos so this part is working fine already. (grldr & grldr.mbr are doing their part successfully)

I'm using the following menu.lst entry to boot the ISO

title Booting OpenSolaris 0906 LiveCD
find --set-root /location/of/the/iso/file.iso
map /location/of/the/iso/file.iso (0xff) || map --mem /location/of/the/iso/file.iso (0xff)
map --hook
chainloader (0xff)

The ISO is booting up and I get the Live CD Grub menu content showing up on the screen.
But choosing one of the menu entries end up in maintenance mode of Opensolaris.

Instead of (0xff) I already tried (hd32)
I also tried to copy the CD content to the Fat32 partition, booting than to freedos and starting grub4dos.
But due to 8.3 filename limitations some of the CD content is not displayed correctly. Filenames like 'x86.microroot' for example.

Any idea out there how to get a the iso content booting up correctly?

Cheers Agent

#2 was_jaclaz

was_jaclaz

    Finder

  • Advanced user
  • 7100 posts
  • Location:Gone in the mist
  •  
    Italy

Posted 09 October 2009 - 02:53 PM

Any idea out there how to get a the iso content booting up correctly?

Unfortunatley NOT. :hypocrite:

OpenSolaris is not exactly a "common" OS, and there are no reports AFAICR about it.

You should:
1) read this:
http://www.boot-land...?showtopic=8944
(just to make you aware of WHERE the problem is, aka in a missing driver for the .iso file in the OpenSolaris or in the parameters passed to it by the "default" GRUB menu.lst)
2) try by-passing the CD bootloader and directly chainloading the Opensolaris
3) Post the contents of the menu.lst inside the OpenSolaris .iso, there may be similarities with other known OS (Linux) that could possibly at least point you in the right direction

jaclaz




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users