Jump to content











Photo
* * * * * 3 votes

BOOTICE: a boot sector manipulation utility [v0.78 released!]


  • Please log in to reply
254 replies to this topic

#251 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 13493 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 20 May 2016 - 10:14 AM

@pasito
Two very different/separate questions.
#1 Sure it is possible to change the CODE in a MBR without changing the DATA in it, but this should not in any way affect a "data only" disk drive.
If you prefer when booting the CODE inside the MBR is read/executed (by the BIOS) whilst in a "data only" drive ony the data inside it (Disk Signature and Partition Table) is used.

#2 there is something that doesn't sound right with your report (or maybe it is only confusing and I cannot get it fully right). :unsure:
Anyway the sector size CANNOT normally be changed via software (and SHOULD NOT) be changed.
The disks are either NOT "identical" OR you are testing them differently OR *somehow* one of the two changed its behaviour (which I strongly doubt, but which still it is possible, at least in theory).
There are some USB "external cases" or "SATA-USB converters" that behave strangely, i.e. automagically convert 512 bytes devices to 4096 or viceversa, (whilst when directly SATA connected they use "native" sector size) if the disk drive is of the "new" (stupid) AF (or Advanced Format) kind.
Your drive(s) is/are seemingly:
https://community.wd...rnally/15580/10
AF (and thus use 4 kb sectors internally), it is entirely possible (though as said not "probable") that something in the disk drive firmware "recognizes" a particular partitioning pattern (or *whatever*) and turns off and on the internal translation from 4096 bytes/sector to 512 bytes sector, but it is more probable that the issue is with the USB to SATA bridge.

Normally an AF drive uses internally 4Kb sectors but exposes a translated 512 bytes geometry, we had a very similar issue here:
http://www.msfn.org/...ent-interfaces/
and now that I am re-checking that thread, I see that it is the EXACT SAME disk drive model :w00t: :ph34r:


Please take some time reviewing that thread on MSFN, JFYI at the time I came out with a specific workaround, NOT solution, here:
http://www.msfn.org/...ent-interfaces/

Then, please start a new thread, (the matter is not suited to this generic Bootice thread) here:
http://reboot.pro/fo...rmat-utilities/
and post there a copy of the MBR of the two disks and the oputput of the fsutil command like Dave-H did on MSFN.

Since you have two drives that behave differently, maybe this time we will be able to find an actual solution.

:duff:
Wonko

#252 Zoso_The_Internet_Tard

Zoso_The_Internet_Tard

    Silver Member

  • Advanced user
  • 527 posts
  • Interests:An investigation is underway to determine whether Trump has any ties to America.

Posted 20 May 2016 - 06:16 PM

I have sometimes had an issue with booticex64 (latest version) writing only zeroes when backing up my MBR. I ran the app from a Windows setup USB. I didn't discover this until later when restoring it, only to find that the PC wouldn't boot. My OSes were installed in legacy BIOS/MBR at the time. Luckily I had multiple backups. Any idea what may be causing this?



#253 pasito

pasito

    Newbie

  • Members
  • 15 posts
  • Location:Barcelona, Venezuela (jeje, not really)
  • Interests:SYS INFO:
    -XPsp3 x86, P4 530J 3GHz, 3GB Ram, ich6, Dell Dimension 4700
    -Internal SATA: 2xIntel SATA1 + 2xSATA3 ASMedia1061(PEG 16X)
    -OS: SATA1 80GB WinNT 5.x MBR, NTLDR boot record
  •  
    Venezuela

Posted 21 May 2016 - 02:31 AM

@wonko, @AnonVendetta

 

wow, thanks for yr replies! Got the warms n fuzzies, especially if my waywardness might actually result in utility if the forum able to ..follow up on the issue u mention wonko. Yeah, sounds like could b related to what Wonko said, and/or to my current half-assed unsupported semi-achi mode -blessed be Fernando 1 and his Forumula Alonso. And yr right, its a Sabrent usb-sata/ide/pata external bridge. Btw, it's not my typo but DeviceMgr does show the problem DriveID with "_01.0" while, as currently ported, the other driveID doesn't have that.

 

So yes, will repost question 2 as directed. With guidance I'm more than willing to run any tests etc to follow it through. Maybe i can help even if i'm a stooge who created this scenario inadvertantly via my original formatting, and only happened to reveal it by switching the drives' port connections around coincidentally right after walkin on thin bootice.



#254 pasito

pasito

    Newbie

  • Members
  • 15 posts
  • Location:Barcelona, Venezuela (jeje, not really)
  • Interests:SYS INFO:
    -XPsp3 x86, P4 530J 3GHz, 3GB Ram, ich6, Dell Dimension 4700
    -Internal SATA: 2xIntel SATA1 + 2xSATA3 ASMedia1061(PEG 16X)
    -OS: SATA1 80GB WinNT 5.x MBR, NTLDR boot record
  •  
    Venezuela

Posted 29 May 2016 - 12:05 AM

hey, I started requested thread regarding Advanced Format usb to sata bridge hdd sector size problem here.

 

But i can't edit my initial post to cut it off at the point where it gets quoted in the new thread. Pardon the interruption in the BootIce releases thread.



#255 NimaRB

NimaRB
  • Members
  • 1 posts
  •  
    Pakistan

Posted 28 January 2017 - 08:18 AM

Is there any complete tutorial available, how to use XorBoot UEFI 0.23 ?

I've used old version 0.63 it had an option 'Distribute' but in the new version its gone! :wacko:

Now how to write MBR of my multiboot USB to boot XorBoot Menu?

 

Please help...

Thanks! :)






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users