Jump to content











Photo
- - - - -

grub4dos booting ubuntu iso


  • Please log in to reply
33 replies to this topic

#1 mipstien

mipstien

    Newbie

  • Members
  • 10 posts
  •  
    United States

Posted 21 August 2009 - 05:36 PM

this has been discussed but i never seem to find an answer that works for me.
basically i have grub4dos installed and ubuntu 8.10 and 9.04 and i don't care which works just wanna get something started. i could use unetbootin but i have larger dreams here. anyways.
when i run grub4dos with this entry
title ubuntu

find --set-root /ubuntu.iso

map /ubuntu.iso (hd32)

map --hook

chainloader (hd32)

boot

it loads up to loading, please wait. . .
(initramfs)
and then hangs.
i have other issue's but i figure if i can get this running then ill deal with the other stuff later. i have been working with grub4dos for only a few days but it has been a constant thing for me for at least 48 hours now haha.
i also have another question about what the hd32 means....

#2 mipstien

mipstien

    Newbie

  • Members
  • 10 posts
  •  
    United States

Posted 21 August 2009 - 11:46 PM

after doing a lot more trial and error testing i still can't get it to move past the initramfs halt.
but i also don't understand why it halts there. is it because it loads something like the kernel and then doesn't let anything else load out of the iso file?

title ubuntu open

find --set-root /ubuntu/casper/vmlinuz

kernel /ubuntu/casper/vmlinuz file=ubuntu/preseed/ubuntu.seed boot=casper console-setup/variantcode=nodeadkeys quiet splash --

initrd /ubuntu/casper/initrd.gz
after un-isoing the ubuntu iso and using that code i get the same halt....

*sigh*

find --set-root /ubuntu/casper/initrd.gz

kernel /ubuntu/casper/vmlinuz boot=casper persistent rw splash

initrd /ubuntu/casper/initrd.gz

boot

found that in another thread and still does the same thing.... apparently im missing something...

#3 tsetya

tsetya

    Member

  • Advanced user
  • 52 posts
  •  
    Indonesia

Posted 24 August 2009 - 11:42 AM

for ubuntu/kubuntu 9.04 see here : http://www.boot-land...?...=5041&st=20

for my set up i use only this neccesarry command
title Ubuntu LiveCD

find --set-root /ubuntu.iso

map /ubuntu.iso (0xff)

map --hook

root (0xff)

kernel /casper/vmlinuz boot=casper iso-scan/filename=/ubuntu.iso

initrd /casper/initrd.gz

boot

where are you booting from? internal HD or USB?
if you boot from usb it may/may not work depend on your motherboard. it is not work on my mobo (ASUS P5Q). Ubuntu on USB work on my p5q only after updating kernel. May be you can try another distro that has newer kernel (perhaps Linuxmint7). you can use the same command ubuntu and linuxmint7.

#4 mipstien

mipstien

    Newbie

  • Members
  • 10 posts
  •  
    United States

Posted 24 August 2009 - 06:42 PM

thank you for your response!
ill work with it tonight a little more at work.

#5 mipstien

mipstien

    Newbie

  • Members
  • 10 posts
  •  
    United States

Posted 24 August 2009 - 10:11 PM

unfortunately that didn't work and it seemed to not get even as far as the other commands i posted.i am downloading linux mint right now and ill see how that works then.


update:
it does actually get a little further during the boot. the line it gets stuck on is
[	  11.215508] sd 2:0:0:0: attached scsi generic sg1 type 0


#6 mipstien

mipstien

    Newbie

  • Members
  • 10 posts
  •  
    United States

Posted 24 August 2009 - 10:52 PM

linux mint worked fine with that grub code. thank you for that. it fixxes part of my problems!

#7 mipstien

mipstien

    Newbie

  • Members
  • 10 posts
  •  
    United States

Posted 24 August 2009 - 11:50 PM

i feel a little dumb. after searching all day one day last week i couldn't find it and it was there in a pinned thread after reading every post i found a link to code that would boot ubuntu 9.04 live cd

title Ubuntu LiveCD

find --set-root /ubuntu-9.04-beta-desktop-i386.iso

map /ubuntu-9.04-beta-desktop-i386.iso (0xff)

map --hook

root (0xff)

kernel /casper/vmlinuz file=/cdrom/preseed/ubuntu.seed boot=casper iso-scan/filename=/ubuntu-9.04-beta-desktop-i386.iso quiet splash --

initrd /casper/initrd.gz

boot

thanks to user tinybit for posting this.

which was apparently in that post .... :D

#8 doveman

doveman

    Frequent Member

  • Advanced user
  • 414 posts
  • Location:Surrey
  •  
    United Kingdom

Posted 20 October 2009 - 02:35 AM

Has anyone got the Ubuntu 9.04 ISO working in VMware? I've tried all the variations suggested here and every time it stops at (initramfs). This is what I get exactly:

Booting command list

(cd)
Filesystem type is iso9660, using whole disk
[Linux-bzImage, setup=0x3000, size=0x353cd0]
[Linux-initrd @ 0x1f77c000, 0x763993 bytes]
[ 2.116611] powernow-k8: BIOS error - no PSB or ACPI _PSS objects
Loading, please wait...

BusyBox v1.10.2 (Ubuntu 1:1.10.2-2ubuntu7) built-in shell (ash)
Enter 'help' for a list of built-in commands.

(initramfs)

#9 shamurshamur

shamurshamur

    Frequent Member

  • Developer
  • 322 posts
  •  
    India

Posted 20 October 2009 - 08:57 AM

i feel a little dumb. after searching all day one day last week i couldn't find it and it was there in a pinned thread after reading every post i found a link to code that would boot ubuntu 9.04 live cd

title Ubuntu LiveCD

find --set-root /ubuntu-9.04-beta-desktop-i386.iso

map /ubuntu-9.04-beta-desktop-i386.iso (0xff)

map --hook

root (0xff)

kernel /casper/vmlinuz file=/cdrom/preseed/ubuntu.seed boot=casper iso-scan/filename=/ubuntu-9.04-beta-desktop-i386.iso quiet splash --

initrd /casper/initrd.gz

boot

thanks to user tinybit for posting this.

which was apparently in that post .... ;)



i have tried just now , working for me too!!
great work!!

#10 doveman

doveman

    Frequent Member

  • Advanced user
  • 414 posts
  • Location:Surrey
  •  
    United Kingdom

Posted 20 October 2009 - 03:37 PM

I tried the ubuntu 9.04 ISO directly in VMware and that boots fine. It's just if I try and boot the ISO from Grub4Dos that I have this problem.

#11 shamurshamur

shamurshamur

    Frequent Member

  • Developer
  • 322 posts
  •  
    India

Posted 20 October 2009 - 05:27 PM

I tried the ubuntu 9.04 ISO directly in VMware and that boots fine. It's just if I try and boot the ISO from Grub4Dos that I have this problem.

i have successfully booted ubuntu iso from grub4dos.
i have used this entry for ubuntu iso in grub4dos
title Ubuntu LiveCDfind --set-root /ubuntu-9.04-desktop-i386.isomap /ubuntu-9.04-desktop-i386.iso (0xff)map --hookroot (0xff)kernel /casper/vmlinuz file=/cdrom/preseed/ubuntu.seed boot=casper iso-scan/filename=/ubuntu-9.04-desktop-i386.iso quiet splash --initrd /casper/initrd.gzboot

what error mesage have you got ?post it here exactly as it appeared.

#12 doveman

doveman

    Frequent Member

  • Advanced user
  • 414 posts
  • Location:Surrey
  •  
    United Kingdom

Posted 20 October 2009 - 07:55 PM

i have successfully booted ubuntu iso from grub4dos.

what error mesage have you got ?post it here exactly as it appeared.


Have you done this in vmware?

The details of what happened are in post #8

#13 shamurshamur

shamurshamur

    Frequent Member

  • Developer
  • 322 posts
  •  
    India

Posted 20 October 2009 - 08:14 PM

yes i have tried that on vmware , running fine .

Following are the softwares i am using:
vmware workstation 6.5.3 build 185404 ( with virtual machine ram set to 512 MB)
ubuntu 9.04.iso
grub4dos-0.4.4 ( using the file 'grub.exe' to load menu.lst file)


the method is working fine without any problem ,
may be you can try changing the settings in vmware or make sure you are making the iso file right way.

#14 doveman

doveman

    Frequent Member

  • Advanced user
  • 414 posts
  • Location:Surrey
  •  
    United Kingdom

Posted 20 October 2009 - 11:38 PM

What bootloader are you using to run grub.exe? I'm booting the CD with grldr bootsector, although I don't think that should make any difference.

I tried with MobaLiveCD/QEMU and got much the same result:
Booting Ubuntu LiveCD



(cd)

Filesystem type is iso9660, using whole disk

[Linux-bzImage, setup=0x3000, size=0x353cd0]

[Linux-initrd @ 0x3f87c000, 0x763993 bytes]

[ 6.643196] pci 0000:00:01:0: PIIX3: Enabling Passive Release

Loading, please wait...



BusyBox v1.10.2 (Ubuntu 1:1.10.2-2ubuntu7) built-in shell (ash)

Enter 'help' for a list of built-in commands.



(initramfs)

I've double checked my entry and it looks OK:

title Ubuntu LiveCD

find --set-root /iso/ubuntu-9.04-desktop-i386.iso

map /iso/ubuntu-9.04-desktop-i386.iso (0xff)

map --hook

root (0xff)

kernel /casper/vmlinuz file=/cdrom/preseed/ubuntu.seed boot=casper iso-scan/filename=/ubuntu-9.04-desktop-i386.iso quiet splash --

initrd /casper/initrd.gz

boot


#15 shamurshamur

shamurshamur

    Frequent Member

  • Developer
  • 322 posts
  •  
    India

Posted 21 October 2009 - 07:35 AM

there's a problem in your entry.
look at this line
find --set-root /iso/ubuntu-9.04-desktop-i386.iso

your path of iso file is /iso/ubuntu-9.04-desktop-i386.iso

in this line
kernel /casper/vmlinuz file=/cdrom/preseed/ubuntu.seed boot=casper iso-scan/filename=/ubuntu-9.04-desktop-i386.iso quiet splash --

path of the iso file is /ubuntu-9.04-desktop-i386.iso ( it should be /iso/ubuntu-9.04-desktop-i386.iso )

you are specifying different path in both lines.

#16 doveman

doveman

    Frequent Member

  • Advanced user
  • 414 posts
  • Location:Surrey
  •  
    United Kingdom

Posted 21 October 2009 - 01:58 PM

Doh! Thanks so much for spotting that, it's finally working at last.

I don't think I would have ever spotted my mistake myself.

#17 shamurshamur

shamurshamur

    Frequent Member

  • Developer
  • 322 posts
  •  
    India

Posted 21 October 2009 - 02:35 PM

Doh! Thanks so much for spotting that, it's finally working at last.

I don't think I would have ever spotted my mistake myself.

cheers!!

#18 curio

curio

    Newbie

  • Members
  • 20 posts
  • Location:Italy
  •  
    Italy

Posted 02 November 2009 - 07:46 PM

i feel a little dumb. after searching all day one day last week i couldn't find it and it was there in a pinned thread after reading every post i found a link to code that would boot ubuntu 9.04 live cd

title Ubuntu LiveCD

find --set-root /ubuntu-9.04-beta-desktop-i386.iso

map /ubuntu-9.04-beta-desktop-i386.iso (0xff)

map --hook

root (0xff)

kernel /casper/vmlinuz file=/cdrom/preseed/ubuntu.seed boot=casper iso-scan/filename=/ubuntu-9.04-beta-desktop-i386.iso quiet splash --

initrd /casper/initrd.gz

boot

thanks to user tinybit for posting this.

which was apparently in that post .... :lol:


Does this settings work also for Ubuntu 9.10?
I tried it but I got the following error:
(hd0,1)

Filesystem type is ISO9660, using whole disk

[Linux-bzImage, setup 0x3400, size 0x3b226e0]

initrd /casper/initrd.gz

Error 15: File not found

Press any key to continue...


#19 was_jaclaz

was_jaclaz

    Finder

  • Advanced user
  • 7100 posts
  • Location:Gone in the mist
  •  
    Italy

Posted 02 November 2009 - 08:10 PM

Does this settings work also for Ubuntu 9.10?
I tried it but I got the following error:
....


Check this:
http://www.boot-land...?...=9391&st=10

Which Kernel does Ubuntu 9.10 use? :lol:

Post the syslinux.cfg or isolinux.cfg entry that normally works.

jaclaz

#20 AndreiV

AndreiV
  • Members
  • 8 posts
  •  
    Romania

Posted 03 November 2009 - 10:14 AM

Does this settings work also for Ubuntu 9.10?
I tried it but I got the following error:

(hd0,1)

Filesystem type is ISO9660, using whole disk

[Linux-bzImage, setup 0x3400, size 0x3b226e0]

initrd /casper/initrd.gz

Error 15: File not found

Press any key to continue...

Be careful,in Ubuntu 9.10, the initrd file has a lz extension, not gz. so the last line should be initrd /casper/initrd.lz

#21 curio

curio

    Newbie

  • Members
  • 20 posts
  • Location:Italy
  •  
    Italy

Posted 03 November 2009 - 03:39 PM

Be careful,in Ubuntu 9.10, the initrd file has a lz extension, not gz. so the last line should be initrd /casper/initrd.lz


GREAT, you are right!

#22 was_jaclaz

was_jaclaz

    Finder

  • Advanced user
  • 7100 posts
  • Location:Gone in the mist
  •  
    Italy

Posted 03 November 2009 - 04:31 PM

More generally, whenever experimenting with new menu.lst entries, do use grub4dos in command mode and it's [TAB] autocompletion features:
http://diddy.boot-la...iles/basics.htm
http://diddy.boot-la...s/files/cli.htm

jaclaz

#23 Guest_P4G0_*

Guest_P4G0_*
  • Guests

Posted 13 May 2010 - 02:37 PM

I've tested this with Ubuntu 9.10 Desktop and it work's generally fine. But it doesn't load the Preseed-File. Does that work for somebody?

[codebox]title Ubuntu 10.04 Desktop find --set-root /ubuntu/ubuntu-10.04-desktop-i386.iso map /ubuntu/ubuntu-10.04-desktop-i386.iso (hd32) map --hook root (hd32) kernel /casper/vmlinuz file=/cdrom/preseed/ubuntu.seed boot=casper iso-scan/filename=/ubuntu/ubuntu-10.04-desktop-i386.iso quiet splash -- initrd /casper/initrd.lz[/codebox] Can somebody tell me what the "--" is for at the end of the kernel-options? I couldn't see any differences when I remove that. And another question: is (hd32) an alias for (0xFF) oder is there any difference?

#24 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 14177 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 14 May 2010 - 08:06 AM

I don't think the "preseed" is "working":
http://www.boot-land...?...=5041&st=20

:cheers:
Wonko

#25 Wonneproppen

Wonneproppen

    Newbie

  • Members
  • 13 posts
  •  
    Germany

Posted 14 May 2010 - 08:28 AM

i found a way to boot Ubuntu 10.04 without an ISO. here is my configuration and works fantastic

title === Ubuntu 10.04 Live USB ===\n Start Ubuntu 10.4 Live USB
kernel /casper/vmlinuz file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz ignore_uuid live-media-path=/casper quiet splash -- locale=en_EN console-setup/layoutcode=en
initrd /casper/initrd.lz






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users