Jump to content











Photo
- - - - -

Error during building VistaPE ISO File


  • Please log in to reply
35 replies to this topic

#1 codera

codera

    Newbie

  • Members
  • 18 posts

Posted 16 August 2009 - 09:24 AM

Hello togehter

I try to build a VistaPE CD with Winbuilder

I installed on my XP Professional PC WinBuilder Version 0.76 (stable). After the installation of Winbuilder i copied the Source Files from my Vista DVD to my Harddisk.

Then i started the WinBuilder and download the required files.
I choose following Projects:
1. Updates.boot-land.net
2. vistape.net/project

I pressed the download Button and after the download i choose in the register "Source" the Source Directory of my Vista Source files.

Then i pressed the Button play and get following 2 errors.

1. Error
RegRead - Failed to read specified key from: [HKLM]Section: [SYSTEM\CurrentControlSet\Services\WimFltr] Key: [DisplayName] to variable:: [%RegName%]


2. Error
Run - Failed to find section [NotConfigured] in file: [%BaseDir%\Projects\VistaPE-Core\Base\00-api-main.script]


with best regards

Attached Files

  • Attached File  log.html   31.17KB   567 downloads


#2 paraglider

paraglider

    Gold Member

  • .script developer
  • 1729 posts
  • Location:NC,USA
  •  
    United States

Posted 16 August 2009 - 11:58 AM

There are several things to try to fix this:

1) Install the windows AIK. Note depending on which servce pack you are using on XP you may need to apply a windows hotfix included with the AIK. GO to www.microsoft.com and search for windows aik. Ugrading to SP2 or SP3 for XP should remove the need for the hotfix.

2) In the projects\tools subdirectory of winbuilder right click on wimfltr.inf from windows explorer and choose install

3) Run from the command line in the same directory as 2):

WimUtil Install


Legal Note: some of the files that the original Vistape let you download are illegal redistributions of MS files. Only legal way to obtain them is from the Windows AIK.

#3 JonF

JonF

    Gold Member

  • .script developer
  • 1185 posts
  • Location:Boston, MA
  •  
    United States

Posted 16 August 2009 - 01:34 PM

You may get better results by manually entering the server vistape.winbuilder.net on the download page (teeny button at the bottom right) and downloading the VistaPE-CAPI project. It's noticably updated from the vistape.net version.

The WAIK is required (absent any illegal redistributions such as wimutil), even if you are building from a Vista DVD. If you download the updated project there are links on the opening page to the WAIK downloads.

I think that the version you get from vistape.net does not include wimutil.exe but refferences to it have not been completely cleaned out.

#4 codera

codera

    Newbie

  • Members
  • 18 posts

Posted 16 August 2009 - 02:28 PM

You may get better results by manually entering the server vistape.winbuilder.net on the download page (teeny button at the bottom right) and downloading the VistaPE-CAPI project. It's noticably updated from the vistape.net version.

The WAIK is required (absent any illegal redistributions such as wimutil), even if you are building from a Vista DVD. If you download the updated project there are links on the opening page to the WAIK downloads.

I think that the version you get from vistape.net does not include wimutil.exe but refferences to it have not been completely cleaned out.



Hello JonF

can you send me please the URL of the server where i can download the VISTAPE Capi-Project. I can't find it.

Must i install the WAIK for Windows Vista on my XP (inkl. SP3) ??

#5 JonF

JonF

    Gold Member

  • .script developer
  • 1185 posts
  • Location:Boston, MA
  •  
    United States

Posted 16 August 2009 - 06:22 PM

an you send me please the URL of the server where i can download the VISTAPE Capi-Project. I can't find it.

It's not practical to access it other than through WinBuilder. Open WinBuilder, click "Download" at the top right. When things settle down, click the top one of the three icons at the bottom right and enter vistape.winbuilder.net. You will then get a VistaPE item in the left pane, and under that will be VistaPE-CAPI and VistaPE-Core. Don't bother with the latter, it's aging and soon to disappear.

Must i install the WAIK for Windows Vista on my XP (inkl. SP3) ??

Yes. It is the only legal way to obtain the required tools.

#6 codera

codera

    Newbie

  • Members
  • 18 posts

Posted 17 August 2009 - 03:04 AM

Hi JonF

I downloades the WAIK Version for Vista SP1 and installed it on my Computer with Windows XP Professional included SP3.

Then i downloaded the WinBuilder Version 077 RC 2 and add the entry for the Vista-Capi Module. (please look attach)

Is it correct when VistaPE-Core and VistaPE-CAPI
and Tools are marked? When i beginn the download it will stop by trying devcon.exe download. (please look attach)

I looket on the website ==> http://vistape.winbuilder.net/.
The devcon.exe is there, but you can't download the File with "right click". An other file example: 7z.dll is ok to download.

Can anybody help me please?

with best regards

codera

Attached Thumbnails

  • WinBuilder_1.jpg
  • WinBuilder_2.jpg


#7 paraglider

paraglider

    Gold Member

  • .script developer
  • 1729 posts
  • Location:NC,USA
  •  
    United States

Posted 17 August 2009 - 03:34 AM

Just ignore the error about devcon. That can only be legally downloaded from MS at:

http://support.microsoft.com/kb/311272

#8 JonF

JonF

    Gold Member

  • .script developer
  • 1185 posts
  • Location:Boston, MA
  •  
    United States

Posted 17 August 2009 - 11:08 AM

Yes, it's OK. My mistake. I'll fix it.

#9 codera

codera

    Newbie

  • Members
  • 18 posts

Posted 17 August 2009 - 12:04 PM

thanks a lot for the information. At what time is the fix available, so i can test it?

#10 JonF

JonF

    Gold Member

  • .script developer
  • 1185 posts
  • Location:Boston, MA
  •  
    United States

Posted 17 August 2009 - 12:11 PM

The fix is to remove devcon from the download page, and it's done. No effect on the project.

#11 codera

codera

    Newbie

  • Members
  • 18 posts

Posted 17 August 2009 - 12:40 PM

thanks for the information. If I understand it correct, i have to download devcon.exe from Microsoft Website before I build the ISO File. Should i copy the devcon.exe in the Tools Folder before i build the iso file?

#12 JonF

JonF

    Gold Member

  • .script developer
  • 1185 posts
  • Location:Boston, MA
  •  
    United States

Posted 17 August 2009 - 03:37 PM

No, if you don't have devcon.exe then the Basic Configuration and Tools script will download it for you, from the approved and legal Microsoft site.

#13 JonF

JonF

    Gold Member

  • .script developer
  • 1185 posts
  • Location:Boston, MA
  •  
    United States

Posted 17 August 2009 - 05:40 PM

That's a bug, which I think I just fixed. Re-download and you will only get the updated scripts.

If you ZIP the log file it will get very small and can be attached.

#14 codera

codera

    Newbie

  • Members
  • 18 posts

Posted 18 August 2009 - 01:26 AM

Hi JonF

i tried again to download the necessary files with WinBuilder Version 077 RC2. Following error appears during the process ==> IniRead - Failed to find file: [%BaseDir%\Projects\VistaPE-Core\Addons\dll.script]

I can't upload more screenshot because there is no more available space. Where could i upload the screenshots and logfile?

with best regards

#15 JonF

JonF

    Gold Member

  • .script developer
  • 1185 posts
  • Location:Boston, MA
  •  
    United States

Posted 18 August 2009 - 12:50 PM

I tried again to download the necessary files with WinBuilder Version 077 RC2. Following error appears during the process ==> IniRead - Failed to find file: [%BaseDir%\Projects\VistaPE-Core\Addons\dll.script]

I can't upload more screenshot because there is no more available space. Where could i upload the screenshots and logfile?

{Edited} Your script.project needs to be updated.

You can definitely attach a log file after you ZIP it. Reasonable sized screenshots should be attachable too. See the "Choose" and "Upload" buttons under the message composition box, on the right. Once you upload you must Manage and insert the reference.

#16 codera

codera

    Newbie

  • Members
  • 18 posts

Posted 18 August 2009 - 04:22 PM

Hi JonF

here i send you the Logfile and screenshot who appears during creating the ISO File.

Attached Thumbnails

  • WinBuilder_10.jpg
  • WinBuilder_11.jpg

Attached Files

  • Attached File  log.zip   74.01KB   211 downloads


#17 JonF

JonF

    Gold Member

  • .script developer
  • 1185 posts
  • Location:Boston, MA
  •  
    United States

Posted 19 August 2009 - 12:44 PM

Script.project is out-of-date. Update by downloading in WinBUilder or http://vistape.winbu.../script.project.

#18 codera

codera

    Newbie

  • Members
  • 18 posts

Posted 20 August 2009 - 04:32 PM

Hi JonF

i tried to build the ISO-File, but it appears the same error.

I changed now to the Win7RescuePE Project and build an ISO File. This works very fine at the moment. Thank you very much for your great patience and support.

with best regards

codera

#19 gnikolic

gnikolic

    Frequent Member

  • Advanced user
  • 112 posts
  • Location:Serbia
  •  
    Serbia

Posted 20 August 2009 - 09:21 PM

Hello all.

I am having a problem with building ISO too.

I am using Vista SP2 and WAIK (installed) for source.
After building ISO and starting in VirtualPC, after some moments there is BlackScreen Error with error message ntoskrnl.exe is missing or corrupt.

There is ntoskrnl.exe inside vista SP2 but for some reason when tryed to boot from VirtualPC or on real CD/DVD, Vista crashed.

Is there some explanation for this problem?

Thanx.

#20 JonF

JonF

    Gold Member

  • .script developer
  • 1185 posts
  • Location:Boston, MA
  •  
    United States

Posted 20 August 2009 - 11:48 PM

Hello all.

I am having a problem with building ISO too.

I am using Vista SP2 and WAIK (installed) for source.
After building ISO and starting in VirtualPC, after some moments there is BlackScreen Error with error message ntoskrnl.exe is missing or corrupt.

There is ntoskrnl.exe inside vista SP2 but for some reason when tryed to boot from VirtualPC or on real CD/DVD, Vista crashed.

Is there some explanation for this problem?

That's a new one. Can you please attach your log?

#21 gnikolic

gnikolic

    Frequent Member

  • Advanced user
  • 112 posts
  • Location:Serbia
  •  
    Serbia

Posted 21 August 2009 - 11:25 AM

That's a new one. Can you please attach your log?


Well, for building, everything went Ok. Got 300MB ISO file and start in VirtuaPC and after booting and starting first screen in high resolution. Puf! Error message about ntoskrnl.exe. Same is with burned CD/DVD on real computer.

For source point, my system is Vista SP2 with installed WAIK for Vista and Vista SP2 DVD.

Where I did wrong?

I opened wim file from ISO file and as far I can see, in windows/system32 there is ntoskrnl.exe.

Where is the problem?


Log is in the attachment.

Attached Files

  • Attached File  log.rar   83.44KB   199 downloads

Edited by gnikolic, 21 August 2009 - 01:12 PM.


#22 JonF

JonF

    Gold Member

  • .script developer
  • 1185 posts
  • Location:Boston, MA
  •  
    United States

Posted 21 August 2009 - 01:07 PM

I have ntoskrnl in my system32.

Please zip and post your log file.

#23 gnikolic

gnikolic

    Frequent Member

  • Advanced user
  • 112 posts
  • Location:Serbia
  •  
    Serbia

Posted 21 August 2009 - 01:12 PM

I have ntoskrnl in my system32.

Please zip and post your log file.


log is in the attachment in rar archive in message before this.
Thanx.

Edited by gnikolic, 21 August 2009 - 01:44 PM.


#24 JonF

JonF

    Gold Member

  • .script developer
  • 1185 posts
  • Location:Boston, MA
  •  
    United States

Posted 21 August 2009 - 03:55 PM

Whoops, sorry, missed the log file

It says it copied ntoskrnl. But you also have a lot of "No matching files found" warnings. That's bothersome.

You also have a lot of apps, which can confuse things. Yeah, I know you need those apps, but let's build up to it.

I suggest you start with a new minimal build, using VistaPE-CAPI (which has many updates and fixes relative to what you're using). In WinBuilder's download page, click the green circular arrow at the bottom right to update the server list. Select vistape.winbuilder.net (and any others you want). Download and run that package and let's see what happens ...

#25 dera

dera

    Gold Member

  • .script developer
  • 1335 posts
  •  
    Hungary

Posted 21 August 2009 - 04:33 PM

if an SP2 source used
in \Base\04-additional.script
try to change the whole [AddDrivers_SP0] section into this:
[codebox][AddDrivers_SP0] ############################################################################# #Windows Vista WITHOUT SP1 & WAIK 1.0 (old) # #recomended If,NotExistDir,"%BootSRC%\Windows\System32\DriverStore\FileRepository\megasr.inf_46a91305",Begin CopyDrv,acpi.inf_97916753 CopyDrv,agp.inf_0006e7a2 CopyDrv,battery.inf_f4c53ba5 CopyDrv,cdrom.inf_e487f727 CopyDrv,cpu.inf_28c60ce0 CopyDrv,disk.inf_e0b0b355 CopyDrv,fdc.inf_34affe5d CopyDrv,flpydisk.inf_7a4ca8e4 CopyDrv,hal.inf_59c500ab CopyDrv,hdaudbus.inf_55037da4 CopyDrv,input.inf_53578522 CopyDrv,keyboard.inf_93b1c41f CopyDrv,machine.inf_920a2c1f CopyDrv,mf.inf_dc41db51 CopyDrv,mshdc.inf_c6c2e699 CopyDrv,msmouse.inf_3dfa3917 CopyDrv,netclass.inf_b52cb833 CopyDrv,netloop.inf_a1515af9 CopyDrv,pcmcia.inf_1259a379 CopyDrv,ts_generic.inf_16acb40f CopyDrv,umbus.inf_6d285360 CopyDrv,unknown.inf_ab390622 CopyDrv,usb.inf_c89fac9c CopyDrv,usbport.inf_4d107f9d CopyDrv,usbstor.inf_bb2778a0 CopyDrv,volsnap.inf_7eb8cdb5 CopyDrv,volume.inf_9320b452 # #others CopyDrv,1394.inf_1c635995 CopyDrv,adp94xx.inf_f5b3bb9d CopyDrv,adpahci.inf_77e04e6f CopyDrv,adpu160m.inf_85e6cb75 CopyDrv,adpu320.inf_5cfd6334 CopyDrv,arc.inf_657749bf CopyDrv,arcsas.inf_88bda0c9 #CopyDrv,brmfcmf.inf_5140410b #CopyDrv,brmfcsto.inf_956882ac #CopyDrv,brmfcumd.inf_771fa3ea #CopyDrv,brmfport.inf_623ef1e2 CopyDrv,bthpan.inf_8632c8ff CopyDrv,bthspp.inf_c4460f35 CopyDrv,dc21x4vm.inf_7d8c6569 CopyDrv,djsvs.inf_324815e2 CopyDrv,elxstor.inf_6dffd8ac CopyDrv,hidbth.inf_d166cc0b CopyDrv,hiddigi.inf_9d4661e2 CopyDrv,hidserv.inf_1e89c3d1 CopyDrv,hpcisss.inf_562ec99c CopyDrv,i2omp.inf_a69da0c1 CopyDrv,iastorv.inf_37cdafa4 CopyDrv,iirsp.inf_65b7b7a5 CopyDrv,iirsp2.inf_9044b1f2 CopyDrv,ipmidrv.inf_d7eee31d CopyDrv,iscsi.inf_ea5644c7 CopyDrv,iteatapi.inf_431397fb CopyDrv,iteraid.inf_c40189b1 CopyDrv,lsi_fc.inf_00991673 CopyDrv,lsi_sas.inf_2c2f30a1 CopyDrv,lsi_scsi.inf_bb68e5dc CopyDrv,mchgr.inf_67902375 CopyDrv,megasas.inf_7a29364b CopyDrv,megasas2.inf_9f2c43d7 CopyDrv,mraid35x.inf_6d2d4d74 CopyDrv,mraid35x2.inf_149127a8 CopyDrv,msports.inf_ac874de4 CopyDrv,net44x32.inf_552df3d2 CopyDrv,net8185.inf_62bf512b CopyDrv,netathr.inf_e7715b92 CopyDrv,netb57vx.inf_f53680c1 CopyDrv,netbc6.inf_816e1530 CopyDrv,nete1e32.inf_258de813 CopyDrv,nete1g32.inf_f2bf8315 CopyDrv,netefe32.inf_38d0f1be CopyDrv,netirda.inf_b08c907b CopyDrv,netmyk01.inf_16948a3b CopyDrv,netnvm32.inf_70198ebf CopyDrv,netrtl32.inf_216a0fc4 CopyDrv,netrtx32.inf_f093b1d0 CopyDrv,netsis.inf_6386ce58 CopyDrv,nettun.inf_fab000c8 CopyDrv,netuli6x.inf_5431e32f CopyDrv,netvgx86.inf_3b667560 CopyDrv,netvt86.inf_c5f85a31 CopyDrv,nfrd960.inf_001da59e CopyDrv,ntrigdigi.inf_c78938e9 CopyDrv,nvraid.inf_733654ff CopyDrv,ql2300.inf_717439c7 CopyDrv,ql40xx.inf_6d89880a CopyDrv,ql40xx2.inf_8bb00f8e CopyDrv,sbp2.inf_2598d929 CopyDrv,scsidev.inf_f902a6c7 CopyDrv,sisraid2.inf_b5866c78 CopyDrv,sisraid4.inf_5bb9e87a CopyDrv,symc8xx.inf_9cedc444 CopyDrv,sym_hi.inf_03fe2321 CopyDrv,sym_u3.inf_e6e42f46 CopyDrv,tape.inf_7704b87a CopyDrv,tdibth.inf_7249bfb5 CopyDrv,tpm.inf_601dc269 CopyDrv,ts_wpdmtp.inf_049fa776 CopyDrv,uliahci.inf_ed370bb8 CopyDrv,ulsata.inf_32231126 CopyDrv,ulsata2.inf_d9526db2 #CopyDrv,usbprint.inf_35521f61 CopyDrv,vsmraid.inf_29a82f17 CopyDrv,wd.inf_2371f5c5 End Else,Begin #Windows Vista WITH SP2 #recomended CopyDrv,acpi.inf_9f72b557 CopyDrv,agp.inf_07e835a6 CopyDrv,battery.inf_fca689a9 CopyDrv,cdrom.inf_ec69452b CopyDrv,cpu.inf_30a75ae4 CopyDrv,disk.inf_e8920159 CopyDrv,fdc.inf_3c914c61 CopyDrv,flpydisk.inf_822df6e8 CopyDrv,hal.inf_61a64eaf CopyDrv,hdaudbus.inf_5ce4cba8 CopyDrv,input.inf_5b38d326 CopyDrv,ipmidrv.inf_dfd03121 CopyDrv,iscsi.inf_f23792cb CopyDrv,keyboard.inf_9b931223 CopyDrv,machine.inf_99eb7a23 CopyDrv,mf.inf_e4232955 CopyDrv,mshdc.inf_cea4349d CopyDrv,msmouse.inf_45db871b CopyDrv,netclass.inf_bd0e0637 CopyDrv,netloop.inf_a932a8fd CopyDrv,pcmcia.inf_1a3af17d CopyDrv,ts_generic.inf_1e8e0213 CopyDrv,umbus.inf_7509a164 CopyDrv,unknown.inf_b31a5426 CopyDrv,usb.inf_d080faa0 CopyDrv,usbport.inf_54f1cda1 CopyDrv,usbstor.inf_c308c6a4 CopyDrv,volsnap.inf_869a1bb9 CopyDrv,volume.inf_9b020256 # #others CopyDrv,1394.inf_2444a799 CopyDrv,adp94xx.inf_b7f3fe5b CopyDrv,adpahci.inf_f98d1b6f CopyDrv,adpu160m.inf_e55a51c3 CopyDrv,adpu320.inf_958163ad CopyDrv,arc.inf_d227d14c CopyDrv,arcsas.inf_7818e38d CopyDrv,bthpan.inf_8e141703 CopyDrv,bthspp.inf_cc275d39 CopyDrv,dc21x4vm.inf_856db36d CopyDrv,djsvs.inf_3a2963e6 CopyDrv,elxstor.inf_a8e7e7e6 CopyDrv,hidbth.inf_d9481a0f CopyDrv,hiddigi.inf_a527afe6 CopyDrv,hidserv.inf_266b11d5 CopyDrv,hpcisss.inf_f1cd9712 CopyDrv,i2omp.inf_ae7eeec5 CopyDrv,iastorv.inf_1281e873 CopyDrv,iirsp.inf_6d9905a9 CopyDrv,iirsp2.inf_9825fff6 CopyDrv,iteatapi.inf_4af4e5ff CopyDrv,iteraid.inf_cbe2d7b5 CopyDrv,lsi_fc.inf_cdc20d2b CopyDrv,lsi_sas.inf_19d1379d CopyDrv,lsi_scsi.inf_a90aecd8 CopyDrv,mchgr.inf_6f717179 CopyDrv,megasas.inf_7f1f2ace CopyDrv,megasas2.inf_a70d91db CopyDrv,megasr.inf_46a91305 CopyDrv,mraid35x.inf_750e9b78 CopyDrv,mraid35x2.inf_1c7275ac CopyDrv,msports.inf_b4689be8 CopyDrv,net44x32.inf_5d0f41d6 CopyDrv,net8185.inf_6aa09f2f CopyDrv,netathr.inf_ef52a996 CopyDrv,netb57vx.inf_fd17cec5 CopyDrv,netbc6.inf_894f6334 CopyDrv,nete1e32.inf_2d6f3617 CopyDrv,nete1g32.inf_faa0d119 CopyDrv,netefe32.inf_40b23fc2 CopyDrv,netirda.inf_b86dde7f CopyDrv,netmyk01.inf_1e75d83f CopyDrv,netnvm32.inf_77fadcc3 CopyDrv,netrtl32.inf_294b5dc8 CopyDrv,netrtx32.inf_f874ffd4 CopyDrv,netsis.inf_6b681c5c CopyDrv,nettun.inf_02914ecc CopyDrv,netuli6x.inf_5c133133 CopyDrv,netvgx86.inf_4347c364 CopyDrv,netvt86.inf_cdd9a835 CopyDrv,netxe32.inf_2203ffe5 CopyDrv,nfrd960.inf_07fef3a2 CopyDrv,ntrigdigi.inf_cf6a86ed CopyDrv,nvraid.inf_9fcd09cb CopyDrv,ql2300.inf_c92faf53 CopyDrv,ql40xx.inf_756ad60e CopyDrv,ql40xx2.inf_93915d92 CopyDrv,sbp2.inf_2d7a272d CopyDrv,scsidev.inf_00e3f4cb CopyDrv,sisraid2.inf_f175e83d CopyDrv,sisraid4.inf_defb89c3 CopyDrv,sym_hi.inf_0bdf7125 CopyDrv,sym_u3.inf_eec57d4a CopyDrv,symc8xx.inf_a4cf1248 CopyDrv,tdibth.inf_7a2b0db9 CopyDrv,tpm.inf_67ff106d CopyDrv,ts_wpdmtp.inf_0c80f57a CopyDrv,uliahci.inf_528a7733
CopyDrv,ulsata.inf_3a045f2a
CopyDrv,ulsata2.inf_4850cc37
CopyDrv,vsmraid.inf_39977a52
CopyDrv,wd.inf_2b5343c9
End[/codebox]




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users