Jump to content











Photo
- - - - -

[WB 053 beta 8] BSOD because of video controller


  • Please log in to reply
8 replies to this topic

#1 Nuno Brito

Nuno Brito

    Platinum Member

  • .script developer
  • 10525 posts
  • Location:boot.wim
  • Interests:I'm just a quiet simple person with a very quiet simple life living one day at a time..
  •  
    European Union

Posted 21 December 2006 - 07:35 PM

Hi, just downloaded and tried NativeEX - this project really looks very professional and very well designed from the start to make efficient builds.


The BSOD might have occured because of the changes added on beta 8, but then I tried on 052 and also outputed another error - perhaps it's my Portuguese source wich causes these issues.

I include the screenshot:
BSOD___graphics_card.JPG

Attached File  log.html   253.4KB   464 downloads

Complains about a a failure to initialize the video controller.. :P


Btw: I've noticed that it adds two more folders on the root of WB, would it be possible to just use %targetdir% and perhaps a profile folder inside %projectdir%?

This would really help to keep things uncluttered - it was also refreshing to see the boot message in native portuguese, awesome! :P

#2 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12701 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 21 December 2006 - 09:33 PM

Complains about a a failure to initialize the video controller.. :P

I think this happens because the nativeEX folder structure is not yet compatible to the new 053 folder structure.
1st Add
%BuildModelScript%=%ProjectDir%\Build\4-buildModel.Script (check the exact name!)
to script.project
2nd check whether hiderun.exe exists in %BaseDir%\tools.
3rd in %BaseDir%\tools there should also be 7za.exe and 7zCon.sfx.

Or try with 052 structure with BetaKit and BetaKit basics and copy only WinBuilder 053 beta 8 into the test dir. Result on my system:


Peter

#3 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12701 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 21 December 2006 - 09:41 PM

Btw: I've noticed that it adds two more folders on the root of WB, would it be possible to just use %targetdir% and perhaps a profile folder inside %projectdir%?

This would really help to keep things uncluttered - it was also refreshing to see the boot message in native portuguese, awesome! :P

I'm going to adapt nativEx to the new stucture and update mechanism.
(In early 2007 ...)

Peter

#4 Nuno Brito

Nuno Brito

    Platinum Member

  • .script developer
  • 10525 posts
  • Location:boot.wim
  • Interests:I'm just a quiet simple person with a very quiet simple life living one day at a time..
  •  
    European Union

Posted 22 December 2006 - 09:45 AM

Nice screenshot Peter - it's a brazilian windows source? :P

Perhaps using %tools% instead of %basedir%\tools will make it compatible on all versions. In the meanwhile I'll add 7za.exe and 7zCon.sfx to the tools folder on webupdate.. :P



Thanks for the help! :P

#5 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12701 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 22 December 2006 - 11:56 AM

Nice screenshot Peter - it's a brazilian windows source? :P
Perhaps using %tools% instead of %basedir%\tools will make it compatible on all versions. In the meanwhile I'll add 7za.exe and 7zCon.sfx to the tools folder on webupdate.. :P

  • Yes, it is Brazilian Portuguese
  • I'll do the %tools% Changes
Peter

#6 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12701 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 22 December 2006 - 01:34 PM

I brought nativeEx into the 053 beta 8 structure.
When running I got the same 'graphical driver' error.

The reason seems to be that version 053 dos not regwrite binaries: A line
RegWrite,"HKLM","0x3","WB_Default\Control Panel\Appearance\Schemes","%DESERT%","02","00", ...
is not executed, but no error message.

Peter

#7 bilou_gateux

bilou_gateux

    Frequent Member

  • Expert
  • 230 posts
  •  
    France

Posted 24 December 2006 - 10:51 AM

off topic but not so much

3rd in %BaseDir%\tools there should also be 7za.exe and 7zCon.sfx.

I'm trying to build a standard project using build [052].
No scripts added and only some options unchecked or changed.

when launched builder ask for WinBuilder052\Tools\7za.exe @5 - [WinSxS.Script]

i have downloaded latest available 7z442 but i don't find the exe after installation on local %ProgramFiles%\7-Zip

In the meanwhile I'll add 7za.exe and 7zCon.sfx to the tools folder on webupdate..

I've tried to update Winbuilder but no success:
This program is using build [052] and the available update build on this server is [049], no update is required at this moment.

Where can i get the required files ?

#8 curare

curare

    Member

  • .script developer
  • 96 posts
  •  
    Philippines

Posted 24 December 2006 - 11:26 AM

Download it here...
7za.exe

#9 bilou_gateux

bilou_gateux

    Frequent Member

  • Expert
  • 230 posts
  •  
    France

Posted 24 December 2006 - 12:52 PM

Thanks, i've got it.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users