Jump to content











Photo
- - - - -

nativeEx


  • Please log in to reply
7 replies to this topic

#1 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12701 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 20 December 2006 - 03:26 PM

Download the latest version of nativeEX here.
(Current: DEC-20-2006 17:00 MEZ)
Unzip it into %BaseDir%\Projects

##############################

This nativeEX project is based on the old HoJoPE PicoXP.
An Explorer shell is added.

The name nativeEX means:
  • First part: native language
  • Second part:
  • Maybe 'Extended'
  • Maybe 'Experimental'
  • Maybe my personal style (most of my programs end with 'EX'; see my logo)
The main features of the nativeEX project are:
  • Everything is in your native language because the project is 100% based on your source CD
  • The project can contain several sub projects, e.g an 'CMD' and an 'Explorer' project.
    You switch between the sub projects by a mouse click.
  • Files are added when necessary. So the old WinSxS.Script is obsolete. The WinSxS C&E commands are placed in the separated scripts where they are needed, e.g. in Explorer.Script and Wordpad.Script.
    As a result: An W2003 ISO built with nativePE has 38326 bytes, while exactly the same Project built by 'Standard' has 42460 bytes.
  • 'Boot from RAM' works, even with ISO burned onto CD
On the other hand, nativeEX demands something:
  • buildModel must be used to define shortcuts
  • no hardcoded file or directory name is allowed
  • (next version) there are some rules to RegHiveLoad
nativeEX is tested ok with
  • W2003
    • German
    • English
  • XP
    • German
    • English
    • Italian
    • French
    • Dutch
Currently there is a smaller issue with the date format of XP Portuguese. The registry entry contains 'aaaa' instead of 'yyyy'. (I think it depends on 'ano'). The date appears as:

And there is a bigger issue with XP Spanish: The ISO crashes, and I do not see any reason!

Maybe somebody else reports another different language which crashes; this could help to find the reason.

Peter

@Nuno: A separate sub forum for nativeEX?

#2 HighwayStar

HighwayStar

    Member

  • .script developer
  • 71 posts
  • Location:Russia,Irkutsk

Posted 20 December 2006 - 04:00 PM

Great work, peter. :P.
It runs fine from XP SP2 RUS source. But it,s wrong console fonts in cmd window.
Also I need two keyboard layouts when I boot into WinPE: native layout and english loayout.
It's very hard to use system without english keyboard.

#3 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12701 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 20 December 2006 - 04:18 PM

Great work, peter. :P .
It runs fine from XP SP2 RUS source. But it,s wrong console fonts in cmd window.
Also I need two keyboard layouts when I boot into WinPE: native layout and english loayout.
It's very hard to use system without english keyboard.


Do you need the 'switch' in the upper right to have a keyboard choice?


I think your hojoPE-Kbd_???_00000419.Script.txt already contains Russian and English keyboards.

Peter

#4 Nuno Brito

Nuno Brito

    Platinum Member

  • Team Reboot
  • 10502 posts
  • Location:boot.wim
  • Interests:I'm just a quiet simple person with a very quiet simple life living one day at a time..
  •  
    European Union

Posted 20 December 2006 - 04:56 PM

Currently there is a smaller issue with the date format of XP Portuguese. The registry entry contains 'aaaa' instead of 'yyyy'. (I think it depends on 'ano'). The date appears as:

I'm portuguese and I don't use a wristwatch - will have to live without it.. :P

And there is a bigger issue with XP Spanish: The ISO crashes, and I do not see any reason!

I went googling but only found this:
http://ubcd4win.com/...p?showtopic=730
http://ubcd4win.com/...amp;mode=linear

No more ideas on why it happens...



@Nuno: A separate sub forum for nativeEX?


Sure, I think we should also work to make scripts be portable cross these projects otherwise it will get confusing when developers wish to add more scripts - let's start defining some basic guidelines for creating scripts too..

Excellent work Peter
- these are really good news! :P

#5 TheHive

TheHive

    Platinum Member

  • .script developer
  • 4147 posts

Posted 23 December 2006 - 08:49 AM

When I try to Open the New Project after placing it in the
\WinBuilder053_beta8\Projects\nativeEX

I get the error.
Access violation at address 0047609F in module 'Winbuilder.exe'. Read address 00000057
Error.jpg

After pressing the ok and then the Refresh button in Winbuilder it shows the nativeEX Project in the list of projects.

#6 TheHive

TheHive

    Platinum Member

  • .script developer
  • 4147 posts

Posted 23 December 2006 - 09:18 AM

In the Misc Settings you have the settings under the Use PELoader options off. Are they not needed anymore to disable the 24 hour limit and the hiding of startup CMD Process.

Ran the nativeEx project with default settings. 18 errors.
It seemed to boot but I received a Display error message from Qemu.

nativeEx.jpg

Where is the log saved to.

When the log is being saved and it opens in explorer it seems to use 100% CPU and takes a long time to process it to show in the browser. Its taking a long time to finish showing the lines of the log.

Ill upload it once its finished loading it to the browser.


#7 Nuno Brito

Nuno Brito

    Platinum Member

  • Team Reboot
  • 10502 posts
  • Location:boot.wim
  • Interests:I'm just a quiet simple person with a very quiet simple life living one day at a time..
  •  
    European Union

Posted 24 December 2006 - 03:01 PM

It happens because the project was meant to work with wb052 - on wb053 beta versions there is still a bugfix that needs to be done in order for nativeex to work as expected.

Once I get some good results I'll let you know! :P

#8 TheHive

TheHive

    Platinum Member

  • .script developer
  • 4147 posts

Posted 24 December 2006 - 06:40 PM

It happens because the project was meant to work with wb052 - on wb053 beta versions there is still a bugfix that needs to be done in order for nativeex to work as expected.

Once I get some good results I'll let you know! :P

:P




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users