Jump to content











Photo
* * * * * 2 votes

WinNTSetup


  • Please log in to reply
109 replies to this topic

#76 Galapo

Galapo

    Platinum Member

  • .script developer
  • 3841 posts
  •  
    Australia

Posted 22 October 2009 - 02:00 AM

Windows Setup will detect changed files and list them in the setuperr.log

Has correct PE Header checksum been written to patched files?

Regards,
Galapo.

#77 was_JFX

was_JFX

    Frequent Member

  • Advanced user
  • 483 posts
  •  
    Germany

Posted 22 October 2009 - 05:41 PM

Has correct PE Header checksum been written to patched files?

Yes, PE Checksum gets corrected by patching. I could remove files from the Digital Signature list,
so the patched files would not be listed, but I think is good to known which of the system files are patched.

It's like olegpov told a normal behaviour of Windows setup.

:cheers:

#78 Galapo

Galapo

    Platinum Member

  • .script developer
  • 3841 posts
  •  
    Australia

Posted 23 October 2009 - 04:09 AM

Yes, PE Checksum gets corrected by patching.

Excellent, everything's covered. Great work as always.

Regards,
Galapo.

#79 was_JFX

was_JFX

    Frequent Member

  • Advanced user
  • 483 posts
  •  
    Germany

Posted 03 November 2009 - 09:46 PM

A bit late, but here is 64-bit Bugfix version :

WinNTSetup_v141_x64

limitation compared with 32-bit version:

-no integration of textmode drivers
-no user creation

:cheers:

#80 was_JFX

was_JFX

    Frequent Member

  • Advanced user
  • 483 posts
  •  
    Germany

Posted 05 December 2009 - 10:27 AM

Change log version 1.42
  • fix problem with windows server editions
  • MiniNT Mode (XP,2003) Systemdriver letter assignment is now calculated instead of using listed ones in Mounted devices key, this should hopefully address an issue with default LiveXP project
  • New hotkeys: Save Settingfile Ctrl + S, Load Settingfile Ctrl + L
  • Optional Using BootIce for MBR / PBR Update
  • Partition indicator icons should now work with Partition on other drives than drive 0


#81 Brito

Brito

    Platinum Member

  • .script developer
  • 10565 posts
  • Location:boot.wim
  • Interests:I'm just a quiet simple person with a very quiet simple life living one day at a time..
  •  
    European Union

Posted 05 December 2009 - 11:46 AM

Thanks JFX.

But it would perhaps be better if you updated your first topic on this discussion with the most recent version to ensure that new and old users all know exactly where to find the updated version.

:thumbsup:

#82 was_JFX

was_JFX

    Frequent Member

  • Advanced user
  • 483 posts
  •  
    Germany

Posted 05 December 2009 - 11:59 AM

Thanks Nuno,

Knew I was missing something :thumbsup:

#83 Brito

Brito

    Platinum Member

  • .script developer
  • 10565 posts
  • Location:boot.wim
  • Interests:I'm just a quiet simple person with a very quiet simple life living one day at a time..
  •  
    European Union

Posted 05 December 2009 - 01:25 PM

I've mentioned a link to your project on my facebook profile and I knew that people would only read the first topic.. :thumbsup:

Thank you for fixing the first topic.

:whistling:

#84 Lancelot

Lancelot

    Frequent Member

  • .script developer
  • 5013 posts
  • Location:Turkiye/Izmir
  • Interests:*Mechanical stuff and Physics,
    *LiveXP, BartPE, SherpyaXPE,
    *Basketball and Looong Walking,
    *Buying outwear for my girlf (Reason: Girls are stupid about buying bad stuff to make themselves uglier :))
    *Girls (Lyric: Girl,...., You will be a womann, Soon)
    *Answering questions for "Meaning of life",
    *Helping people,

    Kung with LiveXP, Fu with Peter :)
  •  
    Turkey

Posted 11 December 2009 - 11:52 PM

Hi JFX,

sorry for late script update :D , Just updated the script at LiveXP server with both x64&x86 editions with some script improvements :rolleyes:

#85 Blue Life

Blue Life

    Member

  • Members
  • 44 posts
  •  
    Turkey

Posted 12 December 2009 - 09:19 AM

Thanks JFX.

UnUpx error! :rolleyes:
Posted Image

#86 was_JFX

was_JFX

    Frequent Member

  • Advanced user
  • 483 posts
  •  
    Germany

Posted 12 December 2009 - 12:26 PM

@Lancelot
Thanks for updating :D
Think bootext.exe and LSimpt driver nolonger really needed. About x64 I will see when we have LiveXP x64 ready.

@Blue Life
Sorry UnUpx is no longer supported, this version should avoid that problem.



:rolleyes:

#87 Galapo

Galapo

    Platinum Member

  • .script developer
  • 3841 posts
  •  
    Australia

Posted 14 December 2009 - 02:51 AM

Thanks for the new version.

Recently I can report that I used your app to install xp from files located on usb stick and everything went really well.

Regards,
Galapo.

#88 john3voltas

john3voltas

    Member

  • Members
  • 97 posts
  •  
    Portugal

Posted 26 December 2009 - 03:34 PM

Hi there,
I love winntsetup and always use it for installing a new XP nlited build on my PCs.
Recently I've been trying to include it on my nativeex bootup pendisk.
Seems easy using livexp's script but when I press the "Launch Program (Test etc)" button, I get script halt because I'm missing bootsect.exe.
The thing is, I don't wanna use bootsect.exe. Instead I want to use bootice.exe which comes with 1.4.2.1.
What do I need to do in order to stop getting my script halted with that error message?
Where should I put my copy of bootice.exe?
Thanks for sharing your work with us. :)
Cheers

#89 was_JFX

was_JFX

    Frequent Member

  • Advanced user
  • 483 posts
  •  
    Germany

Posted 26 December 2009 - 04:46 PM

Thanks for the hint. ;)

bootsect.exe check wasn't optional in launch section, here's new script.

http://public.winbui...nNTSetup_JFX.7z

:dubbio:

#90 john3voltas

john3voltas

    Member

  • Members
  • 97 posts
  •  
    Portugal

Posted 27 December 2009 - 02:06 AM

Thanks JFX.
I'll sure be using it a lot.
Cheers

#91 Lancelot

Lancelot

    Frequent Member

  • .script developer
  • 5013 posts
  • Location:Turkiye/Izmir
  • Interests:*Mechanical stuff and Physics,
    *LiveXP, BartPE, SherpyaXPE,
    *Basketball and Looong Walking,
    *Buying outwear for my girlf (Reason: Girls are stupid about buying bad stuff to make themselves uglier :))
    *Girls (Lyric: Girl,...., You will be a womann, Soon)
    *Answering questions for "Meaning of life",
    *Helping people,

    Kung with LiveXP, Fu with Peter :)
  •  
    Turkey

Posted 27 December 2009 - 09:52 AM

Thanks john3voltas , Thanks JFX

new version on LiveXP server :dubbio:

#92 adric

adric

    Frequent Member

  • Advanced user
  • 168 posts

Posted 22 January 2010 - 12:59 PM

I am using WinNTSetup to install directly from a formatted 20 gig partition. I have Vista on another partition and when I format the install partition, Vista creates a PBR for Bootmgr which is not what XP needs. The new WinNTSetup allows me to change the boot record to use NTLDR instead of BOOTMGR which works fine when I have the partition formatted as NTFS. If I format the partition as FAT32 and alllow for NTLDR via Bootice, and start the installation by rebooting, I see a black screen with a blinking cursor. No error message. It looks like the boot process has gone into never never land. The same procedure works fine when I use NTFS. I don't understand why though. Could it be that the bootsect.dat that ends up in the $WinNT~BT directory doesn't work for FAT32?

Thanks,

#93 was_JFX

was_JFX

    Frequent Member

  • Advanced user
  • 483 posts
  •  
    Germany

Posted 22 January 2010 - 04:25 PM

I don't understand why though. Could it be that the bootsect.dat that ends up in the $WinNT~BT directory doesn't work for FAT32?

Thanks for pointing out :whistling:

Well bootsect.dat is correctly created on FAT32 :ranting2: , just the problem FAT32 doesn't work with bootsect.dat :ranting2:


[v1.43]
-fixed bug in Patch engine
-fixed bugs in Settingfile
-new: detection of some OEM Manufacturers
-fixed bug with FAT32 partitions (Thanks adric :ranting2: )
-updated BOOTICE to v0.73


:ranting2:

#94 NFX

NFX

    Member

  • Members
  • 41 posts
  •  
    Moldova

Posted 01 February 2010 - 09:14 AM

with this program I installed Windows XP SP3 from USB, for this I used UltraISO (Mount Virtual Drive), two ISO
1. Genuine Windows XPSP3
2 Windows XPSP3 + updates/hotfix + DriverPacks + Unattended file
in both cases were successfully installed

Windows intall time ~ 15 min!

A big thanks to JFX :cheers:

#95 wendy

wendy

    Frequent Member

  • Lady
  • 287 posts
  • Location:one mile from the QR main line
  • Interests:Operating systems, Weights and Measures, Geometry
  •  
    Australia

Posted 17 March 2010 - 06:16 AM

Tried this on Windows 3.51 (installation target)

It did not recognise the version of windows to install.

Windows 3.x and 4.x do not use HIVE*.INF, i suppose one could fake one to make it work without further options?

#96 was_JFX

was_JFX

    Frequent Member

  • Advanced user
  • 483 posts
  •  
    Germany

Posted 19 March 2010 - 08:23 PM

Hi Wendy,

I do not have NT 3.x or 4.x versions of windows, so i don't know how to add support.

For NT 5.x WinNTSetup does following.

- validation check of source (just txtsetup.sif and dosnet.inf have to be inside i386/amd64 folder)
- parsing dosnet.inf [floppyfiles.*] section for $WINDOWS.~BT creation
- copying cd source to $WINDOWS.~LS
- create BootSect.dat pointing to $LDS$ (renamed setupldr.bin)

Hope this helps anyway.

:wodoo:

#97 wendy

wendy

    Frequent Member

  • Lady
  • 287 posts
  • Location:one mile from the QR main line
  • Interests:Operating systems, Weights and Measures, Geometry
  •  
    Australia

Posted 29 March 2010 - 07:31 AM

WinNTSetup is not partial to fat16 drives, either for the boot block or for the directory to install. I've only tried fat16 and ntfs so far, but neither winnt 3 or 4 are partial to modern ntfs 5 partitions.

#98 was_JFX

was_JFX

    Frequent Member

  • Advanced user
  • 483 posts
  •  
    Germany

Posted 14 April 2010 - 08:06 PM

hello wendy,

sorry for taking so long. plan for next version is to catch up with latest autoit.

but never found the time to check all changed things.

FAT16 is supported now, for hivefix.inf check help screen (F1 key) hope this is okay so.

however just a work in process build, may a bit buggy

;)

#99 maanu

maanu

    Gold Member

  • Advanced user
  • 1134 posts
  •  
    Pakistan

Posted 14 April 2010 - 08:35 PM

well i dont know if it is the right place to ask for this issue , but let me start ,

a friend of mine asked me to test his moded xp , so since i had never tried this app . so i thought since i am installing xp ,so why not test JFX's tool to install it .

so i booted into my pe ,formated my C drive as NTFS , i mounted his XP iso ,told winNT setup to use that drive for xp files , then i select C , for both the other choices .

every other selection was default . process started . and it gave me success message and asked me to continue after restarting .

after restart , i started system from internal hdd ( default boot) . now blue setup screen started loading , then at the end i guess it asked me to chose drive (is that right /;? ) and it started copying file process . after like 60% it failed and complained that the required file (some file name ) is not present . i skiped it . but the error keep on coming.

i repeated it 2 or 3 times ,everytime same issue ..

what could be the issue ? i used last final version .

#100 was_JFX

was_JFX

    Frequent Member

  • Advanced user
  • 483 posts
  •  
    Germany

Posted 15 April 2010 - 02:09 PM

hi maanu,

i think problem come form the way this xp was moded.

winntsetup does setup very similar to original winnt32.exe.

does it work if you use winnt32.exe?

;)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users