Jump to content











- - - - -

Can't change directory when running the service


  • Please log in to reply
1 reply to this topic

#1 Guest_Phil Lewis_*

Guest_Phil Lewis_*
  • Guests

Posted 11 February 2009 - 10:20 PM

I followed the directions in the file 'tftpd32 service installation.txt' and started the service. It starts in '\Windows\System32'. I tried to use the GUI front-end to change the directory, but I get an error: 'Can't change directory'.

Is there a way to specify the directory used by the service?

thanks
Phil Lewis

#2 andriusst

andriusst

    Member

  • Members
  • 62 posts
  •  
    Lithuania

Posted 08 April 2009 - 08:14 PM

Hi Phil,

If you're running on Vista make sure you start TFTPD32 GUI as Administrator. I've just tried on v3.32 and was able to change a path with no error messages. The only problem is that it is not saved for some reason which means you will still have to type it in by hand in a config.

If there's a file tftpd32.ini in the same folder where your executable is, then this file will be used to load/save TFTPD32 configuration. Otherwise registry key HKLM\SOFTWARE\TFTPD32 will be (created and) used instead.

When it comes to the config file you just need to make sure there's a line specifying your tftp root folder. By default it looks like this:

BaseDirectory=.

and can be changed to anything like this:

BaseDirectory=c:\tftproot

If you want to use registry instead make sure the file mentioned above does not exist. Then you would have to go to HKLM\SOFTWARE\TFTPD32, add/find REG_SZ "BaseDirectory" and set its value to your folder location ie. c:\tftproot
As always be careful when dealing with registry as incorrect changes may break your Windows.

Hope this helps and good luck.

Regards,
Andrius




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users