Jump to content











Photo
* * * * * 1 votes

[Project] New nativeEx


  • Please log in to reply
37 replies to this topic

#1 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12707 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 09 February 2009 - 09:25 PM

Since now you can download (by using WinBuilder download page) a new nativeEx project which offers some important enhancements compared with the old version.

Condition: It needs WB 076, and you must download the complete project, nativeEx_barebone, nativeEx_Core and Tools.

The enhancements:
An additional script can be added to the PE at every time by just running the script. It is not necessary to run the ReOpen script.
The 'Ghost commands' sometimes appearing with shortcuts, do not longer appear.
Shortcuts to apps installed in the RAM drive now are created correctly.

The new functionality can be adapted to existing nativeEX based projects by:
  • Copy BuildModel, HivesFactory and Explorer scripts into your existing project.
  • Replace all '%TargetDir%\$ModelRam' by '%ModelRam%'
  • In 'finalize' scripts like CreateISO add in [process] the first lines
    If,ExistFile,"%PreISOScript%",FileCopy,%PreISOScript%,%ProjectTemplates%
    
     If,ExistFile,%ProjectTemplates%\%PreISOName%,Run,%ProjectTemplates%\%PreISOName%,Process
I hope, that's all.
If there are some troubles, post here.

@Galapo, @Lancelot:

LiveXP and nativeEX have different versions 052 of Explorer.Script. That has to be merged. After you did it, I'll use the merged version in nativeEx.

Peter

#2 Galapo

Galapo

    Platinum Member

  • .script developer
  • 3841 posts
  •  
    Australia

Posted 10 February 2009 - 01:52 AM

Peter, thanks for the new updated core!

The enhancements:
An additional script can be added to the PE at every time by just running the script. It is not necessary to run the ReOpen script.

That is a great feature you've implemented now.

Replace all '%TargetDir%\$ModelRam' by '%ModelRam%'

Scripts which had to be adjusted are:
MMC.script
tweaks.script
VMWarePlayerWorkstation.Script
WimPack.script

LiveXP and nativeEX have different versions 052 of Explorer.Script. That has to be merged. After you did it, I'll use the merged version in nativeEx.

Merged version 53 is now on the LiveXP server. Also get the new MMC.script from there as well at the same time.

Regards,
Galapo.

#3 TheHive

TheHive

    Platinum Member

  • .script developer
  • 4173 posts

Posted 10 February 2009 - 08:08 AM

Download NativeEx Updates and testing with FBWF, no shortcuts where created.

#4 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12707 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 10 February 2009 - 08:59 AM

Download NativeEx Updates and testing with FBWF, no shortcuts where created.

Maybe there is something wrong with merging the updates into your system.

The complete new nativeEx_barebone shows the shortcuts with FBWF

Peter

#5 Brito

Brito

    Platinum Member

  • .script developer
  • 10566 posts
  • Location:boot.wim
  • Interests:I'm just a quiet simple person with a very quiet simple life living one day at a time..
  •  
    European Union

Posted 10 February 2009 - 09:39 AM

An additional script can be added to the PE at every time by just running the script.

Awesome news! :poke:

Thank you for making this available, it's one of my favorite ways to tweak a project.

:poke:

#6 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12707 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 10 February 2009 - 10:35 AM

Peter, thanks for the new updated core!

That is a great feature you've implemented now.

Scripts which had to be adjusted are:
MMC.script
tweaks.script
VMWarePlayerWorkstation.Script
WimPack.script

Merged version 53 is now on the LiveXP server. Also get the new MMC.script from there as well at the same time.

Regards,
Galapo.

I got explorer script and included in nativeEx_barebone.
I also got mmc script, but there was a bug inside. duser.dll was misssing.
You see the advantage of a small project for testing, when not EVERYTHING is already on the target

Corrected version on the nativeEx server.

Peter

#7 Galapo

Galapo

    Platinum Member

  • .script developer
  • 3841 posts
  •  
    Australia

Posted 10 February 2009 - 10:49 AM

You see the advantage of a small project for testing, when not EVERYTHING is already on the target

Yes, I do. But I can be lazy or busy. The bug has probably been there quite a while.

Script is now on the LiveXP server too.

Regards,
Galapo.

#8 dera

dera

    Gold Member

  • .script developer
  • 1335 posts
  •  
    Hungary

Posted 10 February 2009 - 11:10 AM

Hi

I tried to update my LiveXP's script
and now I am a little confused regarding the shortcutWinExp.exe version
currently at me still the ghost '%ProgramFolder%\%ProgramEXE%' remains on my host if I use extra definition of the shortcut icon
(seems there is one in BuildModel.Script an other in Explorer.Script and in LiveXP and in nativeEx they are different one)

Edited by dera, 10 February 2009 - 11:15 AM.


#9 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12707 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 10 February 2009 - 11:16 AM

Hi

I tried to update my LiveXP's script
and now I am a little confused regarding the shortcutWinExp.exe version
currently at me still the ghost '%ProgramFolder%\%ProgramEXE%' remains on my host if I use extra definition of the shortcut icon

Thanks, Dera!

I'll have a look at that.
I really did not fix anything due to a separate icon. I think that a new version of shortcutWinExp has to come soon!

What's your special case?
Icon #? from the app to be installed?
Or icon #? from shell32.dll or something else?
Best is to post the script line(s) here.

Peter

#10 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12707 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 10 February 2009 - 11:59 AM

What's your special case?
Icon #? from the app to be installed?
Or icon #? from shell32.dll or something else?
Best is to post the script line(s) here.

Not necessary to post. I used the MBRFix script.

The issue is fixed > version 54 of explorer.script on the nativeEx server.

Please be sure to delete the ghost entry before test.

If the entry is not created (because it already exists) it is not deleted afterwards!

Peter

#11 dera

dera

    Gold Member

  • .script developer
  • 1335 posts
  •  
    Hungary

Posted 10 February 2009 - 12:01 PM

using standalone icon file from the app's directory
still with the script:
http://livexp.boot-l...R/MBRFix.Script
with my modded shortcut generation lines:
Add_Shortcut,StartMenu,%pTextBox1%,,,,,%PE_Programs%\%ProgramFolder%\MbrFix.ico

If,%pCheckBox2%,Equal,True,Add_Shortcut,Desktop,,,,,,%PE_Programs%\%ProgramFolder%\MbrFix.ico

also have the same
"ghost %ProgramFolder%\%ProgramEXE% remains on host after building the LiveXP project completed"
using my total commander script, on my host the folder 'C:\Program Files\tc' originally does not exist (I have C:\totalcmd\ on my host)
my shortcut generation line is:
Run,%BuildModelScript%,Add-Shortcut,"DE","#$pSystemDrive#$p\%WorkDir%\tc\starttcmd.cmd","Total#$sCommander","-SW:#$pSystemDrive#$p\%WorkDir%\tc#$q#$s#$q-SF:#$pSystemDrive#$p\%WorkDir%\tc\TOTALCMD.EXE#$q#$s#$q-SI:0"

seems there is one in BuildModel.Script an other in Explorer.Script and in LiveXP and in nativeEx they are different one


Edited by dera, 10 February 2009 - 12:04 PM.


#12 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12707 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 10 February 2009 - 12:02 PM

Crossing of posts :poke:

Peter

#13 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12707 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 10 February 2009 - 12:16 PM

seems there is one in BuildModel.Script an other in Explorer.Script and in LiveXP and in nativeEx they are different one


That one in buildmodel script is there by fault and not needed.

I removed it > BuildModel.Script version 70.

Thanks, Dera!

Peter

#14 dera

dera

    Gold Member

  • .script developer
  • 1335 posts
  •  
    Hungary

Posted 10 February 2009 - 12:42 PM

Sorry
maybe I have posted my issue not in the best suitable thread
I have the issue in LiveXP

so in 'nativeEx' using BuildModel Version=70 and Explorer.Script Version=054
there is no this ghost issue

#15 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12707 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 10 February 2009 - 12:47 PM

Sorry
maybe I have posted my issue not in the best suitable thread
I have the issue in LiveXP

so in 'nativeEx' using BuildModel Version=70 and Explorer.Script Version=054
there is no this ghost issue

Be a bit patient! :poke:

For Galapo in Australia now is night. :poke:

I'm sure that he will syncronize tomorrow!

Peter :poke:

#16 dera

dera

    Gold Member

  • .script developer
  • 1335 posts
  •  
    Hungary

Posted 10 February 2009 - 06:40 PM

Download NativeEx Updates and testing with FBWF, no shortcuts where created.

Really

When ImDisk is not used at all
and at 'Define Fundamentals' the settings are:
RAM Drive letter: --
'Settings' Drive: System Drive

Seems in nativeEx in this case there is problem with the sort order in the 'RunOnceEx':
"099"="hiderun net start fbwf"
"100"="shell32.dll|DllInstall|I"
"103"="browseui.dll|DllInstall|I"
"104"="shdocvw.dll|DllInstall|I"
"201"="hiderun /w reg import cplfix.reg"
"202"="regsvr32.exe /s shimgvw.dll" _linenums:0'>[HKEY_LOCAL_MACHINE\WB-Software\Microsoft\Windows\CurrentVersion\RunOnceEx&#92;&#48;00]"imdisktmp"="hiderun.exe /w cmd /c md \"%SystemDrive%\\Documents and Settings\\Default User\\Local Settings\\Temp\"""ModelRam"="hiderun /w cmd.exe /C hiderun /w ModelRam -o%SystemDrive% -y"[HKEY_LOCAL_MACHINE\WB-Software\Microsoft\Windows\CurrentVersion\RunOnceEx\500]<strong class='bbc'>"099"="hiderun net start fbwf"</strong>"100"="shell32.dll|DllInstall|I""103"="browseui.dll|DllInstall|I""104"="shdocvw.dll|DllInstall|I""201"="hiderun /w reg import cplfix.reg""202"="regsvr32.exe /s shimgvw.dll"
looks like the fbwf services sarted at too late

#17 TheHive

TheHive

    Platinum Member

  • .script developer
  • 4173 posts

Posted 10 February 2009 - 07:17 PM

Downloaded latest updates and shortcuts are back. Thanks!

#18 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12707 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 10 February 2009 - 08:14 PM

Really

When ImDisk is not used at all
and at 'Define Fundamentals' the settings are:
RAM Drive letter: --
'Settings' Drive: System Drive

Seems in nativeEx in this case there is problem with the sort order in the 'RunOnceEx':

"099"="hiderun net start fbwf""100"="shell32.dll|DllInstall|I""103"="browseui.dll|DllInstall|I""104"="shdocvw.dll|DllInstall|I""201"="hiderun /w reg import cplfix.reg""202"="regsvr32.exe /s shimgvw.dll" _linenums:0'>[HKEY_LOCAL_MACHINE\WB-Software\Microsoft\Windows\CurrentVersion\RunOnceEx&#92;&#48;00]"imdisktmp"="hiderun.exe /w cmd /c md \"%SystemDrive%\\Documents and Settings\\Default User\\Local Settings\\Temp\"""ModelRam"="hiderun /w cmd.exe /C hiderun /w ModelRam -o%SystemDrive% -y"[HKEY_LOCAL_MACHINE\WB-Software\Microsoft\Windows\CurrentVersion\RunOnceEx\500]<strong class='bbc'>"099"="hiderun net start fbwf"</strong>"100"="shell32.dll|DllInstall|I""103"="browseui.dll|DllInstall|I""104"="shdocvw.dll|DllInstall|I""201"="hiderun /w reg import cplfix.reg""202"="regsvr32.exe /s shimgvw.dll"
looks like the fbwf services sarted at too late

@dera
Can do you make me a favour, and try to test several start orders.

I hope that you understand that this is not a question of nativeE_barebone or LiveXP, but a question of the several scripts, how the define their 'start on boot'

Peter

#19 dera

dera

    Gold Member

  • .script developer
  • 1335 posts
  •  
    Hungary

Posted 10 February 2009 - 08:59 PM

I wanted to point out
in that constellation when only the FBWF used
ImDisk.Script is disabled
in the script 'Define Fundamentals' the
'Settings' Drive: System Drive setting used
in this case the entry:
RunOnceEx\000
"ModelRam"="hiderun /w cmd.exe /C hiderun /w ModelRam -o%SystemDrive% -y"

will fail
because the %SystemDrive% still not writable
as the fbwf service only will start at RunOnceEx\500

#20 Galapo

Galapo

    Platinum Member

  • .script developer
  • 3841 posts
  •  
    Australia

Posted 10 February 2009 - 10:00 PM

I wanted to point out
in that constellation when only the FBWF used
ImDisk.Script is disabled
in the script 'Define Fundamentals' the
'Settings' Drive: System Drive setting used
in this case the entry:
RunOnceEx\000
"ModelRam"="hiderun /w cmd.exe /C hiderun /w ModelRam -o%SystemDrive% -y"

will fail
because the %SystemDrive% still not writable
as the fbwf service only will start at RunOnceEx\500

That bug has long been fixed with the version of CreateISO on the LiveXP server. Grab the script from there.

Regards,
Galapo.

#21 dera

dera

    Gold Member

  • .script developer
  • 1335 posts
  •  
    Hungary

Posted 10 February 2009 - 10:11 PM

Yes, I know

#22 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12707 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 11 February 2009 - 08:32 AM

I wanted to point out
in that constellation when only the FBWF used
ImDisk.Script is disabled
in the script 'Define Fundamentals' the
'Settings' Drive: System Drive setting used
in this case the entry:
RunOnceEx\000
"ModelRam"="hiderun /w cmd.exe /C hiderun /w ModelRam -o%SystemDrive% -y"

will fail
because the %SystemDrive% still not writable
as the fbwf service only will start at RunOnceEx\500

Thanks, Dera!

Now I understood.

Petere

#23 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12707 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 16 February 2009 - 11:03 AM

There are some changed files on the nativeEx server for download.

  • New shortcutWinExp.exe attached to Explorer.Script:
    For programs to be run from RAM (e.g. FileMon) a SUBST is no longer necessary.
    This makes it possible to have a PE RAM drive letter which is used on the host pc.
  • Fixed Explorer.Script (hint by Pedrole15) to work with sub folders of SM correctly
  • AutoRuns.Script, FileMon.Script, RegMon.Script w/o SUBST
Peter

#24 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12707 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 22 February 2009 - 06:08 PM

Following lucho's experiments and suggestions today I added:
  • cmd.Script with optional RAMDrive
  • USB Keyboard and Mouse.
Please let me know if there are some inconsistencies in the project on server.

On my system everything runs well, but upload sometimes forgets something etc. ...

Peter

#25 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12707 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 24 February 2009 - 11:32 AM

There was a concern by JohnDN that SaveBase / RestoreBase does not work.

In doing the rearrangement I simply forgot the SaveBase / RestoreBase pair.

That is done now.

If you use WinBuilder's download center and look (complete) at nativeEx, there will be the newer files:

* !Macros.Script
* !WBManager.Script
* RestoreBase.Script
* SaveBase.Script
* script.project

Adapting to other projects:
  • Compare script.project, and only merge new contents
    Take care on the [Verify] change in script.project!
  • In SaveBase.Script maybe you have to add project specific variables.
    (only variables which may change during build, not constants like %ProjectCache%
If there are issues with Verify, let me know. I think that I changed Verify that in case of 'RestoreBase' a couple of checks are skipped, but who knows ...

Peter




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users