Jump to content











Photo
- - - - -

Standard USB Keyboard and Mouse in VistaPE 12


  • Please log in to reply
38 replies to this topic

#26 PaPeuser

PaPeuser

    Silver Member

  • Advanced user
  • 787 posts
  •  
    United States

Posted 26 January 2009 - 12:25 PM

Hello Dave

I added them to Drivers then looked at what section
[AddDrivers_SP0]? SP2?
And had a few errors on build,

So i put it dead last,, I notice files are copied over and build size increased

I don’t know if this is correct and I am not saying this fixed problem

#27 pecd.net

pecd.net

    Silver Member

  • .script developer
  • 947 posts
  •  
    Germany

Posted 26 January 2009 - 12:42 PM

i edited my post...it now says "end of section process"...

hope this helps...

Yes, it copies more files and so iso/wim will increase in size...but it fixed the problem for me in all cases...

#28 nextgen-networks.de

nextgen-networks.de
  • Members
  • 5 posts
  •  
    Germany

Posted 26 January 2009 - 02:47 PM

Greetings ctmag!

I modified the 04-additioal.script as metioned by you and had a 50% success ;-)

An later attached Logitech wireless mouse works now like a charm but the Cherry keyboard could not be convinced to play with me.

The checkd system was the DELL PowerEdge 2950 III Server with Intel 5000X Chipset.
Later this week I've the ability to test the ASUS system mentioned in my first post of that topic.

At least: Thank you very much for your investigative work!


Ralf

#29 pecd.net

pecd.net

    Silver Member

  • .script developer
  • 947 posts
  •  
    Germany

Posted 26 January 2009 - 02:57 PM

if you can, please try skipping the hardware detection (press end) (just in case it disables the keyboard and it was working before the hardware detection)

also, if possible, test if the keyboard works when booting a normal vista install dvd....

Thanks !!

#30 nextgen-networks.de

nextgen-networks.de
  • Members
  • 5 posts
  •  
    Germany

Posted 26 January 2009 - 03:19 PM

if you can, please try skipping the hardware detection (press end) (just in case it disables the keyboard and it was working before the hardware detection)

also, if possible, test if the keyboard works when booting a normal vista install dvd....

Thanks !!


Hey ctmag!

I'll drain out the server and then give the keyboard a try - takes about one or two hours.

The keyboard worked very well on a normal Server 2008 installation and the grub boot menu - that indicates that it is not broken in general.

I'll report back asap.

Thanks too :-)

#31 pecd.net

pecd.net

    Silver Member

  • .script developer
  • 947 posts
  •  
    Germany

Posted 26 January 2009 - 03:27 PM

thanks, especially the question about the vista boot dvd would be good to know the answer:-)

#32 nextgen-networks.de

nextgen-networks.de
  • Members
  • 5 posts
  •  
    Germany

Posted 27 January 2009 - 09:42 AM

Hi ctmag,

here are the results:
1. skipping the extended hardware detection and network startup results in an well working keyboard
2. when running the extended hardware detection the component that causes the trouble seems to be the "usbport.inf" - after loading it the keyboard wont't be regonized again
3. an standard vista business SP1 dvd works perfectly with the keyboard

I hope these results will help you.

Greetings Ralf

#33 pecd.net

pecd.net

    Silver Member

  • .script developer
  • 947 posts
  •  
    Germany

Posted 27 January 2009 - 10:24 AM

yes, it does...try out the new loader i posted yesterday...

#34 e2p2

e2p2

    Member

  • Members
  • 51 posts
  • Location:NC, USA
  •  
    United States

Posted 29 January 2009 - 03:40 AM

I wanted to let you know that this seems to have fixed my USB keyboard and mouse issue. I also combined it with the new VPELDR so it may have been a combination of the two that fixed it.

#35 nextgen-networks.de

nextgen-networks.de
  • Members
  • 5 posts
  •  
    Germany

Posted 29 January 2009 - 03:19 PM

Hi ctmag!

I've managed it to test the new vpeloader build on one of our terminal server cluster systems (DELL 2950 III) and got an very strange behavior...

1st boot:
complete hardware detection run through - mouse and keyboard detected

2nd boot (same machine 15 minutes later):
complete hardware detection run through - mouse and keyboard worked fine until loading usbport.inf


Attaced to this post you'll find the requested logs from windows and vpeloader.


Greetings Ralf

Attached Files



#36 pecd.net

pecd.net

    Silver Member

  • .script developer
  • 947 posts
  •  
    Germany

Posted 29 January 2009 - 08:49 PM

??? The new vpeloader i posted does not run hardware detection at all...so you probably did not repalce it correctly...

#37 OutCast2

OutCast2
  • Members
  • 4 posts
  •  
    France

Posted 08 February 2009 - 09:22 AM

I have seen this mentioned in a number of threads. Since I have run into this problem my self I thought I would see if anyone has made any progress on this issue. I am trying to run VistaPE 12 on a Dell Poweredge R300. This system does not have PS/2 ports. This limits me to using a standard USB keyboard and mouse. I have tried a number of solutions suggested in other threads but none have worked.

What I have tried:
Wired USB Keyboard and Mouse
Wired PS/2 Keyboard and Mouse through a PS/2 to USB adapter
Building with Vista SP0
Building with Vista SP1
Building with Windows Server 2008
Using C'T VPELDR
AutoStarting HWPNP

Nothing has worked so far. Given that I can not directly connect a PS/2 Keyboard or Mouse to this system any assistance would be greatly appreciated.

hello me my claier maeche not in usb with vistape thank you to bring me of help

#38 brol33

brol33

    Newbie

  • Members
  • 20 posts
  •  
    France

Posted 22 February 2009 - 10:03 AM

Hello.
Here is my experience.
I added to the file :
04-additional.script

[codebox]FileCopy,"%BootSRC%\Windows\Inf\inf*.dat","%TargetDir%\Windows\Inf" # DirCopy,"%BootSRC%\Windows\System32\DriverStore\FileRepository\acpi.inf_c947c6d1","%TargetDir%\Windows\System32\DriverStore\FileRepository" DirCopy,"%BootSRC%\Windows\System32\DriverStore\FileRepository\bthpan.inf_b7e9287d","%TargetDir%\Windows\System32\DriverStore\FileRepository" DirCopy,"%BootSRC%\Windows\System32\DriverStore\FileRepository\bthspp.inf_f5fc6eb3","%TargetDir%\Windows\System32\DriverStore\FileRepository" DirCopy,"%BootSRC%\Windows\System32\DriverStore\FileRepository\cpu.inf_5a7c6c5e","%TargetDir%\Windows\System32\DriverStore\FileRepository" DirCopy,"%BootSRC%\Windows\System32\DriverStore\FileRepository\disk.inf_126712d3","%TargetDir%\Windows\System32\DriverStore\FileRepository" DirCopy,"%BootSRC%\Windows\System32\DriverStore\FileRepository\hal.inf_8b7b6029","%TargetDir%\Windows\System32\DriverStore\FileRepository" DirCopy,"%BootSRC%\Windows\System32\DriverStore\FileRepository\hidbth.inf_031d2b89","%TargetDir%\Windows\System32\DriverStore\FileRepository" DirCopy,"%BootSRC%\Windows\System32\DriverStore\FileRepository\hidserv.inf_5040234f","%TargetDir%\Windows\System32\DriverStore\FileRepository" DirCopy,"%BootSRC%\Windows\System32\DriverStore\FileRepository\input.inf_850de4a0","%TargetDir%\Windows\System32\DriverStore\FileRepository" DirCopy,"%BootSRC%\Windows\System32\DriverStore\FileRepository\keyboard.inf_c568239d","%TargetDir%\Windows\System32\DriverStore\FileRepository" DirCopy,"%BootSRC%\Windows\System32\DriverStore\FileRepository\machine.inf_c3c08b9d","%TargetDir%\Windows\System32\DriverStore\FileRepository" DirCopy,"%BootSRC%\Windows\System32\DriverStore\FileRepository\mshdc.inf_f8794617","%TargetDir%\Windows\System32\DriverStore\FileRepository" DirCopy,"%BootSRC%\Windows\System32\DriverStore\FileRepository\msmouse.inf_6fb09895","%TargetDir%\Windows\System32\DriverStore\FileRepository" DirCopy,"%BootSRC%\Windows\System32\DriverStore\FileRepository\ts_generic.inf_4863138d","%TargetDir%\Windows\System32\DriverStore\FileRepository" DirCopy,"%BootSRC%\Windows\System32\DriverStore\FileRepository\ts_wpdmtp.inf_365606f4","%TargetDir%\Windows\System32\DriverStore\FileRepository" DirCopy,"%BootSRC%\Windows\System32\DriverStore\FileRepository\umbus.inf_9edeb2de","%TargetDir%\Windows\System32\DriverStore\FileRepository" DirCopy,"%BootSRC%\Windows\System32\DriverStore\FileRepository\unknown.inf_dcef65a0","%TargetDir%\Windows\System32\DriverStore\FileRepository" DirCopy,"%BootSRC%\Windows\System32\DriverStore\FileRepository\usb.inf_fa560c1a","%TargetDir%\Windows\System32\DriverStore\FileRepository" DirCopy,"%BootSRC%\Windows\System32\DriverStore\FileRepository\usbport.inf_7ec6df1b","%TargetDir%\Windows\System32\DriverStore\FileRepository" DirCopy,"%BootSRC%\Windows\System32\DriverStore\FileRepository\usbstor.inf_ecddd81e","%TargetDir%\Windows\System32\DriverStore\FileRepository" DirCopy,"%BootSRC%\Windows\System32\DriverStore\FileRepository\volsnap.inf_b06f2d33","%TargetDir%\Windows\System32\DriverStore\FileRepository" DirCopy,"%BootSRC%\Windows\System32\DriverStore\FileRepository\volume.inf_c4d713d0","%TargetDir%\Windows\System32\DriverStore\FileRepository" [/codebox] without the *.dat no USB mouse !? I did not find what is the minimum configuration for the directory dirverStore. with these few lines of code, I can use the mouse of the computer for what I do the maitenance.

Thank you to all involved.
Brol33

#39 pixl0n

pixl0n
  • Members
  • 1 posts
  •  
    Germany

Posted 23 February 2009 - 09:46 PM

Hello.
Here is my experience.
I added to the file :
04-additional.script

FileCopy,"%BootSRC%\Windows\Inf\inf*.dat","%TargetDir%\Windows\Inf"#DirCopy,"%BootSRC%\Windows\System32\DriverStore\FileRepository\acpi.inf_c947c6d1","%TargetDir%\Windows\System32\DriverStore\FileRepository"DirCopy,"%BootSRC%\Windows\System32\DriverStore\FileRepository\bthpan.inf_b7e9287d","%TargetDir%\Windows\System32\DriverStore\FileRepository"DirCopy,"%BootSRC%\Windows\System32\DriverStore\FileRepository\bthspp.inf_f5fc6eb3","%TargetDir%\Windows\System32\DriverStore\FileRepository"DirCopy,"%BootSRC%\Windows\System32\DriverStore\FileRepository\cpu.inf_5a7c6c5e","%TargetDir%\Windows\System32\DriverStore\FileRepository"DirCopy,"%BootSRC%\Windows\System32\DriverStore\FileRepository\disk.inf_126712d3","%TargetDir%\Windows\System32\DriverStore\FileRepository"DirCopy,"%BootSRC%\Windows\System32\DriverStore\FileRepository\hal.inf_8b7b6029","%TargetDir%\Windows\System32\DriverStore\FileRepository"DirCopy,"%BootSRC%\Windows\System32\DriverStore\FileRepository\hidbth.inf_031d2b89","%TargetDir%\Windows\System32\DriverStore\FileRepository"DirCopy,"%BootSRC%\Windows\System32\DriverStore\FileRepository\hidserv.inf_5040234f","%TargetDir%\Windows\System32\DriverStore\FileRepository"DirCopy,"%BootSRC%\Windows\System32\DriverStore\FileRepository\input.inf_850de4a0","%TargetDir%\Windows\System32\DriverStore\FileRepository"DirCopy,"%BootSRC%\Windows\System32\DriverStore\FileRepository\keyboard.inf_c568239d","%TargetDir%\Windows\System32\DriverStore\FileRepository"DirCopy,"%BootSRC%\Windows\System32\DriverStore\FileRepository\machine.inf_c3c08b9d","%TargetDir%\Windows\System32\DriverStore\FileRepository"DirCopy,"%BootSRC%\Windows\System32\DriverStore\FileRepository\mshdc.inf_f8794617","%TargetDir%\Windows\System32\DriverStore\FileRepository"DirCopy,"%BootSRC%\Windows\System32\DriverStore\FileRepository\msmouse.inf_6fb09895","%TargetDir%\Windows\System32\DriverStore\FileRepository"DirCopy,"%BootSRC%\Windows\System32\DriverStore\FileRepository\ts_generic.inf_4863138d","%TargetDir%\Windows\System32\DriverStore\FileRepository"DirCopy,"%BootSRC%\Windows\System32\DriverStore\FileRepository\ts_wpdmtp.inf_365606f4","%TargetDir%\Windows\System32\DriverStore\FileRepository"DirCopy,"%BootSRC%\Windows\System32\DriverStore\FileRepository\umbus.inf_9edeb2de","%TargetDir%\Windows\System32\DriverStore\FileRepository"DirCopy,"%BootSRC%\Windows\System32\DriverStore\FileRepository\unknown.inf_dcef65a0","%TargetDir%\Windows\System32\DriverStore\FileRepository"DirCopy,"%BootSRC%\Windows\System32\DriverStore\FileRepository\usb.inf_fa560c1a","%TargetDir%\Windows\System32\DriverStore\FileRepository"DirCopy,"%BootSRC%\Windows\System32\DriverStore\FileRepository\usbport.inf_7ec6df1b","%TargetDir%\Windows\System32\DriverStore\FileRepository"DirCopy,"%BootSRC%\Windows\System32\DriverStore\FileRepository\usbstor.inf_ecddd81e","%TargetDir%\Windows\System32\DriverStore\FileRepository"DirCopy,"%BootSRC%\Windows\System32\DriverStore\FileRepository\volsnap.inf_b06f2d33","%TargetDir%\Windows\System32\DriverStore\FileRepository"DirCopy,"%BootSRC%\Windows\System32\DriverStore\FileRepository\volume.inf_c4d713d0","%TargetDir%\Windows\System32\DriverStore\FileRepository"
without the *.dat no USB mouse !?I did not find what is the minimum configuration for the directory dirverStore.with these few lines of code, I can use the mouse of the computer for what I do the maitenance.

Thank you to all involved.
Brol33


works great.now i can just plug a mouse or usb device and it works fine.
thank you




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users