Jump to content











Photo
- - - - -

New Beta Script for VistaPE


  • Please log in to reply
221 replies to this topic

#101 Zhang Heng

Zhang Heng

    Member

  • Members
  • 51 posts
  •  
    China

Posted 03 March 2009 - 04:16 PM

the control panel desk script includes desk cpl only, and also the personalization. you can enter personalization in left of explorer. because i deleted all other things. i feel sad i cannot find them back again. i will go on working on it. and i don't
know why there are so many registry entries about power policy in this script.
by the way. i do unchecked vista start menu, it cannot start yet. i will have a see some days later, because i am preparing for an examination. i am sorry.

#102 PaPeuser

PaPeuser

    Silver Member

  • Advanced user
  • 787 posts
  •  
    United States

Posted 03 March 2009 - 04:21 PM

Hello

Yes school is more important good luck preparing!!!!!!
Thanks for your help !!!

#103 Optimus

Optimus

    Newbie

  • Members
  • 10 posts
  •  
    United Kingdom

Posted 11 March 2009 - 10:21 AM

Hi i have no luck with this script at all, when ever i try to boot it from usb or disk i get 0cx0000017 on boot even with everything turned of like explained it earlier posts. any ideas plz :cheers: ty

#104 Haiphong

Haiphong

    Frequent Member

  • Advanced user
  • 237 posts

Posted 14 March 2009 - 07:29 AM

Hi Ludovici,

Excellent Post !!!

#105 Zhang Heng

Zhang Heng

    Member

  • Members
  • 51 posts
  •  
    China

Posted 19 March 2009 - 12:07 AM

en, the attachment will be a preview...

Many things still need to be done.

for example,

Network center

I will finish the script in some weeks later, because I am still preparing the exam.






Hello

Yes school is more important good luck preparing!!!!!!
Thanks for your help !!!

Attached Files



#106 Zhang Heng

Zhang Heng

    Member

  • Members
  • 51 posts
  •  
    China

Posted 19 March 2009 - 12:15 AM

and, to write such a script is hard, I can't do it manually.

So I write a batch file to help me.

extract attachment to a directory.

copy SOFTWARE, DEFAULT from %InstallSRC%\WINDOWS\System32\config to the directory.

copy reg2WBSprg.exe to the directory.

but I forget where I get the reg2WBSprg.exe, that's a usefull tool.

run makewbs.cmd with Administrator permission.

the cpp files are the source code files of the two exe files with the same name.



there must be many mistakes of the batch file. I will rewrite it after the exam.

Attached Files



#107 PaPeuser

PaPeuser

    Silver Member

  • Advanced user
  • 787 posts
  •  
    United States

Posted 19 March 2009 - 12:31 AM

Hello

Thanks I will check this out, when I get a chance.

Good luck take care

#108 ludovici

ludovici

    Silver Member

  • .script developer
  • 610 posts
  • Location:France
  •  
    France

Posted 20 March 2009 - 10:22 AM

Hello Zhang Heng and PaPeuser,

Zhang Heng, you have really to make a very good work. ^_^
Your works is impressive ^_^ ...
I look forward to following... :good:

#109 Zhang Heng

Zhang Heng

    Member

  • Members
  • 51 posts
  •  
    China

Posted 02 April 2009 - 12:51 PM

Hi,

I added Network center to the script.

by the way, the exam finished.

Attached Files



#110 ludovici

ludovici

    Silver Member

  • .script developer
  • 610 posts
  • Location:France
  •  
    France

Posted 04 April 2009 - 07:50 AM

Hello Zhang Heng and PaPeuser  ^_^

Zhang Heng, can you share your screen capture of your VistaPE ?

And can you describe the list of script VistaPE (and the version ...), for your configuration ?

Can you explain, also, your fabulous script; i want understand in the goal to reproduce this methode in other script...  ^_^

Thanks for all  :good:

#111 NewBSOD

NewBSOD

    Member

  • Members
  • 49 posts
  •  
    Norway

Posted 06 April 2009 - 05:55 PM

Hi all

First I want to say thx to all for your great work. ^_^

I do now have WLAN running OK and I have some success with audio on Virtual PC 2007.
Lets look at WLAN first.
--------------------------------------------
I run Ludovici's wlan.script (wlanV3) and Holger's penetwork.script (PENetwork Beta V3) togetter.
Since I use SP1 as source I had to change the entry below in wlan.script and ofcourse add the wlan driver for my cards ^_^
DirCopy,"%InstallSRC%\windows\winsxs\x86_microsoft-windows-wirelesslanhelperclass_31bf3856ad364e35_6.0.6000.16386_none_987a0686b2eefbdd*","%TargetDir%\windows\winsxs"toDirCopy,"%InstallSRC%\windows\winsxs\x86_microsoft-windows-wirelesslanhelperclass_31bf3856ad364e35*","%TargetDir%\windows\winsxs"
Tested on 4 different pc's all OK. ^_^ -------------------------------------------Audio is a lot more tricky, and this is only a beta work in progress.Using Ludovici's audio.script I've added these additional filesRequire_File,avrt.dllRequire_File,batmeter.dllRequire_File,MediaMetadataHandler.dllRequire_File,mf.dllRequire_File,mfc40u.dllRequire_File,mferror.dllRequire_File,mfplat.dllRequire_File,mfpmp.exeRequire_File,mfps.dllRequire_File,mmci.dllRequire_File,mmcico.dllRequire_File,mmcss.dllRequire_File,MMSYSTEM.DLLRequire_File,mmtask.tskRequire_File,sbeio.dllRequire_File,SndVolSSO.dllRequire_File,sound.drvRequire_File,SoundRecorder.exeRequire_File,stobject.dlland ofcourse the driver files for Virtual PC 2007.
Windows/Inf virtualaudiodevice.infwdmaudio.infks.infWindows/System32SysFxUI.dllWMALFXGFXDSP.dllWindows/System32/Driversdrmk.sysdrmkaud.sysportcls.sysVIRTUALAUDIO.sys _linenums:0'><strong class='bbc'>Windows/Inf </strong>virtualaudiodevice.infwdmaudio.infks.inf<strong class='bbc'>Windows/System32</strong>SysFxUI.dllWMALFXGFXDSP.dll<strong class='bbc'>Windows/System32/Drivers</strong>drmk.sysdrmkaud.sysportcls.sysVIRTUALAUDIO.sys
But this is not enough since all the registry entrys are not added during the driver install.Too get audio running I need to run this registry key file after driver is installed, not the correct way but works for testing.Still allot missing, but a step forward :good:
Windows Registry Editor Version 5.00[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\MMDevices\Audio\Render][HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\MMDevices\Audio\Render\{14235d93-5680-4e96-a393-e405740650bd}]"DeviceState"=dword:00000001[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\MMDevices\Audio\Render\{14235d93-5680-4e96-a393-e405740650bd}\Properties]"{a45c254e-df1c-4efd-8020-67d146a850e0},2"="Speakers""{b3f8fa53-0004-438e-9003-51a46e139bfc},6"="Microsoft Virtual Machine Audio Device Driver""{b3f8fa53-0004-438e-9003-51a46e139bfc},2"="{1}.PCI\\VEN_1414&DEV_0007&SUBSYS_00000000&REV_00\\3&267A616A&0&60""{83da6326-97a6-4088-9453-a1923f573b29},3"="oem3.inf:Microsoft:VIRTUALAUDIO:13.811.0.0:pci\\ven_1414&dev_0007""{1da5d803-d492-4edd-8c23-e0c0ffee7f0e},0"=dword:00000001"{259abffc-50a7-47ce-af08-68c9a7d73366},12"="%windir%\\system32\\mmsys.cpl,-3010""{840b8171-b0ad-410f-8581-cccc0382cfef},0"=hex:41,00,72,00,08,01,00,00,01,00,\  00,00,04,01,00,00,00,00,01,00,7b,00,32,00,7d,00,2e,00,5c,00,5c,00,3f,00,5c,\  00,50,00,43,00,49,00,23,00,56,00,45,00,4e,00,5f,00,31,00,34,00,31,00,34,00,\  26,00,44,00,45,00,56,00,5f,00,30,00,30,00,30,00,37,00,26,00,53,00,55,00,42,\  00,53,00,59,00,53,00,5f,00,30,00,30,00,30,00,30,00,30,00,30,00,30,00,30,00,\  26,00,52,00,45,00,56,00,5f,00,30,00,30,00,23,00,33,00,26,00,32,00,36,00,37,\  00,61,00,36,00,31,00,36,00,61,00,26,00,30,00,26,00,36,00,30,00,23,00,7b,00,\  36,00,39,00,39,00,34,00,61,00,64,00,30,00,34,00,2d,00,39,00,33,00,65,00,66,\  00,2d,00,31,00,31,00,64,00,30,00,2d,00,61,00,33,00,63,00,63,00,2d,00,30,00,\  30,00,61,00,30,00,63,00,39,00,32,00,32,00,33,00,31,00,39,00,36,00,7d,00,5c,\  00,54,00,6f,00,70,00,6f,00,6c,00,6f,00,67,00,79,00,2f,00,30,00,30,00,30,00,\  31,00,30,00,30,00,30,00,35,00,00,00"{9a82a7db-3ebb-41b4-83ba-18b7311718fc},1"=dword:00010000"{233164c8-1b2c-4c7d-bc68-b671687a2567},1"="{2}.\\\\?\\PCI#VEN_1414&DEV_0007&SUBSYS_00000000&REV_00#3&267a616a&0&60#{6994ad04-93ef-11d0-a3cc-00a0c9223196}\\Wave""{b3f8fa53-0004-438e-9003-51a46e139bfc},0"=dword:00000001"{f19f064d-082c-4e27-bc73-6882a1bb8e4c},0"=hex:41,00,ee,74,28,00,00,00,fe,ff,\  02,00,44,ac,00,00,10,b1,02,00,04,00,10,00,16,00,10,00,03,00,00,00,01,00,00,\  00,00,00,10,00,80,00,00,aa,00,38,9b,71"{e4870e26-3cc5-4cd2-ba46-ca0a9a70ed04},0"=hex:41,00,ee,74,28,00,00,00,fe,ff,\  02,00,44,ac,00,00,20,62,05,00,08,00,20,00,16,00,20,00,03,00,00,00,03,00,00,\  00,00,00,10,00,80,00,00,aa,00,38,9b,71"{e4870e26-3cc5-4cd2-ba46-ca0a9a70ed04},1"=hex:41,00,63,00,08,00,00,00,a0,86,\  01,00,00,00,00,00[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\MMDevices\Audio\Render\{ea02a5c8-65c4-4081-9933-f6146fd846dd}]"DeviceState"=dword:00000004[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\MMDevices\Audio\Render\{ea02a5c8-65c4-4081-9933-f6146fd846dd}\Properties]"{a45c254e-df1c-4efd-8020-67d146a850e0},2"="Mono Out""{b3f8fa53-0004-438e-9003-51a46e139bfc},6"="Microsoft Virtual Machine Audio Device Driver""{b3f8fa53-0004-438e-9003-51a46e139bfc},2"="{1}.PCI\\VEN_1414&DEV_0007&SUBSYS_00000000&REV_00\\3&267A616A&0&60""{83da6326-97a6-4088-9453-a1923f573b29},3"="oem3.inf:Microsoft:VIRTUALAUDIO:13.811.0.0:pci\\ven_1414&dev_0007""{1da5d803-d492-4edd-8c23-e0c0ffee7f0e},0"=dword:00000006"{259abffc-50a7-47ce-af08-68c9a7d73366},12"="%windir%\\system32\\mmsys.cpl,-3016""{840b8171-b0ad-410f-8581-cccc0382cfef},0"=hex:41,00,72,00,08,01,00,00,01,00,\  00,00,04,01,00,00,00,00,01,00,7b,00,32,00,7d,00,2e,00,5c,00,5c,00,3f,00,5c,\  00,50,00,43,00,49,00,23,00,56,00,45,00,4e,00,5f,00,31,00,34,00,31,00,34,00,\  26,00,44,00,45,00,56,00,5f,00,30,00,30,00,30,00,37,00,26,00,53,00,55,00,42,\  00,53,00,59,00,53,00,5f,00,30,00,30,00,30,00,30,00,30,00,30,00,30,00,30,00,\  26,00,52,00,45,00,56,00,5f,00,30,00,30,00,23,00,33,00,26,00,32,00,36,00,37,\  00,61,00,36,00,31,00,36,00,61,00,26,00,30,00,26,00,36,00,30,00,23,00,7b,00,\  36,00,39,00,39,00,34,00,61,00,64,00,30,00,34,00,2d,00,39,00,33,00,65,00,66,\  00,2d,00,31,00,31,00,64,00,30,00,2d,00,61,00,33,00,63,00,63,00,2d,00,30,00,\  30,00,61,00,30,00,63,00,39,00,32,00,32,00,33,00,31,00,39,00,36,00,7d,00,5c,\  00,54,00,6f,00,70,00,6f,00,6c,00,6f,00,67,00,79,00,2f,00,30,00,30,00,30,00,\  31,00,30,00,30,00,30,00,38,00,00,00[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\MMDevices\SPDIF_Formats][HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\MMDevices\SPDIF_Formats\{00000008-0000-0010-8000-00aa00389b71}]"DisplayName"="DTS Audio""Bitmap"=hex(2):25,00,77,00,69,00,6e,00,64,00,69,00,72,00,25,00,5c,00,73,00,79,\  00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,6d,00,6d,00,73,00,79,00,73,00,\  2e,00,63,00,70,00,6c,00,2c,00,31,00,39,00,32,00,00,00"TestFile"=hex(2):25,00,77,00,69,00,6e,00,64,00,69,00,72,00,25,00,5c,00,6d,00,\  65,00,64,00,69,00,61,00,5c,00,64,00,74,00,73,00,2e,00,77,00,61,00,76,00,00,\  00[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\MMDevices\SPDIF_Formats\{00000092-0000-0010-8000-00aa00389b71}]"DisplayName"="Dolby Digital""Bitmap"=hex(2):25,00,77,00,69,00,6e,00,64,00,69,00,72,00,25,00,5c,00,73,00,79,\  00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,6d,00,6d,00,73,00,79,00,73,00,\  2e,00,63,00,70,00,6c,00,2c,00,31,00,39,00,31,00,00,00"TestFile"=hex(2):25,00,77,00,69,00,6e,00,64,00,69,00,72,00,25,00,5c,00,6d,00,\  65,00,64,00,69,00,61,00,5c,00,61,00,63,00,33,00,2e,00,77,00,61,00,76,00,00,\  00[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\MMDevices\SPDIF_Formats\{00000164-0000-0010-8000-00aa00389b71}]"DisplayName"="Microsoft WMA Pro Audio""Bitmap"=hex(2):25,00,77,00,69,00,6e,00,64,00,69,00,72,00,25,00,5c,00,73,00,79,\  00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,6d,00,6d,00,73,00,79,00,73,00,\  2e,00,63,00,70,00,6c,00,2c,00,31,00,39,00,30,00,00,00"TestFile"=hex(2):25,00,77,00,69,00,6e,00,64,00,69,00,72,00,25,00,5c,00,6d,00,\  65,00,64,00,69,00,61,00,5c,00,77,00,6d,00,61,00,70,00,72,00,6f,00,2e,00,77,\  00,61,00,76,00,00,00
I also run the Service Ultime.script to get the right click on speaker icon in tray
and Max_Real Qnx's xVPE KLITE.script (xVPE K-Lite) to play the movie/sound files.

I have also copyed windows/media folder

#112 ludovici

ludovici

    Silver Member

  • .script developer
  • 610 posts
  • Location:France
  •  
    France

Posted 06 April 2009 - 06:50 PM

Thanks you very much NewBSOD  ^_^

Great job  ^_^

And you have really the sound, you heard beep sound  ^_^ ?
What is your media player ?  :good:

And also a last question... Can you explain more on your wlan link with WPA, WEP, Any keys ? (Pictures if possible)

Thanks,

#113 NewBSOD

NewBSOD

    Member

  • Members
  • 49 posts
  •  
    Norway

Posted 06 April 2009 - 06:51 PM

Oh sorry I forgot. :good:
You also need xVPE DirectX 10.script (xVPE DirectX 10) from Max_Real Qnx or another dx10 script.


As another addon add PhotoMetadataHandler.dll to system32 to get picture preview in folder view.

#114 NewBSOD

NewBSOD

    Member

  • Members
  • 49 posts
  •  
    Norway

Posted 06 April 2009 - 07:07 PM

Hi ludovici :good:

I don't have the windows sounds, but I get sound from Windows Media Player 10.0.0.3802 Eng. from xVPE KLITE.script by Max_Real Qnx when playing the example wmv files in vista. I also have the pling sounds from Playback Devices right click on speakers -> Test.

I have tested WEP 64 bit and 128 bit, my current WLAN is Intel® Wireless Link 4965AGN.

I'll make some screen shots tomorrow ^_^

#115 PaPeuser

PaPeuser

    Silver Member

  • Advanced user
  • 787 posts
  •  
    United States

Posted 06 April 2009 - 07:19 PM

Hello and Welcome

This is great News

I have just one question what version of Service Ultime.script do you use?
there is Services Ultime and a Services Ultime v 2

Thanks again,,,,

EDITED - I just want to keep file versions together

#116 NewBSOD

NewBSOD

    Member

  • Members
  • 49 posts
  •  
    Norway

Posted 06 April 2009 - 07:25 PM

Hi PaPeuser

I use the first one (Services Ultime) :good:

#117 PaPeuser

PaPeuser

    Silver Member

  • Advanced user
  • 787 posts
  •  
    United States

Posted 06 April 2009 - 08:29 PM

Hello

I always got a file copy error with ludovici wlanV3.script

FileCopy - Failed to copy &#91;%BaseDir%\Temp\VistaPE-Core\InstallWimSrc\windows\System32\migwiz\dlmanifests\Microsoft-Windows-WlanSvc-DL.man&#93; to&#58; &#91;%BaseDir%\Target\VistaPE-Core\windows\System32\migwiz\dlmanifests\Microsoft-Windows-WlanSvc-DL.man

Vista Ultimate (SP0)

I have to start over with a new build... Thanks

#118 NewBSOD

NewBSOD

    Member

  • Members
  • 49 posts
  •  
    Norway

Posted 07 April 2009 - 09:04 AM

Hmm, that's the first filecopy in the script, you sure your vista dvd is mounted correctly?
Run the PreConfig.script in Base and see if the folder %BaseDir%\Temp\VistaPE-Core\InstallWimSrc contains files.
If it does, check if the spesified file/folder is present.

Edit: Had the exact same error yesterday after downloading fresh prosject, had to re-download tools and base to get it building :good:

The script dosn't run without errors for me eather, here is my list.

!!! Can not copy wlangpclnt.dll file!!
!!! Can not copy ndisuio.sys file!!
!!! Can not copy nwifi.sys file!!
!!! Can not copy raspptp.sys file!!
!!! Can not copy zd1211u.sys file!!
!!! Can not copy ndistapi.sys file!!

#119 NewBSOD

NewBSOD

    Member

  • Members
  • 49 posts
  •  
    Norway

Posted 07 April 2009 - 09:24 AM

Here are my screen captures. :good:

One from virtual machine where audio from mediaplayer are working.
As you can see in the tray the speaker icon still have the red X, so not 100% working yet.
The secound speakers entry in playback comes from the way the registry key was added.

Secound picture is WLAN working on CD boot while I surf this site ^_^

Attached Thumbnails

  • virtual_audio.jpg
  • wlan.jpg


#120 PaPeuser

PaPeuser

    Silver Member

  • Advanced user
  • 787 posts
  •  
    United States

Posted 07 April 2009 - 11:49 AM

Great work ^_^ ^_^
Today I will try see if I can duplicate your work!
Have you looked a Zhangs work with control Panel and networking services?

I have been working with
Explorer shell V2
VistaPE Patch v3jb
Penetworking beta V2
List control panel items
My build computers sound card does not have Vista drivers ,, so I gave up ^_^
My printer does not have vista drivers so I stopped with printing services. ^_^

I find it very interesting how some scripts work with others, But its allot of scripts ^_^

Make me crazy :good: :)

Thanks for posting pictures

#121 NewBSOD

NewBSOD

    Member

  • Members
  • 49 posts
  •  
    Norway

Posted 07 April 2009 - 01:43 PM

Hi PaPeuser ^_^
Just tested the lastest controlpanel script, looks great ^_^

I'm also useing xVPE Patch.script and xVPE Net.script. (Not needed for audio)
Running VistaPE v.12 RC1 with Vista SP1 as source.
I also added PhotoMetadataHandler.dll and I use the pnp fix in Base folder, 04-additional.script at the end of [process]
[codebox]DirCopy,"%BootSRC%\Windows\inf","%TargetDir%\Windows" DirCopy,"%BootSRC%\Windows\system32\drivers","%TargetDir%\Windows\system32" DirCopy,"%BootSRC%\Windows\system32\driverstore","%TargetDir%\Windows\system32" FileDelete,"%TargetDir%\Windows\inf\*.pnf" DirDelete,"%TargetDir%\Windows\inf\BITS" DirDelete,"%TargetDir%\Windows\inf\RemoteAccess" Require_File,PhotoMetadataHandler.dll[/codebox] Else I haven't tested so many scripts, since it can be messy to debug ^_^ Found a missing dll in my sound addon, mfc40.dll was missing. Sorry :good: Sound will work without, but click on speaker icon will not give volume bar. Require_File,avrt.dll Require_File,batmeter.dll Require_File,MediaMetadataHandler.dll Require_File,mf.dll Require_File,mfc40.dll Require_File,mfc40u.dll Require_File,mferror.dll Require_File,mfplat.dll Require_File,mfpmp.exe Require_File,mfps.dll Require_File,mmci.dll Require_File,mmcico.dll
Require_File,mmcss.dll
Require_File,MMSYSTEM.DLL
Require_File,mmtask.tsk
Require_File,sbeio.dll
Require_File,SndVolSSO.dll
Require_File,sound.drv
Require_File,SoundRecorder.exe
Require_File,stobject.dll


Now tested working audio on Realtek card ^_^

Realtek_Audio.jpg

#122 PaPeuser

PaPeuser

    Silver Member

  • Advanced user
  • 787 posts
  •  
    United States

Posted 07 April 2009 - 03:23 PM

WOW thanks for the pictures.
All of this script gives me a headache

If I use the shell v2 script I have pnp in start menu, programs. And if you run the patch script with the shell script Hardware Wizard works from programs list or if I Right click my computer –system properties – device manger I can install drivers using Hardware wizard. Using the above, device manager correctly detected my printer and sound card and listed them and I could run Hardware wizard to install drivers.

Now with your sound additions this all may work,

Thanks

#123 PaPeuser

PaPeuser

    Silver Member

  • Advanced user
  • 787 posts
  •  
    United States

Posted 07 April 2009 - 03:32 PM

Hi again, :good:

Could you post your entire reworked Audio script or link it?

Edited, note your the only person i know who has more thanks than posts

#124 ludovici

ludovici

    Silver Member

  • .script developer
  • 610 posts
  • Location:France
  •  
    France

Posted 07 April 2009 - 03:42 PM

Hi everybody  ^_^

Really good  :good:

I suggest to write one or two... script where we can choose the windows feature to install in vistape (Sound, Printer, Explorer, System, Tweaks...) ^_^

Suggestion ?  ^_^

#125 PaPeuser

PaPeuser

    Silver Member

  • Advanced user
  • 787 posts
  •  
    United States

Posted 07 April 2009 - 04:26 PM

Hi
I would say Sound and Wireless internet could be first.

Adding Hardware Wizard from shell script would be nice added to Patch script.

This is hard.... but there a 3 scripts




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users