Jump to content











Photo
- - - - -

New Beta Script for VistaPE


  • Please log in to reply
221 replies to this topic

#76 PaPeuser

PaPeuser

    Silver Member

  • Advanced user
  • 787 posts
  •  
    United States

Posted 12 February 2009 - 11:10 PM

Hello
Ludovici

Control Panel does not work in classic view
I would like to set Control Panel to classic view
I think this maybe the problem with Control Panel

I have been thinking Web View is not working and Control Panel with out refreshing

Is there some settings I should look for?
(Remember I am not a script writer)

#77 ludovici

ludovici

    Silver Member

  • .script developer
  • 610 posts
  • Location:France
  •  
    France

Posted 13 February 2009 - 05:45 PM

Hi PaPeuser :poke:

The control panel will not working if the Software Licensing service don't start see here :
Control Panel recquired

Have you test this 3 script together, if you use it you will be a surprise !!!!
Gui
Net
Dx10

#78 PaPeuser

PaPeuser

    Silver Member

  • Advanced user
  • 787 posts
  •  
    United States

Posted 13 February 2009 - 06:08 PM

Thanks :poke: :poke:

I will check the script with your shell

I tried Shell v4 and like Administrator Tool and System Tools

Then I was tring the new PENetwork and PENet Cfg and seeing how that worked with your shell
i could share all of booted computer drives. just could not access other computers on net,

Have a nice day

#79 risolutore

risolutore

    Frequent Member

  • Advanced user
  • 311 posts
  •  
    Italy

Posted 13 February 2009 - 08:13 PM

@ludovici
80 mb script :-((

#80 PaPeuser

PaPeuser

    Silver Member

  • Advanced user
  • 787 posts
  •  
    United States

Posted 14 February 2009 - 12:49 AM

@ lodovici

After a few errors, it did boot
Yes I was totally surprised at desktop and visual effects :poke: :poke: :poke:

Had a stop error with xPE GUI could not find files,
I checked and File is there, just not copied over
FileCopy – Failed to copy [%BaseDir%]\Projects\VistaPE-Core\Base\xPE GUI v4\Main\Shock\*.*] to:[%BaseDir%\Target\VistaPE-Core\Programs

EDITED - this program assumes that the Programs folder is there.

also the main folder itsself disapears from project dir after build, and i have to extract it again

More Control Panel items work!
Some Control Panel items work in MY Computer that do not work from StartMenu??
I can access Date and Time from clock but not in control Panel??
Date and Time also work from,,,, I will call it your taskbar

To test just desktop and control panel I have been disabling Wlan, Printer Services and Sound.

Size with Wlan, Printer Services and Sound disabled, and NO apps = ISO 333,500Kb

What has confused me is some icons are single click like in Webview other icons take a dubble click like classic view ,,,, drives me nuts,

Over all worked well
More later
Have a nice day ,, and thanks for all your work

#81 PaPeuser

PaPeuser

    Silver Member

  • Advanced user
  • 787 posts
  •  
    United States

Posted 14 February 2009 - 06:31 PM

Hello all
Some test results

Shell v4-test - File Copy Errors
Errors do not stop build

!!!Can not copy pnpibs.dll!!!
!!!Can not copy FRAMEDYNOS.dll!!!
!!!Can not copy MSXML.dll!!!
!!!Can not copy MSXML4R.dll!!!
!!!Can not copy MSXML4.dll!!!
!!! Can not copy CPSOKBTTasks.xml!!!
!!!Can not copy SecureKeyBackupCPL.dll!!!
!!!Can not copy SDSPRES.dll!!!
!!!Can not copy DIFXAPI.dll!!!
!!!Can not copy CHCKSHLLdllL!!!

Max
VistaPE Patch v3j scv.15 For VistaPE
xPE Net
DirectX 10
xPE GUI v4

No problem during build using all scripts together (Default settings)

EDITED added
Xpe gui V4 script changes Computer icon on desktop to a folder, right click and all functions work as before
Now i only have 2 explores in VistaPE Loader and tools
When i do enable my APPS they are not listed in StartMenu... icons on Desktop ok

all Programs work as before
This is kind of WILD!!! Frogs, things popping out at me, :poke: :poke: :) :poke: :poke: :poke: :poke: :poke:
Totally amassing

#82 PaPeuser

PaPeuser

    Silver Member

  • Advanced user
  • 787 posts
  •  
    United States

Posted 17 February 2009 - 01:53 AM

Hello
Some NEW BETA features are to run PNP and windows Hardware Wizard from
VistaPE - Start, Programs, Computer Management

Computer Management now includes most options from Control Panel

From ludovici web site
Explorer shell Ultimate or shell V4
http://ludovici.winbuilder.net/
look for and download
BETA/APP/Shell V4.script
Shell V4.script = Explore shell Ultimate V4 [shell_V4.script]

Download and installed to Project\VistaPE\base

Using this script by deselecting

Addons – uncheck EVERYTHING but
Internet Explorer, PENetCfg and Total Commander

Tweaks
– uncheck everything

Uncheck add fonts in Explore shell Ultimate V4 [shell_V4.script]

Check out Hardware detection
One at a time
USB mouse was installed as a Human interface device, when refreshing Device manager
Then keyboard was installed correctly and worked

If both where plugged at same time, both were unknown devices and refresh did not help

But if
I tried to plug keyboard in first it was an unknown device
then mouse would not work.

Strange

#83 PaPeuser

PaPeuser

    Silver Member

  • Advanced user
  • 787 posts
  •  
    United States

Posted 17 February 2009 - 12:53 PM

This is what works for ME and does not work for me

That when VistaPE is loaded and PEloader finds a Human Interface device it will be installed correctly, and plugging in another Human interface device will work. Even if unplugged and plugged back in

If PEloader does not find a Human interface device, device manager, hardware wizard or no matter how many time you refresh a Human interface devices will not be loaded

So my question is does PEloader start a service for Human interface devices if found??
Or does PEloader disable Human interface device detection if none are found?

As long as i have at least one Human Interface device detected at boot i can unplug and plug hit refresh and all is well

Now that i have a PNPUlit from start menu and a Add Hard Ware wizard, i can see whats going on a little better


I can now right click a unknown device in Device manager and update driver and either let windows look for a driver or point it to the folder, USB mouse works well, my junk USB keyboard is just that junk. I can install my sound card by looking for drivers on C:
This is a major change in the way VistaPE can detect and install drivers

Only problem is my USB keyboard,

Being able to right click in device manager and use the wizard to install devices is great

Because its BETA ,,,,

#84 PaPeuser

PaPeuser

    Silver Member

  • Advanced user
  • 787 posts
  •  
    United States

Posted 18 February 2009 - 11:10 AM

Hello

Scripts needed

[Shell V4] - Explorer shell Ultimate V4-test - This script can be installed alone
For StartMenu programs shown and many options for windows explorer

These are needed to use the xTreamGUI script
[xPE Drx 10]
[xPE Net]
VistaPE Patch v3jb
[xpeGUI v4-3 ] - xTreamGui v4 -- Use these scripts if you want Dock Bar and frog on your desktop

All can be found in earlier posts

Tested with Winbuilder 76 and Vista v12 (RC1)
Source Vista ULIT SP0 and WAIK

Thanks ludovici and Max_Real Qnx
:poke: :poke:

#85 PaPeuser

PaPeuser

    Silver Member

  • Advanced user
  • 787 posts
  •  
    United States

Posted 26 February 2009 - 02:02 AM

To Who ever

I have more to report and i may have figured out what some of the problems are
Internet Explorer is the problem you will see if you look at picture page

Well I figured out the internet explorer problem, Internet Explorer 7 can be installed without the original Explorer shell.
Then I started to do some cleanup and deleting of NUUSED files or scripts and I lost hardware detection. So I worked on that,,, in mean time ,, I crashed

I have allot of respect for the developers in here,, :cheers: :cheers: :cheers: :cheers:

I am DONE.......

#86 Zhang Heng

Zhang Heng

    Member

  • Members
  • 51 posts
  •  
    China

Posted 27 February 2009 - 06:37 PM

Hi,

I realy want to know how can you enable control panel in pe as shown in attached picture cutted from your post.

It seems this feature relies on slsvc service.

When the service starting in pe, it returnes a error code. the meaning is the service cannot enable in pe.

Attached Thumbnails

  • cpl.JPG


#87 PaPeuser

PaPeuser

    Silver Member

  • Advanced user
  • 787 posts
  •  
    United States

Posted 27 February 2009 - 07:41 PM

Hello

First download ShellV4 script from ludovici site linked here
Look for ShellV4 Script

Included this script in your Project\VistaPE-Core\Base files

In script window i had to uncheck the option to add fonts (errors on build) - will stop build

READ POST #82

Pictures of what i did get to work before i CRASH Hard can be found HERE and Here

Control panel does not work completely Some features do work.
Good Luck

In standard Explorer shell that came with VistaPE-Core uncheck all options

In new Base\Explorer shell Ultimate V4-test script uncheck
first checkbox - use Vista style start menu - or black screen on boot

this should boot ,,,,,,,,,,

#88 PaPeuser

PaPeuser

    Silver Member

  • Advanced user
  • 787 posts
  •  
    United States

Posted 27 February 2009 - 10:09 PM

Hello :cheers: :cheers:
I hope this helps and i did not miss anything

Download and install to base directory - Shell V4 from ludovicis website

Explorer Shell V4- test script
I uncheck BEFORE build
Add fonts – will stop build
Use Vista style start menu – or will boot to The Black screen about (Hardware changes)
………………………………………………………………
Just for testing purposes and to speed build times I also uncheck these

Visual Effects, I uncheck all to test
Start Menu Vista, All Cascade options – 9 check boxes
Wlan – (Wireless networking options)
Service Audio Beta – (Sound or Audio)
Printer Spooler Service – (printer services)
Print Directory
(you can add these later)
…………………………………………………………………
In Winbuilder under VistaPE-Core I also unchecked

Addons – uncheck EVERYTHING but
Internet Explorer, PENetCfg and Total Commander

Tweaks – uncheck everything

Most of this is included in Explorer Shell V4 script
…………………………………………………………………..
Now when you boot VistaPE Control Panel can be accessed from Computer icon on desktop or Start – Settings
When you open Control Panel go to Tools- Folder Options-View-Reset Folders

I have had a few things working in Control Panel

Problem is we have to 2 explorer shells, I got to the point at one time where I could make the new shell work and delete the original explorer shell

If you or someone gets this far I will try to explain whats next :cheers:

#89 PaPeuser

PaPeuser

    Silver Member

  • Advanced user
  • 787 posts
  •  
    United States

Posted 27 February 2009 - 11:43 PM

Page 2 continued from post # 88

you can Check hide system files in Explorer shell V4 to get rid of desktop.ini showing on desktop

Now we add the xVPE Patch Script from ludovici website, ( xVPE Patch v3jb)
(Same Page as Shell V4 was found) - Default setting, (build)
Now click Computer icon on desktop and Control Panel items are listed on left

Now notice under Control Panel -Ease of Access, Hardware and Sound –Auto Play, Personalize, Power Options, all work !!!!


OO it gets better, PLEASE dont ask me why

#90 PaPeuser

PaPeuser

    Silver Member

  • Advanced user
  • 787 posts
  •  
    United States

Posted 28 February 2009 - 12:39 AM

Page 3 Continued for Post #89

Next I downloaded the xVPE Net and the xVPE_Drx script that ludovici suggested (also from his website)
Hoping to get more of Control Panel working

Then I tried replacing the original explorer shell with the Shell V4 script
THIS GETS TRICKY – do not try this unless you know what your doing
The Internet Explorer 7 script can not be enabled with out the original explorer shell script. SO I modified the Internet Explorer 7 script so it would not look for the old explorer shell script.
Comment out just 6 lines in Internet Explorer 7 script from Line (26 System, Erroroff) to line (31 end)

Select default Explorer Shell in Main Configuration
Now I could uncheck Base\explorer shell and use the new Explorer shell V4 script
build -This worked well

Disclaimer goes here

BUT
I lost hardware detection or I should say Hardware Detection did not work as well
Fixing this problem is when I crashed it all … FIXED!!!!

#91 Zhang Heng

Zhang Heng

    Member

  • Members
  • 51 posts
  •  
    China

Posted 01 March 2009 - 07:40 AM

Hello,

I am sorry. It's a long time I left the question here.

Thank you very much.

you said

Now when you boot VistaPE Control Panel can be accessed from Computer icon on desktop or Start – Settings


but you said

Now click Computer icon on desktop and Control Panel items are listed on left


Did it mean that I open the Control Panel just as doing in a Vista, the Control Panel will appear as in Vista?

to list control panel items left of explorer, it's not so hard.

copy and regist all dlls neccesary, and also the add Namespace entry in Regeistry needed

I will test shell v4 as you said.

Thank you so much.

#92 Zhang Heng

Zhang Heng

    Member

  • Members
  • 51 posts
  •  
    China

Posted 02 March 2009 - 05:03 AM

bug report about shell v4

shell v4 cannot work well on SP1 and non-English local.

If,NotExistDir,"%TargetDir%\Windows\winsxs",DirMake,"%TargetDir%\Windows\winsxs"
If,NotExistDir,"%TargetDir%\Windows\winsxs\Manifests",DirMake,"%TargetDir%\Windows\winsxs\Manifests"
DirCopy,"%InstallSRC%\Windows\winsxs\x86_microsoft.windows.gdiplus*","%TargetDir%\Windows\winsxs"
FileCopy,"%InstallSRC%\Windows\winsxs\Manifests\x86_microsoft.windows.gdiplus*.manifest","%TargetDir%\Windows\winsxs\Manifests"
If,NotExistDir,"%TargetDir%\Windows\winsxs",DirMake,"%TargetDir%\Windows\winsxs"
DirCopy,"%InstallSRC%\Windows\winsxs\x86_microsoft-windows-p..e-spoolss-licensing_31bf3856ad364e35_6.0.6000.16386_none_e8729baedd076f47","%TargetDir%\Windows\winsxs"
#DirCopy,"%InstallSRC%\Windows\winsxs\x86_microsoft-windows-p..e-spoolss.resources_31bf3856ad364e35_6.0.6000.16386_en-us_c500975e897b6283","%TargetDir%\Windows\winsxs"
DirCopy,"%InstallSRC%\Windows\winsxs\x86_microsoft-windows-p..pooler-core-spoolss_31bf3856ad364e35_6.0.6000.16386_none_5902d0e391753282","%TargetDir%\Windows\winsxs"
DirCopy,"%InstallSRC%\Windows\winsxs\x86_microsoft-windows-p..ting-spooler-client_31bf3856ad364e35_6.0.6000.16386_none_90f734231bc2bfb2","%TargetDir%\Windows\winsxs"
DirCopy,"%InstallSRC%\Windows\winsxs\x86_microsoft-windows-printing-spooler-core_31bf3856ad364e35_6.0.6000.16386_none_d414e125c49db442","%TargetDir%\Windows\winsxs"
DirCopy,"%InstallSRC%\Windows\winsxs\x86_microsoft-windows-printing-spooler-ppc_31bf3856ad364e35_6.0.6000.16386_none_646661ebf623ef0e","%TargetDir%\Windows\winsxs"
DirCopy,"%InstallSRC%\Windows\winsxs\x86_microsoft-windows-m..-downlevelmanifests_31bf3856ad364e35_6.0.6000.16386_none_0041f38286aeaf07","%TargetDir%\Windows\winsxs"
#DirCopy,"%InstallSRC%\Windows\winsxs\x86_microsoft-windows-ntvdm-system32_31bf3856ad364e35_6.0.6000.16386_none_fbd6b71e75a2c6c8v","%TargetDir%\Windows\winsxs"
DirCopy,"%InstallSRC%\Windows\winsxs\x86_microsoft-windows-p..-localspl-licensing_31bf3856ad364e35_6.0.6000.16386_none_1177be79edf6a0c2","%TargetDir%\Windows\winsxs"
DirCopy,"%InstallSRC%\Windows\winsxs\x86_microsoft-windows-p..e-spoolss-licensing_31bf3856ad364e35_6.0.6000.16386_none_e8729baedd076f47","%TargetDir%\Windows\winsxs"
DirCopy,"%InstallSRC%\Windows\winsxs\x86_microsoft-windows-printing-spooler-core_31bf3856ad364e35_6.0.6000.16386_none_d414e125c49db442","%TargetDir%\Windows\winsxs"
If,NotExistDir,"%TargetDir%\Windows\winsxs\FileMaps",DirMake,"%TargetDir%\Windows\winsxs\FileMaps"
FileCopy,"%InstallSRC%\Windows\winsxs\FileMaps\$$_system32_spool_drivers_color_714407f67ff22f9d.cdf-ms","%TargetDir%\Windows\winsxs\FileMaps\$$_system32_spool_drivers_color_714407f67ff22f9d.cdf-ms"
FileCopy,"%InstallSRC%\Windows\winsxs\FileMaps\$$_system32_spool_drivers_w32x86_3_8416c27bd490b8bd.cdf-ms","%TargetDir%\Windows\winsxs\FileMaps\$$_system32_spool_drivers_w32x86_3_8416c27bd490b8bd.cdf-ms"
#FileCopy,"%InstallSRC%\Windows\winsxs\FileMaps\$$_system32_spool_drivers_w32x86_3_en-us_cc27677906e15f61.cdf-ms","%TargetDir%\Windows\winsxs\FileMaps\$$_system32_spool_drivers_w32x86_3_en-us_cc27677906e15f61.cdf-ms"
#FileCopy,"%InstallSRC%\Windows\winsxs\FileMaps\$$_system32_spool_drivers_w32x86_3_mui_0409_b123c2e8e96d758d.cdf-ms","%TargetDir%\Windows\winsxs\FileMaps\$$_system32_spool_drivers_w32x86_3_mui_0409_b123c2e8e96d758d.cdf-ms"
FileCopy,"%InstallSRC%\Windows\winsxs\FileMaps\$$_system32_spool_prtprocs_w32x86_ef52e6aef2b8011c.cdf-ms","%TargetDir%\Windows\winsxs\FileMaps\$$_system32_spool_prtprocs_w32x86_ef52e6aef2b8011c.cdf-ms"
#FileCopy,"%InstallSRC%\Windows\winsxs\FileMaps\$$_system32_spool_prtprocs_w32x86_en-us_5b08a36c001a2d60.cdf-ms","%TargetDir%\Windows\winsxs\FileMaps\$$_system32_spool_prtprocs_w32x86_en-us_5b08a36c001a2d60.cdf-ms"
FileCopy,"%InstallSRC%\Windows\winsxs\FileMaps\$$_system32_spool_tools_e03b2d8f300154a4.cdf-ms","%TargetDir%\Windows\winsxs\FileMaps\$$_system32_spool_tools_e03b2d8f300154a4.cdf-ms"
#FileCopy,"%InstallSRC%\Windows\winsxs\FileMaps\$$_system32_spool_tools_en-us_103725fe114f4888.cdf-ms","%TargetDir%\Windows\winsxs\FileMaps\$$_system32_spool_tools_en-us_103725fe114f4888.cdf-ms"
FileCopy,"%InstallSRC%\Windows\winsxs\FileMaps\$$_system32_spool_tools_microsoft_xps_document_writer_6c7957555c36cebb.cdf-ms","%TargetDir%\Windows\winsxs\FileMaps\$$_system32_spool_tools_microsoft_xps_document_writer_6c7957555c36cebb.cdf-ms"
#FileCopy,"%InstallSRC%\Windows\winsxs\FileMaps\$$_system32_printing_admin_scripts_en-us_f242a041737eb912.cdf-ms","%TargetDir%\Windows\winsxs\FileMaps\$$_system32_printing_admin_scripts_en-us_f242a041737eb912.cdf-ms"
If,NotExistDir,"%TargetDir%\Windows\winsxs\Backup",DirMake,"%TargetDir%\Windows\winsxs\Backup"
FileCopy,"%InstallSRC%\Windows\winsxs\Backup\x86_microsoft-windows-ntvdm-system32_31bf3856ad364e35_6.0.6000.16386_none_fbd6b71e75a2c6c8_winspool.exe_af57
28df","%TargetDir%\Windows\winsxs\Backup\x86_microsoft-windows-ntvdm-system32_31bf3856ad364e35_6.0.6000.16386_none_fbd6b71e75a2c6c8_winspool.exe_af57
28df"
If,NotExistDir,"%TargetDir%\Windows\winsxs",DirMake,"%TargetDir%\Windows\winsxs"
If,NotExistDir,"%TargetDir%\Windows\winsxs\FileMaps",DirMake,"%TargetDir%\Windows\winsxs\FileMaps"
If,NotExistDir,"%TargetDir%\Windows\winsxs\Manifests",DirMake,"%TargetDir%\Windows\winsxs\Manifests"


all above lines were written for vistap without sp1 and en-US local.

Require_File,Require_File,FVECPL.DLL


would be a mistake in [Bitlocker] section

FileCopy - Failed to copy [G:\Temp\VistaPE-Core\InstallWimSrc\Windows\System32\wdi.dll] to: [%BaseDir%\Target\VistaPE-Core\Windows\System32\wdi.dll]
!!! Can not copy WPCCPL.DLL file!!!
!!! Can not copy MSVCR71D.DLL file!!!
!!! Can not copy MSVCP71D.DLL file!!!
!!! Can not copy MSVCP50.DLL file!!!
!!! Can not copy NTMSAPI.DLL file!!!
!!! Can not copy pnpibs.dll file!!!
!!! Can not copy MSXML.DLL file!!!
!!! Can not copy MSXML4R.DLL file!!!
!!! Can not copy MSXML4.DLL file!!!
!!! Can not copy win32_tpm.dll file!!!
!!! Can not copy FVENOTIFY.EXE file!!!
!!! Can not copy FVEUI.DLL file!!!
!!! Can not copy Require_File file!!!
!!! Can not copy BITLOCKERWIZARD.EXE file!!!
FileCopy - Failed to copy [G:\Temp\VistaPE-Core\InstallWimSrc\Windows\System32\Drivers\fvevol.sys] to: [%BaseDir%\Target\VistaPE-Core\Windows\System32\Drivers\fvevol.sys]
FileCopy - Failed to copy [G:\Temp\VistaPE-Core\InstallWimSrc\Windows\System32\Drivers\ksecdd.sys] to: [%BaseDir%\Target\VistaPE-Core\Windows\System32\Drivers\ksecdd.sys]
FileCopy - Failed to copy [G:\Temp\VistaPE-Core\InstallWimSrc\Windows\System32\Drivers\dumpfve.sys] to: [%BaseDir%\Target\VistaPE-Core\Windows\System32\Drivers\dumpfve.sys]
FileCopy - Failed to copy [G:\Temp\VistaPE-Core\InstallWimSrc\Windows\inf\tpm.inf] to: [%BaseDir%\Target\VistaPE-Core\Windows\inf\tpm.inf]
FileCopy - Failed to copy [G:\Temp\VistaPE-Core\InstallWimSrc\Windows\inf\tpm.PNF] to: [%BaseDir%\Target\VistaPE-Core\Windows\inf\tpm.PNF]
FileCopy - Failed to copy [G:\Temp\VistaPE-Core\InstallWimSrc\Windows\System32\wbem\wlan.mof] to: [%BaseDir%\Target\VistaPE-Core\Windows\System32\wbem\wlan.mof]
FileCopy - Failed to copy [G:\Temp\VistaPE-Core\InstallWimSrc\Windows\System32\wbem\WLanHC.mof] to: [%BaseDir%\Target\VistaPE-Core\Windows\System32\wbem\WLanHC.mof]
!!! Can not copy NMWCDCLS.DLL file!!!
!!! Can not copy wlangpclnt.dll file!!!
!!! Can not copy CPSOKBTasks.xml file!!!
!!! Can not copy SecureKeyBackupCPL.dll file!!!
!!! Can not copy DIFXAPI.DLL file!!!
!!! Can not copy CHCKSHLL.DLL file!!!

some files cannot be found either installsrc or bootsrc in VistaSP1

maybe they exist in VistaSP0

in vc++ runtime

the msvcrt71d.dll is a debug version, it does not exist in vista dvd

#93 PaPeuser

PaPeuser

    Silver Member

  • Advanced user
  • 787 posts
  •  
    United States

Posted 02 March 2009 - 07:29 AM

Tested with Winbuilder 76 and Vista v12 (RC1)
Source Vista Ultimate SP0 and WAIK
Both English versions

Have you unchecked in Shell v4 script - Printer spooler, Wlan, Audio, and Bitblocker ??

From the same site you downloaded ((Shell V 4)) look for ((xVPE Patch.7z))

Unzip and put the folder in Base

xPE Patch = VistaPE Patch v3jb and will have MS Visual C++2008

I cant help you out with the language problem and some of this script is in French

I have a list of files not copied over and none of them stop build
Yes some missing files i can not find
I have yet to go back and figure out why they are included in first place.

Control Panel from Start Menu opens to blank screen, in this window click TOOLS – FOLDER OPTIONS – VIEW and click Reset Folders.

Contol Panel from My Computer- Folders list will work better
……………………………………………………………………………..
xPE Patch or VistaPE Patch - can be used alone and will give you
Start Menu - Programs - Computer Management.

Computer Management includes most of what you would find in Control Panel.

Computer Management
Date and Time
Device Manager
Folder Options
Fonts
Hardware Wizard - I think this may need Shell V4 installed
Internet Options
Keyboard
Mouse
PnpUtil
Printers
Regional and Language Options
Shared Folders
Sound
System information
System properties
Taskbar and Start Menu
User Accounts

Because Computer Management offers most of what would be needed in Control Panel
I am Happy and can do without Control Panel

Good luck

#94 ludovici

ludovici

    Silver Member

  • .script developer
  • 610 posts
  • Location:France
  •  
    France

Posted 02 March 2009 - 03:05 PM

Hi everybody :cheers:
And thanks for all PaPeuser :cheers:

I like this :
"to list control panel items left of explorer, it's not so hard.
copy and regist all dlls neccesary, and also the add Namespace entry in Regeistry needed"

If it's simple Zhang Heng, can you create this script ?

#95 PaPeuser

PaPeuser

    Silver Member

  • Advanced user
  • 787 posts
  •  
    United States

Posted 02 March 2009 - 03:45 PM

Hello

I hope Zhang Heng can help out!! He may have to learn french :cheers: :cheers:

#96 ludovici

ludovici

    Silver Member

  • .script developer
  • 610 posts
  • Location:France
  •  
    France

Posted 02 March 2009 - 04:29 PM

Hello

I hope Zhang Heng can help out!! He may have to learn french :cheers: :cheers:


Lol, :cheers:
I am eager to test his script for the control panel :cheers:
I'm so bad as that in English ? (Thanks Google Traduction, Lol) :cheers:

#97 PaPeuser

PaPeuser

    Silver Member

  • Advanced user
  • 787 posts
  •  
    United States

Posted 02 March 2009 - 05:00 PM

First we have to get him started - Booted

I would like to see control Panel and Network Places or Network Connections Work

Take one part at a Time

Some Parts of xPE Patch and Shell V4 are almost the same, BUT one needs the other
i get lost in all this script :cheers: :cheers:

Parts of script still need work
Networking
Wlan
Audio
Bitblocker
Printer services
File copy Errors

#98 Zhang Heng

Zhang Heng

    Member

  • Members
  • 51 posts
  •  
    China

Posted 03 March 2009 - 08:14 AM

Hi PaPeuser,

Thank you a lot.

I build pe with shell v4 as you said. and also xVPE Patch.script

unchecked the things, wlan, audio ...

but the pe cannot start, it halted at the bootmgr, something error, 0xc000what what...

en, maybe sometime I will see if I can improve the shell v4 to make it work well on my system.

to list contorl panel items on the left of explorer,

just have a try of the attachment.

no need vpe patch, only this script and cpl.script from vista pe 12.

I tested it in vistape 12 with vista sp1 as source.

When I decided to write this script, I want to make three things work on pe.

1 Set desktop resolution with desk.cpl.

2 Get on line through wireless with network center

3 Mobility center

and, I realy made the network center work as in Vista.

and easy access, syn center, system properties ...

but, I found I cannot start Network list service in PE, so I thought the REFRESH in connect to dialog is no use.

Mobility center depends on dx9

Although I used xVPE DirectX 10.script, it cannot work.

so I deleted all things except set desktop resolution.

This morning, I wanted to recover the things I deleted.

but, I don't know what I missed.

let me work on...

Of course I believe you.

There must be something wrong that I did.


First we have to get him started - Booted

I would like to see control Panel and Network Places or Network Connections Work

Take one part at a Time

Some Parts of xPE Patch and Shell V4 are almost the same, BUT one needs the other
i get lost in all this script :cheers: :cheers:

I even posted a few more pictures for those who dont believe Picture Page

Parts of script still need work
Networking
Wlan
Audio
Bitblocker
File copy Errors

Attached Files



#99 PaPeuser

PaPeuser

    Silver Member

  • Advanced user
  • 787 posts
  •  
    United States

Posted 03 March 2009 - 10:54 AM

Hello
Thanks for the report

In Explorer Shell Ultimate V4 -under Menu properties tweaks ---Uncheck Use Vista style start menu
Sorry if i did not point this out before- if this is check it will do as you say when booted

When I decided to write this script, I want to make three things work on pe.

1 Set desktop resolution with desk.cpl.

2 Get on line through wireless with network center

3 Mobility center

and, I realy made the network center work as in Vista.

Great if make any progress or you need any help lets us know :cheers: :cheers:

I will let you know about ((Control Panel Desk)) you attached

#100 ludovici

ludovici

    Silver Member

  • .script developer
  • 610 posts
  • Location:France
  •  
    France

Posted 03 March 2009 - 01:23 PM

Great work Zhang Heng :cheers:

I will test this script tonight...

Hello PaPeuser, you say :
"Parts of script still need work
Networking
Wlan
Audio
Bitblocker
File copy Errors"
I am agree with you, we must work on this; and we can add Printer at this list...

Zhang Heng, can you explain me how can i work with tour batch files ?
Your work is impressive, and i want understand really all your work...




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users