Jump to content











Photo
- - - - -

New Beta Script for VistaPE


  • Please log in to reply
221 replies to this topic

#51 PaPeuser

PaPeuser

    Silver Member

  • Advanced user
  • 787 posts
  •  
    United States

Posted 02 February 2009 - 01:20 PM

I just found all the options in script window for Explorer shell Ultimate v2
Customizes your Winbuilder's explorer shell

This will take me awhile

in Peloader explorer is listed 4 times,, but if you switch to BSexplorer any ONE will get you back to Explorer shell

:cheers: B)

#52 PaPeuser

PaPeuser

    Silver Member

  • Advanced user
  • 787 posts
  •  
    United States

Posted 02 February 2009 - 06:58 PM

Hi ludovici

I like this script, a few clicks in options and I now have my desktop back

My clock is now in English

Control Panel start menu is the same –folder options reset just like before

Add Printer says spooler service is not started

Networking icon and Speaker icon are no longer on taskbar

Recycle bin disappeared when I got desktop back

lots of options to try yet

This line fix one font issue
FileCopy,"%InstallSRC%\windows\Fonts\*.*","%TargetDir%\windows\Fonts"


file pnpibs.dll not copied over for section PNP

a few files in Wlan not copied over ,, i get list later
Over all I like it Thanks

#53 ludovici

ludovici

    Silver Member

  • .script developer
  • 610 posts
  • Location:France
  •  
    France

Posted 02 February 2009 - 07:54 PM

I am happy than you like my work PaUser :cheers:
Thanks for your participation; i know than my script stay in beta...
Here a picture of the possibility of VistaPE (Stardock 6.3, Icon Packager & My script...)
Posted Image


P.S : My new script for windows features is here
http://ludovici.winb... Feature.script
Be careful the windows photo gallery don't work...
And Windows Media player 11 don't play all the codecs...
A capture of my script
Posted Image

#54 PaPeuser

PaPeuser

    Silver Member

  • Advanced user
  • 787 posts
  •  
    United States

Posted 03 February 2009 - 01:42 AM

Well after many tests with this last script and updating Winbuilder to 76

I can now unplug and plug my USB (wired) Silitek keyboard as well as my USB wired mouse
Click refresh in Device Manager and they both work.

Both are detected and installed as Human Interface Devices

My Wireless USB mouse gets detected as a USB Receiver but not correctly
It works when installed before boot

Its not perfect.

And Winbuilder 76 built my first error free build, :cheers: :cheers: B) :cheers:

#55 PaPeuser

PaPeuser

    Silver Member

  • Advanced user
  • 787 posts
  •  
    United States

Posted 03 February 2009 - 02:22 AM

From post #44 download Shell v.20 (Explorer shell Ultimate V2)

Copy it to Base

In Base files don’t uncheck anything

All Addons may be unchecked except
Internet Explorer 7
PENetCfg
TotalCommander

Drivers uncheck
Tweaks uncheck

App- System folder
You can uncheck everything

In Explorer shell Ultimate V2
I chose to uncheck webview and check ClassicShell
Uncheck add fonts

This is what worked for me. (I think) I hope I didn’t forget anything
I have not gone back and checked or unchecked and tested all other options

boot and please check out explorer shell
:cheers: :cheers: B)
Build should work with these settings

#56 PaPeuser

PaPeuser

    Silver Member

  • Advanced user
  • 787 posts
  •  
    United States

Posted 04 February 2009 - 03:31 PM

Hello :cheers:

Well I got this far I figured I would try this xVPE feature script from post #53
Added Max XPE patch
Added xVPE feature script
Unchecked Addons - Internet Explorer 7

I never had much luck with the Max patch after Vista 11

What is needed from this patch?

I had a few things working. But lost interest and went back to looking at all the options with the Explorer shell Ultimate V2 script.

With Shell v2 script
When I logoff explorer shell could it open Peloader? Other wise logoff is not needed or has no function

Some options do not work
Show My Documents on desktop
Show My Network places on Desktop
Trash bin does not show
Most of these I do not use anyway

I think I would remove Wlan and use a separate script?
Desktop is a gray and when i enable BGInfo desktop returns to standard vistaPE backround

I Need more time to play


Over all I found this a very solid script and I will keep it.. B) :cheers:
all my App's and plugins work!!

Thanks again

#57 PaPeuser

PaPeuser

    Silver Member

  • Advanced user
  • 787 posts
  •  
    United States

Posted 04 February 2009 - 06:05 PM

Hello again

With PNP usb keyboard and mouse work ALLOT better

When plugging in an USB keyboard or mouse after boot you must refresh device manager.
USB mouse and Keyboard are detected correctly and installed
Meaning you still need a PS2 mouse.

USB mouse and Keyboard installed at boot worked in all my tests.

BUT
If this auto refreshed right at detection or when a USB device was plugged in it would be more PNP or hot swappable.
with out refreshing Device Manager

In Explorer Shell Ulit script I could only find this for PNP

[PuP]
Echo,"Processing Extended PnP..."
Require_File,grpconv.exe
Require_File,IoLogMsg.dll
Require_File,pnpibs.dll
Require_File,pnpsetup.dll
Require_File,pnpts.dll
Require_File,pnpui.dll
Require_File,PNPXAssoc.dll
Require_File,PNPXAssocPrx.dll
Require_File,PnPUnattend.exe
Require_File,PnPutil.exe
#
#extra files
If,ExistFile,"%InstallSRC%\Windows\System32\oobe\pnpibs.dll",FileCopy,"%InstallSRC%\Windows\System32\oobe\pnpibs.dll","%TargetDir%\Windows\System32\oobe"
If,ExistFile,"%InstallSRC%\Windows\System32\oobe\%DistLang%\pnpibs.dll.mui",FileCopy,"%InstallSRC%\Windows\System32\oobe\%DistLang%\pnpibs.dll.mui","%TargetDir%\Windows\System32\oobe\%DistLang%"

More testing required
I need a asprin you got me thinking
:cheers: B)

#58 ludovici

ludovici

    Silver Member

  • .script developer
  • 610 posts
  • Location:France
  •  
    France

Posted 04 February 2009 - 07:49 PM

Hello everybody :cheers:

I have change my webpage, in directory beta you have all my script.
My Vistape Core
You have not need of other script...
If you want use XPE Gui script, you must choose XPE Patch and XPE Net...
You have need Winbuilder 76 (Not tested) or Winbuilder 75 Beta 6 (Tested)
Good Luck B)
P.S : I think at your PaPeuser... Thanks for all

#59 TheHive

TheHive

    Platinum Member

  • .script developer
  • 4171 posts

Posted 08 February 2009 - 02:59 AM

You can't seem to download the beta project using Winbuilder. It appears to lock the Winbuilders ability to add a new address or delete youre added address.

#60 PaPeuser

PaPeuser

    Silver Member

  • Advanced user
  • 787 posts
  •  
    United States

Posted 08 February 2009 - 03:52 AM

Hello

I think you misunderstood
MY VISTAPE CORE is only a link to his directory of Beta scripts
In his directory look for scripts we talked about here.

This is not one beta Vistape core file
Is a bunch of scripts he has posted of his personal beta core

I hope i understood your post? :poke: :poke:

#61 TheHive

TheHive

    Platinum Member

  • .script developer
  • 4171 posts

Posted 09 February 2009 - 02:41 AM

The Control Panel link does not download the script on the first post.

Hello

I think you misunderstood
MY VISTAPE CORE is only a link to his directory of Beta scripts
In his directory look for scripts we talked about here.

This is not one beta Vistape core file
Is a bunch of scripts he has posted of his personal beta core

I hope i understood your post? :poke: :poke:



#62 twindude

twindude

    Frequent Member

  • Members
  • 150 posts

Posted 09 February 2009 - 01:00 PM

Nice work..

i clicked on the control link in your post,, don't see the script?

I would like to test out the WLAN and Control Panel scripts..

possible?

#63 PaPeuser

PaPeuser

    Silver Member

  • Advanced user
  • 787 posts
  •  
    United States

Posted 09 February 2009 - 08:36 PM

EDITED - again

From ludovici web site

http://ludovici.winbuilder.net/

look for and download
BETA/APP/ShellV2.script
ShellV2.script = Explore shell Ultimate V2-test [shell_V2.script]

Download and installed to Project\VistaPE\base

script includes Control Panel, Wlan, Audio and many tweaks
Options can be selected in script window before build

Using this script by deselecting

Addons – uncheck EVERYTHING but
Internet Explorer, PENetCfg and Total Commander

Drivers – uncheck everything

Tweaks – uncheck everything

Uncheck add fonts in Explore shell Ultimate V2-test [shell_V2.script]

There will be a few warnings and errors on build but it will boot

Take notice to Hardware detection - USB devices
Take notice to right click take ownership of files, or option to show hidden files
Take notice to networing icon on desktop, right click and start services.
Right click my computer and view system properties,
USB safely Remove Hardware icon - depends on desktop preferences
not all options work but check out what does

Tested with WinBuilder 76 - VistaPE v12 (RC1) all Apps work

This is just BETA SCRIPTS you can test to

I like :poke:

#64 ludovici

ludovici

    Silver Member

  • .script developer
  • 610 posts
  • Location:France
  •  
    France

Posted 10 February 2009 - 03:35 PM

Hello everybody,

Sorry for being late, I had a very good weekend pass :poke:

"I think you misunderstood
MY VISTAPE CORE is only a link to his directory of Beta scripts
In his directory look for scripts we talked about here.
This is not one beta Vistape core file
Is a bunch of scripts he has posted of his personal beta core"

I hope i understood your post?
TheHive : " You can't seem to download the beta project using Winbuilder. It appears to lock the Winbuilders ability to add a new address or delete youre added address."

It's difficult for me to explain the goal of my change of directory...
But The hive has to be right, I wanted add my "Webpage" in winbuilder; for help everybody to download just necessary... I have got the same problem of "TheHive"... I will continue to improve my scripts and share it in the coming days... Thanks everybody for your participation; and sorry for my english

#65 thelegendarypig666

thelegendarypig666

    Member

  • Members
  • 46 posts

Posted 10 February 2009 - 10:31 PM

EDITED

From ludovici web site

http://ludovici.winbuilder.net/

look for and download
BETA/APP/ShellV2.script
ShellV2.script = Explore shell Ultimate V2-test [shell_V2.script]
or
Home/shell.script


Download and installed to Project\VistaPE\base

Both scripts include Control Panel, Wlan, Audio and many tweaks
Options can be selected in script window before build

Using this script by deselecting

Addons – uncheck EVERYTHING but
Internet Explorer, PENetCfg and Total Commander

Drivers – uncheck everything

Tweaks – uncheck everything

Uncheck add fonts in ShellV2.script - errors on build,

There will be a few warnings and errors on build but it will boot

Take notice to Hardware detection - USB devices
Take notice to right click take ownership of files, or option to show hidden files
Take notice to networing icon on desktop, right click and start services.
Right click my computer and view system properties,
USB safely Remove Hardware icon - depends on desktop preferences
not all options work but check out what does

Tested with WinBuilder 76 - all Apps work

This is just BETA SCRIPTS you can test to

I like :poke:


Tryed this script. When compiling it give 11 errors all related with directory copy in winsxs folder. Build seems fine then when I boot the system, every system I do try, I have black screen after loading file with error 0xc0000017.

Build made with XP sp3, WAIK 1.1 installed, DVD Vista SP1. I disabled all the drivers and all the stuff said in the post I do quote above.

#66 PaPeuser

PaPeuser

    Silver Member

  • Advanced user
  • 787 posts
  •  
    United States

Posted 10 February 2009 - 11:16 PM

Hello
I am using Vista Ultimate SP0 but I do not think that should make a difference

I will go back and check settings again,

i get 17 warnings most are files that are not copied

Thanks for letting me know

which shell are you trying?

#67 thelegendarypig666

thelegendarypig666

    Member

  • Members
  • 46 posts

Posted 10 February 2009 - 11:52 PM

Hello
I am using Vista Ultimate SP0 but I do not think that should make a difference

I will go back and check settings again,

i get 17 warnings most are files that are not copied

Thanks for letting me know

which shell are you trying?

Hello and thankx for your reply too. I downloaded and tryed this:

BETA/APP/ShellV2.script

#68 PaPeuser

PaPeuser

    Silver Member

  • Advanced user
  • 787 posts
  •  
    United States

Posted 11 February 2009 - 12:01 AM

Hello

BETA/APP/ShellV2.script
when added to your base file should show in Winbuilder slection window as

base - Explore shell Ultimate V2-test [shell_V2.script]
I just unchecked fonts and left all the rest (default settings) in script

I just went over my uncheck list all looked ok,

This was tested again and again last night with a new builds from Winbuilder 76 and complete Vistape v12 download.
I followed my directions and it boot first time,,


Have a nice day :poke:

#69 thelegendarypig666

thelegendarypig666

    Member

  • Members
  • 46 posts

Posted 11 February 2009 - 10:16 PM

Mmmmm...

Do u disable the Explorer standard shell in VistaPe base dir?

More: after adding your shell, I do have TWO Base on the VistaPE Winbuilder tree: one is with all the VistaPE 12 default scripts and the other is just for your script...

Is this correct?


Thankx

#70 PaPeuser

PaPeuser

    Silver Member

  • Advanced user
  • 787 posts
  •  
    United States

Posted 11 February 2009 - 11:07 PM

Hello

No do not disable anything in first or original base

Yes correct you will have 2 base folders one with just this script

Seond base file will only contain this - Explore shell Ultimate V2-test

When in tree view select Explorer shell Ulitmate V2-test and uncheck
"add fonts" in options

Add font wills error and stop load

Ludovici has a fix ,This line in font section need changed
line 3038
FileCopy,"%InstallSRC%\windows\fonts\*","%TargetDir\windows\Fonts
to this
FileCopy,"%InstallSRC%\windows\fonts\*.*","%TargetDir\windows\Fonts

#71 thelegendarypig666

thelegendarypig666

    Member

  • Members
  • 46 posts

Posted 12 February 2009 - 01:41 PM

The problem was Winbuilder. I've been using 75 and something, and I had to upgrade to 76 to compile.

Then, I can't say it work as expected: I do have pretty much the same default explorer shell desktop, control panel is empty and I can see an audio icon on the traybar.

I just had 10 copy errors in the build, the iso is over 600 MB, so I don't know how to look to launch the new shell.

BTW, I also made a build disabling default Explorer, it compile, the default menu is the v2 explorer shell, then it can't load administrative tools and a lot of others tools becouse it say it need a Internet Explorer > 5.5 version for MCC to work. Obviously disabling original explorer. IE 7 wont compile :-(((

I do use original VPEloader. Where is the problem?

Thankx again!

#72 PaPeuser

PaPeuser

    Silver Member

  • Advanced user
  • 787 posts
  •  
    United States

Posted 12 February 2009 - 02:24 PM

Hello

I used 75 K to build before upgrading to WB 76 builds – (ok make note)

In Control Panel -Tools - folder options - view - reset folders
I have been trying to get control panel working better, I have had some luck

Explorer problem - you have Internet Explorer 7 enabled in Addons?
And you left explorer shell checked in base files?
I have seen that error before and I thought it had to do with not having
Internet Explorer 7 enabled.

Original or default PEloader is what I use, the one the came with download

This shell update works with your existing Explorer shell and Internet Explorer just adds new options

Thanks

#73 PaPeuser

PaPeuser

    Silver Member

  • Advanced user
  • 787 posts
  •  
    United States

Posted 12 February 2009 - 02:56 PM

Hello
EDITED-Updated

This shellv2.script is not a stand alone shell it works with existing Explorer shell and Internet explorer 7

Most of add-ons that you unchecked are already included in this script.
Check scripts options.

Drivers is something that needs tested, because I do not check driver folder or load anything extra for drivers and I have had better luck with driver detection.

Yes all my USB mice and keyboards are detected as human interface devices and installed correctly.

Personally I would rip out Wlan, Audio, Printer services and do separate scripts.
Uncheck Wlan, Audio, and Printer services in script and check size
Size could be cut in half almost

Right click on everything, Computer icon on desktop, look at added options


I would really like it if you get this to work and report what you find!

#74 ludovici

ludovici

    Silver Member

  • .script developer
  • 610 posts
  • Location:France
  •  
    France

Posted 12 February 2009 - 04:47 PM

Thanks for all your work PaPeuser, :poke:
It's good to had help :poke:

I have update my script Shell V4
Content of Update:
- Association files (Html, jpg, wmv...)
- Windows program installation
- Windows Update
- Miscellenous optimization...

Personally I would rip out Wlan, Audio, Printer services and do separate scripts.
Uncheck Wlan, Audio, and Printer services in script and check size
Size could be cut in half almost

Everyone or not want separate my script ?
If yes, No problem...

thelegendarypig666 : i can't load administrative tools and a lot of others tools becouse it say it need a Internet Explorer > 5.5 version for MCC to work
You must use my XPE feature Windows script for this...

I have a problem with my script : The icon of Mypicture/Mydoc/MyVideo are not display on StartMenu as ControlPanel/Help/Search...
Can i have help for this ?

And i can build a "Standard" VistaPE but not a "RAM" VistaPE with my script, an :poke:

#75 PaPeuser

PaPeuser

    Silver Member

  • Advanced user
  • 787 posts
  •  
    United States

Posted 12 February 2009 - 08:46 PM

HI ludovici

For me i would like to get the Basic part of this script right

Hello All :poke: :poke:

Then add Audio, Wlan and Printer Service

I have been looking and working on the Control Panel part of script,,,

BUT do you know how hard it is to go thro all of script looking for problems for just Control Panel?

Lets take just the basic part of script and make it work, then adding options to add the rest, maybe nice,

Do you know that with your other service script some of Control Panel worked better?

I like this script right click my computer options, right click take ownership
Device manager works better,, and I think devices are detected and installed better


There is allot of good stuff included in this script, BUT

Lets take one thing at a time and fix it ,, :poke: :)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users