Jump to content











Photo
- - - - -

VistaPE12b3 updatepack


  • Please log in to reply
18 replies to this topic

#1 pecd.net

pecd.net

    Silver Member

  • .script developer
  • 947 posts
  •  
    Germany

Posted 02 October 2008 - 07:02 AM

Hi all,

i created an update pack for the current VistaPE version that fixes many bugs and adds new features.

As very much was changed i would like a some experienced users to test it and give feedback before i release it to the public.

If anyone is interested please contact me by PM. Please only contact me if you are familiar with VistaPE and Winbuilder scripts.

Script developers are welcome :-)

Thanks!

#2 pecd.net

pecd.net

    Silver Member

  • .script developer
  • 947 posts
  •  
    Germany

Posted 02 October 2008 - 08:14 PM

Several users PMed me and so the test have started. Thanks!

We already found some smaller issues, but please test further.-))

Just to make it clear:

I am trying to make the VistePE core more stable and bugfree, but i am not working on the apps so far.
So if you find bugs in the app scripts please post them here if you want, but they are not adresses in the updatepack right now.

Also there are several vpeldr.exe related problems (like the cubic explorer shell bug) which are not yet adressed, but i am working on an updated vpeldr.exe (nightman was so kind to share his code with me)...this may still take some time...

#3 pecd.net

pecd.net

    Silver Member

  • .script developer
  • 947 posts
  •  
    Germany

Posted 03 October 2008 - 06:00 AM

Some smaller changes were made to the pack, all testers can download it from the known location.

Please post all problems you find here, and please also comment on the changes i made to the scripts interfaces and if all texts are understandable.

When i started with VistaPE i really had problems understanding all the options and i wanted them to be clearer to newbies...

#4 pecd.net

pecd.net

    Silver Member

  • .script developer
  • 947 posts
  •  
    Germany

Posted 06 October 2008 - 06:49 AM

For now only minor cosmetic issues were reported...anything else?

bump

#5 TheHive

TheHive

    Platinum Member

  • .script developer
  • 4172 posts

Posted 06 October 2008 - 05:30 PM

Couldnt use the source I had. Vista SP0. So I have to get SP1.

#6 pecd.net

pecd.net

    Silver Member

  • .script developer
  • 947 posts
  •  
    Germany

Posted 06 October 2008 - 06:08 PM

vista sp0 should work, but it gives a warning (which can be disabled)...

What problems do you have with your sp0 source and what kind of vista dvd is it (language, oem or retail)

Does this problem also accour when using standard vistape12b3 or just when unsing the updatepack?

#7 TheHive

TheHive

    Platinum Member

  • .script developer
  • 4172 posts

Posted 07 October 2008 - 05:12 AM

Will try to post results on weekend.

#8 pecd.net

pecd.net

    Silver Member

  • .script developer
  • 947 posts
  •  
    Germany

Posted 09 October 2008 - 09:05 AM

To all testers who got the url from me:

please redownload the pack, several important things were fixed...thanks

#9 ludovici

ludovici

    Silver Member

  • .script developer
  • 610 posts
  • Location:France
  •  
    France

Posted 10 October 2008 - 03:51 PM

CTmag hello :cheers:
Can you post the modification of the different script, of the pack or write the modification directly in the script, please thanks. :confused1:

#10 pecd.net

pecd.net

    Silver Member

  • .script developer
  • 947 posts
  •  
    Germany

Posted 10 October 2008 - 04:11 PM

for now to much work, sorry...do a simple filecomapare, i am doing mostly bugfixes right now...

#11 TheHive

TheHive

    Platinum Member

  • .script developer
  • 4172 posts

Posted 12 October 2008 - 08:14 AM

When Testing I use a Vista Business Edition, which worked with older VistaPE test . Ill try the full DVD tomorrow hopefully.

Downloaded latest Update, replace old files in Project and replaced Winbuilder with the one in update.

Error:
It seems that one of the paths is wrongly pointing to WimUtil in the wrong folder.

Its in the tools folder
\VistaPEupdatepack\Projects\Tools

not
L:\WINBUILDER\VistaPEupdatepack\Projects\Tools\WimUtil
WinUtil.jpg
Error.jpg

Log:
Attached File  log.zip   54.99KB   159 downloads

#12 TheHive

TheHive

    Platinum Member

  • .script developer
  • 4172 posts

Posted 12 October 2008 - 08:50 AM

Full SP0 Vista Test

Extracted to new folder L:\vistape12b3-base-updatepack3
vistape12b3-base.7z

Extracted contents on update to it
updatepack3.zip

Pointed to DVD source

Added new folder and copied L:\vistape12b3-base-updatepack3\projects\Tools\WimUtil.exe
into
L:\vistape12b3-base-updatepack3\projects\Tools\WimUtil

Pressed play.

Build says it successful.
1.jpg
2.jpg
VistaPE.jpg


So it seems a Lite Version of Vista wont do as per my previous test. Guess I have to use my full DVD.

#13 pecd.net

pecd.net

    Silver Member

  • .script developer
  • 947 posts
  •  
    Germany

Posted 12 October 2008 - 08:55 AM

wimutil\wimutil.exe was a typo by me...updated the pack...

by some strange reason your basedir is wrong too (see log)

%BaseDir% = L:\WINBUILDER\VistaPEupdatepack\

please try with a fresh folder and a fresh copy of vpe and the updatepack...thanks

I do not even have a L drive...post your script.project and your project.ini if you can not fix it...

#14 pecd.net

pecd.net

    Silver Member

  • .script developer
  • 947 posts
  •  
    Germany

Posted 12 October 2008 - 08:57 AM

ahh, you already did:-)) The wimutil problem is fixed now..i hope.-)

#15 TheHive

TheHive

    Platinum Member

  • .script developer
  • 4172 posts

Posted 12 October 2008 - 09:02 AM

Im the one that has the L drive. lol!


since we are testing and updating the over Main scripts and not the apps yet, It is best to recommend to testers to use the
vistape12b3-base.7z instead.

When shutting down it says to remove CD or something like that but the wording is wrong.
It needs to say something like.

CD/DVD/etc... Can be removed now!
Or maybe some like it.

Used boot media can be removed at this time!

Have to :confused1:

#16 pecd.net

pecd.net

    Silver Member

  • .script developer
  • 947 posts
  •  
    Germany

Posted 12 October 2008 - 09:19 AM

hmm, you are using bsexplorer? I believe this diloge is from bsexplorer an i can not change the text...maybe you take a closer look at it..

never tried the vistape12b3-base.7z archive...but the VPE apps should work fine too...just for testing it is less to download...

#17 pecd.net

pecd.net

    Silver Member

  • .script developer
  • 947 posts
  •  
    Germany

Posted 12 October 2008 - 09:33 AM

I sent the updatepack to nightman. I think he is working on an updated VistaPE version. Not sure when it will come.

Until then i will stop working on the pack (except bugfixes) and i offer it for free download to anyone who wants it.

Be aware that there still might be bugs in it and that it may be updated without notice.

The URL: http://www.citro-com.../updatepack.zip

This has nothing to do with my work project, this is just a private download i offer and it is far from the main project i work on. I just want to give back to the community who helped me fixi the bugs. Thanks to all who helped and tested!

#18 darren rose

darren rose

    Frequent Member

  • Advanced user
  • 449 posts
  • Location:Norwich, Norfolk
  •  
    United Kingdom

Posted 13 October 2008 - 03:58 PM

@nighman

any idea of an eta for the updated version of vistape? no hassling, just curious really

#19 pecd.net

pecd.net

    Silver Member

  • .script developer
  • 947 posts
  •  
    Germany

Posted 13 October 2008 - 05:45 PM

as far as i know he no longer follows the forum...so he wont answer...

Not date given, but i already tried his first version, which uses many of my files, but he did not use everything, so by now (from my point of view) bet3 with updatepack will be better than the upcomming rc1 of vpe12 (but this depends on what is imprtant to you).




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users