Jump to content











Photo
- - - - -

Multi Multi Multi Boot USB HD , Backtrack 3 , XP SP3 Installation, Ultimate Boot CD..


  • Please log in to reply
5 replies to this topic

#1 Mesh

Mesh
  • Members
  • 8 posts
  •  
    Jordan

Posted 12 August 2008 - 12:50 PM

Hello there !

i began digging about the boot thingy since a week ago , i used , grub , smart boot manager , isoemu , i am sticking now with the best solution , GRUB4DOS.


i Bought an external Hard disk : Segate Free Agent™Go 160 GB , seems to be SATA or maybe SCSI , i mix between them ( will be good if anyone explains ) but any how , the requirement was as follows :


note : i was thinking of booting iso files off the external hard disk , then i belived that sooner or later , the virtual CD will be lost when another kernal is loaded ( specially in case of windows installation )


i format variant pc's alot , i have a much pc's with same brand and sepcs ( i will use ghost too) , so

REQUIREMENTS :

a GRUB4DOS menu that provides :

1. Backtrack 3 to be run LIVE from the HD. ( if an installed version boots in any pc no problem) [50%]

2. i need an XP installation from the USB Ext. HD ( SP3 ISO Geniun i've downloaded ) [Accomplished]
(i will tell how the trick works ( simple and easy :whistling: )

3. REMOVED

4. Ultimate Boot CD ( 4.1.1 or 5 beta no matter ) [ 0%]

5. maybe an installed version of kubuntu or ubuntu to run from the HD [0%]


so as GRUB4DOS is felixible enough , i guess no matter the partitioning architecture was , there is no problem ..

my menu.lst was like

title BackTrack

root (hd0,0)

kernel /boot/vmlinuz max_loop=255 initrd=initrd.gz init=linuxrc load_ramdisk=1 prompt_ramdisk=0 ramdisk_size=6666 root=/dev/ram0 rw

initrd /boot/initrd.gz

boot



title Windows XP Pro SP3 Setup

root (hd0,2)

chainloader=/$LDR$

boot


where :

1. grub4dos-0.4.4-2008-08-08.zip is intalled on the first primary FAT32 Partition ( i installed it using
bootlace.com through vmware)

2. Backtrack 3 has 2 folders (boot,BT3) are copied on the first primary FAT32 Partition

3. About XP Installation files , the smart trick i discovered was the following:

A. insert a XP CD in your computer , run setup from windows , choose new installation ,
in the options :
check the box which says ( let met choose the drive to install windows on ) and the copy i386 files
from/to check box.

B. enter the windows key you want, and start installation it will complete copying files , and count for
restart with a red bar , press Esc to cancel the operation

C. you will finde 2 folders on C:\ which are : $WIN_NT$.~BT and $WIN_NT$.~LS , i have copied them
to a second primary partition FAT32 , in addition to the following files located also on C:\
txtsetup.sif, ntldr, NTDETECT.COM, MSDOS.SYS, IO.SYS, CONFIG.SYS, AUTOEXEC.BAT, $LDR$
where $LDR$ will be the Loader for the installation the will initialize : inspecting your computer
hardware ..




RESULTS :

1.VMWARE : (VMware config was that i used the external harddisk as a SCSI physical Harddiskin the VM)
A. GRUB4DOS loaded successfully
B. Backtrack Loaded , but cannot access any partition of the external HD
C. Windows installtion begun , after loading files ,on starting windows , blue screen of death crashed.
D. REMOVED

2.My Laptop Dell inspiron 9300
A. GRUB4DOS loaded successfully
B. Backtrack Loaded , but cannot access any partition of the external HD
C.Windows Installation begun and i was able to get the windows partition manager and see my
External HD
D. REMOVED

3. Fujitsu Simens amilo Pi 1505 laptop
A. GRUB4DOS loaded in a strange way , before the menu appeares , it showed me that hd0,0 mounted
but hd0,1 no exist , .. then menu loaded , when choosing any of these , it seemed like there is no
partitions , i went to the command line and typed find , it seems that the only detected harddisk is the
fixed one with the laptop , my External hardisk seemed like not detected , ALthough GRUB4DOS
APPEARED !


My Quastions :

1. Backtrack 3 Final ( usb version or cd ) has a boot splash loader with many options ( using syslinux or
isolinux i dunt know the difference again lol ) , is there away to load that splash loader from grub4dos ?

2. Why the GRUB4DOS is loaded when i chose boot from USB Key in the Fujitsu simens laptop, but menu is not working , because partitions are not found , like the whol external harddisk is not detected , is that becasue the External USB harddisk is SCSI interface ? or SATA , is there any solution ? or just wait for GRUB4DOS to have a SCSI driver ??

3. is it possible have an already installed distro of linux on the harddisk and boot it from any pc in case of
crashing windows ?

Any Recommendation About the Architecture of partitioning and the file systems for each partition ? to get the optimal performance knowing that
the Hard disk real size is , 149.5
first partition is primary FAT32 1 GB,
2nd partition is primary FAT32 2 GB ( though 1 GB is enough too ) ,
third partition is primary FAT32 512 MB,

the rest space will be extended and logicals , a large NTFS partition maybe for ghost images , data back up and drivers.. ,

and in the end of the hard disk ,a linux SWAP of 1 GB.

please advise.

Eng. Mohannad Shaheen .

EDITED by jaclaz:
Removed references to WAREZ.


#2 Mesh

Mesh
  • Members
  • 8 posts
  •  
    Jordan

Posted 14 August 2008 - 09:56 AM

Backtrack 3 was unable to access the same external harddisk because of wrong configuration



the wrong configuration of menu.lst for backtrack 3 sections was

title BackTrack

root (hd0,0)

kernel /boot/vmlinuz max_loop=255 initrd=initrd.gz init=linuxrc load_ramdisk=1 prompt_ramdisk=0 ramdisk_size=6666 root=/dev/ram0 rw

initrd /boot/initrd.gz

boot

the Correct configuration of menu.lst for backtrack 3 sections is

title BT3 Graphics mode (KDE)

root (hd0,1)

kernel= /boot/vmlinuz ramdisk_size=6666 root=/dev/ram0 rw autoexec=xconf;kdm APPEND vga=0x317

initrd=/boot/initrd.gz 

boot


#3 Mesh

Mesh
  • Members
  • 8 posts
  •  
    Jordan

Posted 14 August 2008 - 10:01 AM

So , Any one for the Fujitsu Simens Amilo Pi 1505 Problem ??

#4 Mesh

Mesh
  • Members
  • 8 posts
  •  
    Jordan

Posted 14 August 2008 - 10:57 AM

i've noticed sth strange in the Fujitsu Siemens Amilo Pi 1505 Laptop , as i mentioned before the bios detected the usb external harddisk as declare it as disk0
, but when loaded menu.lsn , it didnt detect the partitions , and the (hd0,0 ) was the first partition in the internal harddisk of the laptop ,

i've tried (hd0-20,0) with no action ( grub said hardisk does not exist )

so i was like , if External USB disk in bios was disk0 and internal HD was disk1
in gurub , internal was disk0 , so i tried in the command line grub4dos

root (hd-1,0)

it gave me : a disk read error

?!?!?!??!?!?!?

#5 Mesh

Mesh
  • Members
  • 8 posts
  •  
    Jordan

Posted 15 August 2008 - 02:20 PM

Hello , i intend as i said before , to load the UBCD menu from a grub4dos that i created is that possible ? loading menu from menu ???

any one reply please !!?!?!

jaclaz please help ??!?!?!

#6 was_jaclaz

was_jaclaz

    Finder

  • Advanced user
  • 7,100 posts
  • Location:Gone in the mist
  •  
    Italy

Posted 19 August 2008 - 06:13 PM

So , Any one for the Fujitsu Simens Amilo Pi 1505 Problem ??


Probably there is nothing to do, it seems like a "bad" BIOS.

You can try using the Hp's utility (or however the Win2k/XP/2003 modified MBR):
http://www.boot-land...opic=2246&st=15
http://www.boot-land...?showtopic=3191
and load grldr through NTLDR/BOOT.INI

But I do not think it will make a difference, it sounds like a BIOS mapping the external drive as non-HD device (maybe superfloppy? :whistling:)

jaclaz




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users