Jump to content











Photo
* * * * * 1 votes

[project] New Make Script


  • Please log in to reply
256 replies to this topic

#26 TheHive

TheHive

    Platinum Member

  • .script developer
  • 4138 posts

Posted 18 October 2006 - 08:10 PM

The probleme is not there upload the new version and see
It now encode the files but only the first repertory
See in the Temp folder an look at the files
Problem is my MksConvert .au3 it tell that all folder are empty and don't encode them

The new Beta2 Script embeds both System32 and Programs files.
The problem about having to select the Show all files is still a bug.

#27 TheHive

TheHive

    Platinum Member

  • .script developer
  • 4138 posts

Posted 18 October 2006 - 08:16 PM

I have created a working Script. YAY! :P :P :P


Suggestion for future.
Addition of way to add EULA or LicenseAgreement button of somekind.

If I can think of anything else Ill let you know. Thanks!

#28 pedrole15

pedrole15

    Silver Member

  • .script developer
  • 731 posts
  •  
    France

Posted 18 October 2006 - 08:27 PM

OK
I hope I understood enough.
But one info I'm missing
What is the reason/meaning for

Peter

it 's the folder i've select for testing it must go in System32

I have now put an Beta3 script in first post work fully but don't test the empty folder
So if there is one empty folder Winbuilder don't encode it and the other folder gone in wrong place

#29 pedrole15

pedrole15

    Silver Member

  • .script developer
  • 731 posts
  •  
    France

Posted 18 October 2006 - 10:32 PM

New Version 004
All is right now
Test it

#30 TheHive

TheHive

    Platinum Member

  • .script developer
  • 4138 posts

Posted 18 October 2006 - 11:20 PM

New Version 004
All is right now
Test it


So far, so good.

Is there a way to create a subfolder in the Shortcut for

Start - Programs - Example Folder - Program Shortcut

#31 pedrole15

pedrole15

    Silver Member

  • .script developer
  • 731 posts
  •  
    France

Posted 19 October 2006 - 12:02 AM

So far, so good.

Is there a way to create a subfolder in the Shortcut for

Start - Programs - Example Folder - Program Shortcut

i am working on that
i hope do it

In this version when chosing an app all sub folder are encoded
If a folder have just sub folder no files you get the same with no error

#32 TheHive

TheHive

    Platinum Member

  • .script developer
  • 4138 posts

Posted 19 October 2006 - 11:25 AM

Here is what I was thinking off when I said folders in the Start - Programs - ...
I manually created those in the example.
Posted Image

One other idea.
Ability to add a shortcut to the "Startup" folder to auto start the Program.

#33 smiley

smiley

    Silver Member

  • .script developer
  • 905 posts
  •  
    Greece

Posted 19 October 2006 - 11:30 AM

Here is what I was thinking off when I said folders in the Start - Programs - ...
I manually created those in the example.
Posted Image

One other idea.
Ability to add a shortcut to the "Startup" folder to auto start the Program.


@TheHive: I think that creating a shortcut in the startup folder is very difficult because its name is localized.
Why not use autoruns?

#34 TheHive

TheHive

    Platinum Member

  • .script developer
  • 4138 posts

Posted 19 October 2006 - 12:33 PM

@TheHive: I think that creating a shortcut in the startup folder is very difficult because its name is localized.

I see what you mean. It auto creates the name for startup based on your language, so it would make it harder to create. ok! Bad Idea i guess.


Why not use autoruns?

What do you mean. I dont see anyway to create shortcuts in the startup folder in the Script.

#35 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12688 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 19 October 2006 - 01:25 PM

@TheHive: I think that creating a shortcut in the startup folder is very difficult because its name is localized.
Why not use autoruns?


Have a look at %Basedir%\Archive\autoTweaks\localeFolder.Script of the sandbox.
maybe it helps.

Peter

#36 pedrole15

pedrole15

    Silver Member

  • .script developer
  • 731 posts
  •  
    France

Posted 20 October 2006 - 10:29 PM

I have updated the MakeScript now Folder in start menu work but for put in the startup menu :P
With autorun perhaps but no icon
Look in XPE-Pnp.script
TXTAddLine,"%TargetDir%\i386\system32\autorun.cmd","start /wait HWPnP.exe

#37 TheHive

TheHive

    Platinum Member

  • .script developer
  • 4138 posts

Posted 22 October 2006 - 01:21 AM

The ability to create a submenu in the Start Menu is great. Thanks!
I will test it some more.

I ran into problem with the xmplayer where it needed a font for it to work properly. Can you add ability similar to the add files to system32 folder for adding fonts to the fonts folder.

#38 pedrole15

pedrole15

    Silver Member

  • .script developer
  • 731 posts
  •  
    France

Posted 22 October 2006 - 07:54 AM

The ability to create a submenu in the Start Menu is great. Thanks!
I will test it some more.

I ran into problem with the xmplayer where it needed a font for it to work properly. Can you add ability similar to the add files to system32 folder for adding fonts to the fonts folder.

Yes, perhaps it would be nice to make a "ToPeSystem" folder
Then you create a folder with other folder like "System32" "Font" and other and they will be add to the I386 folder in respective folder like work the "select app"
I'am thinking now to add possibility to choice multi prog from the same folder of the principal app for integrate them in the menu if i can

#39 TheHive

TheHive

    Platinum Member

  • .script developer
  • 4138 posts

Posted 22 October 2006 - 12:29 PM

Yes, perhaps it would be nice to make a "ToPeSystem" folder
Then you create a folder with other folder like "System32" "Font" and other and they will be add to the I386 folder in respective folder like work the "select app"

Good idea.


I'am thinking now to add possibility to choice multi prog from the same folder of the principal app for integrate them in the menu if i can

lol! you beat me to the idea. I was about to post something about this. :P

#40 TheHive

TheHive

    Platinum Member

  • .script developer
  • 4138 posts

Posted 22 October 2006 - 03:33 PM

I had another idea and question for the "Folder in Menu" .
Is it able to create more then one submenu.

For example. Right Now this is possible.
Start Menu\Programs\Accessories\SHORTCUT

Can it do this aswell:
Start Menu\Programs\Accessories\Entertainment\SHORTCUT

Maybe with syntax like the following

Folder in Menu:
Accessories\Entertainment

Good news. The test I did as mentioned above works.

When I tried doing a subfolder like the following it worked.
Folder in Menu:
Accessories\Entertainment

Might want to mention this or put an example in the gui. :P

#41 TheHive

TheHive

    Platinum Member

  • .script developer
  • 4138 posts

Posted 24 October 2006 - 06:26 PM

Can you take a look at this problem.
http://www.boot-land...?...post&p=4420

#42 pedrole15

pedrole15

    Silver Member

  • .script developer
  • 731 posts
  •  
    France

Posted 28 October 2006 - 01:31 AM

Version 6
See first post

#43 Nuno Brito

Nuno Brito

    Platinum Member

  • Team Reboot
  • 10448 posts
  • Location:boot.wim
  • Interests:I'm just a quiet simple person with a very quiet simple life living one day at a time..
  •  
    European Union

Posted 28 October 2006 - 09:34 AM

Version 6
See first post


Great work! :P

#44 TheHive

TheHive

    Platinum Member

  • .script developer
  • 4138 posts

Posted 28 October 2006 - 03:10 PM

I dont get what the "Select How you want Association file to work".

#45 pedrole15

pedrole15

    Silver Member

  • .script developer
  • 731 posts
  •  
    France

Posted 28 October 2006 - 06:33 PM

I dont get what the "Select How you want Association file to work".

There is 15 checkBox
If in "Select what you want..." you check the second option
You must check the First checkBox for the main application to the 8 if you want
and the checkbox 9 to 15 for the menu2. Must work
But perhaps you have an other script which is create after this, that have the same association then they are erased

#46 TheHive

TheHive

    Platinum Member

  • .script developer
  • 4138 posts

Posted 30 October 2006 - 03:41 AM

I dont fully understand the explanation.

I have a bug to report. Winbuilder seems to report the following at the end of the Process of building the Script. I was building the Opera Script and there is no Progress meter of anykind that tells the user that the script is being created. Winbuilder appears as if it is frozen. Any way to add a progress bar of somekind while building the Script.

Posted Image

#47 Nuno Brito

Nuno Brito

    Platinum Member

  • Team Reboot
  • 10448 posts
  • Location:boot.wim
  • Interests:I'm just a quiet simple person with a very quiet simple life living one day at a time..
  •  
    European Union

Posted 30 October 2006 - 10:48 AM

TheHive, can you start a new thread on the bug forum to report this error message?

I'm trying to replicate the same issue but I still haven't managed to spot it.. :P

This script is very good! :P

#48 phox

phox

    Silver Member

  • .script developer
  • 764 posts

Posted 30 October 2006 - 11:15 AM

Winbuilder seems to report the following
at the end of the Process of building the Script.


I encountered the same problem.
Scripts are done correctly despite annoying error message!

#49 TheHive

TheHive

    Platinum Member

  • .script developer
  • 4138 posts

Posted 30 October 2006 - 05:19 PM

Scripts are done correctly despite annoying error message!

yes! The same in my testing.


TheHive, can you start a new thread on the bug forum to report this error message?

I'm trying to replicate the same issue but I still haven't managed to spot it.. :P

This script is very good! :P



Posted new thread about this here:
http://www.boot-land...p?showtopic=588

Im was building a Script from the Opera 9 folder and when you wait till it finishes even though it looks as Winbuilder is frozen. If you look into the Test folder where the Script is being created you will notice the file is being created because it increments in size from time to time until ti finishes and then you get the error posted at the folowing bug report. Using Build 52 beta 6 of Winbuilder.

#50 Nuno Brito

Nuno Brito

    Platinum Member

  • Team Reboot
  • 10448 posts
  • Location:boot.wim
  • Interests:I'm just a quiet simple person with a very quiet simple life living one day at a time..
  •  
    European Union

Posted 30 October 2006 - 11:04 PM

I'll test the Opera script to see what can be done to solve this!! :P




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users