Jump to content











Photo
- - - - -

Update API


  • Please log in to reply
18 replies to this topic

#1 pedrole15

pedrole15

    Silver Member

  • .script developer
  • 731 posts
  •  
    France

Posted 01 June 2008 - 12:23 PM

Update for API

EN.jpg
Put this file in same folder as script.project

Attached File  Update_Vista_Api_V4.7z   47.28KB   403 downloads
Now compatible with VistaPE Beta 2

For more infos (in french) look here
Same fonctionality will be added in next LiveXP API 14

;)
Pedro

#2 Nuno Brito

Nuno Brito

    Platinum Member

  • .script developer
  • 10562 posts
  • Location:boot.wim
  • Interests:I'm just a quiet simple person with a very quiet simple life living one day at a time..
  •  
    European Union

Posted 01 June 2008 - 01:15 PM

Excellent work, thanks! ;)

#3 JonF

JonF

    Gold Member

  • .script developer
  • 1185 posts
  • Location:Boston, MA
  •  
    United States

Posted 01 June 2008 - 01:17 PM

Anyone have any idea what's happened to NightMan? His last public post was over two months ago, and seemed to indicate another update coming soon.

#4 Nuno Brito

Nuno Brito

    Platinum Member

  • .script developer
  • 10562 posts
  • Location:boot.wim
  • Interests:I'm just a quiet simple person with a very quiet simple life living one day at a time..
  •  
    European Union

Posted 01 June 2008 - 03:13 PM

I've talked with him 10 days ago, he's very busy with his real-life work at the moment but still working actively on VistaPE.

He has a new beta ready, will ask if it can be released.

;)

#5 JonF

JonF

    Gold Member

  • .script developer
  • 1185 posts
  • Location:Boston, MA
  •  
    United States

Posted 01 June 2008 - 06:48 PM

Good that he's OK. No rush on the release.

#6 TheHive

TheHive

    Platinum Member

  • .script developer
  • 4172 posts

Posted 02 June 2008 - 04:27 AM

Im glad his fine. I was worried, since he hasnt been around here.

#7 pedrole15

pedrole15

    Silver Member

  • .script developer
  • 731 posts
  •  
    France

Posted 14 June 2008 - 04:58 PM

Updated to version 3
see post #1

#8 pecd.net

pecd.net

    Silver Member

  • .script developer
  • 947 posts
  •  
    Germany

Posted 14 June 2008 - 05:23 PM

Sorry, but this does not work for me:

When saving the file to api.script and adding it to the project i see only the french options and i can not change to english.
when ich do the update i get an error (something like section updateapi not found) and i can not switch back to the old api, because the script is no longer displayed in the tree..

Am i doing something wrong here?

#9 pedrole15

pedrole15

    Silver Member

  • .script developer
  • 731 posts
  •  
    France

Posted 14 June 2008 - 05:38 PM

Sorry, but this does not work for me:

When saving the file to api.script and adding it to the project i see only the french options and i can not change to english.
when ich do the update i get an error (something like section updateapi not found) and i can not switch back to the old api, because the script is no longer displayed in the tree..

Am i doing something wrong here?

Hi ctmag
Don't rename the file to api script
Simply add this file in same folder as sript.project
and clik on {Install new api}

To change interface language clik on English/French then in left select an other script and come back to Update_Api

#10 pecd.net

pecd.net

    Silver Member

  • .script developer
  • 947 posts
  •  
    Germany

Posted 14 June 2008 - 07:17 PM

OK, thanks!

Everything is fine now, but better 7zip the script, because when i download the file there is no name given and i did not expect the filname to matter...

#11 pedrole15

pedrole15

    Silver Member

  • .script developer
  • 731 posts
  •  
    France

Posted 14 June 2008 - 07:24 PM

OK, thanks!

Everything is fine now, but better 7zip the script, because when i download the file there is no name given and i did not expect the filname to matter...

ok ;)

#12 Max_Real Qnx

Max_Real Qnx

    Gold Member

  • Patrician
  • 1382 posts
  • Location:Istanbul
  • Interests:To be or not to be that is the question.
  •  
    Turkey

Posted 14 June 2008 - 08:23 PM

Thanks for big job ;)

#13 pedrole15

pedrole15

    Silver Member

  • .script developer
  • 731 posts
  •  
    France

Posted 15 June 2008 - 10:44 PM

I 've just download VistaPE 12 Beta 2 and notice that there is some change in api
So warning don't use for VistaPE 12 Beta 2
Will update to version 4 soon

Example for translate or organize StartMenu without change any script just by editing theTranslate.ini

BEFORE01.jpg AFTER03.jpg

#14 pecd.net

pecd.net

    Silver Member

  • .script developer
  • 947 posts
  •  
    Germany

Posted 16 June 2008 - 05:49 AM

hmm, i already applied it to beta2, will your updates version fix the problem (or can i return to old api)

Or will i have to start from scratch?

#15 pedrole15

pedrole15

    Silver Member

  • .script developer
  • 731 posts
  •  
    France

Posted 17 June 2008 - 06:12 AM

hmm, i already applied it to beta2, will your updates version fix the problem (or can i return to old api)

Or will i have to start from scratch?

You must redownload the file script.project and \base\00-api-main.script
Sorry :)

#16 pecd.net

pecd.net

    Silver Member

  • .script developer
  • 947 posts
  •  
    Germany

Posted 17 June 2008 - 07:25 AM

thanks, i fixed it...

#17 pedrole15

pedrole15

    Silver Member

  • .script developer
  • 731 posts
  •  
    France

Posted 19 June 2008 - 11:14 PM

Updated to version 4

#18 pecd.net

pecd.net

    Silver Member

  • .script developer
  • 947 posts
  •  
    Germany

Posted 10 July 2008 - 10:56 AM

@pedrole15

I comapre the current VPE api from beta2 (second edition, as nightman changed some things without calling it beta3) with your version 4 and i noticed that several times the lines

IniRead,%VistaInfo%,"VistaInfo","ForceAllToRam","%ForceAllToRam%"
If,"%ForceAllToRam%",Equal,"Yes",Set,%VPE_CFG%,%VPECFG%

from nightman are not in you api...

as i (have to admit) do not understand everything from your api yet, can you please chekc if this is correct and maybe explain why you removed it...thanks!

#19 pecd.net

pecd.net

    Silver Member

  • .script developer
  • 947 posts
  •  
    Germany

Posted 10 July 2008 - 11:04 AM

I also noticed that the new api uses 7za.exe which is not (by default) in the tools folder of vpe.

And penetcfg and TC give me a wrong parameter warning for quicklaunch...but icons are created in pe...




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users