Jump to content











Photo
* * * - - 1 votes

LiveXP USB boot com Windows 2003


  • Please log in to reply
9 replies to this topic

#1 Cleyton

Cleyton
  • Members
  • 5 posts
  •  
    Brazil

Posted 09 April 2008 - 03:37 PM

Saudações a todos!

Sou novo aqui no fórum, vim a conhece-lo através do colaborador Nuno Brito.

Parabéns a todos pelo excelente fórum!

Nuno obrigado pela rapidez da resposta ao e-mail que lhe foi enviado por mim.

Fiz o disco de boot utilizando o Windows server 2003 que me indicou, consegui gerar o ISO, gravei um CD e ficou muito bom uma excelente versão live do 2003, gravei os arquivos da pasta “Target/LiveXP” utilizando o PetoUsb para dentro do Pen drive de 2Gb, até ai tudo bem, da o boot sem problemas só que quando abre a tela do desktop poucos segundos depois some a tela e aparece uma mensagem falando que o formato de vídeo não é suportado ideal de 1024 x 768 60Hz.

Sendo que o mesmo arquivo gravado em um CD funciona perfeitamente.

Caso alguém saiba o que possa estar ocorrendo ficaria muito grato pela orientação.

#2 Nuno Brito

Nuno Brito

    Platinum Member

  • Team Reboot
  • 10452 posts
  • Location:boot.wim
  • Interests:I'm just a quiet simple person with a very quiet simple life living one day at a time..
  •  
    European Union

Posted 09 April 2008 - 04:32 PM

Olá Cleyton!

Existe um script chamado SetResolution dentro da pasta "Apps\Miscellaneous\SetResolution.script"

Desactiva esse script e faz uma nova imagem.

--------

Outra hipótese é pegar na pendisk e tentar noutro computador só para ver o resultado porque pode ser da placa gráfica ser incompatível com os drivers incluídos.

Boa sorte!!

:thumbsup:

#3 Cleyton

Cleyton
  • Members
  • 5 posts
  •  
    Brazil

Posted 09 April 2008 - 09:51 PM

Grato pela atenção e rapida resposta vossa amigo Nuno!

Gostaria de importunalo mais uma vez com respeito ao boot pela Pendisk.

Tentei a sugestão que me passou porem encontrei o Script dentro da pasta "Basic/Tweaks/SetResolution.script", o desabilitei gerei um novo disco e ocorreu o mesmo erro, tentei dar o Boot em outras maquinas dão o mesmo problema, o que não consigo entender é o por que de funcionar perfeitamente com o LiveCD visto tanto a Pendisk quanto o CD possuirem os mesmos arquivos e drivers.

Estou usando a versão 074 do Winbuilder.

Em uma das maquinas que testei deu o erro 0x0000007b, nas outras continuou dando erro de resolução de video quando o boot é feito pela pendisk, e funciona sem problemas com boot pelo LiveCd.

Pesquisei no forum algo a respeito mas não consegui encontrar uma solução.

#4 Nuno Brito

Nuno Brito

    Platinum Member

  • Team Reboot
  • 10452 posts
  • Location:boot.wim
  • Interests:I'm just a quiet simple person with a very quiet simple life living one day at a time..
  •  
    European Union

Posted 09 April 2008 - 10:40 PM

Fizeste a maioria dos passos que eu faria mas eu esqueci-me do óbvio - desculpa.

Passos a fazer:

- Criar o teu projecto (feito)
- Colocar a pendisk no computador


Através do WinBuilder, dentro da pasta "Finish\2 Create Image" encontras um script chamado BootSDI.

Neste script tens a opção de criar a tua pendisk de arranque.

:thumbsup:

#5 Cleyton

Cleyton
  • Members
  • 5 posts
  •  
    Brazil

Posted 10 April 2008 - 02:46 PM

Grato pela dica.

Já tinha tentado antes pelo BootSDI, mas não tinha entendido como o usar.

Usei a seguinte configuração conforme a imagem anexa:

Indiquei o caminho do meu Pendisk em “Letter”, e os arquivos do Win2003, depois clicando em “Process”.

Foi gerado os seguintes arquivos dentro do Pendisk:

--> ntdetec
--> ntldr
--> BootSDI
--> WINNT.SIF

Mas uma pergunta, feito isso devo copiar os arquivos da pasta “Traget/Livexp” utilizando o PetoUsb desabilitando a formatação?

Ou simplesmente faço a cópia do ISO do Livexp da pasta “ISO/Livexp.iso” com a versão do Win2003 para dentro da Pendisk.

Attached Files



#6 Nuno Brito

Nuno Brito

    Platinum Member

  • Team Reboot
  • 10452 posts
  • Location:boot.wim
  • Interests:I'm just a quiet simple person with a very quiet simple life living one day at a time..
  •  
    European Union

Posted 10 April 2008 - 03:44 PM

O winnt.sif é um ficheiro de texto (que podes abrir com o bloco de notas) e indica qual a imagem a carregar no arranque do windows.

Neste caso deve ser o BootSDI a imagem que contém a imagem a ser carregada na memória.

Tenta arrancar da pendisk assim como o script a deixa e deve funcionar por si mesmo.

:thumbsup:

#7 Cleyton

Cleyton
  • Members
  • 5 posts
  •  
    Brazil

Posted 10 April 2008 - 08:08 PM

Caro Nuno obrigado pela explicação, agora pude compreender como funciona aquele escript, ele gera os arquivos de boot e converte o aquivo ".iso" em ".img".

Não sei o que estou fazendo de errado, mas estou apanhando da configuração do programa. Ou se estou selecionando arquivos errados.

Segui sua dica e gerei a Pendisk, elá da o boot. Só que trava na tela aguardo, que aparece antes de iniciar o LiveWin2003

Conforme imagem no arquivo anexo

testei em outra maquina e ocorreu o mesmo problema!

Attached Thumbnails

  • tela_travada.JPG


#8 Nuno Brito

Nuno Brito

    Platinum Member

  • Team Reboot
  • 10452 posts
  • Location:boot.wim
  • Interests:I'm just a quiet simple person with a very quiet simple life living one day at a time..
  •  
    European Union

Posted 13 April 2008 - 03:24 PM

Parece mesmo um caso impossível.

Talvez seja melhor experimentar com outro projecto mais adequado ao arranque por USB.

Recomendo-te a tentar o VistaPE, encontrei um bom tutorial para explicar passo por passo o que é preciso fazer: http://www.purviance...ashdrive_bl.htm

:thumbsup:

#9 Cleyton

Cleyton
  • Members
  • 5 posts
  •  
    Brazil

Posted 11 July 2008 - 01:31 PM

Caro Nuno.

Depois de muita pesquisa sobre o projeto livexp rodando apartir do Pendisk, descobri que eu estava cometendo um erro.
Estava mandando o PetoUSB buscar os aquivos direto do CD liveXP. E observando o projeto Bartpe que ja havia conseguido rodar da Pendisk vi que o mesmo na geraçao do Disco não havia a pasta [BOOT], o que fiz então foi buscar apenas os outros arquivos, e então sucesso funcionou agora estou super satisfeito com minha pendisk de boot com o live 2003 serve.

Agora meu problema se resume a descobrir como inserir novos Drives dentro da Pendisk, pois não consigo ativar os dispositivos de Audio e de rede Wi-Fi.

Caso possa me ajudar sobre se isso é possivel e como fazer, fico desde já muito grato.

E mais uma vez parabens pelo projeto.

#10 Nuno Brito

Nuno Brito

    Platinum Member

  • Team Reboot
  • 10452 posts
  • Location:boot.wim
  • Interests:I'm just a quiet simple person with a very quiet simple life living one day at a time..
  •  
    European Union

Posted 11 July 2008 - 05:11 PM

Olá Cleyton,

Fico feliz que esteja a funcionar mas infelizmente não creio que suporte a WIFI seja possível neste momento.

No entanto, o suporte para som já foi adicionado num projecto chamado NaughtyPE (disponível na secção de projectos do WinBuilder neste fórum)

Este projecto é semelhante ao LiveXP dado que partilham o mesmo motor (NativeEx) e portanto recomendo-te para tentar adicionar a secção multimédia.

Boa sorte! :)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users