Jump to content











Photo
* * * - - 1 votes

Forum is offline next 25th of March for upgrade


  • Please log in to reply
20 replies to this topic

#1 Nuno Brito

Nuno Brito

    Platinum Member

  • .script developer
  • 10544 posts
  • Location:boot.wim
  • Interests:I'm just a quiet simple person with a very quiet simple life living one day at a time..
  •  
    European Union

Posted 22 March 2008 - 06:13 PM

A forum software upgrade is scheduled for the next 25th of March.


This new IPB software version should provide an overall improvement of the forum security as well as solve some of the bugs noticed when searching for forum posts and posting links.


Hopefully this will be the last time this year that a software upgrade is done and will also feature a forum skin change to improve things a bit.

I've already installed an offline forum to start testing it thoroughly before being uploaded to replace our present software.

Sorry for any inconvenience caused by the time period while boot land is under this much needed maintenance.

:thumbsup:

#2 was_jaclaz

was_jaclaz

    Finder

  • Advanced user
  • 7100 posts
  • Location:Gone in the mist
  •  
    Italy

Posted 22 March 2008 - 06:22 PM

Let's hope that this time links won't be destroyed and that Forum will resume working properly with Opera. :thumbsup:

jaclaz

#3 Nuno Brito

Nuno Brito

    Platinum Member

  • .script developer
  • 10544 posts
  • Location:boot.wim
  • Interests:I'm just a quiet simple person with a very quiet simple life living one day at a time..
  •  
    European Union

Posted 22 March 2008 - 08:28 PM

Crossing my fingers here! :thumbsup:

#4 AeroXP

AeroXP

    Frequent Member

  • Advanced user
  • 177 posts
  • Location:0000:7c00
  • Interests:Motorola 68000 Assembler, PCs, Betas, Boot Disks, x86 Assembler
  •  
    United States

Posted 25 March 2008 - 01:46 AM

We're on the temp. forum right now... right?

#5 Nuno Brito

Nuno Brito

    Platinum Member

  • .script developer
  • 10544 posts
  • Location:boot.wim
  • Interests:I'm just a quiet simple person with a very quiet simple life living one day at a time..
  •  
    European Union

Posted 25 March 2008 - 01:58 AM

I've began overwriting the older files with the ones from this newer version after midnight (>1300 files)

All posts made during this transition are still registered on the database, except if some critical error happens and for some reason we're forced to restore the previously made backup.

No reason to worry, the worse thing is the fine-tunning until everything gets back to normal.

:thumbsup:

#6 Nuno Brito

Nuno Brito

    Platinum Member

  • .script developer
  • 10544 posts
  • Location:boot.wim
  • Interests:I'm just a quiet simple person with a very quiet simple life living one day at a time..
  •  
    European Union

Posted 25 March 2008 - 02:51 AM

Forum software update was completed sucessfully.

During the rest of the day I'll be re-introducing our custom modifications and keep this post updated until the "fine-tune" process is completed.

:thumbsup:

#7 online

online

    Silver Member

  • Advanced user
  • 767 posts

Posted 25 March 2008 - 02:17 PM

Please, Nuno, note that actually the whole left pane (with Log-out link and CP link) during forum navigation is missed...


Btw: really it is visible only from this url... (that is this... :thumbsup: :tabletalk:)




Edit: after just 9 mins from this post it seems solved, now left pane is really visible! :D :D

#8 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12707 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 25 March 2008 - 05:27 PM

And our good old friend 'Internal Server Error' is still alive and very active! :thumbsup:

Peter

#9 online

online

    Silver Member

  • Advanced user
  • 767 posts

Posted 25 March 2008 - 06:36 PM

Yes :D , and left pane is disappeared again (maybe it's because the upgrade is still in progress :tabletalk: )...


@ psc
Please, can you kindly repair your link?
Thanks! :thumbsup:

#10 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12707 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 25 March 2008 - 06:45 PM

Yes :D , and left pane is disappeared again (maybe it's because the upgrade is still in progress :tabletalk: )...


@ psc
Please, can you kindly repair your link?
Thanks! :thumbsup:


It is now moved to http://nativeex.boot...rograms/reg2WBS

If you tell me where the broken link is, I can fix it.

Peter

#11 online

online

    Silver Member

  • Advanced user
  • 767 posts

Posted 25 March 2008 - 07:10 PM

It is now moved to http://nativeex.boot...rograms/reg2WBS

Thanks! :tabletalk:

If you tell me where the broken link is, I can fix it.

It is in its "Submit your program or project" related thread... :thumbsup:

#12 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12707 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 25 March 2008 - 07:14 PM

Thanks! :D


It is in its "Submit your program or project" related thread... :tabletalk:

Thanks :thumbsup:

Peter

#13 Nuno Brito

Nuno Brito

    Platinum Member

  • .script developer
  • 10544 posts
  • Location:boot.wim
  • Interests:I'm just a quiet simple person with a very quiet simple life living one day at a time..
  •  
    European Union

Posted 25 March 2008 - 07:36 PM

I'm having some difficulties implementing a new software package called minervaSEO.

The biggest advantage is the hability to cache pages to save server load and some better policies to keep under control those spam/crawl bots.

Unfortunately this couldn't previously be tested on a demo board because it was incompatible with windows mod_rewrite but I'm hoping to see this solved as quickly as possible.

Discussion with the developer about this matter can be found here: http://icelabz.net/f...ll-install-php/

------

Looking on the bandwith/memory usage I see that even thought the portal (left bar) was removed, the server load has expanded from an average of 500Mb RAM usage to nearly 1Gb and >300 users at the same time.

These are the news for now, if the board gets offline for too long, there's also this blog post as a resort point: http://boot-land.blo...re-upgrade.html and also our alternative forum space on 911CD for generic discussions: http://www.911cd.net...p?&showforum=40

#14 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12707 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 25 March 2008 - 07:44 PM

I'm having some difficulties implementing a new software package called minervaSEO.

The biggest advantage is the hability to cache pages to save server load and some better policies to keep under control those spam/crawl bots.

Unfortunately this couldn't previously be tested on a demo board because it was incompatible with windows mod_rewrite but I'm hoping to see this solved as quickly as possible.

Discussion with the developer about this matter can be found here: http://icelabz.net/f...ll-install-php/

------

Looking on the bandwith/memory usage I see that even thought the portal (left bar) was removed, the server load has expanded from an average of 500Mb RAM usage to nearly 1Gb and >300 users at the same time.

These are the news for now, if the board gets offline for too long, there's also this blog post as a resort point: http://boot-land.blo...re-upgrade.html and also our alternative forum space on 911CD for generic discussions: http://www.911cd.net...p?&showforum=40


Thanks, Nuno!
You are doing a HUGE job!

I know what it means to upgrade a living system. (I did several times for the 2000 issue at several newspapers). It is not a task for a lazy weekend!

I also saw (when the right frame was still visible) the unusual number of guests.

At other sites, I sometimes got the message that the number of guests is exceeded and I should try again later.

It a similar procedure possible here?

Peter

#15 Nuno Brito

Nuno Brito

    Platinum Member

  • .script developer
  • 10544 posts
  • Location:boot.wim
  • Interests:I'm just a quiet simple person with a very quiet simple life living one day at a time..
  •  
    European Union

Posted 25 March 2008 - 08:00 PM

Would be good to make our server run more efficiently, the "internal server error" message is too annoying.

I have the impression that these are not "guests" but rather a hurd of spam bots or google crawler bots.

From what I read around the web - the best way to limit them is adding specific methods to channel them.

Our last soft point was the blog and they pushed the SQL resources to the limit because of the wordpress software. This was solved once the blog was transfered to the blogspot services but we can't do anything similar on the IPB software.

Now it's needed to filter away these "guests" for good.

#16 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12707 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 25 March 2008 - 08:20 PM

I have the impression that these are not "guests" but rather a hurd of spam bots or google crawler bots.

Is in the forum's software a way that guests have to read a random picture and type it into an input box?

Many WEB sites do so.

Peter

#17 Nuno Brito

Nuno Brito

    Platinum Member

  • .script developer
  • 10544 posts
  • Location:boot.wim
  • Interests:I'm just a quiet simple person with a very quiet simple life living one day at a time..
  •  
    European Union

Posted 25 March 2008 - 11:08 PM

Updates:
  • FURL (friendly URLs's) was disabled to let the server support the excess of visitors, will likely be enabled soon.
  • A new skin theme was introduced
  • Renamed "Submit your program or project" to "Project forge"
  • Moved some Winmize and Universal Windows NT family video driver inside the Project Forge
  • Still working on the integration of the minerva component


:thumbsup:

#18 Nuno Brito

Nuno Brito

    Platinum Member

  • .script developer
  • 10544 posts
  • Location:boot.wim
  • Interests:I'm just a quiet simple person with a very quiet simple life living one day at a time..
  •  
    European Union

Posted 26 March 2008 - 01:41 AM

mkportal was upgraded to the latest version which added back the left bar, still some corrections left to be done but they should hopefully be completed tomorrow.

:thumbsup:

#19 Nuno Brito

Nuno Brito

    Platinum Member

  • .script developer
  • 10544 posts
  • Location:boot.wim
  • Interests:I'm just a quiet simple person with a very quiet simple life living one day at a time..
  •  
    European Union

Posted 27 March 2008 - 11:14 AM

A tag system was added to ease organization of topics.

This functions a bit like del.icio.us where anyone can add up tags as they prefer.

As a result, this will generate a tag cloud from where all used tags are mentioned and those who often repeat get bigger font letters.

A function such as this will help many people to "tag" topics and group them without need to use the search tool to find information related to "SDI" (for example).

Look here: http://www.boot-land...mp;CODE=showTag


----

Unfortunately the update process also modified the skin settings and now I'm trying to correct the colors used on the logo box and on the left bar.

:thumbsup:

#20 was_jaclaz

was_jaclaz

    Finder

  • Advanced user
  • 7100 posts
  • Location:Gone in the mist
  •  
    Italy

Posted 27 March 2008 - 08:06 PM

Some good news and some bad news:
1) links are still good :D
2) buttons, emoticons and the like started working again in Opera :thumbsup:
3) the "More Options" button in "Search" takes you nowhere, tthere is not currently a way to search the board with "advanced options" :tabletalk:

jaclaz

#21 Nuno Brito

Nuno Brito

    Platinum Member

  • .script developer
  • 10544 posts
  • Location:boot.wim
  • Interests:I'm just a quiet simple person with a very quiet simple life living one day at a time..
  •  
    European Union

Posted 27 March 2008 - 11:08 PM

I'm still trying to fix the white boxes on the left bar but I'm glad that Opera is (finally) working right! :thumbsup:


Will get my hands on the advanced options search.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users