Jump to content











Photo

Newcomer's Tutorial - LiveXP, Win7PE & Portable Apps!


  • Please log in to reply
369 replies to this topic

#26 amalux

amalux

    Platinum Member

  • Tutorial Writer
  • 2813 posts
  •  
    United States

Posted 05 June 2011 - 06:07 AM

Hi gnikolic,

Fwiw, I ran that test project on an XP machine (with old AIK) using Windows 7 SP1 (Ultimate) x86 source and there is no issues as you describe. Shortcuts are created and work normally in real HW and in VMware. Hope you figure out what's going on.

:dubbio:

#27 gnikolic

gnikolic

    Frequent Member

  • Advanced user
  • 112 posts
  • Location:Serbia
  •  
    Serbia

Posted 05 June 2011 - 07:06 PM

Ok. Now I am confussed! Realy!

I am using XP SP3 with Kaspersky internet Security. There is some problem. I am going to install a fresh XP without Antivirus.

Will send a info!

Thanx.

#28 gnikolic

gnikolic

    Frequent Member

  • Advanced user
  • 112 posts
  • Location:Serbia
  •  
    Serbia

Posted 06 June 2011 - 06:06 AM

Hello Amalux, all!

I`ve got a PE! :cheers:
Solution for me uninstall WAIK, reinstall it. Used Windows 7 SP1. Your build had some error with dhcpsrv.dll and I am using winbuilder from Win7pe_se and your collection of portable tools (some of them).

AIDA64 had a same problem but R-drive Image and R-Studio worked just fine. R-Drive Image had a problem with first starting because window (i think and a process) dissapered but when started again, app worked just fine.

Q. Is it better to build my own portable apps and not using some found on the internet?
Q. Before some 3-4 year i`ve used ghost for imageing but there are some new tools like EASEUS Todo Backup, Acronis Backup & Recovery, Ative! Boot disk, R-Disk-Image, ... Do you have some sugestion for better app for imageing servers and RAID system?
Q. Is there a solution for building PE but where portable apps want implement in WIM file?
Q. A script for multi-WIM is great but there is solution only for 4 or 5 additional WIMs. But what about more WIMs?


Thanx in support.

#29 amalux

amalux

    Platinum Member

  • Tutorial Writer
  • 2813 posts
  •  
    United States

Posted 06 June 2011 - 07:20 AM

Hi

Hey, that's great, glad you've had some success. Just keep playing with it; Win7PE_SE is very flexible and hundreds of portables work great in it. Using that same build, AIDA64 portable works fine.


Q. Is it better to build my own portable apps and not using some found on the internet?

Whatever works best for you, many portables work great as is but I prefer to customize and create my own for fun. Use whatever best suits your specific needs.

Q. Before some 3-4 year i`ve used ghost for imageing but there are some new tools like EASEUS Todo Backup, Acronis Backup & Recovery, Ative! Boot disk, R-Disk-Image, ... Do you have some sugestion for better app for imageing servers and RAID system?

Same answer, what works best for you; I prefer Acronis but there are many nice (free) alternatives available.

Q. Is there a solution for building PE but where portable apps want implement in WIM file?

I don't understand. You mean there not setup to expand to writable temp or you haven't allowed enough writable space? They all work fine if setup properly.

Q. A script for multi-WIM is great but there is solution only for 4 or 5 additional WIMs. But what about more WIMs?

I guess you've asked the question here, I hope 2aCD can help you out.

:cheers:

#30 gnikolic

gnikolic

    Frequent Member

  • Advanced user
  • 112 posts
  • Location:Serbia
  •  
    Serbia

Posted 06 June 2011 - 10:21 AM

I don't understand. You mean there not setup to expand to writable temp or you haven't allowed enough writable space? They all work fine if setup properly.



No. Is there a solution build an ISO file with a folder with portable apps and not injectiong in wim file?

Thanx.

#31 gnikolic

gnikolic

    Frequent Member

  • Advanced user
  • 112 posts
  • Location:Serbia
  •  
    Serbia

Posted 06 June 2011 - 12:11 PM

I have a strange error with using multi-wim script... Dont known is it a problem with wim images.
List index out of bounds (2): set,%BCDEdit%=%Tools%\%OSArch%\bcdedit.exe


Thanx in support.

#32 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12688 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 06 June 2011 - 01:12 PM

set,%BCDEdit%=%Tools%\%OSArch%\bcdedit.exe

The script where this error occurs, has a syntax error.
Correct is:
set,%BCDEdit%,%Tools%\%OSArch%\bcdedit.exe
Comma instead of equals.

Peter

#33 gnikolic

gnikolic

    Frequent Member

  • Advanced user
  • 112 posts
  • Location:Serbia
  •  
    Serbia

Posted 06 June 2011 - 01:45 PM

The script where this error occurs, has a syntax error.
Correct is:

set,%BCDEdit%,%Tools%\%OSArch%\bcdedit.exe
Comma instead of equals.

Peter


Peter, You rocks!

Thanx a lot!

:cheers:

#34 amalux

amalux

    Platinum Member

  • Tutorial Writer
  • 2813 posts
  •  
    United States

Posted 06 June 2011 - 06:11 PM

Is there a solution build an ISO file with a folder with portable apps and not injectiong in wim file?

Yes! You can build an image where ppApps resides at the root of your CD/DVD (not in RAM), gets loaded normally with all programs and shortcuts working as expected etc. However, there are some limitations and special requirements which I will explain.

1) The build model must be set to 'Normal', not to 'In RAM (boot.wim)' in Main Configuration settings.

This will result in an image approx double the size as the same build set to 'In RAM' and can only be booted from CD/DVD, not from HDD/UFD or ISO in VM etc. You will get all of the 'normal' performance degradation associated with running from CD/DVD but also the advantage of far less required RAM.

2) Use CreateISO script's 'Include Files in ISO RootCD' option for importing ppApps folder to CD/DVD root. Just move ppApps folder into directory created by selecting 'Put Files for RootCD Here' button.

3) The ppApps must be setup to extract everything to a writable Temp directory and run from there. All of the programs in the link I posted are setup this way and will work well (including context menus and file associations etc.)
Posted Image

I'm sure many other portables will work as well but many will not. Any program that attempts to unpack or write to its own directory will fail with errors. It's a fine solution for those with very limited (less than 1GB) RAM resources. Hope that helps.

:cheers:

#35 amalux

amalux

    Platinum Member

  • Tutorial Writer
  • 2813 posts
  •  
    United States

Posted 06 June 2011 - 06:20 PM

I have a strange error with using multi-wim script...
List index out of bounds (2): set,%BCDEdit%=%Tools%\%OSArch%\bcdedit.exe

I'm curious what script you refer to, the MultiWim script in the project has only line:

%BCDEdit%=#$q%TargetDir%\Windows\System32\bcdedit.exe#$q


under variables.

#36 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12688 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 06 June 2011 - 08:20 PM

I'm curious what script you refer to, the MultiWim script in the project has only line: ... under variables.

My favorite :cheers: comes to live again!

Peter :cheers:

#37 gnikolic

gnikolic

    Frequent Member

  • Advanced user
  • 112 posts
  • Location:Serbia
  •  
    Serbia

Posted 06 June 2011 - 10:07 PM

:cheers:



Thanx Amalux.
I think a better leave that method and use what is it normal or use all in WIM.

GNikolic.

P.S.: PE is working great and I think I am gone try to build my own portable apps.

One more Q. What is better in stability, Windows 7 or Server 2008 images or it is same?

#38 amalux

amalux

    Platinum Member

  • Tutorial Writer
  • 2813 posts
  •  
    United States

Posted 06 June 2011 - 10:37 PM

Windows 7, original M$ image; not OEM or modified.

:cheers:

#39 gnikolic

gnikolic

    Frequent Member

  • Advanced user
  • 112 posts
  • Location:Serbia
  •  
    Serbia

Posted 09 June 2011 - 06:00 AM

Thanx. I have M$ original Win7 SP1 and I am using it.

Gnikolic.

#40 Reboot

Reboot
  • Members
  • 2 posts

Posted 23 July 2011 - 10:53 PM

I couldn't reboot after burning a disc with lx78sp6cxw. I just see blinking _ on top left corner after BIOS.

#41 amalux

amalux

    Platinum Member

  • Tutorial Writer
  • 2813 posts
  •  
    United States

Posted 24 July 2011 - 12:54 AM

Is it configured in BIOS to boot from CD drive? Try setting it to first in boot order or just tap F-key (Esc, F10 etc.) at startup that gives you boot choices and choose CD drive.

:whistling:

#42 Reboot

Reboot
  • Members
  • 2 posts

Posted 26 July 2011 - 01:29 AM

Is it configured in BIOS to boot from CD drive? Try setting it to first in boot order or just tap F-key (Esc, F10 etc.) at startup that gives you boot choices and choose CD drive.

:wheelchair:


Boot order is already properly configured.

#43 amalux

amalux

    Platinum Member

  • Tutorial Writer
  • 2813 posts
  •  
    United States

Posted 26 July 2011 - 02:05 AM

Please post a link to your log.html (use Mediafire or similar) of the build; make sure the project run is unchanged from how it downloads other than setting your source. The source should be an untouched M$ CD/ISO (XP SP2/3) copied to hard drive folder.

#44 joedirt1954

joedirt1954

    Member

  • Patrician
  • 41 posts
  •  
    United States

Posted 24 September 2011 - 02:45 AM

I can not find how to remove duplicate folder listed on the left side in Winbuilder, have duplicate listing of Drivers and Tweaks folders. When looking in my C:\Win7 Builder\Projects\Win7PE_SE there is only one folder listed.

Thank You

#45 amalux

amalux

    Platinum Member

  • Tutorial Writer
  • 2813 posts
  •  
    United States

Posted 24 September 2011 - 03:24 AM

Not sure what is has to do with the tutorial but...

You've added scripts with alternate level settings. Make all the scripts in those folders to have matching levels and all will be well.

Ex.

[Main]
Title=Driver Package Installer
Author=sbaeder,ChrisR
Level=6
Version=1



#46 joedirt1954

joedirt1954

    Member

  • Patrician
  • 41 posts
  •  
    United States

Posted 24 September 2011 - 09:00 PM

Not sure what is has to do with the tutorial but...

You've added scripts with alternate level settings. Make all the scripts in those folders to have matching levels and all will be well.

Ex.


I did not know were else to post this question,

Thank You for the answer

#47 meoit

meoit

    Newbie

  • Members
  • 23 posts
  • Location:Linux
  •  
    Thailand

Posted 19 October 2011 - 07:29 AM

This is Greatest Post in LiveXp Forum!. Thanks So Much!



#48 amalux

amalux

    Platinum Member

  • Tutorial Writer
  • 2813 posts
  •  
    United States

Posted 19 October 2011 - 02:30 PM

You're very nice and I really appreciate it (there are many great posts in the forum). Thank you again for the kind words. Enjoy!

:)

#49 JanuszChmiel

JanuszChmiel

    Frequent Member

  • Advanced user
  • 201 posts
  •  
    Czech_ Republic

Posted 06 November 2011 - 06:31 PM

Dear syr,

I AM deeply appreciating Yours excellent tutorial. And i would like to thank You very much. that You have been added Yours debugged live XP based project.
I would like to kindly and valuably ask You, if You would send Yours ammazing Live XP project to other INternet file upload service than Mediafire.com.
Why?
Some servers are blocking downloading from The Mediafire server, i AM gotting strange messages when triing to download The files from Mediafire.

Error 404 or some message from Mediafire, that Yours site is unique, we do not using file limits ETC, but i can not download Yours project.
I Am kindly suggesting You The following file uploading service.

http://www.sendspace.com/

Thank You very much

#50 amalux

amalux

    Platinum Member

  • Tutorial Writer
  • 2813 posts
  •  
    United States

Posted 06 November 2011 - 08:20 PM

Sure, no problem; I'll upload now and post the new links when ready. Thank you for appreciation and kind words :)

:cheers:




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users