Jump to content











Photo
- - - - -

imdisk in win 2k


  • Please log in to reply
10 replies to this topic

#1 der.einstein

der.einstein
  • Members
  • 7 posts
  •  
    Germany

Posted 10 February 2008 - 02:22 PM

Hi there,
is anybody besides me using imdisk under win2k? everything works as it should, except that i can't mount images to empty ntfs folders. it just says the path cannot be found. i would be grateful if someone got this to work under win 2k and how.

Greetings from Germany, Einstein

#2 was_jaclaz

was_jaclaz

    Finder

  • Advanced user
  • 7100 posts
  • Location:Gone in the mist
  •  
    Italy

Posted 10 February 2008 - 03:26 PM

It works for me.

How I do it:
1) start the IMDISK CPL applet
2) mount a (hard disk) image "normally" but deleting the (automatically suggested) letter in the top right textbox
3) create a new empty folder on a NTFS drive
4) Open a command prompt and run mountvol (without parameters) and get from it's output the volume id:
\\?\Volume{e6e47810-66dd-11dc-a556-806d6172696f}\

	*** NESSUN PUNTO DI MONTAGGIO ***
5) run again mountvol as:
G:\>mountvol G:\testmountpoint \\?\Volume{e6e47810-66dd-11dc-a5

56-806d6172696f}\

Since I rarely use this, I never bothered to find and learn how this is done via IMDISK command line, but it should well be possible...


jaclaz

#3 der.einstein

der.einstein
  • Members
  • 7 posts
  •  
    Germany

Posted 10 February 2008 - 04:55 PM

Ok, good to here it works for others. i tried it as you explained, but couldn't get the \\?\Volume... listed by the mountvol command. wondering whats wrong. What SP and HotFixes/UpdatePacks do you have installed?

#4 was_jaclaz

was_jaclaz

    Finder

  • Advanced user
  • 7100 posts
  • Location:Gone in the mist
  •  
    Italy

Posted 10 February 2008 - 05:16 PM

Believe me, NOTHING can be related to ServicePacks or Updates.

Just do the following:
1) Uninstall IMDISK
2) Reboot the machine
3) Make sure you log in with Administrator rights
4) Install latest release of IMDISK
5) Open a cmd prompt and run in it:
mountvol>c:\noimdrive.txt
5) Mount the disk image as I told you before (without giving it a letter)
6) run:
mountvol>c:\noletter.txt
7) Unmount the image and re-mount it, this time letting IMDISK assigning a letter to it
8) run:
mountvol>c:\withletter.txt
9) Open Regedit and navigate to the key:
HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices
export it to file c:\HKLMmd.reg
10) compress the four files:
c:\HKLMmd.reg
c:\noimdrive.txt
c:\noletter.txt
c:\withletter.txt
into a .zip or .7z archive and post the archive here.


jaclaz

#5 der.einstein

der.einstein
  • Members
  • 7 posts
  •  
    Germany

Posted 10 February 2008 - 05:56 PM

I did as you said, but it didn't work i'm afraid. in fact all mountvol outputs look the same!

I also chatted with Olof himself about this, and he tried on an w2k installation with no success.

I don't have a clue!

Attached Files



#6 was_jaclaz

was_jaclaz

    Finder

  • Advanced user
  • 7100 posts
  • Location:Gone in the mist
  •  
    Italy

Posted 11 February 2008 - 08:17 AM

That's VERY strange.

I mean, at least when IMDISK has a drive letter assigned, it MUST have a drive letter assigned visible in MOUNTVOL (and in MountedDevices key).

Your MountedDevices key is actually a bit "cluttered", but nothing at first sight appears particularly so.

Is it possible that you have some software installed that uses some kind of filter driver that alters the normal behaviour of mountvol?

Or do i have anything installed that does the same (but in a "positive" way)?

I'll try IMDISK again in a "clean" parallel install I have and report....

Would it be possible that the problem is caused because you already have multiple hard links?:

\\?\Volume{2983d608-b092-11db-8b0d-806d6172696f}\
C:\

\\?\Volume{001bb3ec-d27b-11db-9f66-806d6172696f}\
C:\home\root\media\
C:\mnt\media\

\\?\Volume{001bb3ed-d27b-11db-9f66-806d6172696f}\
E:\

\\?\Volume{2983d602-b092-11db-8b0d-806d6172696f}\
C:\mnt\cdrom\
G:\

can you remove temporarily the:
C:\home\root\media\
C:\mnt\media\
C:\mnt\cdrom\
so that there are "normal" volume drive letters only?


jaclaz

#7 Olof Lagerkvist

Olof Lagerkvist

    Gold Member

  • Developer
  • 1339 posts
  • Location:Borås, Sweden
  •  
    Sweden

Posted 11 February 2008 - 09:27 AM

Sorry I join this discussion a bit late, but anyway...

That's VERY strange.

I mean, at least when IMDISK has a drive letter assigned, it MUST have a drive letter assigned visible in MOUNTVOL (and in MountedDevices key).

No, ImDisk has no Mount Manager support. It uses the "old" methods of defining drive letters as a symbolic link directly in object namespace. The same method is used if you define a drive letter using the subst command or by adding a value to the registry key HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\DOS Devices.

@Einstein:
I have tested on several Win 2000 systems now and it seems not possible to link directories to some kind of native paths, ImDisk device paths are not the only ones with this problem. :thumbsup:

I appreciate that you keep looking for a solution and hope that there is one to be found somewhere... But right now I am not really sure... I am however quite sure that I have tested this feature under Win 2000 and it could be that it was fixed/broken again by some update/Service Pack or some other kind of software (filesystem filter etc). However, it was a while since I used Win 2000 myself on regular basis.

#8 was_jaclaz

was_jaclaz

    Finder

  • Advanced user
  • 7100 posts
  • Location:Gone in the mist
  •  
    Italy

Posted 12 February 2008 - 08:46 AM

I have to offer my public apologies to everyone, and expecially to der.einstein for the "false hope" I may have involuntarily induced.

Most, if not all, of what I have posted before, is completely and utterly wrong. :thumbsup:

What happened yesterday:
1) I had a leftover of another "image/drive utility", which I had fiddled before with, that created a supplemental Device Name (with no letter assigned) of my C:\ drive
2) I used IMDISK to try mounting a RAW image of the same drive I had made the day before
3) I did the steps listed un my initial post and of course had a mountpoint working with what I thought to be the image of C:\ while it was in reality ANOTHER instance of the actual C:\ drive!

So, please disregard anything I wrote in my previous posts. :D

But still, I do remember having tested this thing some time ago and it did work, unless of course at the time I had a similar "brain fart".

I am definitely aging, sorry for the inconveniences....:D

:D

jaclaz

#9 der.einstein

der.einstein
  • Members
  • 7 posts
  •  
    Germany

Posted 12 February 2008 - 05:43 PM

Oh, I'm sorry to hear that. Maybe I'm just stuck with this problem on my Win 2k machine, sadly. ;-(

#10 ChakJack

ChakJack
  • Members
  • 1 posts
  •  
    India

Posted 23 March 2016 - 11:05 AM

Hi - I have ImDisk 1.9.2 currently installed and I want to upgrade it.

 

      
When I run the upgrade executable directly in Administrator account I see it works okay and version is upgrade to 2.0.9.

 

Instead if I try to install it via SYSTEM account version is not upgraded.

 

Any idea why ?

 

Any solution ?

 

thanks



#11 Olof Lagerkvist

Olof Lagerkvist

    Gold Member

  • Developer
  • 1339 posts
  • Location:Borås, Sweden
  •  
    Sweden

Posted 24 March 2016 - 01:18 PM

The .inf file based install process uses a functions in the Windows Setup API that need an interactive logon session to run successfully. I assume that when you run under the SYSTEM account you either don't have access to an interactive (graphical) logon session or access to such features might be limited in various ways. This is known to cause trouble in some cases. Even if there usually are ways to workaround most of this, for instance by modifying security descriptors of WindowStation and Desktop objects and similar, I would recommend you to use a more "manual" install method instead.

 

You can extract the contents of imdiskinst.exe using 7-zip and copy files manually to the correct places. First, stop all ImDisk related drivers and services:

net stop imdsksvc
net stop imdisk
net stop awealloc

Then, place x86 drivers (.sys files) under C:\Windows\system32\drivers and x86 application files (.exe files and imdisk.cpl) under C:\Windows\system32. Start drivers and services again:

net start awealloc
net start imdisk
net start imdsksvc





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users