Jump to content











Photo
- - - - -

[Solved]Acronis-DiskDirector10 - No Shortcuts in LiveXP


  • Please log in to reply
34 replies to this topic

#26 amalux

amalux

    Platinum Member

  • Tutorial Writer
  • 2813 posts
  •  
    United States

Posted 21 January 2008 - 08:42 AM

Thanks for posting the log! That's helped me to see what the issue is.

Basically, the script is written by Thunn with his setup in mind and since we didn't have the following file 'ºseDir%\Temp\buildModel.exe' shortcuts were not created.

See the attached -- hopefully now you have shortcuts!

Yes, yes, YES!! You did it!!! :D :D :thumbsup: Fantastic! Beautiful! What can I say Galapo, I wish there was something I could do to repay you; you're a good man. All I can say is a heartfelt thank you!. Thank you my friend. If you ever need my help with anything, just say the word. ;)

It's a beautiful thing, i never thought I'd be so happy just to see a simple shortcut...


Now, (you're gonna kill me) I have to ask, would the same 'fix' work for these other two scripts? I haven't even tried them yet but I'm planning to test them next. All by Thunn and very similar setups, I wouldn't be surprised if they had the same issue. I can look at what you did on this script and try to apply it to the others or, since you're familiar with what you did, you can check these. If you're sick of me bugging you about this, I can understand that as well; either way, thank you again my friend, you really helped me and hopefully others as well who want to use these very useful programs in their projects.

Cheers mate! :D

#27 thunn

thunn

    Silver Member

  • .script developer
  • 531 posts
  • Location:Brooklyn, New York
  • Interests:computers<br />mechanics<br />distortion<br /><br />
  •  
    United States

Posted 21 January 2008 - 08:47 AM

What I want to know is..
Where did BuildModel go? And what do you have creating shortcuts?

By now, this should be the least of our problems, no?

I thought vistape was using the same api, but guess not, hmmm.
If one needs an api fpr a scripts to work, please always provide the api with the script, or at least a link.
Now,
I hate to be a further pest, but please, please PM if possible before reposting my scripts for Acronis products with changes, in particular acronis scripts. :D They're alot of work.

Thanks, and I'm very glad you find the scripts of use. :thumbsup:

#28 risolutore

risolutore

    Frequent Member

  • Advanced user
  • 311 posts
  •  
    Italy

Posted 21 January 2008 - 10:04 AM

probably we shold contact in PM Mustang since it has on his site the script version for Vista Pe for almost every acronis application.

If someone has his Private Email point his attention here, since we need some knowledge.

#29 Galapo

Galapo

    Platinum Member

  • .script developer
  • 3841 posts
  •  
    Australia

Posted 21 January 2008 - 10:04 AM

Gday Thunn,

Sorry, I'll PM you next time. I was just trying to get the script functioning for amalux.

buildmodel under the latest nativeEx is moved to '%ProjectTemp%', which translates as 'ºseDir%\Temp\%ProjectName%'. Knowing that this was amalux's issue now, your script could be easily adapted to this change rather than having the api accomplish more of the tasks.

Under the posted scipt, the LiveXP/nativeEx api is handling the shortcut generation (which comes now as default hence the unnecessary need to provide the api with each api script), where the parameters are:
Add_Shortcut,&#91;Type&#93;,&#91;Folder&#93;,&#91;FullFileName&#93;,&#91;Title&#93;,&#91;Work Folder&#93;,&#91;Parameters&#93;,&#91;IconFile&#40; .ico .exe&#41;&#93;,&#91;StartMode&#40;1, 2, 3, or 4&#41;&#93;
So in order to create a standard shortcuts, this is all that's needed:
&#91;variables&#93;

%ProgramTitle%=Program&#39;s Title

%ProgramEXE%=Program.exe

%ProgramFolder%=Program&#39;sFolder



&#91;process&#93;

Add_Shortcut,Desktop

Add_Shortcut,StartMenu

Add_Shortcut,QuickLaunch

Add_Shortcut,AutoStart

Hope this helps!

Regards,
Galapo.

#30 amalux

amalux

    Platinum Member

  • Tutorial Writer
  • 2813 posts
  •  
    United States

Posted 21 January 2008 - 10:23 AM

Now,
I hate to be a further pest, but please, please PM if possible before reposting my scripts for Acronis products with changes, in particular acronis scripts. :thumbsup: They're alot of work.

Thanks, and I'm very glad you find the scripts of use. :D

I was just marveling, again, at the complexity and beauty of your scripts, Thunn and thinking how cool it is we can use these powerful Acronis tools in our projects. Thank you for all your effort in bringing these scripts to life and sharing them with us. I apologize for any misunderstanding or transgression regarding the proper handling of your scripts here. I was somewhat aware that there is a protocol to follow in this regard but am still not fully certain of the correct procedure and would like to flesh it out a bit. In fairness to Galapo, he was only trying to help me. I did PM you early on to inform you of the situation with the scripts and that I was seeking to correct it; I also had every intention of PM'ng you again as soon as there was a final 'fix' in hand. You must know, however, that to 'get your permission' at each step of the process would, effectively, kill the process. So, in the spirit of an open and free exchange of ideas for the betterment of all, I ask that we be allowed to continue this 'tweaking' of your scripts, within the confines of this thread until such time that shortcuts appear freely on desktops without hindrance and a final approval by you is requested before these updated scripts can be posted for download beyond this thread. Is that fair and do you find this to be an acceptable compromise?

#31 Galapo

Galapo

    Platinum Member

  • .script developer
  • 3841 posts
  •  
    Australia

Posted 21 January 2008 - 10:31 AM

Hi amalux,

Knowing now what the issue exactly is, I would actually do differently what I did to get the script functioning for you. Basically, I adapted thunn's script to the api in terms of its shortcut generation to narrow down what was happening and removed a little bit, which I now wouldn't do knowing now what I do.

Regards,
Galapo.

#32 amalux

amalux

    Platinum Member

  • Tutorial Writer
  • 2813 posts
  •  
    United States

Posted 21 January 2008 - 10:43 AM

Hi amalux,

Knowing now what the issue exactly is, I would actually do differently what I did to get the script functioning for you. Basically, I adapted thunn's script to the api in terms of its shortcut generation to narrow down what was happening and removed a little bit, which I now wouldn't do knowing now what I do.

Regards,
Galapo.

OK, this is somewhat cryptic, can you post or PM me an example of the script with these changes you refer to? (assuming it's OK with Thunn). Thanks again Galapo, you've really put a lot of effort into this and it's greatly appreciated!

#33 Galapo

Galapo

    Platinum Member

  • .script developer
  • 3841 posts
  •  
    Australia

Posted 21 January 2008 - 10:56 AM

Basically, I think that this is all that may be required: changing this
...

If,ExistFile,&#34;%BaseDir%\Temp\buildModel.exe&#34;,Run,%ScriptFile%,BMSC

...

If,NotExistDir,&#34;%BaseDir%\Temp&#34;,DirMake,&#34;%BaseDir%\Temp&#34;

If,NotExistFile,&#34;%BaseDir%\Temp\buildModel.exe&#34;,ExtractFile,%BuildModelScript%,&#34;Folder&#34;,&#34;buildModel.exe&#34;,&#34;%BaseDir%\Temp&#34;

to this
...

If,ExistFile,&#34;%ProjectTemp%\buildModel.exe&#34;,Run,%ScriptFile%,BMSC

...

//If,NotExistDir,&#34;%BaseDir%\Temp&#34;,DirMake,&#34;%BaseDir%\Temp&#34;

If,NotExistFile,&#34;%ProjectTemp%\buildModel.exe&#34;,ExtractFile,%BuildModelScript%,&#34;Folder&#34;,&#34;buildModel.exe&#34;,&#34;%ProjectTemp%&#34;

Regards,
Galapo.

#34 amalux

amalux

    Platinum Member

  • Tutorial Writer
  • 2813 posts
  •  
    United States

Posted 21 January 2008 - 03:40 PM

Basically, I think that this is all that may be required: changing this

...

If,ExistFile,&#34;%BaseDir%\Temp\buildModel.exe&#34;,Run,%ScriptFile%,BMSC

...

If,NotExistDir,&#34;%BaseDir%\Temp&#34;,DirMake,&#34;%BaseDir%\Temp&#34;

If,NotExistFile,&#34;%BaseDir%\Temp\buildModel.exe&#34;,ExtractFile,%BuildModelScript%,&#34;Folder&#34;,&#34;buildModel.exe&#34;,&#34;%BaseDir%\Temp&#34;

to this
...

If,ExistFile,&#34;%ProjectTemp%\buildModel.exe&#34;,Run,%ScriptFile%,BMSC

...

//If,NotExistDir,&#34;%BaseDir%\Temp&#34;,DirMake,&#34;%BaseDir%\Temp&#34;

If,NotExistFile,&#34;%ProjectTemp%\buildModel.exe&#34;,ExtractFile,%BuildModelScript%,&#34;Folder&#34;,&#34;buildModel.exe&#34;,&#34;%ProjectTemp%&#34;

Regards,
Galapo.

Simple, clean and makes sense. I like it! Hopefully this will work for the other two scripts as well, in which case I really like it :thumbsup: . Thanks Galapo!

#35 amalux

amalux

    Platinum Member

  • Tutorial Writer
  • 2813 posts
  •  
    United States

Posted 22 January 2008 - 12:56 AM

Simple, clean and makes sense. I like it! Hopefully this will work for the other two scripts as well, in which case I really like it :thumbsup: . Thanks Galapo!

OK, so just to wrap this up; everything is working perfectly now with the desktop and start menu folder shortcuts on all three* of thunn's truly awesome, inspired Acronis scripts and another huge thanks to Galapo for getting them to work in LiveXP!


*Acronis-DiskDirector10 and Acronis-TrueImage91 scripts required the fix worked out by Galapo; Acronis-TrueImageServer91-Lite worked as is with no change! Nice.

@Thunn!

Thank you again for what must have been a hell of a job putting those Acronis scripts together! I have a question re the Acronis-TrueImage91 script; it doesn't work with my licensed version because there's no option to enter a SN or key. Apparently this script is for a free version 9.1 (which I don't think is available anymore?) - Is there another version of the script which allows the SN or is there a way to add it to this one? Thanks again Thunn :D

:D to all!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users