Jump to content











Photo
- - - - -

[Solved]Acronis-DiskDirector10 - No Shortcuts in LiveXP


  • Please log in to reply
34 replies to this topic

#1 amalux

amalux

    Platinum Member

  • Tutorial Writer
  • 2813 posts
  •  
    United States

Posted 16 January 2008 - 06:48 PM

I've spent some hours playing with this and reading much about it but still can't get start menu or desktop shortcuts to materialize. The program seems to work (more testing required) but I have to go into Program Files in LiveXP and manually create the shortcuts. I've tried v014 and v017 (only ones I've found) with same results; Program is included in build but NO SHORTCUTS :D . Additionally, anyone know of any (other) good partition managers that can be used in LiveXP builds? Thanks :thumbsup:

#2 Galapo

Galapo

    Platinum Member

  • .script developer
  • 3841 posts
  •  
    Australia

Posted 17 January 2008 - 02:38 AM

Additionally, anyone know of any (other) good partition managers that can be used in LiveXP builds? Thanks :thumbsup:

You could try my script for Paragon HDM 8.0 special edition which is available from my page or the LiveXP server.

Regards,
Galapo.

#3 amalux

amalux

    Platinum Member

  • Tutorial Writer
  • 2813 posts
  •  
    United States

Posted 17 January 2008 - 06:30 PM

You could try my script for Paragon HDM 8.0 special edition which is available from my page or the LiveXP server.

Regards,
Galapo.

Hey, that's pretty cool; thanks Galapo! :thumbsup:

:D

#4 Galapo

Galapo

    Platinum Member

  • .script developer
  • 3841 posts
  •  
    Australia

Posted 17 January 2008 - 08:17 PM

And hopefully there's no shortcut issues with the script. Please post if there is.

Regards,
Galapo.

#5 amalux

amalux

    Platinum Member

  • Tutorial Writer
  • 2813 posts
  •  
    United States

Posted 18 January 2008 - 05:36 AM

And hopefully there's no shortcut issues with the script. Please post if there is.

Regards,
Galapo.

Your script works flawlessly! :thumbsup:

#6 thunn

thunn

    Silver Member

  • .script developer
  • 531 posts
  • Location:Brooklyn, New York
  • Interests:computers<br />mechanics<br />distortion<br /><br />
  •  
    United States

Posted 20 January 2008 - 07:39 AM

@Galapo

Maybe you can post the api that you share with vistape under downloads in an obvious spot (?)
:thumbsup:

#7 amalux

amalux

    Platinum Member

  • Tutorial Writer
  • 2813 posts
  •  
    United States

Posted 20 January 2008 - 08:22 AM

@Galapo

Maybe you can post the api that you share with vistape under downloads in an obvious spot (?)
:D

Thank you for looking at this thunn, it is really appreciated :thumbsup:

@Galapo, your script for Paragon is fine but the program is inferior to Acronis. If there is any way we could find a work around for this shortcut issue, it would be a great addition to LiveXP! I've already tested the Acronis program in LiveXP and it works beautifully! I've managed to get a shortcut to show up on the desktop but it has to be 'fixed' the first time you dbl-click it. Any help is appreciated!! :D

#8 Galapo

Galapo

    Platinum Member

  • .script developer
  • 3841 posts
  •  
    Australia

Posted 20 January 2008 - 08:33 AM

@Galapo

Maybe you can post the api that you share with vistape under downloads in an obvious spot (?)
:thumbsup:

Gday Thunn,

I personally don't use VistaPE, so I have no api to share myself. Does Pedro's one work with the latest VistaPE, or is there now another one?

http://pedrole15.boo...pi_Vista.Script

LiveXP and nativeEx have Pedro's api for download:

http://pedrole15.boo...veXP/api.script
http://livexp.boot-l...uild/api.script
http://nativeex.boot...uild/api.script

But it looks like the nativeEx server requires a version update from 6 to 7.

Regards,
Galapo.

#9 Galapo

Galapo

    Platinum Member

  • .script developer
  • 3841 posts
  •  
    Australia

Posted 20 January 2008 - 08:36 AM

@Galapo, your script for Paragon is fine but the program is inferior to Acronis.

But not in regards to price! I can't afford to pay for more software at the moment until I find a job...

I've managed to get a shortcut to show up on the desktop but it has to be 'fixed' the first time you dbl-click it. Any help is appreciated!! :thumbsup:

Please post a link to the script and I can take a look.

Thanks,
Galapo.

#10 amalux

amalux

    Platinum Member

  • Tutorial Writer
  • 2813 posts
  •  
    United States

Posted 20 January 2008 - 09:03 AM

Please post a link to the script and I can take a look.

Thanks,
Galapo.

Here's the link and the specific script


But not in regards to price! I can't afford to pay for more software at the moment until I find a job...

The programs are less money than you think... Let me know if you need some info. :thumbsup:

#11 Galapo

Galapo

    Platinum Member

  • .script developer
  • 3841 posts
  •  
    Australia

Posted 20 January 2008 - 09:54 AM

OK, try the attached. I can't test as I don't have the software installed.

Attached Files



#12 amalux

amalux

    Platinum Member

  • Tutorial Writer
  • 2813 posts
  •  
    United States

Posted 20 January 2008 - 04:41 PM

OK, try the attached. I can't test as I don't have the software installed.

No problem, I'm your tester! Anything you want tested, just send my way :thumbsup:

This one = no change (but don't give up!)

FYI, if you add

Add_Shortcut,Desktop

Add_Shortcut,StartMenu,Acronis
to the [Process] section, you do get an icon on the desktop which, when first clicked, informs you 'The item has been moved... do you want it fixed?' 'Yes' = Program opens and all is well. I know this is hack scripting at its worst but maybe gives some clue?


#13 risolutore

risolutore

    Frequent Member

  • Advanced user
  • 311 posts
  •  
    Italy

Posted 20 January 2008 - 08:02 PM

I think that acronis are great product, but we have to take care of dependencies and exclusion betweeen script that user upper filter. I wait for a new ver..of the script,

#14 amalux

amalux

    Platinum Member

  • Tutorial Writer
  • 2813 posts
  •  
    United States

Posted 20 January 2008 - 08:19 PM

I think that acronis are great product, but we have to take care of dependencies and exclusion betweeen script that user upper filter. I wait for a new ver..of the script,

I have read about this issue but don't fully understand what the problem is; the conflict only arises when trying to use both acronis products, Disk Director and True Image together, right? It's up to Acronis to fix this, nothing to do with the script(s) AFAIK.

#15 Galapo

Galapo

    Platinum Member

  • .script developer
  • 3841 posts
  •  
    Australia

Posted 20 January 2008 - 09:00 PM

This one = no change (but don't give up!)

Are the following lines in your script.project:
%Core%=%ProjectDir%

%BuildModelScript%=%Core%\Basic\Build\4 - buildModel.Script
Thanks,
Galapo.

#16 carfan

carfan

    Frequent Member

  • Advanced user
  • 196 posts
  •  
    United States

Posted 20 January 2008 - 09:55 PM

Are the following lines in your script.project:

%Core%=%ProjectDir%

%BuildModelScript%=%Core%\Basic\Build\4 - buildModel.Script
Thanks,
Galapo.



look at buildmodel script and make sure the "do not refresh shortcuts on iso boot" isn't checked
i had the same problem and that's how i fixed my shortcut missing issue.

Galapo:

remove "PartMgr" from upper filters to fix conflict. Anyone using both DD10 and HDM8 needs to add "hotcore2" to DD10 script on the upper filter line and make sure remove "PartMgr" from filters
is checked and run the post script tool by pressing the generate now button. that will make the upper filters be added last so it isnt over written by other scripts.

ex:

change
RegWrite,HKLM,0x7,"WB-Setup\ControlSet001\Control\Class\{71A27CDD-812A-11D0-BEC7-08002BE2092F}","UpperFilters","snapman"
If,%pCheckBox2%,Equal,True,RegWrite,HKLM,0x7,"WB-Setup\ControlSet001\Control\Class\{4D36E967-E325-11CE-BFC1-08002BE10318}","UpperFilters","snapman"
If,%pCheckBox2%,Equal,False,RegWrite,HKLM,0x7,"WB-Setup\ControlSet001\Control\Class\{4D36E967-E325-11CE-BFC1-08002BE10318}","UpperFilters","PartMgr","snapman"

to this
RegWrite,HKLM,0x7,"WB-Setup\ControlSet001\Control\Class\{71A27CDD-812A-11D0-BEC7-08002BE2092F}","UpperFilters","snapman","hotcore2"
If,%pCheckBox2%,Equal,True,RegWrite,HKLM,0x7,"WB-Setup\ControlSet001\Control\Class\{4D36E967-E325-11CE-BFC1-08002BE10318}","UpperFilters","snapman","hotcore2"
If,%pCheckBox2%,Equal,False,RegWrite,HKLM,0x7,"WB-Setup\ControlSet001\Control\Class\{4D36E967-E325-11CE-BFC1-08002BE10318}","UpperFilters","PartMgr","snapman","hotcore2"

#17 Galapo

Galapo

    Platinum Member

  • .script developer
  • 3841 posts
  •  
    Australia

Posted 20 January 2008 - 09:57 PM

I think that acronis are great product, but we have to take care of dependencies and exclusion betweeen script that user upper filter. I wait for a new ver..of the script,

Frodo on the 911cd forums has a couple of plugins or utilities which does this. Would just need adapting to WB. If I had mutiple programs accessing the upper filters I would do it myself...

Regards,
Galapo.

#18 amalux

amalux

    Platinum Member

  • Tutorial Writer
  • 2813 posts
  •  
    United States

Posted 20 January 2008 - 11:22 PM

Are the following lines in your script.project:

%Core%=%ProjectDir%

%BuildModelScript%=%Core%\Basic\Build\4 - buildModel.Script
Thanks,
Galapo.

&#91;BMSC&#93;

If,NotExistDir,&#34;%BaseDir%\Temp&#34;,DirMake,&#34;%BaseDir%\Temp&#34;

If,NotExistFile,&#34;%BaseDir%\Temp\buildModel.exe&#34;,ExtractFile,%BuildModelScript%,&#34;Folder&#34;,&#34;buildModel.exe&#34;,&#34;%BaseDir%\Temp&#34;

Run,%BuildModelScript%,Add-Shortcut,&#34;SM\Acronis&#34;,&#34;%PE_Programs%\%programdir%\%programexe%&#34;,&#34;Acronis Disk Director&#34;

If,%pCheckBox1%,Equal,True,Run,%BuildModelScript%,Add-Shortcut,&#34;DE&#34;,&#34;%PE_Programs%\%programdir%\%programexe%&#34;,&#34;Acronis Disk Director&#34;

If,%pCheckBox5%,Equal,True,Run,%BuildModelScript%,Add-Shortcut,&#34;QL&#34;,&#34;%PE_Programs%\%programdir%\%programexe%&#34;,&#34;Acronis Disk Director&#34;
is as close as you get...

#19 Galapo

Galapo

    Platinum Member

  • .script developer
  • 3841 posts
  •  
    Australia

Posted 20 January 2008 - 11:33 PM

Sorry, you misunderstood me. Have a look in '%ProjectDir%\script.project' and see if the two lines I mentioned (or ones very similar) exist.

Thanks,
Galapo.

#20 amalux

amalux

    Platinum Member

  • Tutorial Writer
  • 2813 posts
  •  
    United States

Posted 21 January 2008 - 01:36 AM

Sorry, you misunderstood me. Have a look in '%ProjectDir%\script.project' and see if the two lines I mentioned (or ones very similar) exist.

Thanks,
Galapo.

Sorry Galapo, you're right, I did misunderstand you. Both lines do exist in '%ProjectDir%\script.project'. What does this mean?

#21 amalux

amalux

    Platinum Member

  • Tutorial Writer
  • 2813 posts
  •  
    United States

Posted 21 January 2008 - 01:46 AM

look at buildmodel script and make sure the "do not refresh shortcuts on iso boot" isn't checked
i had the same problem and that's how i fixed my shortcut missing issue.

It was checked, so imagine my excitement at hearing this :D but, alas, unchecking it makes no difference :D . Are you sure this is what did it for you? I'll include my latest log for reference in case it helps. Thank you for helping to figure out this annoying bugger. :thumbsup:


#22 Galapo

Galapo

    Platinum Member

  • .script developer
  • 3841 posts
  •  
    Australia

Posted 21 January 2008 - 01:56 AM

Hi amalux,

it means that buildmodel should be found by the script to create the shortcuts. Trouble is, it doesn't seem to be as shortcuts aren't being created.

So what happens if we conform Thunn's script a little more to the api:Attached File  dd10.script   28.14KB   269 downloads

#23 amalux

amalux

    Platinum Member

  • Tutorial Writer
  • 2813 posts
  •  
    United States

Posted 21 January 2008 - 02:06 AM

remove "PartMgr" from upper filters to fix conflict. Anyone using both DD10 and HDM8 needs to add "hotcore2" to DD10 script on the upper filter line and make sure remove "PartMgr" from filters
is checked and run the post script tool by pressing the generate now button. that will make the upper filters be added last so it isnt over written by other scripts.

Carfan,

Just to be clear, you're saying, checking this option...

is the only change needed to avoid conflict if using both Acronis DD10 and Acronis TI91, right? The other stuff is only required if using both Acronis DD10 and Paragon HDM8. Have I understood you correctly?

#24 amalux

amalux

    Platinum Member

  • Tutorial Writer
  • 2813 posts
  •  
    United States

Posted 21 January 2008 - 03:05 AM

Hi amalux,

it means that buildmodel should be found by the script to create the shortcuts. Trouble is, it doesn't seem to be as shortcuts aren't being created.

So what happens if we conform Thunn's script a little more to the api:Attached File  dd10.script   28.14KB   269 downloads

Same :D

The program exists, where it should be...


but no Start - Programs folder or desktop icon!



It's crazy this should be so difficult, maybe we're looking at it the wrong way :thumbsup: . We have two known locations, the program .exe and the desktop; isn't it possible to just create a shortcut between these from 'outside' of the DD10 script? I mean, if I can do it manually in LiveXP, can't a script mimic this action?

#25 Galapo

Galapo

    Platinum Member

  • .script developer
  • 3841 posts
  •  
    Australia

Posted 21 January 2008 - 03:27 AM

Thanks for posting the log! That's helped me to see what the issue is.

Basically, the script is written by Thunn with his setup in mind and since we didn't have the following file '%BaseDir%\Temp\buildModel.exe' shortcuts were not created.

See the attached -- hopefully now you have shortcuts!

Attached Files






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users