Jump to content











Photo
- - - - -

A special App doesnt work (Compatib.-Mode/16bit)


  • Please log in to reply
14 replies to this topic

#1 st-dv

st-dv

    Frequent Member

  • Members
  • 121 posts
  •  
    Germany

Posted 29 September 2007 - 07:56 AM

hello,

my vistape-cd is nearly finished.... but there is still one single applikation that does not work... but it is a very important prog...

if i start in vistape i get a runtime error...

a friend told me that the applikation would need "visual c" and a runtime dll to work......... but i have no idea how to manage this....


anyone could helpme??

#2 booty#1

booty#1

    Frequent Member

  • .script developer
  • 285 posts
  • Location:Near Frankfurt
  •  
    Germany

Posted 29 September 2007 - 09:11 AM

my vistape-cd is nearly finished.... but there is still one single applikation that does not work... but it is a very important prog...

if i start in vistape i get a runtime error...

a friend told me that the applikation would need "visual c" and a runtime dll to work......... but i have no idea how to manage this....
anyone could helpme??

Use the ProcessMonitor for finding out which files are searched (and not found) by the prog. In the end you should have one or more filenames.

booty#1

#3 st-dv

st-dv

    Frequent Member

  • Members
  • 121 posts
  •  
    Germany

Posted 29 November 2007 - 09:21 PM

Hello,

thanks, but what process monitor do you mean? there is no process mon "on board" with vista pe....

or not ???

#4 booty#1

booty#1

    Frequent Member

  • .script developer
  • 285 posts
  • Location:Near Frankfurt
  •  
    Germany

Posted 30 November 2007 - 07:47 AM

Of course there is.
See section VistaPE/App/System of VistaPE010 - http://www.vistape.net/project/

booty#1

#5 Max_Real Qnx

Max_Real Qnx

    Gold Member

  • Patrician
  • 1382 posts
  • Location:Istanbul
  • Interests:To be or not to be that is the question.
  •  
    Turkey

Posted 02 December 2007 - 07:01 AM

Hi :cheers:
This will become maybe useful for you :cheers:

Exe Dependancy Scanner

scan.jpg

Download File


Microsoft Visual C++ 2005 SP1 Redistributable Package (x86)


MS runtime



Good luck :cheers:

#6 st-dv

st-dv

    Frequent Member

  • Members
  • 121 posts
  •  
    Germany

Posted 03 December 2007 - 02:30 PM

Thank you really a lot....

But I tried this "ExeScan-Prog" and also the "Dependency Walker".....

I copied all the files that where needed into the %targetdir%\%systemroot%\system32\ - FOLDER.....

But I still get the same error.

I have no idea....

#7 st-dv

st-dv

    Frequent Member

  • Members
  • 121 posts
  •  
    Germany

Posted 04 December 2007 - 05:59 PM

I got it !!!!!!!!!!

Very special thanks to all who helped...

The problem was that I forgot one single DLL-file ! (UOUPS)

The Prog runs"

The "EXE-Watcher"worked fine !

Thanks a lot

S.

#8 Max_Real Qnx

Max_Real Qnx

    Gold Member

  • Patrician
  • 1382 posts
  • Location:Istanbul
  • Interests:To be or not to be that is the question.
  •  
    Turkey

Posted 04 December 2007 - 07:47 PM

I got it !!!!!!!!!!

Very special thanks to all who helped...

The problem was that I forgot one single DLL-file ! (UOUPS)

The Prog runs"

The "EXE-Watcher"worked fine !

Thanks a lot

S.


You succeeded the congratulations , you are welcome :cheers:

#9 st-dv

st-dv

    Frequent Member

  • Members
  • 121 posts
  •  
    Germany

Posted 15 December 2007 - 01:35 PM

Oups....

I am very sorry, but I still got problems with my program.... the thing is.... I get NO Runtime Error at this moment.... the program STARTS fine.... but it does not
work as it should....
It is a prog, based on Visual-C I think, that is a GUI to a DOS-Applikation.... and when I start the prog running the DOS-Box starts for a few seconds and closes then....
I tried it in Vmware with an installed Windows-Vista for to watch if there are problems with Vista-Compatibility.... but also on Vista the Program works....

Except in my PE-Environment...

Does anybody has another idea?

I copied all files that where shown about the EXESCAN to the Target-Folder.... no result....

#10 st-dv

st-dv

    Frequent Member

  • Members
  • 121 posts
  •  
    Germany

Posted 15 December 2007 - 01:54 PM

I got an idea, but no solution:


I tried to start the Program in my normal host-environment (winxp).... under CMD...... here the prog does work fine...

When selecting the Command Line - Shell in VistaPE, or opening the CMD in the Explorer-Shell, and starting the program there, it does not work...

Is it possible that - in VistaPE - there is no real full CMD??????

Because... if I start "program.exe" vistape says "file "program.exe" not found.... although the EXE is there !

#11 lurch

lurch
  • Members
  • 8 posts
  •  
    United States

Posted 15 December 2007 - 05:47 PM

I got an idea, but no solution:


like you, i have an idea but no solution.

you could use your exe dependency scanner to see what vista CMD is using in your real vista, and then check it against your vistaPE? if there are more dependencies under real vista than there are under PE copy the files to the custom directory and in the right places and remake the cd/dvd with all the files from both.

the other idea would be to browse to the vista windows directory on your computer and start the CMD program that is on the computer from within VISTAPE and see if your program will work.


the last idea would be to lt us all know what "program.exe" is or give us a link to program so that we can download it and maybe one of us can get it going, we too may find the program useful.

thats all i got for now, i am out of ideas.

lurch

#12 st-dv

st-dv

    Frequent Member

  • Members
  • 121 posts
  •  
    Germany

Posted 16 December 2007 - 10:03 AM

Hello,

I think that now I can be shure that the app is a 16bit-application... cause I tried to run it in the "dependecy-walker" which told me that there where no 32- or 64-bit EXE-Files to analyze.....

So I got to find a solution for running a 16bit-app on vista-pe....

To your 3rd:
The program is a special software of Law Enforcement / Computer Investigation.... so there's no possibility to give you a special download link.....
But a demo-version of the program you can download at www.perkeo.net !

#13 MedEvil

MedEvil

    Platinum Member

  • .script developer
  • 7771 posts

Posted 16 December 2007 - 12:45 PM

I think that now I can be shure that the app is a 16bit-application

I might be wrong, but as far as i know, 16bit support was removed in Vista.

:cheers:

#14 st-dv

st-dv

    Frequent Member

  • Members
  • 121 posts
  •  
    Germany

Posted 16 December 2007 - 12:47 PM

I might be wrong, but as far as i know, 16bit support was removed in Vista.

:cheers:



Ok that wouldn't be nice.... in the worsest case, I got to say goodbye to VistaPE and return to BartPE with WinXP....

But... on the other hand..... when starting the 16-bit-app under my host-vista.... f.e. in a full-installed vista in VMWARE.... the program works.......!

#15 TheHive

TheHive

    Platinum Member

  • .script developer
  • 4173 posts

Posted 16 December 2007 - 06:58 PM

One way you can go is trying to use DosBox. It supports Vista. And if you have questions, they have a forum.
http://www.dosbox.com/

http://www.dosbox.co...osbox_and_Vista

Forum
http://vogons.zetafl...m/index.php?c=7


Maybe someone can create a Script for Vista




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users