Jump to content











Photo
- - - - -

SATA disks problem


  • Please log in to reply
4 replies to this topic

#1 Igor Vin

Igor Vin
  • Members
  • 1 posts

Posted 16 September 2007 - 05:24 PM

Hello,

Before to ask my question, I want to thank all people who build excellent project :loleverybody:

I created distributive disk with SATA Drivers support, but the system is not seeing Serial ATA disks
I tried to run NativePE on different PCs but with same results :w00t:
Please assist me with this issue



Thanks in advance

#2 cquirke

cquirke
  • Members
  • 8 posts
  • Interests:Maintenance OS (mOS), PCs, memetics, data recovery, formal malware management. On mOS, have some Bart skills, need to build WinPE 2.0 and Linux skills. My profile "date of birth" is a lie, of course.
  •  
    South Africa

Posted 07 October 2007 - 11:31 AM

I created distributive disk with SATA Drivers support, but the system is not seeing Serial ATA disks
I tried to run NativePE on different PCs but with same results :cheers:


I'm new here, but am seeing similar S-ATA hassles in Bart PE Builder that depend on the motherboard chipset.

Specifically, Intel's chipsets up to 965 have been OK with Bart CDRs built from the XP SP2 \i386 code base, but once you move onto G33 chipset, the S-ATA hard drives are not seen from the Bart CDR, and thus drivers must be added. The same goes for many laptops that use S-ATA hard drives. The details with Intel's chipsets appear to be something like "ICH8 OK, ICH9 fails" (note: none of these use RAID).

So if you have a system that needs a "special drivers disk" at an F6 prompt in oder to install XP SP2, you can expect bad mileage in Bart CDR, and prolly other CDR-booted XP-derived projects unless drivers added. In contrast, Vista WinPE 2.0 and Ubuntu 7.04 boot CDRs wotrk with G33.

Sorry if this background info is what you know already!

#3 Nuno Brito

Nuno Brito

    Platinum Member

  • .script developer
  • 10549 posts
  • Location:boot.wim
  • Interests:I'm just a quiet simple person with a very quiet simple life living one day at a time..
  •  
    European Union

Posted 07 October 2007 - 12:13 PM

Welcome to boot-land.net Igor!

Have you already tried with the sata drivers script that comes with livexp? :cheers:

Here's a link: http://livexp.boot-l...rs/SATA2.script

Place it on your nativeEx project and try it.. :cheers:


btw: I'm moving this topic to the nativeEx / LiveXP sub forum.. :cheers:

#4 Galapo

Galapo

    Platinum Member

  • .script developer
  • 3841 posts
  •  
    Australia

Posted 09 October 2007 - 02:16 AM

Hi Igor Vin,

I actually just finished a script for DriverPacks massstorage drivers. Haven't really tested it yet, so I'd be interested if it solves your issue. Script is for version 7.09.2 of the massstorage DriverPacks.

http://galapo.boot-l...sStorage.script

Regards,
Galapo.

#5 Brunzwick

Brunzwick
  • Members
  • 1 posts
  •  
    United States

Posted 30 October 2007 - 10:42 PM

<a href="http://galapo.boot-l...Storage.script" target="_blank"><a href="http://galapo.boot-l...Storage.script" target="_blank">http://galapo.boot-land.net/scripts/driver...sStorage.script</a></a>


It worked for me, at least as far as getting me to the desktop. Before I added your script I got a BSoD 7b (mass storage error) on a Dell Optiplex 755 with an ICH9. I can now boot as far as the desktop before it crashes, but I dont believe that the crash has anything to do with the DriverPack.

Also, the link above is a 404. I have to type the URL in by hand to download it.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users