Jump to content











Photo
- - - - -

Help LiveXP Unable to Execute command line:'explorer.exe'


  • Please log in to reply
3 replies to this topic

#1 PKdoRx3

PKdoRx3
  • Members
  • 2 posts
  •  
    United States

Posted 03 September 2007 - 07:53 AM

I build a regular PEs before [BCD4Win] and just now also the Vita PE
which is great. But no matter how i try to build LiveXP it just wont boot
and keep giving an error.

Unable to Execute command line:'explorer.exe'

Right at the screen with the grass in the background I'm using the
Windows XP Pro SP2 iso of my CD original as a source, on my last
build. But I tried the server 03 trial and same problem. I tried my
last build with both Explorer and Xoblite on both sources with upx
and no upx, but same result.

I have no idea what else to edit its not a full build as I am not installing
some scripts and im down to pretty much only what I would use, my final
iso is 178MB and has all driver scripts exept for all the qemu driver scripts
and no upx. I tried many different configs including with qemu driver scripts,
all give me the same problem. It happens in a real live PC and also on VMWare.
so I believe is something to d with the "5 - CopyAndExpand" or any of
the shell scripts.

I'm out of ideas and any help would be greatly appreciated.

Here is my log and a pic of the screen.

Attached Thumbnails

  • Capture.JPG

Attached Files

  • Attached File  log.rar   109.07KB   161 downloads


#2 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12707 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 03 September 2007 - 08:51 AM

Unable to Execute command line:'explorer.exe'

PELoader wants to start Explorer as shell. But instead of Explorer Xoblite is added to the PE.

BTW: The PE is very full with items.
You should for the first trials go throuh the project and consider at every script whether you need it or not.
If this build has success you may add items step by step ...

Please ZIP the log. It decreases remarkably fom more than 2 MB to some 10 kB.

Peter

#3 PKdoRx3

PKdoRx3
  • Members
  • 2 posts
  •  
    United States

Posted 03 September 2007 - 09:46 AM

PELoader wants to start Explorer as shell. But instead of Explorer Xoblite is added to the PE.

BTW: The PE is very full with items.
You should for the first trials go throuh the script and consider at every script whether you need it or not.
If this build has success you may add items step by step ...

Please ZIP the log. It decreases remarkably fom more than 2 MB to some 10 kB.

Peter

I RARed the Log and removed more scripts , any suggestion as to how t fix this??

#4 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12707 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 03 September 2007 - 09:59 AM

I rared the log and removed her sripts , any sugestion as to how t fix this??

In the project tree, navigate to Basic >> Shells and check 'Explorer'
Xoblite should uncheck automatically. If not, do it manually.

Then rebuild the script.

Maybe for a beginner, to become familar with WinBuilder, you should try nativeEx_barebone.

Like LiveXP it is based on the nativeEx idea, but it is much more simple and contains besides the core just some example apps, no API and other enhancements of LiveXP.

You can download it from the nativeEx server.
It the server is not in the list, add a server 'nativeex.boot-land.net'

Peter




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users