Jump to content











Photo
- - - - -

Drive ImageXML


  • Please log in to reply
34 replies to this topic

#1 yahoouk

yahoouk

    Silver Member

  • .script developer
  • 518 posts

Posted 26 July 2007 - 09:52 PM

File name: Drive ImageXML


Description:
Any comments welcome.
Just unrar and eat.
Thanks for testing.

Sorry for my mistake in script.
Edited on 28-07-07.

yahooUK

Download file

Edited by yahoouk, 27 July 2007 - 11:39 PM.


#2 Nuno Brito

Nuno Brito

    Platinum Member

  • .script developer
  • 10549 posts
  • Location:boot.wim
  • Interests:I'm just a quiet simple person with a very quiet simple life living one day at a time..
  •  
    European Union

Posted 26 July 2007 - 09:59 PM

Nice.. :yahoo:

#3 Haiphong

Haiphong

    Frequent Member

  • Advanced user
  • 237 posts

Posted 27 July 2007 - 04:15 AM

File name: Drive ImageXML
Description:
Any comments welcome.
Just unrar and eat.
Thanks for testing.

yahooUK

Download file


Hello Yahoouk and Nuno_Brito,

Yesterday, I has installed "Drive Image XML" and has compiled with the Script of "Boot-Land" for "VistaPE" and it work like a charm !!!

Bye !!!

#4 yahoouk

yahoouk

    Silver Member

  • .script developer
  • 518 posts

Posted 27 July 2007 - 08:14 AM

Hello Yahoouk and Nuno_Brito,

Yesterday, I has installed "Drive Image XML" and has compiled with the Script of "Boot-Land" for "VistaPE" and it work like a charm !!!

Bye !!!


Thanks for your quick response.
Glad to hear that it does work.

Regards.

yahooUK

#5 Haiphong

Haiphong

    Frequent Member

  • Advanced user
  • 237 posts

Posted 27 July 2007 - 10:39 AM

Thanks for your quick response.
Glad to hear that it does work.

Regards.

yahooUK


Hello Yahoouk,

This morning, I do a try under "VistaPE" and I has this messages :

Menu Screenshot :
Posted Image

Warning 1 :
Posted Image

Warning 2 :
Posted Image

Because of this problem, I decided to do a try of "Portable Norton Ghost 8.0" under "VistaPE" and What is my surprise :

1) It work fine !!!
2) It's versy quick !!! I do a Backup of a Partition of 4,37 Go ==> Compressed in an Image of 1,99 go
for 4 minutes 35 seconds !!!

I go to build a script for "VistaPE".

#6 yahoouk

yahoouk

    Silver Member

  • .script developer
  • 518 posts

Posted 27 July 2007 - 11:43 PM

Hello Yahoouk,

This morning, I do a try under "VistaPE" and I has this messages :
.......................


Thanks for your reply.
Yes, I forgot to add reg in script.
Sorry to all downloaders.
Just edited and uploaded.

Thanks & regards.

yahooUK

#7 Haiphong

Haiphong

    Frequent Member

  • Advanced user
  • 237 posts

Posted 28 July 2007 - 04:15 AM

Thanks for your reply.
Yes, I forgot to add reg in script.
Sorry to all downloaders.
Just edited and uploaded.

Thanks & regards.

yahooUK


I do a test and I have the same Error Messages then I mention above !!!

Good Luck !!!

#8 online

online

    Silver Member

  • Advanced user
  • 767 posts

Posted 28 July 2007 - 11:24 AM

Because of this problem, I decided to do a try of "Portable Norton Ghost 8.0" under "VistaPE" and What is my surprise :

1) It work fine !!!
2) It's versy quick !!! I do a Backup of a Partition of 4,37 Go ==> Compressed in an Image of 1,99 go
for 4 minutes 35 seconds !!!

I go to build a script for "VistaPE".

Hi,
I'm very interesting in VistaPE (thank you, NightMan!) and in (the best possible) partition's Backup Image file creation (@ low level & not compressed).
"Norton Ghost 8.0" is a great app, but in my experience under Vista doesn't work as fine as under XP: in fact after PerfectDisk defragmentation (and free space consolidation) I created Ghost image file, but after restoring it then the disk analysis shown the disk free space not consolidate anymore.
Now I get Terabyte Image for Windows 1.70a (its plugin under BartPE > Flash Drive) and it works so very fine (the best that I've never tried).
Image for Windows under VistaPE would be the TOP (imho) :yahoo:, but I am not still able to create a plugin or to add this program into VistaPE… :)
Every comment will be a lot appreciated.

#9 allanf

allanf

    Gold Member

  • .script developer
  • 1256 posts

Posted 28 July 2007 - 02:27 PM

Image for Windows under VistaPE would be the TOP (imho) :), but I am not still able to create a plugin or to add this program into VistaPE… :)
Every comment will be a lot appreciated.


online,

:)

I assume you have installed "Image for Windows" on your WinBuilder machine.

Download IFW Plugin from Terabyte http://www.terabyteu.../ifw_plugin.zip, and extract files. Go to extracted ifw.inf file and open with editor (Notepad). Remove semi-colons from ";autorun_ifw.cmd=2,,4" and ";0x4, "TeraByte Unlimited\Image", "Settings", "0x001e0007".

In WinBuilder, click Tools, click Convert tab, select "Type of File" => BartPE Plugin (*.inf), select "Add Files.." and navigate to your extracted ifw.inf and open, click Convert. You should end up with:
[s]I386[/s]Windows\system32"FileCopy,"%ScriptDir%\cdboot.f35","%TargetDir%\Programs\ifw"FileCopy,"%ScriptDir%\imagew.exe","%TargetDir%\Programs\ifw"FileCopy,"%ScriptDir%\imagew.key","%TargetDir%\Programs\ifw"Echo,"Loading registry hive _linenums:0'>Echo,"Making new directories.."DirMake,%TargetDir%\Programs\ifwEcho,"Copying files.."FileCopy,"%ScriptDir%\autorun_ifw.cmd","%TargetDir%\[s]I386[/s]Windows\system32"FileCopy,"%ScriptDir%\cdboot.f35","%TargetDir%\Programs\ifw"FileCopy,"%ScriptDir%\imagew.exe","%TargetDir%\Programs\ifw"FileCopy,"%ScriptDir%\imagew.key","%TargetDir%\Programs\ifw"Echo,"Loading registry hive: [%TargetDir%\[s]I386[/s]Windows\System32\Config\software]"RegHiveLoad,Tmp_software,%TargetDir%\[s]I386[/s]Windows\System32\Config\softwareEcho,"Writing new values on registry hive.."RegWrite,HKLM,0x4,"Tmp_software\TeraByte Unlimited\Image","Settings","[s]1966087[/s]"RegHiveUnLoad,Tmp_software
Edit where indicated. Read the extracted ifw.htm in the downloaded folder for instructions to edit the Registry Settings. Note that "1966087" is an example only. I'm afraid I don't know if this should be the hex value or the decimal value. Winbuilder "Convert" has change it from hex in the BartPE Plugin to decimal in the Script. :) Also see the ifw.htm for instructions about your licence key.In WinBuilder's Script Panel, Select All and Copy. (Right-Clicking, or <ctrl>+a and <ctrl>+c) Make sure to Copy because moving away from this screen will lose the work.In WinBuilder, click "Create Script.." tab. In the Script Template, under "[process]..... unpack", Paste (No Right-Clicking?! Use <ctrl>+v).In the Left Panel, click "Add files.." tab, click "+", locate and add each of the files: autorun_ifw.cmd, cdboot.f35, imagew.exe and imagew.key.Edit the "my" values in the Template, and delete everything above the "[main]" section. The script might look like this:
[main]Title=IFWDescription=IFW will be added on the projectSelected=TrueLevel=5Version=1[variables]%ProgramTitle%=IFW%ProgramEXE%=imagew.exe%ProgramFolder%=Terabyte[process]Add_Shortcut,DesktopAdd_Shortcut,StartMenu,TerabyteunpackEcho,"Making new directories.."DirMake,%TargetDir%\Programs\ifwEcho,"Copying files.."FileCopy,"%ScriptDir%\autorun_ifw.cmd","%TargetDir%\Windows\system32"FileCopy,"%ScriptDir%\cdboot.f35","%TargetDir%\Programs\ifw"FileCopy,"%ScriptDir%\imagew.exe","%TargetDir%\Programs\ifw"FileCopy,"%ScriptDir%\imagew.key","%TargetDir%\Programs\ifw"Echo,"Loading registry hive: [%TargetDir%\Windows\System32\Config\software]"RegHiveLoad,Tmp_software,%TargetDir%\Windows\System32\Config\softwareEcho,"Writing new values on registry hive.."RegWrite,HKLM,0x4,"Tmp_software\TeraByte Unlimited\Image","Settings","[s]1966087[/s] (edit this)"RegHiveUnLoad,Tmp_software......

The script looks OK. Save to App folder and test. :sos:

I haven't tested because I don't use IFW. And I'm only learning! :yahoo:

Good luck. :)

#10 Nuno Brito

Nuno Brito

    Platinum Member

  • .script developer
  • 10549 posts
  • Location:boot.wim
  • Interests:I'm just a quiet simple person with a very quiet simple life living one day at a time..
  •  
    European Union

Posted 28 July 2007 - 04:44 PM

Seems you're a quick learner! :yahoo:

#11 yahoouk

yahoouk

    Silver Member

  • .script developer
  • 518 posts

Posted 28 July 2007 - 06:31 PM

I do a test and I have the same Error Messages then I mention above !!!

Good Luck !!!


Hi Haiphong,

It does work for me, see below.
http://www.boot-land...l...show&ida=72

Regards,

yahooUK

#12 online

online

    Silver Member

  • Advanced user
  • 767 posts

Posted 28 July 2007 - 07:04 PM

The script looks OK. Save to App folder and test. :)

I haven't tested because I don't use IFW. And I'm only learning! :)

Good luck. :)

allanf,
thank you so very much! :)
I'm trying this and later I'll know to tell you... :)

:yahoo:

#13 Haiphong

Haiphong

    Frequent Member

  • Advanced user
  • 237 posts

Posted 28 July 2007 - 07:22 PM

Hi Haiphong,

It does work for me, see below.
http://www.boot-land...l...show&ida=72

Regards,

yahooUK


Hi YahooUK,

I think that it miss something !!! Yet, my Program seems to be work, because I can made a backup.

Regards.

#14 online

online

    Silver Member

  • Advanced user
  • 767 posts

Posted 29 July 2007 - 01:01 AM

The script looks OK. Save to App folder and test.

Yes, it works!
Using "WinBuilder 069-beta2" and following your instructions I've created (and modified) this "ifw.script":
&#91;main&#93;

Title=IFW

Description=IFW will be added on the project

Selected=True

Level=5

Version=1



&#91;variables&#93;

%ProgramTitle%=IFW

%ProgramEXE%=imagew.exe

%ProgramFolder%=Terabyte



&#91;process&#93;

Add_Shortcut,Desktop

Add_Shortcut,StartMenu,Terabyte

unpack



Echo,&#34;Making new directories..&#34;

DirMake,%TargetDir%\Programs\IFW



Echo,&#34;Copying files..&#34;

FileCopy,&#34;%ScriptDir%\autorun_ifw.cmd&#34;,&#34;%TargetDir%\Windows\System32&#34;

FileCopy,&#34;%ScriptDir%\cdboot.f35&#34;,&#34;%TargetDir%\Programs\IFW&#34;

FileCopy,&#34;%ScriptDir%\imagew.exe&#34;,&#34;%TargetDir%\Programs\IFW&#34;

FileCopy,&#34;%ScriptDir%\imagew.key&#34;,&#34;%TargetDir%\Programs\IFW&#34;



Echo,&#34;Loading registry hive&#58; &#91;%TargetDir%\Windows\System32\Config\software&#93;&#34;

RegHiveLoad,Tmp_software,%TargetDir%\Windows\System32\Config\software

Echo,&#34;Writing new values on registry hive..&#34;

RegWrite,HKLM,0x4,&#34;Tmp_software\TeraByte Unlimited\Image&#34;,&#34;Settings&#34;,&#34;0x00390005&#34;

RegHiveUnLoad,Tmp_software
then I've created "IFW" folder in "C:\...\Projects\VistaPE\App\" and I've copied "ifw.script", "autorun_ifw.cmd", "cdboot.f35", "imagew.exe" and "imagew.key". ["In the Left Panel, click "Add files.." tab, click "+", locate and add each of the files: autorun_ifw.cmd, cdboot.f35, imagew.exe and imagew.key." > doesn't work.]
I've inserted Vista Installation DVD and downloaded VistaPE files, then I've created and burned ISO file.
Image for Windows doesn't appear in Programs menu, but it runs like a charme browsing and executing through LiteStep and A43 FM.
If Explorer Vista runs then the machine doesn' restart and doesn't shutdown.
I don't know how to set IFW Autorun (like it works under BartPE), but I'm very satisfied... for now! :)
allanf, Nuno Brito, NightMan: thank you very much!!!
Thanks a lot to all.
:yahoo:

#15 allanf

allanf

    Gold Member

  • .script developer
  • 1256 posts

Posted 29 July 2007 - 05:53 AM

Using "WinBuilder 069-beta2"...

@online,

For "unpack" and "shortcuts" features, try:
WinBuilder072 Download: http://www.boot-land...amp;showfile=53

For "autorun" feature, try:
VistaPE-BETA 009 (In WinBuilder072, click "Download" tab, and "Add new web server" => http://vistape.boot-land.net/beta/)

AutoRun API
.....
bonus: manual sample

&#91;Process&#93;

If,notExistFile,%AutoRunFile%,FileCreateBlank,%AutoRunFile%

TXTAddLine,%AutoRunFile%,&#34;1|s|HwPNP|s|X&#58;\Windows\System32|s|hwpnp.exe|s|&#34;,&#34;Append&#34;
(run hwpnp.exe in normal window without parameters and wait when program will be finished)

|s| - separator

more information will be soon :)


Try:
&#91;Process&#93;

If,notExistFile,%AutoRunFile%,FileCreateBlank,%AutoRunFile%

TXTAddLine,%AutoRunFile%,&#34;1|s|IFW|s|X&#58;\Windows\System32|s|autorun_ifw.cmd|s|&#34;,&#34;Append&#34;
Or:
&#91;Process&#93;

If,notExistFile,%AutoRunFile%,FileCreateBlank,%AutoRunFile%

TXTAddLine,%AutoRunFile%,&#34;1|s|IFW|s|X&#58;\Programs\IFW|s|imagew.exe|s|&#34;,&#34;Append&#34;

If you are happy with your Script, Upload to the Downloads section. This will automatically start a new topic with your comments. (... so as not to upset yahooUK too much. :) ).

Good to see you got it working. :yahoo:

#16 online

online

    Silver Member

  • Advanced user
  • 767 posts

Posted 29 July 2007 - 07:43 AM

For "unpack" and "shortcuts" features, try: WinBuilder072

[edited >] I'm trying it and it works (only if I download files from VistaPE-beta Server)... then a "dll not found" error for LiteStep appears...

(... so as not to upset yahooUK too much. :) ).

I apologize if this was an annoyance... :yahoo:
allanf, many thanks again. :)

:)

#17 Haiphong

Haiphong

    Frequent Member

  • Advanced user
  • 237 posts

Posted 30 July 2007 - 01:58 PM

Hi Haiphong,

It does work for me, see below.
http://www.boot-land...l...show&ida=72

Regards,

yahooUK


Hello Yahoouk,

Can you sent to me your Full Plugin of "DriveImageXML", i.e. Script and All the Files and Directories.
I want to do a try !!! perhaps, there is a mistake for me !!!

Thanks for your Help !!!

#18 online

online

    Silver Member

  • Advanced user
  • 767 posts

Posted 01 August 2007 - 11:40 AM

This morning, I do a try under "VistaPE" and I has this messages

Hi Haiphong,

I see your screenshots under VistaPE and I have a great curiosity: how have you captured them? Running ISO file under a Virtual Machine or @ low level running VistaPE CD-ROM?
In the first case: how does DriveImageXML to see your partitions?
In the second case: how to capture that perfect screenshot under VistaPE CD-ROM?
If I run Image for Windows ISO file under a Virtual Machine, then the program doesn't see other than this... :yahoo:

#19 Haiphong

Haiphong

    Frequent Member

  • Advanced user
  • 237 posts

Posted 01 August 2007 - 11:51 AM

Hi Haiphong,

I see your screenshots under VistaPE and I have a great curiosity: how have you captured them? Running ISO file under a Virtual Machine or @ low level running VistaPE CD-ROM?
In the first case: how does DriveImageXML to see your partitions?
In the second case: how to capture that perfect screenshot under VistaPE CD-ROM?
If I run Image for Windows ISO file under a Virtual Machine, then the program doesn't see other than this... :yahoo:



Hello Online,

Under "VistaPE" after "Boot" Cd or USB 2.0 Key and after to launch "DriveImageXML"!!!

Thanks !!!

#20 paraglider

paraglider

    Gold Member

  • .script developer
  • 1729 posts
  • Location:NC,USA
  •  
    United States

Posted 01 August 2007 - 12:00 PM

Normal way to capture a screen is run an image editing program like mspaint then use the <Print Screen> key on your keyboard to capture the current screen to the clipboard. Then paste the clipboard into mspaint, edit the image as appropriate and save the file. That all works on PE.


Vista has a built in snippingtool.exe to allow easy capture and editing of the current screen. Don't know if this is available in VistaPE yet.

#21 online

online

    Silver Member

  • Advanced user
  • 767 posts

Posted 01 August 2007 - 12:06 PM

Hello Online,

Under "VistaPE" after "Boot" Cd or USB 2.0 Key and after to launch "DriveImageXML"!!!

Thanks !!!

Thanks for your quick reply.
Ok, then I explain to me that the program see all partitions... but how capture you a screenshot under VistaPE (CD-ROM booting)?
Explain to me, please.
Thanks!
:yahoo:

#22 online

online

    Silver Member

  • Advanced user
  • 767 posts

Posted 01 August 2007 - 12:53 PM

Normal way to capture a screen is run an image editing program like mspaint then use the <Print Screen> key on your keyboard to capture the current screen to the clipboard. Then paste the clipboard into mspaint, edit the image as appropriate and save the file.

Sure, this is needed under Windows.
paraglider,
I asked to understand about the situation: Windows or low level. Then about the manner to do it under VistaPE (CD-ROM boot, not ISO image under VM). :)
The advantage of the VMware Workstation integrated capture function consists in the fact that the result picture doesn't need to edit and that it show just the interested screen area, not like Print key (the whole screen captured) or Alt+Print key (only explorer window captured).
I converted bitmap to PNG file for web use (smaller file)... :)
Under VistaPE (CD-ROM booting, not ISO image running under Virtual Machine) which is the way for capture screenshots?
Many thanks. :)

That all works on PE.

Sure? :yahoo:

#23 Haiphong

Haiphong

    Frequent Member

  • Advanced user
  • 237 posts

Posted 01 August 2007 - 02:44 PM

Thanks for your quick reply.
Ok, then I explain to me that the program see all partitions... but how capture you a screenshot under VistaPE (CD-ROM booting)?
Explain to me, please.
Thanks!
:yahoo:


Hello Online,

I use for Capture on "VistaPE", either "Portable Snagit 8.02" or "Portable FastStone Capture 5.5". The 2 Programs is well, but "Portable Snagit 8.02" is better, if you want to do some modifications with your Capture !!!

Thanks !!!

#24 online

online

    Silver Member

  • Advanced user
  • 767 posts

Posted 01 August 2007 - 03:08 PM

Hello Online,

I use for Capture on "VistaPE", either "Portable Snagit 8.02" or "Portable FastStone Capture 5.5". The 2 Programs is well, but "Portable Snagit 8.02" is better, if you want to do some modifications with your Capture !!!

Thanks !!!

Great!!!
I have just opened a new thread on this...
Thank you very much, I'll try these apps!
:yahoo:

#25 Haiphong

Haiphong

    Frequent Member

  • Advanced user
  • 237 posts

Posted 01 August 2007 - 04:52 PM

Great!!!
I have just opened a new thread on this...
Thank you very much, I'll try these apps!
:yahoo:


Hello Online,

You can see some "Portable Program" compatible with "VistaPE" and handled by the excellent Launcher "PStart" at this thread : http://www.boot-land...?...5&hl=Pstart

Good Luck !!!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users