Jump to content











Photo
* * * * * 1 votes

Windows (Msi) Installer 4.0.6000.16386


  • Please log in to reply
42 replies to this topic

#1 Max_Real Qnx

Max_Real Qnx

    Gold Member

  • Patrician
  • 1382 posts
  • Location:Istanbul
  • Interests:To be or not to be that is the question.
  •  
    Turkey

Posted 02 July 2007 - 04:44 PM

File name: Windows (Msi) Installer 4.0.6000.16386


Description:

Windows (Msi) Installer 4.0.6000.16386 & InstallShield ® 11.0.0.28844 & InstallShield ® Setup Engine 6.31.100.1221


From now on everytime you can work *.msi setup species of file on VistaPE :1st:

Lol lol use :thumbup:

Screen Shot : http://maxrealqnx.bo...t/msi4/msi.html



Download file

Attached Thumbnails

  • xmsi.jpg


#2 TheHive

TheHive

    Platinum Member

  • .script developer
  • 4171 posts

Posted 02 July 2007 - 05:40 PM

Thanks for the plugin. You are doing a great job.

#3 Max_Real Qnx

Max_Real Qnx

    Gold Member

  • Patrician
  • 1382 posts
  • Location:Istanbul
  • Interests:To be or not to be that is the question.
  •  
    Turkey

Posted 02 July 2007 - 05:51 PM

Thanks for the plugin. You are doing a great job.


Hi :thumbup:

No problem my friend, i am thank you for interest :1st:

Lol lol use :thumbup:

#4 Nuno Brito

Nuno Brito

    Platinum Member

  • .script developer
  • 10549 posts
  • Location:boot.wim
  • Interests:I'm just a quiet simple person with a very quiet simple life living one day at a time..
  •  
    European Union

Posted 02 July 2007 - 06:29 PM

Impressive indeed, great work!! :1st:

#5 Max_Real Qnx

Max_Real Qnx

    Gold Member

  • Patrician
  • 1382 posts
  • Location:Istanbul
  • Interests:To be or not to be that is the question.
  •  
    Turkey

Posted 02 July 2007 - 06:48 PM

Impressive indeed, great work!! :1st:


From Turkey greeting to Portugal :thumbup:

Lol lol use my friend :thumbup:

#6 Haiphong

Haiphong

    Frequent Member

  • Advanced user
  • 237 posts

Posted 15 July 2007 - 04:41 PM

Hello Max_Real Qnx,

Excellent Share !!! Have you this Plugin, but for "BartPE" or "WinXPE" ?

Thanks one thousand times !!!

#7 TheHive

TheHive

    Platinum Member

  • .script developer
  • 4171 posts

Posted 15 July 2007 - 06:38 PM

You can try this Msi Installer Plugin from the 911 CD forum
http://www.911cd.net...t...f=21&t=4623

The one posted by Max_Real Qnx is meant for Vista PE.

#8 Max_Real Qnx

Max_Real Qnx

    Gold Member

  • Patrician
  • 1382 posts
  • Location:Istanbul
  • Interests:To be or not to be that is the question.
  •  
    Turkey

Posted 15 July 2007 - 06:42 PM

Hello Max_Real Qnx,

Excellent Share !!! Have you this Plugin, but for "BartPE" or "WinXPE" ?

Thanks one thousand times !!!


Hi :)

VistaPE need development so i make script for VistaPE only :yahoo:

Are you make more script to this project for support ?


Good luck :)

#9 Haiphong

Haiphong

    Frequent Member

  • Advanced user
  • 237 posts

Posted 15 July 2007 - 06:57 PM

You can try this Msi Installer Plugin from the 911 CD forum
http://www.911cd.net...t...f=21&t=4623

The one posted by Max_Real Qnx is meant for Vista PE.



Hello Thehive,

I use it and it work fine with "WinXPE", but it don't support "MSI Installer" !!!

Thanks !!!

#10 TheHive

TheHive

    Platinum Member

  • .script developer
  • 4171 posts

Posted 15 July 2007 - 11:05 PM

ok! I see. Sorry that it doesnt support it.

#11 Haiphong

Haiphong

    Frequent Member

  • Advanced user
  • 237 posts

Posted 18 July 2007 - 06:20 AM

Hello Max_Real Qnx,

I have 2 questions :

I'm in "Windows XP" and I want to compil my Project with Your Script of "Windows Msi Installer" :

1) Have I to install your version of "Windows Msi Installer" or it's installed by default on my Computer ?
2) Where have I to add this "script" in my Project, before to Compil ?

Thanks for your help !!!

#12 Max_Real Qnx

Max_Real Qnx

    Gold Member

  • Patrician
  • 1382 posts
  • Location:Istanbul
  • Interests:To be or not to be that is the question.
  •  
    Turkey

Posted 19 July 2007 - 02:29 PM

Hello Max_Real Qnx,

I have 2 questions :

I'm in "Windows XP" and I want to compil my Project with Your Script of "Windows Msi Installer" :

1) Have I to install your version of "Windows Msi Installer" or it's installed by default on my Computer ?
2) Where have I to add this "script" in my Project, before to Compil ?

Thanks for your help !!!


Hi :)

For the WinPE , I did the plugin but it isn't working :)
Maybe it isn't working for it can't write media (CD - X:\) :yahoo:

But, it is working on WinPE MiniNT version :)
Exchange the minint with the i386 in script file !!!


msiexec.exe /regserver - this is option import settings to registry.
msiexec.exe /V - this is option make run service


The WinPE became out of date, new trend is VistaPE :ok:

Download


Good Luck :)

#13 Haiphong

Haiphong

    Frequent Member

  • Advanced user
  • 237 posts

Posted 20 July 2007 - 03:59 PM

Hi :yahoo:

For the WinPE , I did the plugin but it isn't working :)
Maybe it isn't working for it can't write media (CD - X:\) :)
The WinPE became out of date, new trend is VistaPE :ok:

Download
Good Luck :)


Hello Max_Real_Qnx,

1) I do a try of your "WinXPE" Plugin of "Msi Installer" on an USB 2.0 Key and I tell you about
2) Now, i have some experience of "VistaPE" and I want to do a try of your "VistaPE Script"
Can you ask me where have I to place this "Script", because after my last Compil, it seems not to work for me !!! Have I to modify the Path in your Script and install this new "MSI Installer" on my Desktop ? Can I use "Winbuilder" (VistaPE Project) on "Windows XP Pro" or "Windows Vista" ? Can you build a little "Tuto", because I'm a Newbie for "VistaPE".

Thanks for your help and your share !!!

See you soon !!!

#14 Haiphong

Haiphong

    Frequent Member

  • Advanced user
  • 237 posts

Posted 20 July 2007 - 07:23 PM

Hi :yahoo:

For the WinPE , I did the plugin but it isn't working :)
Maybe it isn't working for it can't write media (CD - X:\) :)
The WinPE became out of date, new trend is VistaPE :ok:

Download
Good Luck :)


Hello Max_Real Qnx,

I do a try with an USB 2.0 Key and your Plugin works with "WinXPE", but some Programs work and some programs does'n work, for sample :

- Driver Genius 2007 is installed and work
- Sandra Sisoft 2007 is installed and work
- Kaspersky Anti-Virus and AVG Anti-Spyware ==> I can't install
- Outpost dont work ==> I can't install

I would like to try your "VistaPE" Version !!!

Thanks for your Help.

See you soon !!!

#15 Max_Real Qnx

Max_Real Qnx

    Gold Member

  • Patrician
  • 1382 posts
  • Location:Istanbul
  • Interests:To be or not to be that is the question.
  •  
    Turkey

Posted 22 July 2007 - 09:08 AM

Hello Max_Real Qnx,

I do a try with an USB 2.0 Key and your Plugin works with "WinXPE", but some Programs work and some programs does'n work, for sample :

- Driver Genius 2007 is installed and work
- Sandra Sisoft 2007 is installed and work
- Kaspersky Anti-Virus and AVG Anti-Spyware ==> I can't install
- Outpost dont work ==> I can't install

I would like to try your "VistaPE" Version !!!

Thanks for your Help.

See you soon !!!


Congratulations :)

Please you are download these files and set, later try again :yahoo:

InstallShield ® 11.0.0.28844

InstallShield ® Setup Engine 6.31.100.1221

For more knowledge



Good luck :)

#16 Haiphong

Haiphong

    Frequent Member

  • Advanced user
  • 237 posts

Posted 22 July 2007 - 05:02 PM

Congratulations :)

Please you are download these files and set, later try again :yahoo:

InstallShield ® 11.0.0.28844

InstallShield ® Setup Engine 6.31.100.1221
Good luck :)


Hello Max_Real Qnx,

This is the results of my first tests on An External Disk USB 2.0 :

See this ScreenShots :
KAV 6 - Install :
Posted Image

Spyware Doctor - Menu :
Posted Image

I create one Partition for "VistaPE" = 14,5 Go

As you see, after "Boot", you have 3 partitions :

1) Partition X: ==> VOL = Boot = 46 Mo With :

Program Files <DIR> 2007/07/22 14:58
ProgramData <DIR> 2007/07/22 14:52
Sources <DIR> 2007/07/22 14:52
Users <DIR> 2007/07/22 14:52
Windows <DIR> 2007/07/22 14:58
$wimdesc 700 b 2007/07/22 15:00

2) Partition Y: ==> VOL = VistaPE = 13 Go With :

7-zip <DIR> 2007/07/22 15:57
A43 <DIR> 2007/07/22 15:56
AbiSuite2 <DIR> 2007/07/22 15:58
Apciinfo <DIR> 2007/07/22 15:56
CDrtfe <DIR> 2007/07/22 15:56
Dc-Pass <DIR> 2007/07/22 15:58
DefragNT <DIR> 2007/07/22 15:56
DreamPackPL <DIR> 2007/07/22 15:58
FileZilla <DIR> 2007/07/22 15:57
FireFox <DIR> 2007/07/22 15:57
Ftpserver3lite <DIR> 2007/07/22 15:57
HDDScan <DIR> 2007/07/22 15:56
HEXEdit <DIR> 2007/07/22 15:58
Hfs <DIR> 2007/07/22 15:57
InfraRecorder <DIR> 2007/07/22 15:56
LanSpy <DIR> 2007/07/22 15:57
Mark <DIR> 2007/07/22 15:58
MbrFix <DIR> 2007/07/22 15:56
MBRWizard <DIR> 2007/07/22 15:56
NetMet <DIR> 2007/07/22 15:57
Netscan <DIR> 2007/07/22 15:57
NTPWEdit <DIR> 2007/07/22 15:58
OEView <DIR> 2007/07/22 15:58
Pcw2007 <DIR> 2007/07/22 15:56
PDFReader <DIR> 2007/07/22 15:58
Penetcfg <DIR> 2007/07/22 15:58
Pserv <DIR> 2007/07/22 15:58
PuTTY <DIR> 2007/07/22 15:58
RegistryLoaderPE <DIR> 2007/07/22 15:58
Salapasswd <DIR> 2007/07/22 15:58
ServiceControl <DIR> 2007/07/22 15:58
ServicesPE <DIR> 2007/07/22 15:58
Ssft <DIR> 2007/07/22 15:58
TestDisk <DIR> 2007/07/22 15:56
TheBee <DIR> 2007/07/22 15:58
TrueCrypt <DIR> 2007/07/22 15:58
UltraVNC <DIR> 2007/07/22 15:58
WinSCP <DIR> 2007/07/22 15:58
Wrr <DIR> 2007/07/22 15:58
Wul <DIR> 2007/07/22 15:58
Xchm <DIR> 2007/07/22 15:58
XPKeyReaders <DIR> 2007/07/22 15:58

3) Partition G: ==> VOL = VistaPE = 13 Go With :

! Install <DIR> 2007/07/22 16:06
%WorkDir% <DIR> 2007/07/22 12:33
Boot <DIR> 2007/07/22 16:00
Programs <DIR> 2007/07/22 15:58
Sources <DIR> 2007/07/22 16:03
Bootmgr 428 kb 2006/11/02 22:00
Bootsect.bin 166 kb 2007/07/22 15:59
Menu.lst 801 b 2007/07/22 15:59
Vistape.cd 0 b 2007/07/22 15:59

I can't install "KAV 6", because there is not enough Disk Space on "X:". I try to change to "Y:",
but it don't accept to finish the installation !!!

For "SpyWare Doctor" as you see ==> The install is OK !!!

Questions :

Why "X:" has a so small Disk Space ? Can i affect it with this of "Y:" ?

What is your opinions ?

Thanks for your Help !!!

Congratulations !!!

#17 Max_Real Qnx

Max_Real Qnx

    Gold Member

  • Patrician
  • 1382 posts
  • Location:Istanbul
  • Interests:To be or not to be that is the question.
  •  
    Turkey

Posted 23 July 2007 - 08:36 PM

Hello Max_Real Qnx,

This is the results of my first tests on An External Disk USB 2.0 :

I can't install "KAV 6", because there is not enough Disk Space on "X:". I try to change to "Y:",
but it don't accept to finish the installation !!!

For "SpyWare Doctor" as you see ==> The install is OK !!!

Questions :

Why "X:" has a so small Disk Space ? Can i affect it with this of "Y:" ?

What is your opinions ?

Thanks for your Help !!!

Congratulations !!!



Hi :)

; PE Builder v3 plug-in INF file
; by reatogo

[Version]
Signature="$Windows NT$"

[PEBuilder]
Name="990 My Custom Settings (<Help> for complete list of options)"

Help="list_of_settings.txt"
Enable=1

[SetupReg.AddReg]
; Disable timezone...
0x4, "ControlSet001\Control\TimeZoneInformation", "ActiveTimeBias", 0x0
0x4, "ControlSet001\Control\TimeZoneInformation", "Bias", 0x0
0x4, "ControlSet001\Control\TimeZoneInformation", "DaylightBias", 0x0
0x1, "ControlSet001\Control\TimeZoneInformation", "DaylightName", "Local time"
0x3, "ControlSet001\Control\TimeZoneInformation", "DaylightStart", \
00,00,03,00,05,00,02,00,00,00,00,00,00,00,00,00
0x4, "ControlSet001\Control\TimeZoneInformation", "StandardBias", 0x0
0x1, "ControlSet001\Control\TimeZoneInformation", "StandardName", "Local time"
0x3, "ControlSet001\Control\TimeZoneInformation", "StandardStart", \
00,00,0A,00,05,00,03,00,00,00,00,00,00,00,00,00

;Defaults directory Max_Real Qnx 2006

[Software.AddReg]
0x1, "Microsoft\Windows\CurrentVersion\Setup","SourcePath","x:\minint"
0x1, "Microsoft\Windows\CurrentVersion","DevicePath","%SystemRoot%\inf"
0x1, "Microsoft\Windows\CurrentVersion","MediaPathUnexpanded","%SystemRoot%\Media"
0x1, "Microsoft\Windows\CurrentVersion","ProgramFilesDir","X:\Program Files"
0x1, "Microsoft\Windows\CurrentVersion","CommonFilesDir","X:\Program Files\Common Files"
0x1, "Microsoft\Windows\CurrentVersion","ProgramFilesPath","%ProgramFiles%"
0x1, "Microsoft\Windows\CurrentVersion","MediaPath","X:\minint\Media"

[Software.AddReg]
0x1, "Microsoft\Windows NT\CurrentVersion","ProductName","Microsoft Windows XP"
0x1, "Microsoft\Windows NT\CurrentVersion","RegisteredOrganization","Linuz"
0x1, "Microsoft\Windows NT\CurrentVersion","RegisteredOwner","Max_Real Qnx"
0x1, "Microsoft\Windows NT\CurrentVersion","SoftwareType","SYSTEM"
0x1, "Microsoft\Windows NT\CurrentVersion","CurrentVersion","5.1"
0x1, "Microsoft\Windows NT\CurrentVersion","CurrentBuildNumber","2600"
0x1, "Microsoft\Windows NT\CurrentVersion","SystemRoot","X:\minint"
0x1, "Microsoft\Windows NT\CurrentVersion","PathName","X:\minint"
0x1, "Microsoft\Windows NT\CurrentVersion","CSDVersion","Service Pack 2"

[SetupReg.AddReg]
0x4, "ControlSet001\Control\Session Manager\Memory Management","LargeSystemCache", 0x00000000
0x4, "ControlSet001\Control\Session Manager\Memory Management","ClearPageFileAtShutdown", 0x00000001
0x1, "ControlSet001\Control\Session Manager\Environment","windir","%SystemRoot%"


[Software.AddReg]
0x2,"Microsoft\Windows NT\CurrentVersion\ProfileList","ProfilesDirectory","%ProfilesDir%"
0x1,"Microsoft\Windows NT\CurrentVersion\ProfileList","DefaultUserProfile","Default User"
0x1,"Microsoft\Windows NT\CurrentVersion\ProfileList","AllUsersProfile","All Users"

[SetupReg.AddReg]
; Profiles to RamDrive Required
0x2,"ControlSet001\Control\Session Manager\Environment","USERPROFILE","X:\@ProfilesDir@\Default User"
0x2,"ControlSet001\Control\Session Manager\Environment","ProfilesDir","X:\@ProfilesDir@"

[Default.AddReg]
; Point My Document to %ramdrv%Documents and Settings\Default User\My Documents\
0x1,"Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders","Personal","X:\Documents and Settings\Default User\My Documents"


[SetupReg.AddReg]
; default computer name
0x1,"ControlSet001\Control\ComputerName\ComputerName","ComputerName","MiniNT"
0x1,"ControlSet001\Control\Session Manager\Environment","ComputerName","MiniNT"



; Explorer various visual effects modifier Max_Real Qnx
[Default.AddReg]
0x4, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","Hidden", 0x00000001
0x4, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","ShowCompColor", 0x00000001
0x4, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","HideFileExt", 0x00000000
0x4, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","DontPrettyPath", 0x00000000
0x4, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","ShowInfoTip", 0x00000001
0x4, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","HideIcons", 0x00000000
0x4, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","MapNetDrvBtn", 0x00000000
0x4, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","WebView", 0x00000001
0x4, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","Filter", 0x00000000
0x4, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","SuperHidden", 0x00000000
0x4, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","SeparateProcess", 0x00000000
0x4, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","ListviewAlphaSelect", 0x00000001
0x4, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","ListviewShadow", 0x00000001
0x4, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","ListviewWatermark", 0x00000001
0x4, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","TaskbarAnimations", 0x00000001
0x4, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","StartMenuInit", 0x00000002
0x4, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","TaskbarSizeMove", 0x00000001
0x4, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","TaskbarGlomming", 0x00000001
0x4, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","StartButtonBalloonTip", 0x00000001
0x4, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","NoNetCrawling", 0x00000000
0x4, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","FolderContentsInfoTip", 0x00000001
0x4, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","FriendlyTree", 0x00000001
0x4, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","WebViewBarricade", 0x00000000
0x4, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","DisableThumbnailCache", 0x00000000
0x4, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","ShowSuperHidden", 0x00000001
0x4, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","ClassicViewState", 0x00000000
0x4, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","PersistBrowsers", 0x00000000
0x4, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","ServerAdminUI", 0x00000000
0x1, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","CascadeNetworkConnections","YES"
0x4, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","Start_LargeMFUIcons", 0x00000000
0x4, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","Start_MinMFU", 0x0000000c
0x4, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","Start_ShowControlPanel", 0x00000001
0x4, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","Start_EnableDragDrop", 0x00000001
0x4, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","StartMenuFavorites", 0x00000000
0x4, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","Start_ShowHelp", 0x00000001
0x4, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","Start_ShowMyComputer", 0x00000001
0x4, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","Start_ShowMyDocs", 0x00000001
0x4, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","Start_ShowMyMusic", 0x00000001
0x4, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","Start_ShowMyPics", 0x00000001
0x4, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","Start_ShowPrinters", 0x00000001
0x4, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","Start_ShowRun", 0x00000001
0x4, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","Start_ScrollPrograms", 0x00000000
0x4, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","Start_ShowSearch", 0x00000001
0x4, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","Start_ShowSetProgramAccessAndDefaults", 0x00000001
0x4, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","Start_ShowRecentDocs", 0x00000002
0x4, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","Start_AutoCascade", 0x00000001
0x4, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","Start_NotifyNewApps", 0x00000001
0x4, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","Start_AdminToolsRoot", 0x00000002
0x4, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","StartMenuAdminTools", 0x00000001
0x4, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","Start_ShowNetConn_ShouldShow", 0x00000042
0x1, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","CascadeControlPanel","NO"
0x1, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","CascadeMyDocuments","NO"
0x4, "Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced","EnableBalloonTips", 0x00000001

;No low disk warning modifier Max_Real Qnx
;[Default.AddReg]
;0x4, "Software\Microsoft\Windows\CurrentVersion\Policies\Explorer","NoDriveTypeAutoRun", 0x00000091
;0x3, "Software\Microsoft\Windows\CurrentVersion\Policies\Explorer","NoStartBanner",\
; 00,00,00,00
;0x4, "Software\Microsoft\Windows\CurrentVersion\Policies\Explorer","NoInstrumentation", 0x00000000
;0x4, "Software\Microsoft\Windows\CurrentVersion\Policies\Explorer","NoLowDiskSpaceChecks", 0x00000001


[SetValue]
; startmessage
"txtsetup.sif","SetupData","loaderprompt","""USB MiniNT xPE SP2 24.11.2006 Max_Real Qnx Presents..."""




Attached File  z990_Custom_Settings.inf   9.23KB   506 downloads

0x1, "Microsoft\Windows\CurrentVersion","ProgramFilesDir","X:\Program Files"

0x1, "Microsoft\Windows\CurrentVersion","ProgramFilesDir","Y:\Program Files"


Please try again; perhaps , it works.
Good luck :yahoo:

#18 Haiphong

Haiphong

    Frequent Member

  • Advanced user
  • 237 posts

Posted 24 July 2007 - 06:05 AM

Hello Max_real QNX,

0x1, "Microsoft\Windows\CurrentVersion","ProgramFilesDir","X:\Program Files"

0x1, "Microsoft\Windows\CurrentVersion","ProgramFilesDir","Y:\Program Files"


Please try again; perhaps , it works.
Good luck


This is the results of my Tests with "WinXPE" and with your "XPE Plugin" (Y:\Program files) :

1) By default, I has directory to install = "Y:\Programs Files", but I can choose the Drive Letter I want.
2) MSI Installer don't work, because i can't install "KIS" 6 and 7.
3) The only Programs I has installed are :
- Avast 4.7 Free ==> work fine !!!
- AVG 7.5 ==> work but not fully
- Spyware Doctor ==> work but not fully
- ZoneAlarm 7.0.337.000 Free ==> work fine !!!
- Driver Genius 7.1.0.622 ==> work fine !!!
- Irfanview 4.0 Free ==> work fine !!!
- and others...

I can't install Programs on "Y:", because i can't change the Drive Letter of my Test Partition to "Y:".
I have a message : "Access Denied". You can change this automatically by using "USBManager".
I use it by "Booting" on a CD, then chaining for the Programs to a Key or External Disk USB 2.0.

I also use the Plugin "zzzFBWF" (BartPE, but functional on XPE 1.06) by Alan Clark and when
I "Reboot", all the modifications (New installed Programs and New Shortcuts) are updated.

I build my application on an External Disk 2"1/2 USB 2.0.

Can you convert this plugin in "Script" for "VistaPE", with the possibility to install programs on "Y:"
and not "X:", because there is not enough Disk Space on "X:" !!!

Thanks for your Help and your usefull Job !!!

See you soon !!!

#19 Max_Real Qnx

Max_Real Qnx

    Gold Member

  • Patrician
  • 1382 posts
  • Location:Istanbul
  • Interests:To be or not to be that is the question.
  •  
    Turkey

Posted 24 July 2007 - 08:26 AM

Hello Max_real QNX,
This is the results of my Tests with "WinXPE" and with your "XPE Plugin" (Y:\Program files) :

1) By default, I has directory to install = "Y:\Programs Files", but I can choose the Drive Letter I want.
2) MSI Installer don't work, because i can't install "KIS" 6 and 7.
3) The only Programs I has installed are :
- Avast 4.7 Free ==> work fine !!!
- AVG 7.5 ==> work but not fully
- Spyware Doctor ==> work but not fully
- ZoneAlarm 7.0.337.000 Free ==> work fine !!!
- Driver Genius 7.1.0.622 ==> work fine !!!
- Irfanview 4.0 Free ==> work fine !!!
- and others...

I can't install Programs on "Y:", because i can't change the Drive Letter of my Test Partition to "Y:".
I have a message : "Access Denied". You can change this automatically by using "USBManager".
I use it by "Booting" on a CD, then chaining for the Programs to a Key or External Disk USB 2.0.

I also use the Plugin "zzzFBWF" (BartPE, but functional on XPE 1.06) by Alan Clark and when
I "Reboot", all the modifications (New installed Programs and New Shortcuts) are updated.

I build my application on an External Disk 2"1/2 USB 2.0.

Can you convert this plugin in "Script" for "VistaPE", with the possibility to install programs on "Y:"
and not "X:", because there is not enough Disk Space on "X:" !!!

Thanks for your Help and your usefull Job !!!

See you soon !!!


Hi :)

1- Make run the CMD.EXE
2- mountvol /? |Enter|
3- Follow the example |f:\ Cd-Rom Drive|

1.jpg

22.jpg |Enter|

3.jpg |The result|



Good luck :yahoo:

#20 Haiphong

Haiphong

    Frequent Member

  • Advanced user
  • 237 posts

Posted 24 July 2007 - 11:03 AM

Hello Max_Real QNX,

Commande-Cmd-Help.jpg
Posted Image

Disk-Director-10 (Partition-Suite-Fr).jpg
Posted Image

Change-Letter-Drive.jpg
Posted Image

I don't understand what you want ? as you see, I want to change
the Drive Letter "E:" By "Y:", and I can't, because of this Message !!!


I'm in "WinXPE", after "Boot" from External disk Usb 2.0.

good Luck !!!

#21 Max_Real Qnx

Max_Real Qnx

    Gold Member

  • Patrician
  • 1382 posts
  • Location:Istanbul
  • Interests:To be or not to be that is the question.
  •  
    Turkey

Posted 24 July 2007 - 02:19 PM

Hi :)

You can exchanged for Y: to E: with mountvol.exe !!!

1- Make run as Administrator the CMD.EXE
2- mountvol e: /d |Enter|
3- mountvol Y: \\?\Volume{20f0b809-39e1-11dc-8a4b-806d6172696f}\ |Enter|

Good luck :yahoo:

#22 Haiphong

Haiphong

    Frequent Member

  • Advanced user
  • 237 posts

Posted 24 July 2007 - 05:09 PM

Hi :)

You can exchanged for Y: to E: with mountvol.exe !!!

1- Make run as Administrator the CMD.EXE
2- mountvol e: /d |Enter|
3- mountvol Y: \\?\Volume{20f0b809-39e1-11dc-8a4b-806d6172696f}\ |Enter|

Good luck :yahoo:


Hello Max_Real QNX,

Mount Volume "Y:" ==> "E:" (OK) :
Posted Image

Disk Director 10 (Control) "Y:" ==> "E:" (OK) :
Posted Image

Install AVASt 4.7 Free ==> "Y:" (OK) :
Posted Image

Menu Avast 4.7 Free - After Key Serial :
Posted Image

Install ZoneAlarm 7.0.337.000 Free ==> "Y:" (OK) :
Posted Image

Menu ZoneAlarm 7.0.337.000 Free :
Posted Image

As you see, It's OK !!!!!!!!!! But very Complex for "Newbies". Can you build a Script or use "USB Manger" (Freeware).

Thanks !!!

#23 yahoouk

yahoouk

    Silver Member

  • .script developer
  • 518 posts

Posted 25 July 2007 - 08:38 AM

Hi :'Max_Real Qnx:

Nice shot, hit the taget.
Thanks for your script. :yahoo:

yahooUK

#24 2aCD

2aCD

    Frequent Member

  • .script developer
  • 345 posts
  •  
    Germany

Posted 09 September 2007 - 01:09 PM

Hello Max_Real Qnx,

I have a problem with your scripts vor VistaPe.
I can no install software that needs msi (KAV, ..).
The Language of my VistaPE is German.
The Errormsg is: msi is not correct installed.
In the commadprompt I testet: net start msiserver
The Errormessage is: msiserver cannot start without messages.

Can You help me?

#25 Max_Real Qnx

Max_Real Qnx

    Gold Member

  • Patrician
  • 1382 posts
  • Location:Istanbul
  • Interests:To be or not to be that is the question.
  •  
    Turkey

Posted 10 September 2007 - 05:06 AM

Hello Max_Real Qnx,

I have a problem with your scripts vor VistaPe.
I can no install software that needs msi (KAV, ..).
The Language of my VistaPE is German.
The Errormsg is: msi is not correct installed.
In the commadprompt I testet: net start msiserver
The Errormessage is: msiserver cannot start without messages.

Can You help me?


Hi :loleverybody:

Please copy files %InstallSRC%\msi.dll, msiexec.exe, msihnd.dll, msimsg.dll and msisip.dll to %Windir%\system32\

and run this commands on the cmd.exe

msiexec.exe /regserver - this is option import settings to registry.
msiexec.exe /V - this is option make run service

Please you are download these files and set, later try again

InstallShield ® 11.0.0.28844

InstallShield ® Setup Engine 6.31.100.1221

For more knowledge



Or use the Kaspersky 6-7 script I do

Good luck :w00t:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users