Jump to content











Photo

can't mount iso file in win10pe


Best Answer n_g , 4 days ago

In win10pe you can use WinNTSetup to mount an iso file by using R-mouse click on Select location of Windows installation files.

 

It is based on making use of ImDisk Virtual Disk driver that also has Configuration Control Panel applet to Mount and Remove ISO files in win10pe.

 

More Info in ImDisk subforum and in How to make Win10XPE 

 

attachicon.gifPE_ImDisk_2020-09-14_075926.jpg

 

Thanks,

Imdisk is a good solution, but when i saw your post, i already start a hardway just like "Wonko the Sane"'s suggestion.

After spend some hours, I got the native ISO mount work without explorer.exe:

 

1.create a miso.ps1 file, this file used to run mount iso powershell command:

Param(

  [string]$fileName

)

$fileName

Mount-DiskImage -ImagePath $fileName -StorageType:ISO

 

2. modify the PE registry, clear the HKLM\SOFTWARE\Classes\.iso, only keep the default value.

modify the HKLM\SOFTWARE\Classes\Windows.IsoFile, final result should like:

[HKEY_CLASSES_ROOT\Windows.IsoFile\shell\mount]

[HKEY_CLASSES_ROOT\Windows.IsoFile\shell\mount\command]

@="x:\\Windows\\System32\\WindowsPowerShell\\v1.0\\powershell.exe -file \"x:\\windows\\miso.ps1\" \"%1\""

[HKEY_CLASSES_ROOT\Windows.IsoFile\shell\open]

[HKEY_CLASSES_ROOT\Windows.IsoFile\shell\open\command]

@="x:\\Windows\\System32\\WindowsPowerShell\\v1.0\\powershell.exe -file \"x:\\windows\\miso.ps1\" \"%1\""

 

3. modify startnet.cmd, add one line:

powershell.exe -Command set-executionpolicy -executionpolicy Unrestricted

 

Use any graphic file explorer(I have tested total commander) double click some .ISO file will mount that iso as a virtual cdrom.

Go to the full post


  • Please log in to reply
8 replies to this topic

#1 n_g

n_g
  • Members
  • 3 posts
  •  
    China

Posted 6 days ago

Hello,

This is the first time i try to build a PE from windows ADK, without third pty software.

I can mount iso image using powershell command : mount-diskimage -imagepath z:\sample.iso

but when i right click on a iso file and select "mount", there is a error: sorry, there was a problem mounting the file.

I tried use third pty file browser (total commander), and use notepad (from file-open dialog, select all files, right click iso file, mount), the errors are the same.

 

seach engine gives me no answer, any suggestion is useful.

 



#2 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 15464 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 6 days ago

Check that the .iso is associated with Explorer?

https://www.tenforum...g-iso-file.html

 

Or can it be that the .iso file was downloaded and/or flagged as sparse?

https://www.danielen...nting-the-file/

https://social.techn...m=winserver8gen

 

There are also issues if the .iso is on a network path.

In this case usually copying the .iso solves the issue.

 

:duff:

Wonko



#3 steve6375

steve6375

    Platinum Member

  • Developer
  • 7309 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars, www.easy2boot.com
  •  
    United Kingdom

Posted 5 days ago

Try opening the ISO file with 7z.



#4 n_g

n_g
  • Members
  • 3 posts
  •  
    China

Posted 5 days ago

checked that ,iso is associated to a "Windows Shell Common DLL", that is a winpe default setting.

The default PE image doesnot contain explorer.exe, Is that means i must integrate all explorer componets to PE or just copy explorer.exe and make .iso accociate to it will work? 

I'll try to find that out later.

 

Check that the .iso is associated with Explorer?

https://www.tenforum...g-iso-file.html

 

Or can it be that the .iso file was downloaded and/or flagged as sparse?

https://www.danielen...nting-the-file/

https://social.techn...m=winserver8gen

 

There are also issues if the .iso is on a network path.

In this case usually copying the .iso solves the issue.

 

:duff:

Wonko



#5 wimb

wimb

    Platinum Member

  • Developer
  • 2966 posts
  • Interests:Boot and Install from USB
  •  
    Netherlands

Posted 4 days ago

In win10pe you can use WinNTSetup to mount an iso file by using R-mouse click on Select location of Windows installation files.

 

It is based on making use of ImDisk Virtual Disk driver that also has Configuration Control Panel applet to Mount and Remove ISO files in win10pe.

 

More Info in ImDisk subforum and in How to make Win10XPE  Attached File  Win10_Install.pdf   659.52KB   12 downloads

 

Attached File  PE_ImDisk_2020-09-14_075926.jpg   253.08KB   1 downloads



#6 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 15464 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 4 days ago

I thought you had somehow Explorer in the build (that provided the right click option).

 

Anyway the issue should be connected to the right click action associated to *something* that cannot actually mount the .iso.

 

I don't know what exactly is mounting .iso (and I believe also .vhd) in a "plain" Win10PE : :blush: .

 

The simplest way out would probably be making a script with those Powershell commands and connect it to the right click option, I don't know how the file path should be passed in the right click option, in batch this is %1, cannot say how to have the Powershell get it. :unsure:

 

 

:duff:

Wonko



#7 n_g

n_g
  • Members
  • 3 posts
  •  
    China

Posted 4 days ago   Best Answer

In win10pe you can use WinNTSetup to mount an iso file by using R-mouse click on Select location of Windows installation files.

 

It is based on making use of ImDisk Virtual Disk driver that also has Configuration Control Panel applet to Mount and Remove ISO files in win10pe.

 

More Info in ImDisk subforum and in How to make Win10XPE 

 

attachicon.gifPE_ImDisk_2020-09-14_075926.jpg

 

Thanks,

Imdisk is a good solution, but when i saw your post, i already start a hardway just like "Wonko the Sane"'s suggestion.

After spend some hours, I got the native ISO mount work without explorer.exe:

 

1.create a miso.ps1 file, this file used to run mount iso powershell command:

Param(

  [string]$fileName

)

$fileName

Mount-DiskImage -ImagePath $fileName -StorageType:ISO

 

2. modify the PE registry, clear the HKLM\SOFTWARE\Classes\.iso, only keep the default value.

modify the HKLM\SOFTWARE\Classes\Windows.IsoFile, final result should like:

[HKEY_CLASSES_ROOT\Windows.IsoFile\shell\mount]

[HKEY_CLASSES_ROOT\Windows.IsoFile\shell\mount\command]

@="x:\\Windows\\System32\\WindowsPowerShell\\v1.0\\powershell.exe -file \"x:\\windows\\miso.ps1\" \"%1\""

[HKEY_CLASSES_ROOT\Windows.IsoFile\shell\open]

[HKEY_CLASSES_ROOT\Windows.IsoFile\shell\open\command]

@="x:\\Windows\\System32\\WindowsPowerShell\\v1.0\\powershell.exe -file \"x:\\windows\\miso.ps1\" \"%1\""

 

3. modify startnet.cmd, add one line:

powershell.exe -Command set-executionpolicy -executionpolicy Unrestricted

 

Use any graphic file explorer(I have tested total commander) double click some .ISO file will mount that iso as a virtual cdrom.


Edited by n_g, 4 days ago.


#8 wimb

wimb

    Platinum Member

  • Developer
  • 2966 posts
  • Interests:Boot and Install from USB
  •  
    Netherlands

Posted 4 days ago

Imdisk is a good solution, but when i saw your post, i already start a hardway just like "Wonko the Sane"'s suggestion.

After spend some hours, I got the native ISO mount work without explorer.exe:

 

 

Ok, so the problem is solved  :)



#9 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 15464 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 4 days ago

Very good, happy to know that you solved the issue and thanks for sharing the solution :).

 

:duff:

Wonko






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users