Jump to content











Photo
- - - - -

grub2 themes


  • Please log in to reply
2 replies to this topic

#1 paraglider

paraglider

    Gold Member

  • .script developer
  • 1738 posts
  • Location:NC,USA
  •  
    United States

Posted 4 weeks ago

I am using this config file ( invader theme is from Super-UEFIinSecureBoot-Disk):

loadfont unicode
insmod regexp
#set pager=1
set gfxmode=auto
set gfxpayload=keep
insmod all_video
insmod gfxterm
terminal_output gfxterm
insmod fatfs
insmod png
set theme=${prefix}/themes/invader/theme.txt

probe --set rootuuid --fs-uuid $root

# Required to have these available in other configfile files
export theme
export rootuuid

# Menu!
#

menuentry "Win 10 XPE 64 (100%)" --class windows {
  dd --if=/EFI/Microsoft/Boot/bcd.pe100 --of=/EFI/Microsoft/Boot/bcd --bs=4096
  chainloader ($root)/EFI/Microsoft/Boot/bootx64.efi
}

menuentry "Win 10 XPE 64 (200%)" --class windows{
  dd --if=/EFI/Microsoft/Boot/bcd.pe200 --of=/EFI/Microsoft/Boot/bcd --bs=4096
  chainloader ($root)/EFI/Microsoft/Boot/bootx64.efi
}

menuentry "Shutdown" --class shutdown {
  halt
}

menuentry "Reboot" --class shutdown {
  reboot
}

You can see from the attached image that some sort of status is output in a large black box for the last icon. Is there any way to suppress the status output?
 

Attached Thumbnails

  • IMG_0662.jpg

  • Nuno Brito likes this

#2 a1ive

a1ive

    Newbie

  • Members
  • 19 posts
  •  
    China

Posted 4 weeks ago

set enable_progress_indicator=0

add this line before "set theme".



#3 paraglider

paraglider

    Gold Member

  • .script developer
  • 1738 posts
  • Location:NC,USA
  •  
    United States

Posted 3 weeks ago

Thanks. That worked.






1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users