Jump to content











Photo
- - - - -

Getting 'Missing operating system' on boot after debian install


  • Please log in to reply
13 replies to this topic

#1 Peter80

Peter80

    Frequent Member

  • Advanced user
  • 115 posts

Posted 4 weeks ago

I have two disks on my laptop Thinkpad T420: first disk is SSD with Windows 7 installed, and the disk is encrypted with Veracrypt; and second HDD disk on which i installed Debian 10. I installed grub on the second disk, but when i try to boot to Debian i get 'Missing operating system'.
I tried to use boot-repair from live usb but i get this message:

The current session is in Legacy mode. Please reboot the computer, and use this software in an EFI session. This will enable this feature. For example, use a live-USB of Boot-Repair-Disk-64bit (www.sourceforge.net/p/boot-repair-cd), after making sure your BIOS is set up to boot USB in EFI mode.


Maybe there is some issue with EFI mode, though few months ago i installed Ubuntu on the same hard disk and i didn't have any boot problems. I don't know why i have boot problems with Debian 10.



#2 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 15062 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 4 weeks ago

Well, the message you posted seems clear enough, for *some reasons* you booted in BIOS (or EFI/UEFI CSM) mode, you need to change to EFI/UEFI to boot that "boot-repair-cd" (BTW, besides the senselessness of UEFI bootng in general, making a "boot-repair" that can only boot in UEFI and not in BIOS seems particularly unfriendly, as it is supposed to be a tool used by less experienced users having an issue).

:duff:
Wonko

#3 Peter80

Peter80

    Frequent Member

  • Advanced user
  • 115 posts

Posted 4 weeks ago

If you mean i have to change something in the bios settings i am not sure what exactly. On this bois screen i found settings that are related to UEFI and these are default settings:

 

IMG_20191013_205446.jpg



#4 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 15062 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 4 weeks ago

You need to change something in these:
UEFI/Legacy boot -> BOTH
UEFI/Legacy Priority -> Legacy first

Most probably you can have "UEFI only" in the first one or "UEFI first" in the second (but you will need to try).

Check also what you have under the "Security" tab, there may be a setting for "Secure OS only" or "Secure boot" (or similar) that might be needed.

:duff:
Wonko

#5 Peter80

Peter80

    Frequent Member

  • Advanced user
  • 115 posts

Posted 4 weeks ago

I changed 'UEFI/Legacy boot' to 'UEFI Only' but it didn't worked, i couldn't boot neither to second hard disk, nor the live usb. And in the 'Security' tab i didn't see option for 'Secure boot'.



#6 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 15062 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 4 weeks ago

In theory when you change that, the following "UEFI/Legacy Priority " should become automatically "UEFI", maybe it didn't?

 

Post a screenshot of the "Security" tab, it is entirely possible that there is some related option called by *any other name*.

 

Which EXACT Thinkpad model is it?

 

Maybe there is something in the manual about the needed settings.

 

:duff:

Wonko



#7 Peter80

Peter80

    Frequent Member

  • Advanced user
  • 115 posts

Posted 4 weeks ago

I tried with changing UEFI/Legacy Priority to 'UEFI first' but also it didn't worked. This is a screenshot of the 'Security' tab:

IMG_20191013_230732.jpg

The laptop model is Thinkpad T420. I bought it second hand so i don't have the original manual.



#8 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 15062 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 4 weeks ago

Good.

Get the manual here:

https://download.len...t420i_ug_en.pdf

 

The settings seem fine, but it is possible that for *whatever reasons* the USB thingy is bootable in BIOS mode (and shows you the message about having been booted in "legacy" mode) but is not bootable in UEFI mode.

Try the settings:

 

UEFI/Legacy boot -> BOTH
UEFI/Legacy Priority -> UEFI first

 

This should attempt to boot UEFI first, and if it fails, boot in BIOS mode (and you will have the same text message.

 

But you will also probably need to check/change device boot order, cannot say specifically on that PC, but I have seen a few ones where choosing the boot device at boot time with F12 or similar didn't work, whilst changing the fevice boot order did.

 

:duff:

Wonko



#9 Peter80

Peter80

    Frequent Member

  • Advanced user
  • 115 posts

Posted 4 weeks ago

I tried this settings, and also changed the boot order but still getting 'Missing operating system'.   



#10 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 15062 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 4 weeks ago

I tried this settings, and also changed the boot order but still getting 'Missing operating system'.   

Hmmm.

 

The "Missing operating system" may be a message from the MBR or PBR of the device (booted in BIOS mode).

So it is likely that - for *whatever* reason - the GRUB2 was not installed properly on second hard disk (or there is a partitioning/formatting issue) but I was referring to the boot-repair from live usb.

 

If the USB stick is properly created (Rufus comes to mind) it should be able to boot in UEFI mode:

https://sourceforge....r-cd/home/Home/

 

:duff:

Wonko



#11 Peter80

Peter80

    Frequent Member

  • Advanced user
  • 115 posts

Posted 4 weeks ago

Can i try to fix grub from the command line from live USB? Like Parted Magic, for example?

I still don't get what exactly is the issue. Does Debian 10 require UEFI boot, or grub? Also, why Ubuntu, which i installed before that, didn't have boot issues?

If it matters the partitions on the hard disks are: one encrypted with veracrypt partition and one 50GB partition which i separated on three partitions - root, home and swap, and installed Debian on it.

I created the usb with WinSetupFromUSB. 



#12 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 15062 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 4 weeks ago

The issue is that - for whatever reason - the PC you are using was booted in one mode (probably BIOS) and consequently the install was made in that mode but *for some reasons* it doesn't work in that mode (there could be tens of reasons why) or that it was booted in one mode and the install was instead made for the "other" mode but either did not complete successfully or the actual PC (again for whatever reasons) does no boot correctly with the other mode.

 

WinsetupfromUSB last time I checked did not make UEFI bootable sticks (but this may have changed recently).

 

You should try forgetting whatever you did till now, download the https://sourceforge....r-cd/home/Home/and make a new stick with Rufus or Unetbootin, following the instructions.

 

Alternatively, to attempt to actually boot the installed Debian, you could try the SUPERGRUB2 disk:

https://www.supergru...per-grub2-disk/

 

:duff:

Wonko



#13 Peter80

Peter80

    Frequent Member

  • Advanced user
  • 115 posts

Posted 4 weeks ago

I used Rufus and installed boot-repair on another flash drive, then booted and run boot-repair successfully. It fixed grub and i was able to boot into Debian after that. So, the issue was not with the bois settings, but grub. And the issue, i think, might be related to Windows 10 bootloader which probably was left in the mbr, because i also had Windows 10 installed on this hard disk. I don't know why Debian install didn't overwrite it when i installed grub. In boot-repair i selected to install grub on 'sdb' which i think installs it on the mbr sector.

But i don't know why i had issue with boot-repair from the usb drive i created with WinsetupfromUSB. I used the same boot-repair iso disk for the rufus install on the other usb drive.



#14 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 15062 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 4 weeks ago

Good :), so the issue is solved.

 

Seemingly the reason is that WinsetupfromUSB makes a BIOS bootable USB stick whilst the boot-repair (see the original message) wants to be run in UEFI mode (or maybe it happens only with that specific Lenovo BIOS/UEFI, or with the specific USB stick, cannot really say).

 

Anyway it doesn't matter, since as soon as you followed to the letter the recommended procedure (Rufus) it started working fine.

 

About the reason why Debian didn't install the GRUB2 as it should have it could be something connected to having tried to install it on second disk (without changing boot/device order) or with the first disk being encrypted or simply a small glitch in the matrix.

 

Let's call it voodoo :wodoo: .

 

:duff:

Wonko






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users