Jump to content











Photo
- - - - -

imdisk unmount taking forever


  • Please log in to reply
2 replies to this topic

#1 Azev

Azev

    Newbie

  • Members
  • 10 posts
  •  
    Brazil

Posted 4 weeks ago

Hi, I'm trying to unmount .iso images that I have mounted in A: but sometimes the removal takes forever:

 

mount command:

imdisk -a -o ro -o cd -o rem -f "d:\test.iso" -m A:

dettach command: (takes forever)

imdisk -D -m A:
Notifying applications...
Flushing file buffers...
Locking volume...
Failed, forcing dismount...
Removing device...
Removing mountpoint...

Whenever I try to use the -R switch, imdisk will say the command is invalid.

 

How can I avoid this taking too long to remove?

 

Thanks.

 

 

 

 



#2 Olof Lagerkvist

Olof Lagerkvist

    Gold Member

  • Developer
  • 1415 posts
  • Location:Borås, Sweden
  •  
    Sweden

Posted 4 weeks ago

Dismounting a CD image should usually never fail. There must be something holding open file handles on the virtual CD drive for some reason. You could probably check with for example Process Explorer what processes that could be.

 

Otherwise, with the -R switch you need to also specify -u and a device number, such as 0:

imdisk -R -u 0

Device number is shown when you mount with -a and also when you list device information with for example -l -m A: and similar.



#3 Azev

Azev

    Newbie

  • Members
  • 10 posts
  •  
    Brazil

Posted 4 weeks ago

Thanks Olof.

 

The ISOs are photos CD images. The image viewer process was locking the mount point.

Superb program!


  • Olof Lagerkvist likes this




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users