Jump to content











Photo
- - - - -

Reboot.pro page links not working


  • Please log in to reply
8 replies to this topic

#1 steve6375

steve6375

    Platinum Member

  • Developer
  • 6997 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars, www.easy2boot.com
  •  
    United Kingdom

Posted 4 weeks ago

Noticed this for a while and thought it would be fixed by now. I keep finding links on this site which don't work - e.g.

http://www.boot-land...p?showforum=114

and other page links are not working

 

e.g. This page has links which dont work

http://reboot.pro/forum/31-tutorials/

 

Also same Tutorials links on main reboot.pro home page  Groups section don't work.

 

not sure if there are others?



#2 erwan.l

erwan.l

    Platinum Member

  • Developer
  • 2735 posts
  • Location:Nantes - France
  •  
    France

Posted 4 weeks ago

The first links points to the old bootland : not sure what we can do here.

Wonko masters the logic pretty well to convert old links to new links (i even recall a web site to handle this).

Worse case : i can run a sql query to update old links to new links.

 

About the tutorials sections, can you provide an example?



#3 steve6375

steve6375

    Platinum Member

  • Developer
  • 6997 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars, www.easy2boot.com
  •  
    United Kingdom

Posted 4 weeks ago

None of the links in the main page - Groups - Tutorials work

 

1. Load main page

2. Scroll down until you see Groups - Tutorials - now click on any of the linked words - e.g. Forensics or WinBuilder or grub4dos or 'Boot from anywhere' or Security or Windows Support.



#4 erwan.l

erwan.l

    Platinum Member

  • Developer
  • 2735 posts
  • Location:Nantes - France
  •  
    France

Posted 4 weeks ago

Got it : I see what you mean.

All links end up on boot land.

 

I wonder since when this is like this?

If Wonko passes by and refresh my red fish memory, I might be able to fix these links by updating the database.



#5 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 14830 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 4 weeks ago

In this case it is "something else" :w00t:

If you get the actual link in that section (let's say for the sake of the example) "Forensics", you obtain a "right" link:
http://reboot.pro/forum/111-forensics/

the issue is that link *somehow* resolves to
http://www.boot-land...p?showforum=107

The "right" syntax to get to forum #107 (on reboot.pro) is:
http://reboot.pro/in...p?showforum=107
Which resolves to:
http://reboot.pro/forum/107-forensics/

I.e. there must have been in one of the stupid board changes or in one of the stupid board software updates a mis-numeration or a mis-linking of some kind.

The links in forum #31 (Tutorials) are:
#111 (Forensics) resolves to bootland #107
#113 (Winbuilder) resolves to bootland #112
#115 (Grub4Dos) resolves to bootland #114
#117 (Boot from Anywhere) resolves to bootland #116
#120 (Security) resolves to bootland #119
#121 (Windows Support) resolves to bootland #118

To make thing worse (if poossible) in this mess, there is a tab on the main forum "Tutorials" that brings you here:
http://reboot.pro/links/
where you can find a number of differently categorized tutorials, which are actually links to topics "here and there, all over the board".

I would say that the issue dates back to the end of 2012 :ph34r:

Anyway, those forums can be accessed with the "right" syntax:
Right -> New, stupid:

http://reboot.pro/in...p?showforum=107 ->http://reboot.pro/forum/107-forensics/
(but it should actually go to #108)
http://reboot.pro/in...p?showforum=108-> http://reboot.pro/forum/108-tutorials/

http://reboot.pro/in...p?showforum=112 -> http://reboot.pro/forum/112-tutorials/
http://reboot.pro/in...p?showforum=114-> http://reboot.pro/forum/114-tutorials/
http://reboot.pro/in...p?showforum=116-> http://reboot.pro/forum/116-tutorials/
http://reboot.pro/in...p?showforum=119-> http://reboot.pro/forum/119-tutorials/
http://reboot.pro/in...p?showforum=118-> http://reboot.pro/forum/118-tutorials/

:duff:
Wonko

#6 erwan.l

erwan.l

    Platinum Member

  • Developer
  • 2735 posts
  • Location:Nantes - France
  •  
    France

Posted 4 weeks ago

Are you sure about http://reboot.pro/forum/111-forensics/ being the proper tutorials\forensics link?

 

Is not this security\forunsics link?

 

Or are actually links below turorials "shortcuts" to actual link under other forums?

 

Edit : reading myself a second time, it is probably the latter (i.e tutorials forum is "only" a forum with shorcuts to categories under other forums on this site).



#7 erwan.l

erwan.l

    Platinum Member

  • Developer
  • 2735 posts
  • Location:Nantes - France
  •  
    France

Posted 4 weeks ago

Edit : I have, I believe "fixed" the windows support category under tutorials.

Give it a try and let me know if this is the expected behavior.

If yes, I will fix other categories under tutorials.

 

Always a bit touchy as I dont want to delete by mistake a whole category (aka sub forum) :)

 

Which makes me think i would be advised to do a backup before...



#8 erwan.l

erwan.l

    Platinum Member

  • Developer
  • 2735 posts
  • Location:Nantes - France
  •  
    France

Posted 4 weeks ago

Well, actually, was an easy one to fix thanks to Wonko explanations and details.

 

Should be all fixed now...

 

If you guys spot a missing shortcut under tutorials or a typo in an existing shortcut, let me know : I know how to do it now :)



#9 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 14830 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 4 weeks ago

All's well that ends well. :thumbsup: 

:duff:
Wonko






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users