Jump to content











Photo
- - - - -

Windows 10 setup won't boot in UEFI GPT mode by Rufus


  • Please log in to reply
1 reply to this topic

#1 SoloKing

SoloKing
  • Members
  • 1 posts
  •  
    Germany

Posted 5 days ago

I used Rufus to make a bootable USB using an ISO of Windows 10 Pro while setting the "Partition Scheme" to GPT & "File System" to FAT32, BIOS set to boot in "UEFI only" mode & "Secure Boot" feature was disabled.

Now, the Boot Screen detects the USB drive as UEFI device but the problem is that it never starts the installation process after being selected! It just goes back to the Boot Screen.

I tried enabling CSM & legacy boot mode, as well as changing the USB port used, but to no avail.

My Mobo is Gigabyte x370 K7.

Your help is highly appreciated.

Thanks so much guys!

 


#2 steve6375

steve6375

    Platinum Member

  • Developer
  • 6901 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars, www.easy2boot.com
  •  
    United Kingdom

Posted 4 days ago

When the USB drive is listed in the BIOS Boot Selection menu, is it listed by Make and Model (how exactly is it listed)?

When you select it, does the USB LED activity light flash at all as it tries to boot from it?

Did you disable Fast Boot in the BIOS settings?

Is there a \EFI\BOOT\BOOTX64.EFI file on the USB drive?

Can you boot from the same USB drive on another system?

Is your USB drive tested and known to be good (or recently purchased and possibly fake or faulty)?


Edited by steve6375, 4 days ago.

  • SoloKing likes this




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users