Jump to content











Photo
- - - - -

Qemu and FreeDOS install - reboot fail - partition signature ! 55AA


  • Please log in to reply
1 reply to this topic

#1 rjolbrich

rjolbrich
  • Members
  • 1 posts
  •  
    United States

Posted 25 January 2019 - 11:54 PM

Hello,

 

  I'm having trouble installing FreeDOS 1.2 with QEMU under Linux Mint 19.

My first attempt used the following:

 

qemu-img create dos.img 200M
qemu-system-i386 -m 16 -k en-us -rtc base=localtime -soundhw sb16,adlib -device cirrus-vga -hda dos.img -cdrom FD12CD.iso boot order=d

 

After a successful partition creation I accidentally ended the process.

The second command now always yields:

 

qemu-system-i386: -hda dos.img: drive with bus=0, unit=0 (index=0) exists

 

 

 

I try the following command:

 

qemu-system-i386 -drive format=raw,file=dos.img -cdrom FD12CD.iso

 

which gets me back into the installation once. I again create the partition, reboot

and get the following:

 

Booting from disk , Partition Signature ! 55AA and the install hangs.

 

At that point if I retry:

 

qemu-system-i386 -drive format=raw,file=dos.img -cdrom FD12CD.iso

 

I still receive Partition Signature ! 55AA

 

 

 

Fdisk dos.img yields

 

Disk dos.img: 200 MiB, 209715200 bytes, 409600 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x00000000

Device     Boot Start    End Sectors   Size Id Type
dos.img1   *       63 409247  409185 199.8M  6 FAT16

 

 

How do I get to format the drive if I can't get back into the installer?

I'm new to QEMU, so it may be something simple!

 

Thanks
 



#2 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 14712 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 26 January 2019 - 08:31 AM

Start again from scratch.

 

Delete the dos.img

Re-run the two commands, after having checked them, first one seems OK to me, the second not so much.

 

qemu-img create dos.img 200M
qemu-system-i386 -m 16 -k en-us -rtc base=localtime -soundhw sb16,adlib -device cirrus-vga -hda dos.img -cdrom FD12CD.iso boot order=d

The first one creates the image, the second one should boot the VM with the dos.img as hard disk and the FD12CD.iso as Cdrom and boot from the latter, but it doesn't look like a valid command, it should be (but it may depend on the version of Qemu :dubbio:)

https://wiki.gentoo....ions#Boot_order

.-boot d

 

instead.

 

 

The Partition Signature !55AA error should mean that  the PBR of the volume you created doesn't have the "Magic Bytes" 55AA at the end (which is normal, since you created the partition but did not format the volume).

 

What happens should be that:

1) you boot NOT from the CDROM, but rather from the hard disk (which is 00ed and thus fails graciously passing control to the CD-ROM)

2) you partition the disk (but create not the volume/fiesystem, i.e. "format", since you need a reboot)

3) you reboot in order to have the system load the MBR data you just wrote, but now this is a valid MBR with booting code, so the system attempts to boot from it, the code in the MBR tries to chainload the PBR of the volume (that is not there yet) and throws the error.

 

:duff:

Wonko






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users