Jump to content











Photo
- - - - -

PEBakery Beta 5 (v0.9.5.1)


  • Please log in to reply
4 replies to this topic

#1 TheHive

TheHive

    Platinum Member

  • .script developer
  • 4159 posts

Posted 09 September 2018 - 02:48 AM

You should set appropriate compatibility options to build legacy projects successfully.
Presets are provided for known projects.

 

Ok! That should be fine for most users. Most will be using known projects such as: .the ones included in PeBakery or what known projects.

 

 

To build Win10PESE or Win10XPE, rename PEBakery_Win10PESE_Win10XPE.ini to PEBakery.ini.
To build ChrisPE or MistyPE, rename PEBakery_ChrisPE_MistyPE.ini to PEBakery.ini.
If a build fails even after applying presets, try deleting project temp directories.

 

 

Can't PeBakery attempt to do this for the user. How is the user suppose to know what needs to be done, unless they read the release notes.

 

 

 

 

 

 

 

 



#2 homes32

homes32

    Gold Member

  • .script developer
  • 1029 posts
  • Location:Minnesota
  •  
    United States

Posted 10 September 2018 - 02:24 PM

Can't PeBakery attempt to do this for the user. How is the user suppose to know what needs to be done, unless they read the release notes.

 

Its not so much can't as should it? If PEBakery starts doing this automatically then we open a floodgate of issues.

 

Some of the big ones are:

 

  • Suppose someone forks a project and removes the need for compatibility options, but PEBakery decides based on its detection that is still the "original" and keeps flipping compatibility options on, causing issues with the project.
  • Suppose the project author changes something that renders the detection ineffective? Now we need to update, test, and recompile PEBakery, AND make sure users download and use the new version.
  • Currently compatibility settings are stored globally in PEBakery.ini, so if you have multiple projects in a single instance they could have different compatibility needs. this would be alot of flip/flopping.

The plan is for the PEBakery 1.0 release to store compatibility options in the project itself (script.project) instead of PEBakery.ini. This will allow the project author to define what is needed and make the necessary updates if/when they are needed, independently from PEBakery development.


  • ied206 likes this

#3 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 14389 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 10 September 2018 - 04:02 PM

@TheHive
Here kid :), let me help you cross the road, here is a batch for creating the configuration file:
@ECHO OFF
ECHO What do you want to build?
ECHO 1) Win10PESE or Win10XPE
ECHO 2) ChrisPE or MistyPE
ECHO 3) Something else
SET /P mychoice=Please type 1, 2 or 3 and press ENTER:
FOR %%A IN (PEBakery_Win10PESE_Win10XPE.ini PEBakery_ChrisPE_MistyPE.ini) DO (
IF NOT EXIST %%A ECHO File %%A is missing&GOTO :OhOh
)
IF %mychoice%.==1. COPY PEBakery_Win10PESE_Win10XPE.ini PEBakery.ini&GOTO :OkOk
IF %mychoice%.==2. COPY PEBakery_ChrisPE_MistyPE.ini PEBakery.ini&GOTO :OkOk
IF %mychoice%.==3. GOTO :OhOh

:OhOh
ECHO you are on your own
PAUSE
GOTO :EOF

:OkOk
ECHO Hopefully the program has succeeded in copying and renaming a single file.
PAUSE
ECHO Was it so difficult?
PAUSE

:duff:
Wonko
  • alacran likes this

#4 paraglider

paraglider

    Gold Member

  • .script developer
  • 1728 posts
  • Location:NC,USA
  •  
    United States

Posted 11 September 2018 - 12:28 PM

PEBakery is an excellent builder and is close to being a replacement to WB 0.82. However to my mind it has gone down the wrong path. Before the scripting language was extended it should have ensured compatibility with the projects the currently build with wb 0.82. You should not have to set compatibility options via the UI or ini files or the projects to make it compatible with wb 0.82. Once compatibility was achieved then that would be the time to add language extensions that are incompatible with wb 0.82. Such extensions should be explicitly enabled via configuration i.e not enabled by default.



#5 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 14389 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 11 September 2018 - 01:26 PM

PEBakery is an excellent builder and is close to being a replacement to WB 0.82. However to my mind it has gone down the wrong path. Before the scripting language was extended it should have ensured compatibility with the projects the currently build with wb 0.82.

Sure :), and someone saw it coming in advance  :innocent:  (and of course he couldn't keep his big mouth shut, and even more obviously the suggestions were ignored), only for the record :

 

https://msfn.org/boa...comment=1148734

 

:duff:

Wonko






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users