Jump to content











Photo
- - - - -

Apply Customized Image after PXE boot


  • Please log in to reply
3 replies to this topic

#1 hr550077

hr550077
  • Members
  • 1 posts
  •  
    Canada

Posted 10 July 2018 - 02:30 PM

I am trying to implement pxe on my virtual machines (virtualbox), if worked fine later planning to implement in our production environment. I  have PXELinux (ubuntu server) and copied the contents of DVD (wimboot, bdi,bcd,boot.wim etc)

I am able to load Winpe using wimboot which ends up in command line (wpeinit). It works fine when I do net use command and give setup.exe from the OS DVD contents. But I want to load a customized ISO images (having scripts etc) which does not have a setup.exe. Using daemon tool I was able to find that it was having a customized wim file inside but am not able to deploy that wim file. I also tried to deploy the wim files using the DISM apply image command , but it always result in error 1: Incorrect function.

Can someone please help me figure out why I am not able to deploy the wim file using DISM or guide me into the path if we have any other method to deploy customized windows 10 image ?



#2 cdob

cdob

    Gold Member

  • Expert
  • 1392 posts

Posted 10 July 2018 - 09:15 PM

Can you dism apply the customized wim file at local boot, without pxe?

Can you dism apply a default Win 10 install.wim at pxe boot?

Does imagex apply the customized wim file?

Does wimlib apply the customized wim file? http://reboot.pro/to...implementation/

#3 Ankur.k1991

Ankur.k1991

    Member

  • Members
  • 55 posts
  •  
    India

Posted 26 July 2018 - 10:25 AM

You can find all PXE related solution in video tutorial

@

 

 

https://youtube.com/ankurdahar



#4 Slimaure

Slimaure
  • Members
  • 1 posts
  •  
    Peru

Posted 15 August 2018 - 03:59 PM

you may need to display winpe.wim,
and if it does not work you should create a new BCD store

In the pxe, you must specify load wimboot, bcd, bcd.sdi and the wim (winpe.wim)

https://www.itprotod...scratch-bcdedit

Sorry for my bad English




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users