Jump to content











Photo
- - - - -

Modifying Startnet.cmd after the ISO is built


  • Please log in to reply
6 replies to this topic

#1 Tr33x0rs

Tr33x0rs
  • Members
  • 3 posts
  •  
    United States

Posted 24 March 2018 - 08:21 AM

I have started working with WinPE as well as Dell Command | Configure to automate the process of changing BIOS settings. I setup Simulators which often require me to set BIOS settings on dozens or even hundreds of computers. I have gotten WinPE and Command | Configure to work and the process is automated but I wanted to know if there is any way to modify the startnet.cmd file after the ISO is built. 

 

I basically ran the following commands to setup a WinPE boot:

-copype amd64 C:\WinPE

-Dism /Mount-Image /ImageFile:"C:\WinPE\media\sources\boot.wim" /index:1 /MountDir:"C:\WinPE\mount"

-Here is where I would modify my Startnet.cmd file as I wanted it

-Dism /Unmount-Image /MountDir:"C:\WinPE\mount" /commit

-MakeWinPEMedia /ISO C:\WinPE c:\WinPE\WinPE.iso

 

I now have my WinPE.iso file. If I decided I wanted to go back and modify my Startnet.cmd file to add other things to it, is this possible to open the ISO and modify it there? I was unable to locate Startnet.cmd in my .iso. Is the only way to fix this file to go through and run through all the commands again? Thank you in advance for the help. 



#2 steve6375

steve6375

    Platinum Member

  • Developer
  • 6725 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars
  •  
    United Kingdom

Posted 24 March 2018 - 08:38 AM

Is your objective to simply run a cmd script from WinPE?

Why use an ISO? Do you intend to boot from a CD or DVD or will you always boot from a USB drive?

Will the USB drive be a Removable USB Flash drive or a USB HDD drive?

Could the WinPE be a ready-made WinPE (32 and 64 bit)?

Do you need UEFI-booting as well as MBR booting?

 

I ask because there may be easier and more flexible ways to achieve what you want.



#3 steve6375

steve6375

    Platinum Member

  • Developer
  • 6725 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars
  •  
    United Kingdom

Posted 24 March 2018 - 08:52 AM

The official way is

http://www.dell.com/...1456&lang=en-us

or

http://www.dell.com/...8f42&lang=en-us

etc.



#4 Tr33x0rs

Tr33x0rs
  • Members
  • 3 posts
  •  
    United States

Posted 24 March 2018 - 08:57 AM

Is your objective to simply run a cmd script from WinPE? No, I essentially want to update the BIOS using Dell's Flash64W, as well as set BIOS settings using Dell's Command | Configure, so just run 2 exe files.
 

Why use an ISO? Do you intend to boot from a CD or DVD or will you always boot from a USB drive? It will always be booted from a USB hard drive. There are about 6 technicians that will need to Update/Configure BIOS' as well as image some computers using Clonezilla. Currently we use an Easy2Boot USB drive to store all the ISO's on so that we can do all these things from 1 USB. 

 

Will the USB drive be a Removable USB Flash drive or a USB HDD drive? USB Flash Drive

 

Could the WinPE be a ready-made WinPE (32 and 64 bit)? I don't see why not. 

 

Do you need UEFI-booting as well as MBR booting? I'm not certain on this. 



#5 Tr33x0rs

Tr33x0rs
  • Members
  • 3 posts
  •  
    United States

Posted 24 March 2018 - 08:59 AM

Those are basically the directions I followed. What I'm asking is that once the ISO is made, where does the startnet.cmd file live? If I decided I wanted to add something to it can I manually open the ISO and modify that file, or do I need to follow all those steps again?



#6 steve6375

steve6375

    Platinum Member

  • Developer
  • 6725 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars
  •  
    United Kingdom

Posted 24 March 2018 - 09:09 AM

Well it depends on what cctk_x86_64_winpe_10.bat does. I don't know what this does as I don't have it.

 

 

The first thing to check is that there is only one  image in the boot.wim file (use 7zip?)

If not, check image #2 (one should be marked as the 'boot' image).

 

I would boot to the WinPE and look in X:\Windows\System32 for any files with recent dates.

Also check for XML files anywhere within the ISO file.

Check for .log files too - e.g. \Windows\system32\xxx.log (under WinPE).

 

There may be a winpeshl.ini or a startnet.cmd or XML which will kick things off.

 

https://slightlyover...ence-explained/

 

P.S. Can you clarify what E2B device you will be using - you say USB hard drive and then you say USB Flash drive? Which is it? It may be important when finding a solution for you.


Edited by steve6375, 24 March 2018 - 09:14 AM.


#7 steve6375

steve6375

    Platinum Member

  • Developer
  • 6725 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars
  •  
    United Kingdom

Posted 24 March 2018 - 09:37 AM

Sorry, another Q!

 

Is you intention to run a BIOS update and Command | Configure in the same boot session?

 

If so this may not work because the Command | Configure would be setting BIOS configuration settings for BIOS version 1, but you have just modified the EEROM so that it contains BIOS version 2. So when it reboots, it will run BIOS version 2 but have BIOS version 1 configuration settings.

 

This may work in cases where the configuration structure has not changed, but you may find some very weird things are going on if the structure has subtly changed between versions.

 

I don't know if this will happen, but it would not surprise me at all if it did!

 

It would be much safer to first update the BIOS, then reboot, then update the settings.

Or change the settings first and then update the BIOS (but not sure if the settings would be persistent).


Edited by steve6375, 24 March 2018 - 09:51 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users