Jump to content











Photo
- - - - -

BIOS Black Screen when Changing Boot Device


  • Please log in to reply
7 replies to this topic

#1 Alexander Ceed

Alexander Ceed

    Frequent Member

  • Advanced user
  • 211 posts

Posted 2 weeks ago

Hello,

 

 

I'm dealing with a weird issue and I really need some help. I have two SSD drives connected to an ASUS MAXIMUS RANGER VII motherboard. In one SSD I'm using Windows 8.1 Pro x64, on the other SSD I have openSuse x64.

I don't have dual-boot enabled so when I want to swicth between them I just use the boot menu and select which drive to boot.

The problem is that whenever I try to boot Linux (after using Windows) I get a black screen. No BIOS POST, no boot selection, nothing. DEL key or F8 key does nothing.

I get POST only when I disconnect both SSDs and do a reboot. Only then I can boot to Linux. I only get the back screen when trying to switch from one device to the other.

 

What I've tried so far:

  • switched monitor from dedicated graphics card output to onboard card output
  • disconnected all usb devices from motherboard
  • enabled/disabled onboard graphics card
  • switch SSDs to different SATA ports

 

The BIOS has enabled CSM with Secure Boot. And I'm using the latest BIOS version.

 

 

Thank you!



#2 steve6375

steve6375

    Platinum Member

  • Developer
  • 6637 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars
  •  
    United Kingdom

Posted 2 weeks ago

Did you try 

1. Switch off

2. Wait 10 seconds

3. Switch on

 

 

Did you try - Power off - Power on - Windows boot OK - warm reboot - select linux - ???

 

Same but with power off/on cycle instead of warm reboot.



#3 alacran

alacran

    Silver Member

  • Advanced user
  • 506 posts
  •  
    Mexico

Posted 2 weeks ago

 

The problem is that whenever I try to boot Linux (after using Windows) I get a black screen. No BIOS POST, no boot selection, nothing. DEL key or F8 key does nothing.

 

What about disabling the fast boot in Win 8.1?
If this is enabled, it is certainly the cause of your problem.

 

alacran



#4 Alexander Ceed

Alexander Ceed

    Frequent Member

  • Advanced user
  • 211 posts

Posted A week ago

I forgot to mention that this does not happen all the time. Only sometimes, and I need to find out a pattern. So far, it hasn't occurred.

Thank you for your suggestions. I will test them as soon as I encounter the error again.



#5 Alexander Ceed

Alexander Ceed

    Frequent Member

  • Advanced user
  • 211 posts

Posted 5 days ago

@steve6375

I've tried the following:

  • unplug computer from output, wait 10 seconds, pluggged it back on
  • shutdown via psu power button, wait 1 minute, plugged it back on
  • did all sorts of warm/cold boot

 

@alacran

Windows fastboot is dsiabled.

 

 

Here's what I've discovered so far:

  • everything works fine if I use only the windows drive plugged, while having the linux drive unplugged
  • once I get to the black screen, nothing will work unless I unplug both drives (windows, and linux)
  • on my motherboard I cannot disable secure boot. I only have the option of clearing the 4 keys for secure boot. I'm not sure if by clearing these my problem will be fixed
  • Windows was installed and Linux were installed in CSM mode.
  • On my BIOS boot menu I have both options for legacy and uefi boot, while linux also has secure boot (ie opensuse, opensuse-secureboot, and UEFI opensuse)


#6 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 13787 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 5 days ago

I am clearly missing something.

If you have the Operating systems in CSM (please read as BIOS) then you have not "secure boot" enabled (which is UEFI only).

 

Or you installed them in CSM mode (how) and then switched to UEFI boot? :dubbio:

 

In any case GRUB2 can be setup in "secure boot", so what happens if you always use the Opensuse GRUB2 as "primary" bootmanager and boot Windows from it?

 

:duff:

Wonko



#7 Alexander Ceed

Alexander Ceed

    Frequent Member

  • Advanced user
  • 211 posts

Posted 5 days ago

It's an idiotic feature of my motherboard. The manufacturer states that if you set OS Type to Other OS and enable CSM, then Secure Boot is disabled (even though it says enabled).

nOHVlXJ.jpg

 

As you can see in the picture, there is no way to fully disable Secure Boot. And it has no other options except clear its keys.



#8 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 13787 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 5 days ago

I cannot see the image, in any case you seem like having some misconceptions :w00t: :ph34r: about Secure Boot.

 

Secure Boot CANNOT be enabled in CSM mode, it is a feature of UEFI (and of UEFI ONLY), no matter what the firmware reports, no matter what the manufacturer says.

It is likely that the setting is left "set" to allow easily shift from CSM (non-Secure Boot) to UEFI (with Secure Boot). :unsure:

 

Let's put it differently.

 

Can you boot to grub4dos?

 

If yes, you are in CSM and have NOT secure boot.

 

:duff:

Wonko






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users