Jump to content











Photo
- - - - -

"Error loading ImDisk Virtual Disk Driver: Access is denied." - solved


  • Please log in to reply
No replies to this topic

#1 Wenzel

Wenzel
  • Members
  • 1 posts

Posted 17 September 2017 - 05:15 AM

Hello.

Tried to create virtual disk at startup by adding the job in the task scheduler. Manual starting the job works fine, but not at startup - no new disk appeared after rebooting. Digging a bit deeper revealed the problem - there was an error message issued by imdisk exe when it was started at system startup by task scheduler.

Changing startup type for "ImDisk Virtual Disk Driver" from "Automatic" to "System" solved that problem. It works fine now.

 

Hope this will help to somebody.


  • Olof Lagerkvist likes this

#2 Wenzel

Wenzel
  • Members
  • 1 posts

Posted 17 September 2017 - 06:25 AM

UPD: system is Windows Server 2003, ImDisk version 2.0.9



#3 Olof Lagerkvist

Olof Lagerkvist

    Gold Member

  • Developer
  • 1346 posts
  • Location:Borås, Sweden
  •  
    Sweden

Posted 17 September 2017 - 05:15 PM

This unfortunately happens sometimes because there will be a conflict when the driver is both auto-started by Service Control Manager and by the imdisk.exe tool (which will find out that the driver is not loaded yet). You can solve it by either setting the driver to "system start" or "manual start". "Manual start" makes sure that imdisk.exe can load the driver automatically without interfering with any SCM auto-start of the driver, while "system start" makes sure that the driver is already loaded before either of imdisk.exe or SCM auto-start mechanisms run.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users