Jump to content











Photo
- - - - -

PXE Boot stops after "succeeded to download nbp file"

windows 7 pxe nbp iscsi diskless stops stop

Best Answer Slzy , 02 May 2017 - 07:15 AM

Wow, I solved it.

 

I wasn't actually loading a PXE file.. my bootfile had to be "grldr" not ipxe.iso.. I should read more carefully next time.

Go to the full post


  • Please log in to reply
2 replies to this topic

#1 Slzy

Slzy
  • Members
  • 3 posts
  •  
    Germany

Posted 28 April 2017 - 12:48 PM

Hello,

 

I am currently trying to boot a Windows7.img file from my iSCSI Volume via PXE.

 

I've gotten my DHCP Options to work and the TFTP Server also seems to work fine (as far as I can tell from the logs - file transfer passes trough without any errors) but for whatever reason while PXE booting the machine downloads the file and then just stops. Nothing else happens.

 

I have mostly been following this tutorial - not 1:1 as I have no need for a virtual SAN, I have my iscsi volume hosted on a NAS and my Windows Server 2012 R2 acts as the TFTP Server right now - (http://web.archive.o....wordpress.com/ - found by pure chance on stackoverflow) and cross-checked a few things with some posts from Misty on this Forum.

 

My bootfile is called "ipxe.iso" and the files are configured like this:

 

ISOLINUX.CFG

# These default options can be changed in the geniso script
SAY iPXE ISO boot image
TIMEOUT 30
DEFAULT ipxe.lkrn
LABEL ipxe.lkrn
 KERNEL ipxe.krn
 INITRD conf.ipxe
 

conf.ipxe

#!ipxe
dhcp net0
sanboot iscsi:<ip of my tftp server>::::<iscsi LUN>.domain:myCompany.de
set keep-san 1

I thought that it may have to do with the IP I've written in conf.ipxe so I have changed it to the IP of my NAS and any other server that could possibly be relevant but to no avail.

 

I try to boot the machines in UEFI Mode since when I'm trying to boot them in Legacy it just stops after DHCP, the client doesn't even try to contact the TFTP Server.

 

if more information is needed I can give you a full description of any server / file I've tinkered with.

Any help is greatly appreciated! 



#2 Slzy

Slzy
  • Members
  • 3 posts
  •  
    Germany

Posted 28 April 2017 - 02:26 PM

I can't find the option to edit my post so this will be the Update post:

I found out that this error happens when I don't make use of the DHCP Option 66 (Boot-file-name), instead I used the filename option.

 

When using DHCP Option 66 however I get a very weird problem.

When the client tries to download the ipxe.iso file he looks for the WRONG file.

 

This is how the PXE Process looks:

>>>Start PXE over IPv4.
   Station IP address is: 192.168.1.137

   Server IP address is 192.168.1.222
   NBP filename is \ipxe.isoÿ
   NBP filesize is 0 Bytes
   PXE-E23: Client received TFTP error from Server

As you can see, for some reason a "ÿ" gets added at the end of the filename. I have no clue where this character comes from.

 

I have renamed my ipxe.iso to ipxe.isoÿ and now the same error as before happens.

 

When renaming the file this is how the PXE process looks:

>>>Start PXE over IPv4.
   Station IP address is: 192.168.1.137

   Server IP address is 192.168.1.222
   NBP filename is \ipxe.isoÿ
   NBP filesize is 1048576 Bytes
  Downloading NBP file...

   Succeed to download NBP file.

After that the Machine goes straight back to the boot menu.



#3 Slzy

Slzy
  • Members
  • 3 posts
  •  
    Germany

Posted 02 May 2017 - 07:15 AM   Best Answer

Wow, I solved it.

 

I wasn't actually loading a PXE file.. my bootfile had to be "grldr" not ipxe.iso.. I should read more carefully next time.







Also tagged with one or more of these keywords: windows 7, pxe, nbp, iscsi, diskless, stops, stop

4 user(s) are reading this topic

0 members, 4 guests, 0 anonymous users