Jump to content











Photo
- - - - -

FreeDOS or other DOS on a Wyse Sx0 thin client?


  • Please log in to reply
3 replies to this topic

#1 Galane

Galane
  • Members
  • 2 posts
  •  
    United States

Posted 11 February 2017 - 09:07 AM

I have an old benchtop CNC milling machine for which the only control software ever made runs in DOS. First manufactured in the late 80's or early 90's, the machine was produced (or inventory sold off) into the early 2000's while the software remained frozen in time.

 

Since it only requires a single RS232C connection and could be run from a PC as ancient as a Model 5150 PC from 1981, a Wyse Sx0 (S10, S30, S50, S90) thin client with a 64 meg IDE flash drive, 128 meg RAM and 366 Mhz AMD Geode GX500 CPU should easily do the job.

 

I need as much free RAM as possible in order to load large GCODE files. The software uses EMS with this environment variable in autoexec.bat.

 

SET LMCEMS=number of 16K blocks with All A or -1 to use all available memory.

 

If a GCODE file is too large to fit completely into available RAM, there's a program with the software to split it into chunks of user specified size. It inserts a command at the end of each chunk to load the next chunk by filename.

 

The control software user interface uses ANSI graphics (or the IBM line drawing characters) and supports a mouse, so I'll need USB support for that and for USB flash drives (and/or a USB floppy drive) for loading GCODE files. I've downloaded the Panasonic USB mass storage DOS driver.

 

I'd like to set up a RAM disk and have it copy the CNC software (614,229 bytes in 30 files) to it as part of the boot process. I have 128 meg and 512 meg SODIMMs that work in these thin clients.

 

Hardware info below.

 

The client has 4 USB 2.0 ports, a VGA out, Realtek RTL8100 10/100 ethernet, Realtek ALC655 AC97 audio with stereo out and mic in. Aside from those and the CPU, the other major component is the Geode Companion CS5536 which handles the video, north and south bridge tasks.

 

The BIOS setup is extremely limited. The only settings available are changing the password (default is Fireport), setting date and time (there's no CMOS battery, original OSes typically use a network time server) and changing the boot order, which has three options, IDE, USE, PXE.

 

S10 is WTOS or ThinOS. By default does not have a flash drive installed due to OS sharing the BIOS chip.

S30 is Windows CE 5.0 or 6.0. Minimum 64 meg flash. Final release available resizes larger partition to 64 meg, despite the download claiming to be for 128 meg.

S50 is Wyse Linux. 64 meg and 128 meg installs available.

S90 is Windows XP Embedded. Requires minimum 512 meg flash and at least 256 meg RAM, S90 upgrade kit came with 512 meg flash and 512 meg RAM.

There is a way to put Linux, CE or XPe on, no matter what the original OS. (Hint, simple edit of XML file.)

 

The original hardware version (02) had soldered RAM and an odd flash module for the S50. I think S30 and S90 may only have come in the revised model with a 44pin IDE header and DDR1 SODIMM socket. There's two slightly different but functionally identical versions of the 02L revision. Easy to ID by the black (early) or silver (late) heat sink visible through the top grille.

 

Having the Ethernet and Audio working are not important for using this to control the CNC mill, but I'd like to try because I have three of these little computers and one would probably run DOOM and possibly even Duke Nukem 3D and other BUILD engine games.

 

Ethernet in DOS should be no problem due to Realtek having a DOS driver for the 81xx series.

 

Sound in DOS will depend on whether or not both VIA and Realtek used the same "rulebook" when making their AC97 codec chips. The only DOS AC97 driver I've found is from VIA, and it is known to work with some non-VIA AC97 chips - but I've not found any yea or nay on the ALC655.


Edited by Galane, 11 February 2017 - 09:09 AM.


#2 steve6375

steve6375

    Platinum Member

  • Developer
  • 6739 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars
  •  
    United Kingdom

Posted 11 February 2017 - 10:22 AM

Is there a question or problem?

Do you have all these versions of Wyse thin clients?

Have you tried booting to a FreeDOS USB drive?



#3 Galane

Galane
  • Members
  • 2 posts
  •  
    United States

Posted 3 weeks ago

I tried MS-DOS 6.22. Boots from floppy and installs but won't boot from the IDE DOM (Disk On Module). Just sits there with a blinking cursor on a blank screen.

 

PC-DOS 2000. Same result as MS-DOS 6.22.

 

FreeDOS. Looks like it's seeing the IDE controller and DOM during boot from install floppy or USB, but the installer itself refuses to acknowledge there is a fixed disk so it can't be installed.

 

MS-DOS 7.1 CDU. This one boots off the install floppy, installs, and boots from the DOM.

 

No idea what MS-DOS 6.22 and PC-DOS 2000 do wrong with the drive formatting. The partition is marked Active, everything checks out with FDISK. It *should work* but does not.



#4 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 14289 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 3 weeks ago

Usually these thin clients and DOM's particularly if matched with an older OS have some hard disk geometry issues, which are confirmed by the blinking cursor on the blank screen which is typical of a mismatched geometry.

 

Basically:

1) CHS is used to boot (and not LBA)
2) for *some* reasons parts of the OS believe there is a given geometry (let's say 64/32) whilst other parts believe it is another one.

 

So basically the MBR code chainloads an empty sector (instead of the PBR) or the PBR cannot find "itself".

 

I would try checking the actual working partitoning (and also the failing one, this latter from a floppy) with Ranish Partition Manager to see what is actually written to the MBR partition table first thing.

Then it needs to be checked the geometry and "sectors before" written to the PBR.

 

:duff:

Wonko
 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users