Jump to content











Photo
- - - - -

Reboot (Spyware, Windows Xp, Windows Vista/7)


  • Please log in to reply
7 replies to this topic

#1 Frankie_G

Frankie_G
  • Members
  • 4 posts
  •  
    Italy

Posted 30 November 2016 - 05:44 PM

Ciao a tutti,
Vi scrivo perché ho bisogno d'aiuto per la risoluzione del seguente problema, relativamente al quale ho già trovato diversi post sul forum che tuttavia non mi sono stati d'aiuto. All'avvio, il pc rimane per diverso tempo sulla schermata iniziale (della scheda madre), per poi indirizzarmi su di una schermata (GRUB4DOS 0.4.5b) in cui mi compaiono tre opzioni (Spyhunter 4, Windows Xp, e Windows Vista/7) nessuna delle quali tuttavia, una volta avviata, risulta funzionante (find --set-root /sh4eldr/vmlinuz ; Error 15: File not found).
Ho letto online che questo problema emerge dopo avere installato e svolto una scansione con Spyhunter, cosa che però nel mio caso mi risulta piuttosto strana: Spyhunter l'ho installato diverse settimane fa a causa di un virus, per poi disinstallarlo quasi immediatamente - e se anche la disinstallazione "tradizionale" non avesse funzionato, credo che i file relativi al programma dovrebbero essere stati eliminati attraverso il ripristino di sistema, al quale ho optato a causa del malware stesso.
Un altro dettaglio: tempo fa ho compiuto l'aggiornamento da windows vista a windows 10, ma sulla lista di avvio non compare! Perché?
Mi sono chiesto se fosse un problema relativo all'hard disk, così ho controllato sul software della scheda madre (ASUS EZ Flash2) al quale posso accedere all'avvio, nel caso non riuscisse a rilevarlo, ma mi pare funzioni correttamente.
Dopodiché, ho controllato anche nel bios, e qui invece ho notato che l'hard disk su cui il sistema operativo è installato non viene rilevato (non compare in "boot device priority").

... Cosa posso fare?

Grazie in anticipo per le risposte,

Frankie_G


Edited by Frankie_G, 30 November 2016 - 05:48 PM.


#2 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 13440 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 30 November 2016 - 06:14 PM

Anche se ti sembra strano, è proprio così che lo (stupido) spyhunter funziona, in pratica ti installa (a tradimento) una versione minima di Linux MA durante questa installazione (che in teoria dovrebbe essere temporanea) altera in maniera permanente la sequenza di avvio, molto spesso lasciando il sistema in una condizione di non avviabilità, perchè sostituisce o rinomina uno dei files di avvio pricncipali.

 

La soluzione è comunque questa:
http://reboot.pro/to...s-7-unbootable/

 

MA (e questo è un bel ma) l'esperienza finora è con Windows 7, mentre te - se ho ben capito - hai Windows 10, per cui qualcosa potrebbe essere cambiato.

Non credo proprio che tu abbia fatto un upgrade da Vista a 10, per quanto ne so si può (poteva) aggiornare sole 7/8/8.1 (e non Vista) a 10, se avevi 10 deve essere una nuova installazione.

 

Se vuoi più dettagli bisogna che tu ne fornisca molti di più, quali OS (ESATTI) avevi, come è partizionato il disco, cosa succedeva (che sequenza di avvio avevi/che boot manager usavi) PRIMA di installare lo (stupido) Spyhunter, etc.

 

:duff:

Wonko



#3 Frankie_G

Frankie_G
  • Members
  • 4 posts
  •  
    Italy

Posted 30 November 2016 - 07:17 PM

Grazie mille, la seconda sequenza di codici ha funzionato! 
Ma quando lo riavvierò? Mi si ripresenterà la stessa situazione? D: 

​P.S. per quanto riguarda i dettagli non sono ancora informato, purtroppo (ho ricevuto il computer da poco, usato). Appena ne so di più, comunico; anche perché ho notato che, ora, non posso accedere ad un hard disk prima presente.


Edited by Frankie_G, 30 November 2016 - 07:25 PM.


#4 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 13440 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 30 November 2016 - 07:28 PM

Grazie mille, la seconda sequenza di codici ha funzionato! 
Ma quando lo riavvierò? Mi si ripresenterà la stessa situazione? D: 

​P.S. per quanto riguarda i dettagli non sono ancora informato, purtroppo. Appena ne so di più, comunico.

Si e no.

Nel senso che puoi ripetere la "sequenza di codici" tutte le volte che vuoi, ma prima o poi dovrai riparare la sequenza di avvio.

 

Il problema con un sistema multi-boot è che bisogna capire la situazione pre-esistente e quindi riparare la sequenza di avvio in modo da ricreare la situazione preesistente (ad esempio se ripari da XP, poi non riuscirai più ad avviare 7, etc.)

 

La cosa buona di avere - sia pure "a tradimento" - installato un grub4dos è che hai la possibilità di avviare manualmente il sistema, se ripari la sequenza di avvio e ti richiudi da solo in - per dire - un BOOTMGR o un NTLDR con \boot\BCD o BOOT.INI mal configurati, non ne esci più.

 

I dettagli servono per farti riparare il sistema mantenendo comunque - come opzione (e temporaneamente)  - la possibilità di avviare grub4dos, in modo da potere - in caso di problemi - avere sempre la stessa possibilità di usare i suoi comandi.

 

:duff:

Wonko



#5 Frankie_G

Frankie_G
  • Members
  • 4 posts
  •  
    Italy

Posted 30 November 2016 - 11:34 PM

Sto notando che, effettivamente, nonostante il riavvio manuale il pc mi dà comunque problemi. Ripristinarlo darebbe qualche tipo di problema?

Edited by Frankie_G, 30 November 2016 - 11:35 PM.


#6 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 13440 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 01 December 2016 - 10:09 AM

Sto notando che, effettivamente, nonostante il riavvio manuale il pc mi dà comunque problemi. Ripristinarlo darebbe qualche tipo di problema?

Sì/No.

Non ho idea di che sistemi operativi stai parlando, di come funzionava prima, di quali problemi stai avendo ora, di quali danni il virus/malware (ed il suo "rimedio" Spyhunter) possano aver fatto, di che tipo di ripristino stai parlando ....

http://www.imdb.com/...?item=qt0362962

Fa' la cosa giusta!

 

:duff:

Wonko



#7 Frankie_G

Frankie_G
  • Members
  • 4 posts
  •  
    Italy

Posted 11 December 2016 - 12:21 PM

Con "Ripristino" intendevo la funzione di "Windows 10 Pro" utile a formattare parzialmente l'hard disk, e reinstallare il sistema operativo. Però purtroppo questa volta non posso riutilizzarla perché il pc non riesce ad accedere ai file utili alla reinstallazione. 

Windows 10 è installato su 2 hard disk (sul primo, quello al quale riesco ad accedere attraverso i codici da te forniti, è presente solo un utente, mentre sull'altro, il sistema operativo era tale da ospitare più utenti locali), ai quali, prima di questo problema, si sceglieva di accedere da una schermata nera che si presentava poco dopo l'accensione del pc.
Ho anche un terzo hard disk (del quale si poteva - se non ricordo male (purtroppo il pc è usato...) - accedere da entrambi i sistemi operativi), che però non compare più, al solito posto, in risorse del computer. 

Come faccio, ora, a comunicarti il bootmanager?  


Edited by Frankie_G, 11 December 2016 - 12:22 PM.


#8 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 13440 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 11 December 2016 - 06:24 PM

Ancora non ho un'idea chiara di cosa avevi prima.

E' molto raro avere due dischi come li descrivi con sistemi operativi separati, di solito c'è un solo disco "di avvio" da cui puoi scegiere wuale sistema opertivo avviare (sullo stesso o su un altro disco).

 

In ogni caso, parlando del primo disco, adesso sei in questa situazione:

BIOS->MBR->grub4dos->scelte non valide->comandi manuali->BOOTMGR (seconda copia)->\boot\BCD->Windows 10

La situazione "normale" per Windows 10 é:

BIOS->MBR->PBR della partizione attiva->BOOTMGR->\boot\BCD->Windows 10

 

Non ci sono problemi a ripristinare la situazione "normale", il metodo é descritto qua (sempre testato con Windows 7 ma dovrebbe funzionare lo stesso con 10):

http://reboot.pro/to...table/?p=199900

Si tratta di copiare il BOOTMGR usato sulla partizione di avvio (che può essere necessario montare temporaneamente su una lettera con diskpart o disk manager) e sistemare MBR e PBR con bootsect.exe.

 

Ma se vuoi re-installare Windows 10 ti conviene scaricare la ISO da Microsoft :
https://www.microsof...ad/windows10ISO

 

:duff:

Wonko






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users