Jump to content











Photo
* * * * * 1 votes

Booting Super Grub2 Disk in UEFI mode using E2B


  • Please log in to reply
6 replies to this topic

#1 TheReduxPL

TheReduxPL

    Newbie

  • Members
  • 12 posts
  •  
    Poland

Posted 06 November 2016 - 03:32 PM

As in title.

I tried converting the .iso file to .imgPTN using the MPI Tool Pack but it doesn't work - when trying to boot in UEFI mode, it just skips right into booting Windows from my SSD.

Is there anything I have to do to make it work?



#2 IAmTheTrueMeaningOfCovfefe

IAmTheTrueMeaningOfCovfefe

    Silver Member

  • Advanced user
  • 558 posts
  • Location:In hiding
  • Interests:An investigation is underway to determine whether Trump has any ties to America.
  •  
    United States

Posted 06 November 2016 - 10:06 PM

It may not be UEFI compatible. Check the ISO to see if it has a /boot/efi folder. If it does you should see at least one file with *.efi extension. Also search the ISO for a file similarly named to efiboot.img or efi.img (can't remember the exact name). Open the file with 7-Zip or whatever, then create the /boot/efi path, extract into that. There is an option in E2B's MPI Toolpack to create bootable media from a folder, so extract the rest of the ISO as well. I had to do this with Kali Linux ISO, which is UEFI-compatible but had no /boot/efi folder, only a small img file.

 

You'll also want to disable 8.1/10's Fast Startup feature.


  • TheReduxPL likes this

#3 TheReduxPL

TheReduxPL

    Newbie

  • Members
  • 12 posts
  •  
    Poland

Posted 06 November 2016 - 11:21 PM

Thanks, I've done what you said. I extracted the entire ISO, extracted the bootx64.efi file from efi.img into the /boot/efi directory and created a bootable media out of the extracted directory. Sadly that didn't work, the image still won't boot up.

Also looks like this tool is available as an .EFI file. Maybe using this file would be easier to prepare a valid UEFI file for E2B?

 

And thanks for the reminder about fast startup, I know it has to be disabled for dualboot setups but I actually forgot to switch it off :)



#4 IAmTheTrueMeaningOfCovfefe

IAmTheTrueMeaningOfCovfefe

    Silver Member

  • Advanced user
  • 558 posts
  • Location:In hiding
  • Interests:An investigation is underway to determine whether Trump has any ties to America.
  •  
    United States

Posted 06 November 2016 - 11:25 PM

I'll try this myself to test. It should have worked.



#5 TheReduxPL

TheReduxPL

    Newbie

  • Members
  • 12 posts
  •  
    Poland

Posted 06 November 2016 - 11:38 PM

Wait... Isn't it /efi/boot instead of /boot/efi?



#6 IAmTheTrueMeaningOfCovfefe

IAmTheTrueMeaningOfCovfefe

    Silver Member

  • Advanced user
  • 558 posts
  • Location:In hiding
  • Interests:An investigation is underway to determine whether Trump has any ties to America.
  •  
    United States

Posted 06 November 2016 - 11:41 PM

Actually you may be right. Yes I do believe it's /efi/boot. If there were any other files in efi.img, they need to be extracted too. Also check BIOS.

 

To boot E2B in UEFI mode, select imgptn, select Y to replace partition table. Then you will see a bunch of options. One will be boot in MBR. Select reboot instead, then choose UEFI boot option after pressing whatever key your PC requires to choose boot device.


  • TheReduxPL likes this

#7 TheReduxPL

TheReduxPL

    Newbie

  • Members
  • 12 posts
  •  
    Poland

Posted 07 November 2016 - 12:38 AM

Yeah, /efi/boot worked, thank you for your help!






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users