Jump to content











Photo
- - - - -

Lan boot iso using san


  • Please log in to reply
2 replies to this topic

#1 pazhanii

pazhanii

    Member

  • Members
  • 57 posts
  • Location:India
  •  
    India

Posted 14 August 2016 - 03:24 PM

Hai,

        I have been loading windows 7 vhd using iscsi target using Solar wind tftp server and TPTP32.

 

Below is the ipxe

 

#!ipxe
dhcp net0
set initiator-iqn iqn.1991-05.com.microsoft:win-murugaa-target
set root-path iscsi:192.168.1.30::::iqn.1991-05.com.microsoft:win-murugaa-target
set keep-san 1
sanboot ${root-path}
exit
 
But how to boot iso from iscsi target?
Not from http...but from san
Placing iso alone is not enough, what to do additional?
 


#2 pazhanii

pazhanii

    Member

  • Members
  • 57 posts
  • Location:India
  •  
    India

Posted 16 August 2016 - 04:33 AM

Extracting ISO content to root of ISCSI Target works like a charm. Like Gandalfs ISO, Active Boot and others.

 

No problems.

 

But this works only for windows based PE.

 

But for linux based what to do?



#3 pazhanii

pazhanii

    Member

  • Members
  • 57 posts
  • Location:India
  •  
    India

Posted 17 August 2016 - 06:19 AM

I found a easy way to boot ISO from iscsi target disk.

The solution is to Simply Deploy BCD using easyBCD software.

Add an entry for Windows ISO or Linux ISO and it works fine.

No need to extract to root.

Place the ISO in iscsi target disk before adding an entry.

 

But windows installation doesn't work. It boots fine but "a required device usb is missing error appears".

But Windows pe works.

 

Every USB boot supported cd works by this way.

Example, avira, kaspersky, bitdefender etc..


Edited by pazhanii, 17 August 2016 - 06:21 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users