Jump to content











Photo
- - - - -

Help with 3com 3c90x packet driver


  • Please log in to reply
2 replies to this topic

#1 ColdfireMC

ColdfireMC
  • Members
  • 2 posts
  •  
    Chile

Posted 07 July 2016 - 11:36 PM

Hello

I'm trying to set up a pc with freeDOS and I need network access. Checking driver availability, i have chosen a 3com 3c905-TX NIC. I'm using the clarkson packet driver(comes from 5.2 etherCD). However, programs using WATTCP stack, can't talk with the packet driver(wget and arachne fail), but others using mTCP work without problems. I Don't know how to troubleshoot this, the only thing i can touch in the packet driver is the software interrupt vector(0x60). has wattcp another default setting for interrupt?.

At this time, the pc has the following hardware installed:


Cpu: Pentium III 667mhz
256mb sdram, PC133

motherboard: a 440bx based gigabyte

video: Trident 8900CL, 1mb, ISA.

NIC: 3com 3c905-TX.
Sound: AWE64 CT4500

Software:

Freedos 1.1. there's only few differences with the default setup. I added UNIVBE 6.7 and the clarkson packet driver, So appended this to Autoexec.bat
C:\univbe\Univbe
C:\3c-2\pktdvr\3c90xpd /I=0x60

pls help



#2 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 13226 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 08 July 2016 - 08:42 AM

Maybe you can - before attempting to troubleshoot your installation - try a "simpler" network floppy disk and see how it behaves on your hardware and in connection with the software you mentioned. :unsure: but I believe most of them use NDIS drivers, it is a lot of time I have played with those things. :(

Have you tried the Georg Potthast version of the driver? (it may be updated):
http://www.georgpott...ioux/packet.htm

At least that version uses not the 0x seemingly, i.e. /I=60 and not /I=0x60:

 

 

Example
-------
The following example shows a typical command line. If you want to
load the driver at software interrupt 60h with receive Parallel Tasking
feature disabled, a PCI bus type, slot number = 1, and PCI bus
number = 0, the command line should look like this:

3C90XPD -r /S=1 /K=0 /I=60

For a complete summary of usage guidelines, type at the command line:

3C90XPD -?

 

:duff:

Wonko



#3 ColdfireMC

ColdfireMC
  • Members
  • 2 posts
  •  
    Chile

Posted 10 July 2016 - 09:20 PM

Well, WATTCP programs work only if i set IP manually. I will test with another NIC and driver. Is Intel 82555 a good card for DOS?






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users